Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-04-2013 15:18:53

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

[Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

bonjour les gens,

voilà je suis enfin passé en "tout Debian" y compris mon pc pro, le terrible "hp Touchsmart TM2" (écran tactile qui se rabat en tablette)
pas mal de petites configurations à faire mais je suis presque content du résultat.

J'ai chiffré mon disques, grub se lance-> lance le système-> il me demande ma passphrase puis il écrit les 3-4 1er lignes (jusque là tout est normal hein!) et juste après celle indiquant : "waiting for /dev to be fully populated" --->>> hop écran noir ! suspense d'1/2 seconde et disons, 2x sur 10 le système se fige (pas de possibilité de régler la luminosité, disque dur à l’arrêt...). les 8 autres x/10 je ne peux rien faire pendant cette demi seconde mais après je peux manuellement remonter la luminosité et tout roule les autres lignes s'écrivent. Heureusement j'avais connaissance grâce à la documentation de debian facile ( big_smile ) des "touches magiques" et le "alt-impr-b" fonctionne.

quels sont donc les services lancés à se moment là qui pourraient se bloquer ?


à savoir/début de pistes :
-avant j'avais ubuntu 11.4 que je n'ai pas mis à jour jusque à aujourd'hui sachant que je passais sous debian. là c'était 5x/10 que ça figeai mais juste après grub et c'est le "ctrl-alt-supr" qui redémarrai.
-j'avais également installé en vu de tests : une linuxmint debian edition avec xfce ; une debian wheezy avec gnome 3 qui n'ont *jamais* eu ce souci (mais elles n'étaient pas chiffrées et je ne les ai pas "configurés" plus que ça, cf : vga_switcheroo).
-il y a 2 cartes graphiques sur ce pc. J'utilise vga_switcheroo (et installation de firmware-linux-nonfree sinon ça marche pas). C'est la carte intégré intel qui est utilisée ce qui me conviens bien. Mais je n'ai jamais réussi à faire passer le système sur la carte discrète ATI pour tester le problème. Il y a donc une règle dans /etc/rc.local pour couper la ATI en alimentation et j'ai également rajouté le "sleep1" (sans effet). (http://doc.ubuntu-fr.org/vga_switcheroo … switcheroo)
-J'ai longtemps soupçonné la batterie : j'avais l'impression que si il était démarré sur secteur par exemple, le prochain démarrage sur batterie, hop ça plante et inversement. Mais en fait c'est pas systématique non plus...

voilà. Je suis en train de penser à la réinstallation du système des fois que... mais je préfère demander conseil avant de le faire pour rien smile
merci

Dernière modification par jean-kiki (19-05-2013 20:33:08)


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#2 15-04-2013 11:04:27

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

petit up,
j'ai trouvé ici : http://www.debian.org/doc/manuals/debia … ian_system des explications sur le lancement du système.

Comme le problème vient après grub, peut-être est-ce lié au système "mini-debian" avec le initrd ? un matériel non/mal reconnu ?

quand ça bloque est-ce cela que l'on appel un "kernel panic" ? comme je n'ai pas de luminosité je ne vois pas un éventuel message d'erreur, mais existe t-il des logs accessibles une fois le système lancé ?

est-ce que ça peut expliquer que sur linuxmint debian edition il n'y ai jamais eu le problème ? (un pilote/firmware installé en plus ? mais lequel ?)

j'ai vu qu'on pouvait shunter le système "mini-debian" pour passer directement vers le lancement du système lui même. est-ce une bonne idée ?

j'espère que ce n'est pas lié au chiffrement des partitions car j'en ai besoin...
Tout ça me dépasse un peu mais si vous avez des idées, merci d'avance smile

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#3 17-04-2013 19:31:32

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

Bon à présent j'ai trouvé d’où viens le problème. Ça va simplifier les choses... ou pas.

il s'agit de la carte graphique et de l'installation de "firmware-linux-nonfree". Lorsque je le désinstalle : plus aucun problème, le lancement ne bloque plus du tout et il n'y a même plus cette 1/2 seconde d'hésitation lors du lancement après le message ""waiting for /dev to be fully populated".

par contre vga_switcheroo n'est plus utilisable donc la carte ATI est alimentée en courant pour rien. De plus au lancement j'ai (logiquement) le message :

waiting for /dev to be fully populated ...[24.818955] [drm : radeon_pci_probe] *ERROR* radeon kernel modesetting for R600 or later requires firmware-linux-nonfree



à fin de test j'ai réinstallé le "firmware-linux-nonfree" en me disant que les cartes étaient peut-être mal reconnu. J'ai donc créer un fichier xorg car il n'existait pas en suivant la procédure : http://wiki.debian.org/fr/Xorg (arrêt de lightdm, puis xorg -configure) et il me sort ça :


Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
  Screen      1  "Screen1" RightOf "Screen0"
  Screen      2  "Screen2" RightOf "Screen1"
  InputDevice    "Mouse0" "CorePointer"
  InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  ModulePath   "/usr/lib/xorg/modules"
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic"
  FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
  FontPath     "built-ins"
EndSection

Section "Module"
  Load  "dbe"
  Load  "glx"
  Load  "extmod"
  Load  "record"
  Load  "dri"
  Load  "dri2"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/input/mice"
  Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Monitor"
  Identifier   "Monitor1"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Monitor"
  Identifier   "Monitor2"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "AccelMethod"         # <str>
        #Option     "DRI"                 # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "VideoKey"            # <i>
        #Option     "Tiling"              # [<bool>]
        #Option     "LinearFramebuffer"   # [<bool>]
        #Option     "Shadow"              # [<bool>]
        #Option     "SwapbuffersWait"     # [<bool>]
        #Option     "TripleBuffer"        # [<bool>]
        #Option     "XvPreferOverlay"     # [<bool>]
        #Option     "DebugFlushBatches"   # [<bool>]
        #Option     "DebugFlushCaches"    # [<bool>]
        #Option     "DebugWait"           # [<bool>]
        #Option     "HotPlug"             # [<bool>]
        #Option     "RelaxedFencing"      # [<bool>]
        #Option     "Throttle"            # [<bool>]
        #Option     "UseVmap"             # [<bool>]
        #Option     "ZaphodHeads"         # <str>
        #Option     "DelayedFlush"        # [<bool>]
        #Option     "FallbackDebug"       # [<bool>]
        #Option     "BufferCache"         # [<bool>]
  Identifier  "Card0"
  Driver      "intel"
  BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"            # [<bool>]
        #Option     "Rotate"              # <str>
        #Option     "fbdev"               # <str>
        #Option     "debug"               # [<bool>]
  Identifier  "Card1"
  Driver      "fbdev"
  BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"            # [<bool>]
        #Option     "DefaultRefresh"      # [<bool>]
        #Option     "ModeSetClearScreen"  # [<bool>]
  Identifier  "Card2"
  Driver      "vesa"
  BusID       "PCI:0:2:0"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Card0"
  Monitor    "Monitor0"
  SubSection "Display"
    Viewport   0 0
    Depth     1
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     4
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     8
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     15
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection

Section "Screen"
  Identifier "Screen1"
  Device     "Card1"
  Monitor    "Monitor1"
  SubSection "Display"
    Viewport   0 0
    Depth     1
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     4
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     8
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     15
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection

Section "Screen"
  Identifier "Screen2"
  Device     "Card2"
  Monitor    "Monitor2"
  SubSection "Display"
    Viewport   0 0
    Depth     1
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     4
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     8
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     15
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection
 



hum il me parait un peu bizarre...

Pour résumer j'ai le choix entre :
-ne pas installer le firmware et trouver une autre solution pour désactiver la carte graphique ! (je n'ai pas encore essayé de désinstaller le firmware mais en conservant le xorg.conf vu que je ne sais pas ce qu'il vaut).
-trouver ce qui cloche dans le firmware et si ce "bug du démarrage" est lié au xorg.conf ? j'ai aussi vu que le firmware est en version 0.37 dans experimental (0.36 whezzy et sid) mais je suis pas super chaud...

Dernière modification par jean-kiki (17-04-2013 19:40:49)


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#4 17-04-2013 21:26:43

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

Euh, t'as essayé de virer ton xorg.conf louche ? ça bug encore dans ce cas ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 18-04-2013 10:03:36

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

Merci pour ta réponse captnfab (c'est agréable de se sentir moins seul face à son problème smile )

En fait le xorg.conf n'était pas présent quand ça bugait au début. Donc là ou pas dans les 2 cas ça bug en fait (mais si c'est la question, non je n'ai pas essayé de le ré-enlever après l'avoir créé).

si je l'ai créé c'est parce-que j'ai cru comprendre que maintenant le serveurX se débrouille au démarrage pour trouver la bonne configuration sans forcément passer par le xorg.conf (il n'est plus créé par défaut). Mais si il détecte pas bien le matériel alors autant lui dire quoi penser ! d'où la création du xorg.conf.
Si ce xorg.conf par défaut correspond à ce qu'il analyse au démarrage alors je trouve ça louche qu'il reconnaisse 3 screen, 3 monitor et 3 device !!! Je pensais donc lui dire : tiens ! ça c'est du intel, ça c'est du ATI et pis c'est tout ! Mais je ne sais pas si mon raisonnement est correct, ni bien manipuler ce type de fichier... (et encore moins si ça changera quelque-chose...)

sympathiquement smile

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#6 18-04-2013 10:20:22

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

Héhé smile
Je pensais que tu avais créé le xorg.conf *après* avoir installé les firmware pour ta carte ati, je me trompe ? Je voulais juste voir si maintenant que les firmware étaient là, il ne se débrouillait pas bien sans xorg.conf

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 18-04-2013 10:52:24

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

ah oui ok. effectivement c'est pt'etre pas clair mon truc. oui c'est exactement ça : j'ai créé le xorg.conf après que le firmware ai été installé. MAIS si je l'ai créé c'est parce-que le firmware faisait planter le démarrage. Donc il y avait bien le firmware SANS le xorg.conf. En fait pour faire encore plus simple : quand le firmware est installé avec ou sans le xorg.conf pour l'instant ça plante ! smile (d’où mon intérêt pour le configurer plus finement ???).

Actuellement le seul cas ou ça plante pas au démarrage c'est quand le firmware n'est pas là. Mais comme dit plus haut, ben... je peux pas désactiver la carte ATI via vga_switcheroo sad

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#8 18-04-2013 11:05:33

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

Ok smile
Essaye peut-être le combo suivant :
- pas de xorg.conf
- firmware installé
- option "nomodeset" dans la ligne de boot du noyau

Pour cette dernière, tu peux par exemple éditer le /etc/default/grub et modifier la ligne ressemblant à
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
pour qu'elle ressemble à
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"
Puis lancer un « update-grub »

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 19-04-2013 12:36:31

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

Alors ! C'est tout à fait particulier. Je connaissais "nomodeset" pour l'avoir utilisé avec mon pc fixe perso (le démarrage plantait car il manquait le driver proprio que j'ai pu installer comme ça). Mais il n'y a pas une histoire comme quoi c'est le processeur qui gère l'affichage avec ça ?


Bref, pour ce qui concerne mon pc portable pro avec nomodeset dans grub au démarrage, c'est une bonne idée je crois ça amène de nouveaux éléments :

-si je laisse le xorg.conf (j'ai oublié de l'enlever la 1er fois) : le démarrage se bloque sur "waiting for /dev to be fully populated" (la luminosité reste présente, le disque dur continue de "gratter" un peu, le curseur en fin de ligne clignote... mais ça n'avance pas).

-si je renomme le xorg.conf pour le désactiver : ça se lance, j'ai un vielle écran baveux pendant le démarrage. Puis j'arrive sur l'écran de connexion mais les polices et l’apparence en générale ont pris du volume. C'est tout gros ! Quand je lance un "cat /sys/kernel/debug/vgaswitcheroo/switch" il répond : le dossier n'existe pas.


Voilà. Je ne sais que penser.
Après je ne sais pas si vgaswitcheroo est la solution ultime (la carte est-elle réellement désactivée ? À savoir que je n'ai jamais réussi à switcher vers la carte ATI via cet outil par exemple). N'y a t-il pas un moyen plus radical de bloquer le matériel ATI au démarrage ? (comme ça je désinstalle linux-firmware-nonfree). ou bien dans mon xorg dans la section device en face driver si je met du ATI quelque part ? (genre c'est quoi fbdev ?)

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#10 19-04-2013 20:21:53

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

j'ai également bidouillé le xorg.conf. j'ai fais plusieurs modifications mais à chaque tentative ça bug sévère. Suite à mon expérience ce que je peux affirmer c'est que xorg c'est lié à l'affichage big_smile et que je suis content de ne plus avoir peur de la ligne de commande pour réparer ça big_smile big_smile

lien intéressants : http://doc.ubuntu-fr.org/xorg ; http://www.freebsd.org/doc/fr/books/han … onfig.html ; http://www.siteduzero.com/informatique/ … -xorg-conf
et ça c'est un lien vers un bug d'un xorg qui reconnaît plein de screen et device comme moi : https://bugs.launchpad.net/ubuntu/+sour … ug/1155289

Dernière modification par jean-kiki (19-04-2013 20:26:37)


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#11 20-04-2013 08:25:24

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

jean-kiki a écrit :

je suis content de ne plus avoir peur de la ligne de commande pour réparer ça big_smile big_smile

Et bien voilà ! Prochaine étape : tu te passes de session graphique. lol

Dernière modification par paskal (20-04-2013 08:26:11)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#12 20-04-2013 14:02:09

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

paskal a écrit :

Et bien voilà ! Prochaine étape : tu te passes de session graphique. lol


ah ! si seulement je pouvais/savais-> cool mais faut me dire comment avoir l'équivalent de medintux en ligne de commande big_smile (oui j'aime bien me faire du mal avec un matériel informatique très particulier et des logiciels galères à installer.... pour ceux qui savent pas il est hyper compliqué à installer sous gnu/linux et hyper simple sous windows sic!)

mais sinon note bien que le problème n'est à priori pas lié à l'interface graphique wink


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#13 23-04-2013 18:20:55

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

hopla des nouvelles :

récemment il y a eu une mise à jour de xserver-xorg ! Depuis plus aucun bug ! J'ai enlevé le xorg.conf pour voir : pareil plus aucun problème. Ça fait 2 jours maintenant alors que quand même avant c'était au moins 1x/jour...

bon, j’attends encore un peu et puis je mettrai résolu. Mais c'est pas drôle ya même pas à bidouiller sad (c'est une blague hein ! Je suis content si c'est résolu wink faut juste pas qu'une prochaine mise à jour re-détraque tout...)

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#14 19-05-2013 20:32:37

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

Je mets résolu dans le sujet même si ce n'est pas tout à fait vrai. Ça va beaucoup mieux le blocage ne se produit plus très souvent et je suis passé à autre chose. Je verrai avec le temps et les mises à jour si ça s'améliore...

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#15 20-05-2013 10:16:21

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

Ok !
Ça reste obscur comme problème ^^"

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 20-05-2013 10:54:20

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] démarrage bloqué aléatoirement à cause cartes graphiques.

oui certes cela reste obscure (et ça oblige à faire un alt+impr+b de temps à autre je sais pas si c'est très conseillé...). Mais je n'ai pas le temps de trop approfondir xorg (déjà mes quelques bidouilles à l'aveugle n'ont pas été concluantes). ou alors d'empêcher un matériel d'être reconnu... bon pour l'instant ça tourne quand même bien (je m'en sert tout les jours, disons qu'une fois par semaine ça bloque pour donner un ordre d'idée, c'est pas non plus trop gênant et comme debian est rapide à se lancer je perds pas trop de temps...)

je redirai si un jour j'ai mieux...

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

Pied de page des forums