Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-04-2013 00:17:19

Freesly
Membre
Distrib. : Débian Sqeeze
Noyau : Linux 3.2.0-0.bpo.4-amd64
(G)UI : gnome 3
Inscription : 13-04-2013

[Résolu] Problème firmware not found

Bonjour, petit nouveau sur le forum et dans le monde Linux je me tourne vers vous pour m'aider à résoudre un problème insoluble pour moi. Je me suis monté un serveur Debian squeeze avec Xbmc et Openmediavault. Après avoir bien galéré et écumé le net (dont le wiki et le forum de debian-facile) il tourne presque nickel smile

Ma carte mère est une Asus P8P67 avec bluetooth intégré. Mais impossible de le faire fonctionner. Aprés recherche j'ai trouvé qu'il y avait un bug avec le kernel 2.6 de squeeze a propos du firmware Atheros et que le moyen facile etait d'upgrader le kernel sur le 3.2. Seulement j'ai déjà le 3.2 ! J'ai direct fait la mise à jour après l'install pour pouvoir activer le trim du ssd. Toujours est il que j'ai pas mon bluetooth... Dans mes recherches j'ai aussi trouvé un truc bizarre avec le firmware ethernet qui pourtant fonctionne lui (peut être que cela explique la lenteur du partage samba). Bref plus qu'un long discours voici des cmds :

uname -a :

Linux PCHC 3.2.0-0.bpo.4-amd64 #1 SMP Debian 3.2.39-2~bpo60+1 x86_64 GNU/Linux



dmesg | grep firmware : (qui m'a mis la puce à l'oreille)

[   12.628954] Bluetooth: Atheros AR30xx firmware driver ver 1.0
[   12.632501] usb 5-1.7: firmware: agent aborted loading ath3k-1.fw (not found?)
[   12.632696] Bluetooth: Error loading firmware
[   13.437163] r8169 0000:07:00.0: firmware: agent aborted loading rtl_nic/rtl8168e-2.fw (not found?)
[   13.437306] r8169 0000:07:00.0: eth0: unable to load firmware patch rtl_nic/rtl8168e-2.fw (-2)



dmesg (j'ai gardé que le principal, enfin je pense) :


....
[   12.627972] Bluetooth: Core ver 2.16
[   12.627985] NET: Registered protocol family 31
[   12.627986] Bluetooth: HCI device and connection manager initialized
[   12.627988] Bluetooth: HCI socket layer initialized
[   12.627990] Bluetooth: L2CAP socket layer initialized
[   12.627994] Bluetooth: SCO socket layer initialized
[   12.628954] Bluetooth: Atheros AR30xx firmware driver ver 1.0
[   12.629214] alg: No test for __gcm-aes-aesni (__driver-gcm-aes-aesni)
[   12.630174] asus_wmi: ASUS WMI generic driver loaded
[   12.631166] asus_wmi: Initialization: 0x0
[   12.631183] asus_wmi: BIOS WMI version: 0.9
[   12.631220] asus_wmi: SFUN value: 0x0
[   12.631476] input: Eee PC WMI hotkeys as /devices/platform/eeepc-wmi/input/input5
[   12.632501] usb 5-1.7: firmware: agent aborted loading ath3k-1.fw (not found?)
[   12.632696] Bluetooth: Error loading firmware
[   12.632763] ath3k: probe of 5-1.7:1.0 failed with error -5
[   12.632777] usbcore: registered new interface driver ath3k
....
[   13.437163] r8169 0000:07:00.0: firmware: agent aborted loading rtl_nic/rtl8168e-2.fw (not found?)
[   13.437306] r8169 0000:07:00.0: eth0: unable to load firmware patch rtl_nic/rtl8168e-2.fw (-2)
[   13.455044] r8169 0000:07:00.0: eth0: link down
[   13.455074] r8169 0000:07:00.0: eth0: link down
[   13.455817] ADDRCONF(NETDEV_UP): eth0: link is not ready
....
[   14.326156] Bluetooth: RFCOMM TTY layer initialized
[   14.326160] Bluetooth: RFCOMM socket layer initialized
[   14.326162] Bluetooth: RFCOMM ver 1.11
[   14.331110] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.331112] Bluetooth: BNEP filters: protocol multicast
....
[   15.037866] r8169 0000:07:00.0: eth0: link up
[   15.038278] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
....
 



lsusb :

Bus 005 Device 004: ID 0cf3:3000 Atheros Communications, Inc. AR3011 Bluetooth (no firmware)



lsusb -v -d 0cf3:3000 :

Bus 005 Device 004: ID 0cf3:3000 Atheros Communications, Inc. AR3011 Bluetooth (no firmware)
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x0cf3 Atheros Communications, Inc.
  idProduct          0x3000 AR3011 Bluetooth (no firmware)
  bcdDevice            2.00
  iManufacturer           0
  iProduct                0
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           25
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      0
      bInterfaceProtocol      0
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
Device Status:     0x0000
  (Bus Powered)



lspci -knn : (pour l'ethernet)

07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8432]
        Kernel driver in use: r8169



Voila, une idée quelqu'un ? big_smile

Dernière modification par Freesly (14-04-2013 12:15:16)

Hors ligne

#2 14-04-2013 01:16:21

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Problème firmware not found

[   13.437163] r8169 0000:07:00.0: firmware: agent aborted loading rtl_nic/rtl8168e-2.fw (not found?)
[   13.437306] r8169 0000:07:00.0: eth0: unable to load firmware patch rtl_nic/rtl8168e-2.fw (-2)

Sans chercher beaucoup :

# aptitude search '~d atheros'
p   collectd-core                                 - statistics collection and monitoring daemon (core system)                                          
p   collectd-core:i386                        - statistics collection and monitoring daemon (core system)                                          
i   firmware-atheros                           - Binary firmware for Atheros wireless cards                                                        
i A firmware-linux-free                       - Binary firmware for various drivers in the Linux kernel                                            
p   zd1211-firmware                          - Firmware images for the zd1211rw wireless driver    


tu as installé  firmware-linux-free et  firmware-atheros  ?


« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#3 14-04-2013 12:10:34

Freesly
Membre
Distrib. : Débian Sqeeze
Noyau : Linux 3.2.0-0.bpo.4-amd64
(G)UI : gnome 3
Inscription : 13-04-2013

Re : [Résolu] Problème firmware not found

Non je ne les avais pas installé... Du coup je viens de le faire et le bluetooth fonctionne !! J'etais persuadé après les lectures de divers forums qu'il fallait recompiler le kernel et tous pleins de trucs me dépassant... Bref merci smile Du coup j'ai aussi installé le paquet firmware-realtek pour le souci avec l'ethernet. Merci encore!

Hors ligne

Pied de page des forums