Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-07-2008 18:50:14

koshie
Membre
Inscription : 19-06-2008

Epiphany + Flash Player, installation

Bonjour,

en googlant un peu je découvre qu'Ephiphany supporte le Flash, alors pourquoi s'en priver?

Je télécharger le tar.gz, je l'extrait et lance en root l'executable, là viens la question fatidique :

Please enter the installation path of the Mozilla, Netscape,
or Opera browser (i.e., /usr/lib/mozilla):


Je me rend dans mon /usr/lib/ et je découvre qu'Ephiphany n'a que deux dossier, epiphany-gecko et epiphany-webkit et aucun des deux ne fonctionne.

J'ai quand même cherché et j'ai trouvé ça expliquant comment installer flash sur Epiphany mais je n'ai pas de flashplayer.xpt, est-ce le fichier d'installation que le lance avec un sh <le fichier> ?

J'évite de bidouiller, la dernière fois... Bref :-p !

Merci de votre aide, Koshie.

Hors ligne

#2 03-07-2008 00:16:01

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Epiphany + Flash Player, installation

Salut

Tu as installé le plugin flash pour mozilla?

Hors ligne

#3 03-07-2008 09:07:48

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

Non, il y a un rapport?

Hors ligne

#4 03-07-2008 12:44:29

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Epiphany + Flash Player, installation

Il me semble oui...car flashplayer marche chez moi avec epiphany alors que je n'ai rien installé d'autre...
Je dis pt'être une bétise....à tester wink

Hors ligne

#5 03-07-2008 17:06:56

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

J'ai pas compris ce que tu me dis, d'abord tu me demande si flash est installé pour firefox, puis tu me dit que ça n'a aucun rapport hmm.

Hors ligne

#6 03-07-2008 17:29:56

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Epiphany + Flash Player, installation

Salut,

Si j'ai bien compris,Palmito dit qu'il lui paraît possible que le plugin flash de Mozilla soit aussi utilisé par Epiphany, et que donc l'installation du plugin flash de Mozilla permettrait (peut-être) à Epiphany de lire les flash.

Je suis du même avis que lui.

@+ smile

Hors ligne

#7 03-07-2008 17:47:01

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

J'ai téléchargé le tar.gz du site d'adobe, je vous montre l'installation détaillé :

Cassy:/home/cassy/install_flash_player_9_linux# sh flashplayer-installer

Copyright(C) 2002-2006 Adobe Macromedia Software LLC.  All rights reserved.

Adobe Flash Player 9 for Linux

Adobe Flash Player 9 will be installed on this machine.

You are running the Adobe Flash Player installer as the "root" user.
Adobe Flash Player 9 will be installed system-wide.

Support is available at http://www.adobe.com/support/flashplayer/

To install Adobe Flash Player 9 now, press ENTER.

To cancel the installation at any time, press Control-C.



NOTE: Please exit any browsers you may have running.

Press ENTER to continue...



Please enter the installation path of the Mozilla, Netscape,
or Opera browser (i.e., /usr/lib/mozilla): /usr/lib/iceweasel
flashplayer-installer: line 155: strings: command not found
flashplayer-installer: line 161: [: `)' expected, found 9
flashplayer-installer: line 163: [: `)' expected, found 9
flashplayer-installer: line 165: [: `)' expected, found 9


----------- Install Action Summary -----------

Adobe Flash Player 9 will be installed in the following directory:

Browser installation directory = /usr/lib/iceweasel

Proceed with the installation? (y/n/q): y

Installation complete.


Mais ça ne marche pas, visiblement il y a des erreurs, mais il me dit quand même que l'installation est finit.

Dernière modification par koshie (03-07-2008 17:47:31)

Hors ligne

#8 03-07-2008 18:09:26

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Epiphany + Flash Player, installation

Re,

Tu disposes avec Debian d'une distribution, c'est à dire un ensemble de programmes qui ont été adaptés pour fonctionner ensemble. Donc avant d'aller chercher des tar.gz quelque part, le bon réflexe consiste à vérifier ce qui existe dans la distribution.

aptitude search flash
p   flashplugin-nonfree-extrasound                              - Adobe Flash Player platform support library for Esound and OSS
p   flashrom                                                    - Universal BIOS/ROM/flash programming utility
p   flashybrid                                                  - automates use of a flash disk as the root filesystem
p   libflash-dev                                                - GPL Flash (SWF) Library - development files
p   libflash-mozplugin                                          - GPL Flash (SWF) Library - Mozilla-compatible plugin
p   libflash-swfplayer                                          - GPL Flash (SWF) Library - stand-alone player
p   libflash0c2                                                 - GPL Flash (SWF) Library - shared library
p   libroxen-flash2                                             - Flash2 module for the Roxen Challenger web server
p   m16c-flash                                                  - Flash programmer for Renesas M16C and R8C microcontrollers
p   vrflash                                                     - tool to flash kernels and romdisks to Agenda VR


Je tenterai plutôt un

aptitude install libflash-mozplugin


A vérifier sous Etch, ça c'est sous Lenny, et je n'ai pas pu vérifier, www.debian.org ne répond toujours pas.

Hors ligne

#9 03-07-2008 19:32:28

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

Je sais ce qu'est une distribution ^^ !

J'ai déjà essayé d'installe flashplugin-nonfree, pas dans les dépôts, j'ai fait ta commande, installé mais ça ne marche toujours pas.

Hors ligne

#10 03-07-2008 21:23:26

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Epiphany + Flash Player, installation

Re,

Je ne vois pas comment tu peux dire que tu as passé la commande et installé sans que ça soit dans les dépots.
Et sans plus de détails ça va pas être simple.

Tu as vérifié quels dépots étaient dans ton sources.list?

Hors ligne

#11 03-07-2008 21:37:02

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

J'ai dis que flashplugin-nonfree je ne pouvais pas l'installer car oui il n'est pas dans mes dépôts, je n'y ai pas touché et je sais que ce paquet n'est pas dans les dépôts de base.

J'ai dis que j'avais installé libflash-mozplugin.

Tiens, je te montre quand même mon sources.list (j'aurais du y penser plus tôt) :

#
# deb cdrom:[Debian GNU/Linux testing _Lenny_ - Official Snapshot i386 CD Binary-1 20080314-21:27]/ lenny main

# deb cdrom:[Debian GNU/Linux testing _Lenny_ - Official Snapshot i386 CD Binary-1 20080314-21:27]/ lenny main

deb http://ftp.fr.debian.org/debian/ lenny main
deb-src http://ftp.fr.debian.org/debian/ lenny main

deb http://security.debian.org/ lenny/updates main
deb-src http://security.debian.org/ lenny/updates main

Hors ligne

#12 03-07-2008 22:04:24

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Epiphany + Flash Player, installation

Eh bien il n'y a plus qu'à ajouter le bon dépot. smile

Hors ligne

#13 03-07-2008 22:07:13

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

Je vais googler un peu et si je trouve pas je préviendrais.

Hors ligne

#14 03-07-2008 22:28:21

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

J'ai fait une petite modification de mon sources.list, j'ai rajouté "contrib non-free" aux deux premiers dépôts, j'ai rechargé et ça n'a pas marché, j'ai fais ça aux dépôts security et ça ne marche pas aussi. En même temps sur ces deux derniers ça ne m'étonne pas.

PS : J'ai pas eu d'erreur lors de l'update !

Dernière modification par koshie (03-07-2008 22:28:51)

Hors ligne

#15 03-07-2008 22:48:17

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Epiphany + Flash Player, installation

Ok. Avec la modif sur le premier dépot c'est suffisant en principe. Si tu as fait l'update et que ça c'est bien passé, tout marche - jusqu'ici.

Ensuite il reste à installer le paquet. L'as tu fait? Quels messages d'erreur obtiens tu?

Hors ligne

#16 03-07-2008 22:54:49

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

J'ai laissé contrib non-free pour le premier, j'ai update :

Cassy:/home/cassy# apt-get update
Atteint http://ftp.fr.debian.org lenny Release.gpg
Ign http://ftp.fr.debian.org lenny/main Translation-fr                                                 
Atteint http://security.debian.org lenny/updates Release.gpg                                           
Ign http://security.debian.org lenny/updates/main Translation-fr                     
Ign http://ftp.fr.debian.org lenny/contrib Translation-fr                           
Atteint http://security.debian.org lenny/updates Release                             
Ign http://ftp.fr.debian.org lenny/non-free Translation-fr                           
Atteint http://ftp.fr.debian.org lenny Release
Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
Ign http://security.debian.org lenny/updates/main Sources/DiffIndex
Atteint http://ftp.fr.debian.org lenny/main Packages/DiffIndex
Atteint http://security.debian.org lenny/updates/main Packages
Atteint http://ftp.fr.debian.org lenny/contrib Packages/DiffIndex
Atteint http://security.debian.org lenny/updates/main Sources
Atteint http://ftp.fr.debian.org lenny/non-free Packages/DiffIndex
Atteint http://ftp.fr.debian.org lenny/main Sources/DiffIndex
Atteint http://ftp.fr.debian.org lenny/contrib Sources/DiffIndex
Atteint http://ftp.fr.debian.org lenny/non-free Sources/DiffIndex
Lecture des listes de paquets... Fait


Et voici ce qui se passe :

Cassy:/home/cassy# apt-get install flashplugin-nonfree
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet flashplugin-nonfree n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
E: Aucun paquet ne correspond au paquet flashplugin-nonfree

Dernière modification par koshie (03-07-2008 22:56:05)

Hors ligne

#17 03-07-2008 23:32:07

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Epiphany + Flash Player, installation

Le paquet s'appelle libflash-mozplugin wink

Hors ligne

#18 04-07-2008 08:51:25

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

Cassy:/home/cassy# apt-get install libflash-mozplugin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libflash-mozplugin est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.


Et je n'ai toujours pas de Flash.

Hors ligne

#19 05-07-2008 01:41:02

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Epiphany + Flash Player, installation

Ben là je ne sais pas. Désolé. hmm

edit: Oups, pardon, Bonjour. il se fait tard. wink

Dernière modification par tux12 (05-07-2008 01:41:56)

Hors ligne

#20 05-07-2008 16:02:31

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Hors ligne

#21 05-07-2008 17:43:56

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

Jour',

Palmito relis mon premier topic ^^ !

Hors ligne

#22 07-07-2008 17:36:17

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

Ça avance plus trop malheureusement... Et je sais toujours pas quoi faire.

Hors ligne

#23 07-07-2008 18:34:23

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Epiphany + Flash Player, installation

koshie a écrit :

Jour',

Palmito relis mon premier topic ^^ !


Ooops smile

Bon, y'a quelque chose qui cloche....est ce que ce ne serais pas un "conflit" entre l'install via le depot debian et le paquet adobe?

As tu essayé de tout désinstaller proprement (flash) avec l'option --puge?

EDIT: le plugin fonctionne t'il avec firefox??

Hors ligne

#24 08-07-2008 09:15:07

koshie
Membre
Inscription : 19-06-2008

Re : Epiphany + Flash Player, installation

Il ne marchait pas sous Firefox (iceweasel plutôt) non plus, j'ai désinstallé et purgé et j'ai réinstallé libflash-mozplugin mais rien n'y fait.

Hors ligne

#25 08-07-2008 19:39:31

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Epiphany + Flash Player, installation

Bon...dans iceweasel, si tu saisis "about:plugins", tu ne vois plus rien concernant flash alors.....

Hors ligne

Pied de page des forums