Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-05-2013 20:24:19

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

[Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Bonjour,

Je viens de passer de squeeze à wheezy (la transition s'est mal faite et j'ai dû réinstaller, heureusement j'ai gardé mon home sur une partition séparée). J'ai aussi sid sur une autre partition, avec le même home, et le même problème apparaît tant avec sid qu'avec wheezy, pour l'utilisation de périphériques usb.

Lorsque j'utilisais squeeze, tout allait bien: je branchais une clef usb ou un disque dur externe usb, presque aussitôt son icône apparaissait sur l'écran, et Nautilus en affichait le contenu. Cela marchait parfaitement bien, avec les clefs usb formatées en fat, les disques durs externes formatés en ext4 ou en ntfs. Lorsque ces périphériques avaient un label (en général, c'était le cas) ils étaient automatiquement montés en /media/" le label du périphérique". Un clic droit sur l'icône du périphérique me permettait de "retirer le volume sans risque", et une fois cela fait on voyait la petite loupiote de la clef usb ou du disque dur s'éteidre, et on savait qu'on pouvait sans risque débrancher le périphérique.

Maintenant, çà marche beaucoup moins bien! lorsque je branche une clef usb ou un disque dur usb, il est monté automatiquement en /media/usb0, ou /media/usb1, ... (il y a huit /media/usbx, x allant de 0 à 7, qui ont été automatiquement créés sans que je le demande!). De plus impossible d'accéder au périphérique, sauf en root, l'utilisateur normal n'y a pas droit! Pour couronner le tout, impossible de débrancher le périphérique sans risque. Il n'y a plus d'icône représentant le périphérique sur le bureau donc pas moyen de faire un clic droit dessus. Il y a bien le nom du périphérique qui apparaît dans Nautilus; un clic droit sur ce nom offre bien la commande "Débrancher le périphérique sans risque", mais lorsqu'on lance cette commande, çà ne marche pas, au contraire cela ouvre le contenu du périphérique dans une autre fenêtre de Nautilus!

J'ai commenté les lignes /dev/sdb qui avaient été automatiquement créées, à mon insu, dans /etc/fstab, j'ai installé pmount et usbmount, j'ai lu les explications concernant ces commandes données par le wiki. Cela a un peu amélioré les choses: maintenant, je peux accéder aux clefs usb et aux disques durs externes en utilisateur ordinaire, j'en suis propriétaire, ce n'est plus root qui en est propriétaire. Mais la commande
"débrancher le périphérique sans risque" ne marche toujours pas. Je peux démonter le périphérique, soit en ligne de commande, soit avec l'"utilitaire de disque", mais la loupiote indiquant que la clef usb ou le disque externe est toujours sous tension reste allumée et j'ai toujours un peu d'inquiétude en débranchant la clef ou le disque.

J'ai aussi désactivé dans     dconfEditor le montage automatique des media amovibles par gnome: cela n'a rien changé du tout.

En résumé, sid et wheezy me font regretter squeeze, qui marchait beaucoup mieux! Je pense sérieusement à le réinstaller!

Cordialement,

C.-M. M.

Dernière modification par cmm (22-05-2013 09:52:04)

Hors ligne

#2 19-05-2013 22:25:44

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

bonjour,
pfiou, comme tu as l'air tout dépité sad
Je n'ai pas bien compris une chose quand tu parles du home commun. Tu as Sid et Wheezy avec un même nom d'utilisateur dans le même home? C'est ça ou je n'ai rien compris?

<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#3 20-05-2013 00:51:43

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Lætitia a écrit :

bonjour,
pfiou, comme tu as l'air tout dépité sad
Je n'ai pas bien compris une chose quand tu parles du home commun. Tu as Sid et Wheezy avec un même nom d'utilisateur dans le même home? C'est ça ou je n'ai rien compris?



Je pense avoir en effet compris qu'il utilisait un répertoire /home commun aux deux versions.

Lorsqu'une nouvelle version de Debian apparait, il est préférable d'attendre encore quelques mois afin de palier à toutes les éventualités. J'avais été plus prudent avec Squeeze auparavant et je me suis tout comme toi jeté sur la Wheezy tant la dernière transition m'avait laissé un excellent souvenir (passage de lenny à squeeze, que du bonheur !)
Bref!
Je n'ai plus de montage automatique des supports usb que je palie en utilisant les commandes shell. Je n'ai pas encore creusé le pourquoi du comment...

@+

Zoroastre.

Hors ligne

#4 20-05-2013 01:19:11

Yagermoe
Membre
Lieu : Entre Lyon et Valence
Distrib. : Jessie/Stretch
Noyau : 3.16.0-4-amd64/4.0-amd64
(G)UI : Openbox+Tint2/Xcfe
Inscription : 15-12-2011

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Salut,
J'ai eu aussi des problèmes de montage usb sur Wheezy au début. J'ai résolu en modifiant certaines valeurs dans le fichier

/usr/share/polkit-1/actions/org.freedesktop.udisks.policy

Pour chaque action qui t'intéresse, il faut remplacer

<allow_active>auth_admin</allow_active>

par

<allow_active>yes</allow_active>

C'est la seule manière que j'ai trouvé de ne plus avoir ce problème avec ma configuration. Faut quand même être prudent et faire une sauvegarde du fichier avant.

A+

Asus M5A97 - Phenom X4 965 - 8 Go - Radeon HD6850
"Ceux qui ne savent rien en savent toujours autant que ceux qui n'en savent pas plus qu'eux" (P. Dac)

Hors ligne

#5 20-05-2013 07:15:58

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Merci pour vos réponses!

Oui, j'ai à la fois sid et wheezy sur deux partitions différentes, avec le même /home sur une troisième partition. Cela marche très bien, j'avais déjà cette configuration avec sid et squeeze avant de mettre à jour squeeze en wheezy. je me suis trop précipité pour faire cette mise à jour! Avant j'utilisais essentiellement squeeze, sid posait déjà ce problème avec les périphériques usb, je ne m'en souciais pas trop puisque c'est squeeze que j'utilisais, je n'avais mis sid que par curiosité et parce qu'il y avait une partition libre sur mon disque.

Merci Yagermoe pour ces indications. je vais essayer!

Cordialement, C.-M. M.

Hors ligne

#6 20-05-2013 22:20:14

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Bonsoir,

Yagermoe, je n'ai pas encore osé faire la manip que tu indiques de peur de faire des bêtises.

Cependant, j'ai un peu progressé. J'ai supprimé usbmount, qui a l'inconvénient de monter les clefs usb ou les disques durs usb en en donnant la propriété à root. J'ai conservé pmount et installé hal. Maintenant, lorsque je connecte une clef usb ou un disque externe usb, il est immédiatement monté et son contenu s'affiche dans une fenêtre nautilus, et j'en suis le propriétaire, en tant qu'utilisateur ordinaire, je peux donc lire et écrire sur cette clef ou ce disque.

Par contre, la fonction "retirer le périphérique sans risque" ne marche toujours pas. Bien au contraire, si j'ai au préalable démonté le périphérique, soit en ligne de commande soit avec "Utilitaire de disque", la commande "retirer le périphérique sans risque" le monte à nouveau, et en affiche le contenu dans une autre fenêtre Nautilus.

J'ai essayé d'installer xfce4, c'est exactement pareil qu'avec gnome.

Bon, je vais m'en accomoder, jusqu'à ce que quelqu'un de plus savant que moi m'explique ce qui ne va pas!

Cordialement,

C.-M. M.

Dernière modification par cmm (20-05-2013 22:21:18)

Hors ligne

#7 20-05-2013 23:40:12

Yagermoe
Membre
Lieu : Entre Lyon et Valence
Distrib. : Jessie/Stretch
Noyau : 3.16.0-4-amd64/4.0-amd64
(G)UI : Openbox+Tint2/Xcfe
Inscription : 15-12-2011

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Salut cmm,
J'ai fait ce week-end une install minimale de Jessie.
J'ai juste installé plusieurs paquets gvfs, et pas de usbmount ou autre. Et j'ai fait la manip décrite plus haut. Et ça marche, y compris pour le démontage.
A+

Asus M5A97 - Phenom X4 965 - 8 Go - Radeon HD6850
"Ceux qui ne savent rien en savent toujours autant que ceux qui n'en savent pas plus qu'eux" (P. Dac)

Hors ligne

#8 21-05-2013 13:53:52

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Bonjour Yagermoe et merci pour ces encouragements!

Qu'est-ce que c'est Jessie, et les paquets gvfs? que dois-je installer?

Merci et bien cordialement,

C.-M. M.

Hors ligne

#9 21-05-2013 20:09:38

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Salut,

Jessie, c'est Debian Testing

Les paquets gvfs ce sont les paquets du Gnome Virtual File System, un « aptitude search gvfs » te montreras la liste des paquets.

Pour ce qui est de ce que tu dois installer, je ne sais pas smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#10 21-05-2013 20:35:27

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Merci Captnfab!

J'essaierai demain la manip indiquée par Yagermoe.

Cordialement, C.-M. M.

Hors ligne

#11 22-05-2013 09:47:25

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu (mal)] Montage auto des périphériques usb sous sid et wheezy.

Bonjour,

J'ai fait la manip indiquée par Yagermoe. De plus, j'ai viré hal. Il y a une légère amélioration:
lorsque je branche une clef usb dont le label est Cruzer16GB, elle se monte automatiquement en
/media/Cruzer16GB, ce sous-dossier de /media étant créé automatiquement. Et j'en suis propriétaire
(alors qu'avant la suppression de usbmount, c'est root qui était propriétaire de tous les devices usb externes). Pareil avec mon dique dur usb externe, dont le label est disquerouge: il se monte automatiquement en /media/disquerouge. Jusque là, c'est parfait.

Les choses se gâtent un peu lorsque je fais (par un clic droit sur le nom du volume dans une fenêtre Nautilus) "retirer le volume sans risque". Pendant quelques secondes, la loupiote indiquant que le volume est sous tension s'éteint et son nom disparaît de la fenêtre Nautilus. Il faut alors très vite le débrancher, car si on attend plus de 4 ou 5 secondes, hop le volume se reconnecte, et même une nouvelle fenêtre nautilus s'ouvre et affiche son contenu!

C'est moins bien qu'avec squeeze, mais on peut s'en accomoder...

J'ai maintenant un autre problème avec la connexion réseau: l'installation du firmware pour faire marcher la carte wifi broadcom a eu une conséquence gênante: la connexion filaire ne marche plus! mais c'est un autre problème, je mettrai un autre post si je n'arrive pas à résoudre ce problème tout seul.

En résumé, je pense que la sortie en stable de Debian 7 est bien prématurée, squeeze marchait bien mieux!

Merci à tous pour votre aide.

Bien cordialement,

C.-M. M.

Hors ligne

Pied de page des forums