Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-05-2013 01:06:58

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

[Résolu] micrologiciel absent pour le wifi sur un Macbook Pro 7.1

Bonsoir,

tout est dit dans le titre : j'ai installé LMDE sur mon MacBook Pro 7.1, et le wifi ne marche pas, j'ai l'indication « Micrologiciel absent », ou « firmware absent » selon les endroits, ce qui doit vouloir dire la même chose il me semble. J'ai fouillé tout ce que j'ai pu trouver sur le net, j'ai trouvé des indications très détaillées sur http://wiki.debian.org/fr/WiFi ce site, en particulier, mais c'est trop savant pour moi, je ne comprends pas ce que je dois trouver comme renseignement, ni à quel niveau est le problème…

Merci pour vos conseils !

(il est tard, je suis sur cette question depuis la fin de l'après-midi et je sature, je vais dormir, je reviendrai voir demain…)

Dernière modification par Muselaar (21-05-2013 12:12:46)


MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#2 20-05-2013 06:45:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] micrologiciel absent pour le wifi sur un Macbook Pro 7.1

Bien qu'en construction, voici un tuto à consulter :
Le manuel du wiki façon df.

Et pour firmware ou micrologiciel, voir cette explication :
Les firmwares

Hop hop hop ! big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 20-05-2013 08:13:32

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] micrologiciel absent pour le wifi sur un Macbook Pro 7.1

La commande, depuis un terminal

$ lspci

t'indiquera la référence de ta carte wifi.
Cela permettra de déterminer quel firmware chercher.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 20-05-2013 09:10:10

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] micrologiciel absent pour le wifi sur un Macbook Pro 7.1

Salut!
Je suis tombé sur cette page : http://wiki.debian.org/MacBook , ça te sera sans doute utile!
La section WiFi redirige à cet endroit : http://wiki.debian.org/MacBook/Wireless
qui t'indique :
- Installer le paquet wireless-tools

apt-get install wireless-tools


- Lancer les deux commandes suivantes :

update-pciids
lspci | grep -E "Atheros|Broadcom"


Ce qui t'es retourné est la référence de ta carte wifi.

Il y a de bonnes chances d'après la doc que ce soit une carte broadcom. Donc tu devras installer le paquet firmware-b43-installer . (Assures-toi d'avoir activé la section "contrib" dans ton fichier des sources) :

Fichier /etc/apt/sources.list ressemble à ça :

deb http://ftp.fr.debian.org/debian/ wheezy main contrib
...
 


Puis :

apt-get update && apt-get install firmware-b43-installer


YA3HGA-H

Hors ligne

#5 21-05-2013 00:46:23

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] micrologiciel absent pour le wifi sur un Macbook Pro 7.1

Bonsoir.

et merci pour toutes ces indications, qui m'ont permis d'aller un peu plus loin.

Je dispose donc d'une puce BCM4322, et j'ai installé le firmware correspondant, qui est effectivement le b43.

j'ai ensuite utilisé les instructions de la page
http://debian-facile.org/doc:materiel:wifi:detecter

et je suis arrivé à scanner les réseaux wifi du coin, au premier rang desquels le mien.

Surprise (il va falloir que je m'y fasse, à ce que taper quelques lignes de caractères sur un écran tout noir ait autant d'impact sur le fonctionnement de l'ordinateur, c'est encore magique pour moi !), les réseaux wifi apparaissent dans l'applet réseau.

Et c'est en utilisant le wifi que j'envoie le présent message

Merci encore une fois à tous ceux qui m'ont aidé.

MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#6 21-05-2013 01:05:13

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] micrologiciel absent pour le wifi sur un Macbook Pro 7.1

Bon, j'ai écrit trop vite, j'ai effectué l'envoi du post précédent par wifi, mais ensuite, ça s'est déconnecté, et je ne peux pas me reconnecter, ça tourne en rond en alternant « authentification requise » et « connexion en cours ». Pourtant, j'ai été connecté une fois, preuve que tout est en ordre en principe, et l'autre mac (celui que j'ai loué temporairement pour switcher plus facilement) reste connecté sans problème (il est sous Mac Os X).
Qui cause le problème ? Le modem, le fournisseur, le système… ?
Je vais aller dormir encore une fois.

MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#7 21-05-2013 01:15:54

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] micrologiciel absent pour le wifi sur un Macbook Pro 7.1

Avant de dormir, j'ai quand même tenté ce que j'aurais dû faire avant d'écrire le précédent post : redémarrer l'ordinateur, et pas seulement la session.
Apparemment, ça a résolu le problème, puisque j'étais connecté au wifi dès l'ouverture de session, et qu'une fois encore, j'envoie ce post par wifi.
Reste à savoir comment on place la notification [Résolu] dans l'entête de la discussion. J'ai cherché où je l'avais lu, et je n'ai pas retrouvé.

MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#8 21-05-2013 04:01:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] micrologiciel absent pour le wifi sur un Macbook Pro 7.1


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums