Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-05-2013 23:22:36

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

[bug rapporté] Gimp 2.8 efface les tags

Salut cool

Hum, je crois que le nouveau Gimp (2.8) ne me plaît pas du tout. Il y a déjà l'histoire de l'obligation d' "exporter" vers le jpg et l'abandon de l'universel enregistrer/enregistrer sous pour le jpg, mais bon, on finit sûrement par s'y faire. Mais je viens de découvrir quelque chose de plus ennuyeux : Gimp efface les tags que j'enregistre dans les images avec Digikam. Si je retouche l'image, bigre, la version retouchée a perdu les tags.

Après une recherche sur la Toile, j'installe le paquet libexif-dev, je paramètre évidemment Gimp pour gader les exifs (ce qu'il fait par défaut en fait) et les données xmp, mais rien n'y fait.

J'ai cherché une alternative à Gimp mais là aussi, rien ? J'ai testé pinta mais lui efface carrément toutes les exifs... Je ne comprends pas, conserver les exifs et les tags est pourtant essentiel en photo.

Dernière modification par captnfab (01-06-2013 12:39:44)

Hors ligne

#2 30-05-2013 06:12:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut Octopus Riot,

On ne retouche que des copies d'originaux en photo.
C'est le B A BA de l'image.

smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 30-05-2013 09:57:47

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut Smolski,

Oui, mais ça ne résout en rien le problème avec Gimp 2.8, me voilà avec une copie sans tags sans que j'ai choisi d'enlever les tags, ça ne me convient pas du tout. Mes originales sont en raw, je produits le jpg à l'aide de Rawtherapee, ensuite parfois j'utilise Gimp pour un coup de tampon (outil n'existant pas sous RT) puis c'est le tagage (Digikam). Jusque là ok. Mais pour envoyer une photo sur le Web ou à un pote par mail, je passe aussi par Gimp pour réduire la taille et le poids et ensuite rehausser un poil de netteté pour compenser le flou du à la réduction de l'image. C'est là que je me retrouve avec une image sans les tags de Digikam à l'insu de mon plein gré...  et si je voulais que mon pote lise les tags ? Hé ben, monsieur Gimp dit "non". Je trouve ce bug de Gimp 2.8 rédhibitoire et je n'ai pas envie de me le coltiner 2 ans jusqu'à Jessie. Me voilà avec un Gimp 2.8 qui ne sait pas faire ce que faisait bien Gimp 2.6. C'est bien d'avoir un nouveau système comme Wheezy, mais si c'est pour se taper des versions dégradées des logiciels (cf. Digikam, j'ai aussi des pb de pdf - lecture, impression - que je n'avais pas sous Squeeze), je commence à douter de Wheezy qui me fait perdre des heures pour rien. OS stable + logiciels buggués = mauvais cocktail.

édit : Je rêve (façon de parler), je teste Krita, et lui non plus ne sait pas modifier une image et garder les tags !!! Je résume, ni Gimp, ni pinta, ni krita ne savent faire ce que faisait Gimp 2.6, c'est n'importe quoi. mad

Dernière modification par Octopus Riot (30-05-2013 10:33:28)

Hors ligne

#4 30-05-2013 11:25:05

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [bug rapporté] Gimp 2.8 efface les tags

Yep Octopus Riot !

Perso, le pc de prod est toujours sous squeeze+backports en attendant que wheezy s'installe dans les boxes. wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 30-05-2013 11:42:21

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Le problème c'est que maintenant, Gimp 2.8 est dans le Debian stable, il va y rester jusqu'à la prochaine stable, donc ce genre de bug ne sera pas corrigé avant une éventuelle nouvelle version de Gimp sous Jessie... Les seules corrections sont celles des failles de sécurité, donc un bug qui ne présente pas de faille de sécurité demeure tel quel non ?

Reste la possibilité de downgrader Gimp à la version 2.6 en restant sous Wheezy. Je réfléchis à cette piste.

Hors ligne

#6 30-05-2013 11:46:13

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [bug rapporté] Gimp 2.8 efface les tags

J'ai ouvert une photo en JPEG, j'ai retouché, je l'ai ré-enregistrée sur une copie en JPEG et ça m'a gardé les tags sans installer libexif-dev

Donc :
- Sur quel format d'image ?
- Quel appareil ? (un tag non standard qui ferait planter ?)
- Avec une étape intermédiaire en XCF ?

Après pour l'enregistrement c'est pas anormal que l'image "de réference" soit en XCF et c'est plus logique comme ça dans l'absolu.

C'est un peu comme le Ctrl-Supr de Gnome qui perturbe les habitudes mais est totalement cohérent avec les Ctrl-X Crtl-C et tous autres raccourcis du même genre.

Dans la pratique, si tu ne passe pas par une version en XCF, désactive la confirmation pour qu'elle ne t'enquiquine pas. C'est juste une combinaison de touche à apprendre pour éviter le menu : Ctrl-E / Shift-Ctrl-E au lieu de Ctrl-S./ Shift-Ctrl-S

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#7 30-05-2013 11:49:20

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [bug rapporté] Gimp 2.8 efface les tags

Le problème c'est que maintenant, Gimp 2.8 est dans le Debian stable, il va y rester jusqu'à la prochaine stable,



Stable ne signifie pas "aucune correction de bug" mais pas de changement de version majeure.


« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#8 30-05-2013 12:46:52

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut Haricophile,

Merci de passer par là cool

Pour l' "export" des images j'avais bien désactivé la confirmation, je peux m'y habituer.

Pour les tags, hé bien, je parle de jpg tagués par Digikam. Si je visualise les tags et exifs avec Geeqie, ils sont là. Si je retouche avec Gimp, quand je regarde les exifs de la nouvelle image avec Geeqie, les exifs sont là, mais plus aucune trace des tags. Sous Squeeze, avec les mêmes logiciels, tout fonctionnait bien.

Bizarre que ce soit différent chez toi, je ne fais rien d'exotique. Mon appareil photo est un Canon EOS-450D, mais ça n'a rien à voir avec mon problème, les exifs vont bien, c'est les tags de Digikam qui passent à la trappe.

Je ne passe pas par le format XCF, je fais juste avec Gimp du tampon, du redimensionnement et du rehaussement de netteté des jpg.

Dernière modification par Octopus Riot (30-05-2013 12:47:25)

Hors ligne

#9 30-05-2013 18:16:17

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Qui peut me dire comment installer Gimp 2.6 sur Wheezy ? Par les dépots de Squeeze ? N'y a t-il pas alors le risque de mettre un peu le waï dans le système avec les dépendances ?

Dernière modification par Octopus Riot (30-05-2013 18:16:39)

Hors ligne

#10 30-05-2013 18:29:13

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut,

Pour faire ça proprement, il te faudrait récupérer les sources du paquet Debian de Gimp 2.6 et le recompiler pour Wheezy.
Pour faire ça salement, il te suffit de prendre les sources de Gimp 2.6 et de les recompiler pour ton système.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 30-05-2013 20:17:20

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut et merci captnfab, mais je ne suis pas chaud pour compiler...

Je viens de me rendre compte que les tags illisibles par Geeqie ne sont pas vraiment effacés car la commande exiftool photo.jpg sait les lire. C'est quand même étrange que l'intervention de Gimp 2.8 rende les tags illisibles pour Geeqie alors que ça ne le faisait pas avant. C'est vraiment la 4 e dimension et le brouillard total... Pour moi cette histoire est très grave, on ne peut pas faire confiance aux logiciels "images" tantôt ça lit les tags, puis un jour ça ne les lira plus, peut être dans deux ans Geeqie y arrivera de nouveau avec les fichiers passés par Gimp ?

Franchement ça me reste en travers de la gorge, Wheezy est un échec pour moi et ressemble à une version bêta pas finie, la légende de la stabilité "comme un roc" prend du plomb dans l'aile, elle m'a fait perdre des heures pour rien, j'ai un système plus neuf qui marche moins bien, certains logiciels ne s'articulent plus entre eux, franchement, encore un plan comme ça et je laisse béton Debian, c'est purement stérile de perdre ainsi du temps et n'arriver à rien. Autant Lenny et Squeeze ont été superbement solides sans accro, là, c'est le crash... C'est Debian en dégradé.

Vous savez la meilleure ? La gestion des pdf part en vrille ! Je veux en imprimer un, ça rogne une partie du texte qui ne s'imprime pas, et les pdf ne sont pas tous lisibles par les mêmes logiciels, je dois en utiliser deux au petit bonheur la chance, un coup l'un lit le pdf, l'autre coup, ah non, il faut ouvrir avec un autre logiciel voyons ! Évidemment je n'ai jamais eu ce pb sous Squeeze ni Lenny... Bienvenue sur Mars.

Dernière modification par Octopus Riot (30-05-2013 20:30:32)

Hors ligne

#12 30-05-2013 20:52:53

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut,

Tu sais, si personne ne fait de rapport de bug, ce genre de situation ne peut pas être détecté. La distribution Testing sert à ça, à tester, et faire des rapports de bug.
Qui plus est, il ne faut pas confondre les bugs de la distribution avec les bugs des logiciels qu'elle inclut.
Tu te plains de tes problèmes, les as-tu rapportés ? C'est grâce à ses utilisateurs qu'une distribution avance, et devine quoi ? Le nombre de rapport de bug effectués par les utilisateurs a énormément baissé ces dernières années. La faute aux développeurs Debian qui investissent leur temps dans la distribution ? Certainement pas.
On a (collectivement) le Mars que l'on sème.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#13 30-05-2013 23:07:25

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Tu as raison captnfab mais ça fait râler (même si c'est puéril) d'installer un système tout neuf pour se retrouver avec des déboires qui n'existaient pas avant sans voir l'ombre d'une amélioration avant deux ans... Utiliser testing, sid, et rapporter les bugs, j'aime bien Linux et le logiciel libre, mais je ne suis pas un passionné d'informatique non plus.

Hors ligne

#14 30-05-2013 23:09:41

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [bug rapporté] Gimp 2.8 efface les tags

Comme dirait smolski, c'est ça le libre, tu profites, et tu partages ! smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#15 31-05-2013 01:21:40

KDP
Membre
Lieu : Savoie
Distrib. : Jessie
Noyau : linux 3.16
(G)UI : LXQT
Inscription : 26-12-2011
Site Web

Re : [bug rapporté] Gimp 2.8 efface les tags

J'ai essayé avec la 2.8.4, les données EXIF sont bien incluses dans l'export en jpeg.
À tout hasard, dans la fenêtre de dialogue "Exporter comme jpeg" (ou quelque chose ressemblant), il y a un item "Options avancées". L'option "Enregistrer les données EXIF" est-elle cochée ?

Hors ligne

#16 31-05-2013 08:22:21

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut KDP,

Mais oui c'est bien coché.

Hors ligne

#17 31-05-2013 13:50:53

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Petit complément, j'ai découvert un nouvel aspect du problème. Les exifs de l'image sont également touchées mais le problème ne se voit pas de la même façon. Geeqie les lit très bien avec l'image originale et l'image passée par Gimp, sans les tags bien sûr..., mais, en postant une photo travaillée par Gimp 2.8 sur le Web, je m'aperçois que le module complémentaire lecteur d'exifs de iceweasel (fxif) lit mal les exifs (alors qu'il les lisait très bien avec des photos travaillées par Gimp 2.6), il ne mets pas la bonne valeur d'ouverture du diaphragme (par exemple, f/4) et écrit systématiquement f/0.0 à la place. De même il ne lit pas le temps de pause et je me retrouve avec une vitesse aberrante de 1/0 secondes. Je change de module et Exif viewer lit les bonnes valeurs. Donc ici l'intervention de Gimp 2.8 rend certaines valeurs des exifs aberrantes pour certains logiciels comme fxif mais pas pour d'autres (Exif viewver).

C'est vraiment compliqué cette histoire.

Exif viewver me permets de cliquer sur un lien nommé "Show/Hide XMP Source", il m'affiche ça :

<?xpacket begin='' id='W5M0MpCehiHzreSzNTczkc9d'?>
<x:xmpmeta xmlns:x='adobe:ns:meta/'>
<rdf:RDF xmlns:rdf='http://www.w3.org/1999/02/22-rdf-syntax-ns#'>

 <rdf:Description xmlns:tiff='http://ns.adobe.com/tiff/1.0/'>
  <tiff:Software>digiKam-2.6.0</tiff:Software>
 </rdf:Description>

 <rdf:Description xmlns:xmp='http://ns.adobe.com/xap/1.0/'>
  <xmp:CreatorTool>digiKam-2.6.0</xmp:CreatorTool>
 </rdf:Description>

 <rdf:Description xmlns:digiKam='http://www.digikam.org/ns/1.0/'>
  <digiKam:PickLabel>0</digiKam:PickLabel>
  <digiKam:ColorLabel>0</digiKam:ColorLabel>
  <digiKam:TagsList>
   <rdf:Seq>
    <rdf:li>toulon</rdf:li>
    <rdf:li>mont faron</rdf:li>
    <rdf:li>araneae (ordre)</rdf:li>
    <rdf:li>arachnida (classe)</rdf:li>
    <rdf:li>salticidae (famille)</rdf:li>
    <rdf:li>philaeus chrysops</rdf:li>
   </rdf:Seq>
  </digiKam:TagsList>
  <digiKam:PickLabel>0</digiKam:PickLabel>
  <digiKam:ColorLabel>0</digiKam:ColorLabel>
  <digiKam:TagsList>
   <rdf:Bag>
    <rdf:li>toulon</rdf:li>
    <rdf:li>mont faron</rdf:li>
    <rdf:li>araneae (ordre)</rdf:li>
    <rdf:li>arachnida (classe)</rdf:li>
    <rdf:li>salticidae (famille)</rdf:li>
    <rdf:li>philaeus chrysops</rdf:li>
   </rdf:Bag>
  </digiKam:TagsList>
 </rdf:Description>

 <rdf:Description xmlns:dc='http://purl.org/dc/elements/1.1/'>
  <dc:subject>
   <rdf:Bag>
    <rdf:li>araneae (ordre)</rdf:li>
    <rdf:li>arachnida (classe)</rdf:li>
    <rdf:li>salticidae (famille)</rdf:li>
    <rdf:li>toulon</rdf:li>
    <rdf:li>philaeus chrysops</rdf:li>
    <rdf:li>mont faron</rdf:li>
   </rdf:Bag>
  </dc:subject>
 </rdf:Description>

 <rdf:Description xmlns:MicrosoftPhoto='http://ns.microsoft.com/photo/1.0/'>
  <MicrosoftPhoto:LastKeywordXMP>
   <rdf:Seq>
    <rdf:li>toulon</rdf:li>
    <rdf:li>mont faron</rdf:li>
    <rdf:li>araneae (ordre)</rdf:li>
    <rdf:li>arachnida (classe)</rdf:li>
    <rdf:li>salticidae (famille)</rdf:li>
    <rdf:li>philaeus chrysops</rdf:li>
   </rdf:Seq>
  </MicrosoftPhoto:LastKeywordXMP>
  <MicrosoftPhoto:LastKeywordXMP>
   <rdf:Bag>
    <rdf:li>toulon</rdf:li>
    <rdf:li>mont faron</rdf:li>
    <rdf:li>araneae (ordre)</rdf:li>
    <rdf:li>arachnida (classe)</rdf:li>
    <rdf:li>salticidae (famille)</rdf:li>
    <rdf:li>philaeus chrysops</rdf:li>
   </rdf:Bag>
  </MicrosoftPhoto:LastKeywordXMP>
 </rdf:Description>

 <rdf:Description xmlns:lr='http://ns.adobe.com/lightroom/1.0/'>
  <lr:hierarchicalSubject>
   <rdf:Bag>
    <rdf:li>toulon</rdf:li>
    <rdf:li>mont faron</rdf:li>
    <rdf:li>araneae (ordre)</rdf:li>
    <rdf:li>arachnida (classe)</rdf:li>
    <rdf:li>salticidae (famille)</rdf:li>
    <rdf:li>philaeus chrysops</rdf:li>
   </rdf:Bag>
  </lr:hierarchicalSubject>
  <lr:hierarchicalSubject>
   <rdf:Seq>
    <rdf:li>toulon</rdf:li>
    <rdf:li>mont faron</rdf:li>
    <rdf:li>araneae (ordre)</rdf:li>
    <rdf:li>arachnida (classe)</rdf:li>
    <rdf:li>salticidae (famille)</rdf:li>
    <rdf:li>philaeus chrysops</rdf:li>
   </rdf:Seq>
  </lr:hierarchicalSubject>
 </rdf:Description>

 <rdf:Description xmlns:exif='http://ns.adobe.com/exif/1.0/'>
  <exif:ImageWidth>3500</exif:ImageWidth>
  <exif:ImageLength>2333</exif:ImageLength>
  <exif:BitsPerSample>8</exif:BitsPerSample>
  <exif:Compression>Non compressé</exif:Compression>
  <exif:Make>Canon</exif:Make>
  <exif:Model>Canon EOS 450D</exif:Model>
  <exif:Orientation>Top-left</exif:Orientation>
  <exif:SamplesPerPixel>3</exif:SamplesPerPixel>
  <exif:XResolution>300</exif:XResolution>
  <exif:YResolution>300</exif:YResolution>
  <exif:PlanarConfiguration>Planar format</exif:PlanarConfiguration>
  <exif:ResolutionUnit>pouces</exif:ResolutionUnit>
  <exif:Software>RawTherapee</exif:Software>
  <exif:DateTime>2013:05:27 15:05:00</exif:DateTime>
  <exif:ExposureTime>1/1000 sec.</exif:ExposureTime>
  <exif:FNumber>f/4,0</exif:FNumber>
  <exif:ExposureProgram>Priorité ouverture</exif:ExposureProgram>
  <exif:ISOSpeedRatings>
   <rdf:Seq>
    <rdf:li>400</rdf:li>
   </rdf:Seq>
  </exif:ISOSpeedRatings>
  <exif:ExifVersion>Version d'exif 2.21</exif:ExifVersion>
  <exif:DateTimeOriginal>2013:05:27 15:05:00</exif:DateTimeOriginal>
  <exif:DateTimeDigitized>2013:05:27 15:05:00</exif:DateTimeDigitized>
  <exif:ShutterSpeedValue>10,00 EV (1/1024 sec.)</exif:ShutterSpeedValue>
  <exif:ApertureValue>4,00 EV (f/4,0)</exif:ApertureValue>
  <exif:ExposureBiasValue>0,00 EV</exif:ExposureBiasValue>
  <exif:MeteringMode>Motif</exif:MeteringMode>
 </rdf:Description>

</rdf:RDF>
</

Parsing Error!



Les tags sont bien inclus dedans, par exmple,

<rdf:li>salticidae (famille)</rdf:li>



Mais à la fin il y a

Parsing Error



Il y a même les bonnes valeurs de diaphragme et de temps de pause... Tout est là mais tous les logiciels ne lisent pas tout comme il faut alors qu'ils lisent tout bien sur les jpg sortis par Rawtherapee et tagués par Digikam.

Un sacré sac de noeuds non lol ?

Dernière modification par Octopus Riot (31-05-2013 13:57:36)

Hors ligne

#18 31-05-2013 13:55:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [bug rapporté] Gimp 2.8 efface les tags

Sinon, Digikam ne permet-il pas de gérer ce que tu transformes avec gimp ? roll

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#19 31-05-2013 14:26:33

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Digikam ne me convient pas pour éditer les images, il n'a pas d'outil tampon et ne sait pas afficher le poids de l'image au redimensionnement comme le fait Gimp.

Hors ligne

#20 31-05-2013 14:38:02

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut,

En fait, Haricophile a fait quelques recherches et a trouvé ces rapports de bug :



Des bugs que les développeurs de Gimp n'ont visiblement pas corrigé à temps pour la version stable, où qu'ils n'ont pas rétro-porté vers celle-ci.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#21 31-05-2013 19:35:08

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Merci de ces infos Captnfab, peut-être y aura-t-il un gimp corrigé un de ces 4 dans les backports ?

Hors ligne

#22 01-06-2013 00:48:03

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Laissez tout tomber, j'abandonne debian, le bogue de trop a eu lieu :  cf. http://debian-facile.org/viewtopic.php?pid=61877#p61877

yikes

mad

Dernière modification par Octopus Riot (01-06-2013 00:48:24)

Hors ligne

#23 01-06-2013 12:12:42

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [bug rapporté] Gimp 2.8 efface les tags

Lieutenant Kao au rapport!!! big_smile


Je confirme, Gimp transmet bien les données Exif (et en ajoute d'autres) mais corrompt les données xmp.
On peut s'en apercevoir avec un clic droit dans nautilus sur le fichier en sortie de gimp: les tags sont décochés.

Donc pour moi une des solutions est de bypasser Gimp pour ce qui est de l'écriture des xmp (et même des exifs).

Ce que l'on peut faire avec l'outil exiv2


 sudo aptitude install exiv2
 man exiv2
 



Plusieurs commandes sont possibles:
Dans le dossier des fichiers orignaux:


exiv2 extract *.jpg #extrait les données exifs dans un fichier exv.
exiv2 -eX *.jpg  #extrait les données xmp dans un fichier xmp.
 


On copie les fichiers metadata dans le dossier d'export de gimp "finaux"


cp *.exv ../finaux/;
cp *.xmp ../finaux/;
 


Puis on supprime les données inscrites xmp et exif dans les jpg issues de gimp


exiv2 -dx *.jpg
exiv2 -de *.jpg
 


Pour les remplacer par ceux disponible dans les fichiers xmp et exv.


exiv2 -iX *.jpg #xmp
exiv2 insert *.jpg #exif
 




si on résume ça dans un script que l'on place dans le dossier "originaux" et les fichiers issues de Gimp dans le dossier "finaux":


#!/bin/sh

for file in *.jpg;
do
#extraction des données xmp
  xmp=${file%%.jpg}.xmp;
  exiv2 -eX $file
  cp "$xmp" "../finaux/$xmp";
#extraction des données exif
  exif=${file%%.jpg}.exv;
  exiv2  extract $file
  cp $exif ../finaux/$exif;
#réécriture des données xmp
  cd ../finaux
  exiv2 -dx "$file";
  exiv2 -iX "$file";
  rm "$xmp" "../originaux/$xmp";
#réécriture des données exif
  exiv2 -de "$file";
  exiv2 insert "$file";
  rm "$exif" "../originaux/$exif";
done
 



Comme le dit si bien la pub: "Il y a une commande pour ça" big_smile

Hors ligne

#24 03-06-2013 16:19:00

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Salut Kao,

Ok, je testerai ce script.

Hors ligne

#25 09-07-2013 19:51:11

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [bug rapporté] Gimp 2.8 efface les tags

Aux nouvelles, Gimp 2.8.4 puis 2.8.6 sont sortis, mais rien dans les backports de Wheezy... Faut-il prier les dieux de l'Olympe ?

Dernière modification par Octopus Riot (09-07-2013 19:51:45)

Hors ligne

Pied de page des forums