Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-09-2013 21:48:41

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

[résolu] Problème de son avec Songbird

Salut à tous !

Sous Wheezy x64, j'ai choisi comme lecteur de musique Songbird, après avoir testé tous ceux proposés dans les dépôts et n'en avoir trouvé aucun qui me convienne (et avoir lamentablement échoué en tentant de faire marcher Winamp avec Wine, à mon grand dam). Le développement ayant été arrêté pour GNU/Linux, et n'ayant pas trouvé de version d'un plugin dont j'ai besoin (Now Playing List) qui soit compatible avec son fork Nightingale, j'utilise la version 2.0.0 pour Windows avec Wine. En temps normal ça marche bien (première fois que j'arrive à faire tourner un truc de manière potable avec Wine, j'y croyais pas au début), mais j'ai quand même un conflit avec les autres logiciels voulant émettre du son. Plusieurs exemples :

- Je lance une vidéo Youtube (Iceweasel + plugin Flash non-free), tout marche bien, j'ai du son. Je lance SB sans rien lire, toujours du son sur Youtube. Je commence à lire un morceau sur SB, je le met en pause, et plus de son sur Youtube. Je ferme SB, de nouveau du son sur Youtube.

- Même situation avec VLC.

- Plus ou moins la même situation avec Audacity, à part que si c'est Audacity qui commence à lire en premier, c'est SB qui a plus de son, et tout le reste marche.

Et bien entendu, quand SB est fermé, aucun conflit entre ces différents logiciels.

Plusieurs questions, donc.

Déjà, avez vous déjà rencontré ce problème ? À quoi peut-il être du ? Est-il du à Wine, à SB, à la combinaison des deux ou à une mauvaise congig système ?

Ensuite, parce que j'ai pas trouvé mais on sait jamais, est-ce qu'on peut encore trouver la dernière version de SB pour GNU/Linux ?

Et pour finir, ça non plus j'ai pas réussi à le faire, mais est-ce qu'il est possible de faire fonctionner une version du plugin Now Playing List avec Nightingale ?

Merci d'avance pour vos réponses !

Dernière modification par Ralph W. Llama (21-10-2013 18:35:27)


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#2 11-10-2013 04:39:37

david96
Invité

Re : [résolu] Problème de son avec Songbird

Yo,


Je ne connais pas winamp, mais as-tu testé xmms, apparemment ce serait un clône de ce dernier, qui gère aussi les listes de lectures :

apt-get install xmms2




Édite : https://fr.wikipedia.org/wiki/XMMS2

280px-XMMS.png
Source : https://fr.wikipedia.org/wiki/XMMS

Dernière modification par Invité-2 (11-10-2013 04:44:05)

#3 11-10-2013 10:11:36

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

Salut ! Et merci pour ta réponse !

Mais XMMS est un clone d'une ancienne version de Winamp. Il ne peut que lire la musique et faire des playlists, il ne gère pas de bibliothèque.

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#4 11-10-2013 10:40:00

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

Des paquets deb pour songbird ici: http://pkgs.org/ubuntu-12.04/getdeb-app … 4.deb.html

La version pour Ubuntu 12.04 devrait fonctionner dans Wheezy, à tester.

Hors ligne

#5 11-10-2013 11:27:53

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [résolu] Problème de son avec Songbird

Un post sur ubuntu obselete  mais qui pourrait toujours servir :

http://forum.ubuntu-fr.org/viewtopic.php?id=1231881

Dernière modification par golgot200 (11-10-2013 11:34:25)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#6 11-10-2013 12:10:41

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

Merci ! Je savais pas qu'on trouvait des versions pour GNU/Linux...

Par contre, tout ça c'est pour Ubuntu. Ça pose pas de problème si je tente d'installer sous Debian ?

Et puis j'ai voulu tester la 2.0.0, mais il réclame Firefox, alors que j'ai Iceweasel. Y'a moyen de rendre ça compatible ou faut obligatoirement que j'installe Firefox ?

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#7 11-10-2013 12:17:21

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

Perso, je l'ai installé pour essayé et je n'ai pas eu de problème.

Mais j'avoue que ce n'est pas conseillé.

Je n'ai pas Firefox mais Iceweasel.

Hors ligne

#8 11-10-2013 12:20:10

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

T'as fait l'installation comment ? En ajoutant le dépôt, avec dpkg ou avec Gdebi ?

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#9 11-10-2013 19:23:55

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

Avec


dpkg -i songbird_2.0.0-1~getdeb1_i386.deb
apt-get install -f



Je suis en i386

Hors ligne

#10 11-10-2013 19:25:26

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

OK, bah je vais essayer.

EDIT : même problème en i386 qu'en amd64 :

antoine@Gnunux:~$ sudo dpkg -i /media/C990-6AF7/songbird_2.0.0-1~getdeb1_i386.deb
Sélection du paquet songbird précédemment désélectionné.
(Lecture de la base de données... 191106 fichiers et répertoires déjà installés.)
Dépaquetage de songbird (à partir de .../songbird_2.0.0-1~getdeb1_i386.deb) ...
dpkg: des problèmes de dépendances empêchent la configuration de songbird :
 songbird dépend de firefox ; cependant :
  Le paquet firefox n'est pas installé.

dpkg: erreur de traitement de songbird (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Des erreurs ont été rencontrées pendant l'exécution :
 songbird



Il manque Firefox. Comment t'as fait pour qu'il te le demande pas ?

Dernière modification par Ralph W. Llama (11-10-2013 19:38:24)


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#11 11-10-2013 20:49:36

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

bon je ne me rappelle p.lus mais je suis sûre de l'avoir installé

je vais recommencé

Hors ligne

#12 11-10-2013 21:15:36

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

Bien j'ai fait la manip comme toi et j'ai eu le même résultat. sad

Désolé, j'était pourtant sûre de l'avoir déjà fait.

Hors ligne

#13 11-10-2013 21:53:54

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

Sinon j'avais trouvé la dernière version officiellement supportée : http://www.toocharger.com/fiches/linux/ … /19028.htm
Un peu vieille mais elle marche, et c'est pas un package .deb, juste une archive, faut juste extraire les dossiers, donc ça fout pas la merde avec Firefox. J'aurais préféré avoir une version plus récente, mais entre ça et un truc qui tourne avec Wine...

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#14 11-10-2013 22:09:01

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

j'ai réussi à installer la version 2.00

il faut télécharger cette archive: http://ftp.dk.debian.org/getdeb/ubuntu/ … rig.tar.xz

l'extraire avec file-roller
on obtient un tar.gz qu'il faut aussi extraire.
On a alors un dossier songbird avec dedans un fichier songbird. Double clic sur ce fichier et l'installation se fait. Il suffit de suivre les instructions et ça marche. smile

Hors ligne

#15 14-10-2013 10:51:36

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

Merci pour le lien !

J'ai téléchargé, extrait le dossier, mais au début, en le lançant, il se passait rien. J'ai tenté de le lancer depuis un terminal, et le terminal me disait "couldn't load XPCOM". En cherchant sur Google, je tombe sur ça : http://support.mozilla.org/fr/questions/890256 C'est pour Firefox, Songbird étant basé sur Firefox j'ai pensé que ça pourrait marcher. Effectivement, une fois ia32-libs-gtk installé, les choses se passent différemment. Mais pas mieux.

J'ai lancé depuis un terminal pour avoir plus d'infos. Quand je lance, j'ai ça qui se passe :

antoine@PC:~$ /usr/local/Songbird/songbird

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »

(songbird-bin:9335): GStreamer-WARNING **: Failed to load plugin '/usr/local/Songbird/gst-plugins/libgstmatroska.so': libbz2.so.1: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type

(songbird-bin:9335): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpython.so': /usr/lib/gstreamer-0.10/libgstpython.so: mauvaise classe ELF : ELFCLASS64

(songbird-bin:9330): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(songbird-bin:9330): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(songbird-bin:9330): Gdk-WARNING **: gdk_window_set_icon_list: icons too large



Puis un message d'erreur en graphique :

10265402186_4a0eb7ae41_o.png

Quand je clique sur Delete Library and Restart, la même chose s'affiche dans le terminal, puis le même message d'erreur revient.

Et quand je clique sur Continue Anyway, Songbird se ferme.

J'ai désinstallé la version Windows au cas où, ça change rien. Qu'est-ce que je peux faire d'autre ?

Merci d'avance, encore !

EDIT : lancé avec sudo, Songbird s'installe sans problème. J'attends qu'il ait fini de s'installer pour voir si il se lance bien en user.

REEDIT : et non, il ne se lance toujours pas bien en user.

Dernière modification par Ralph W. Llama (14-10-2013 11:00:08)


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#16 14-10-2013 16:44:40

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

(songbird-bin:9330): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « murrine »



Chez moi cela fonctionne j'ai même indiqué où se trouvaient mes fichiers de musique lors du 1er lancement.

Je vois que chez toi, il est dans /usr/local/ et chez moi je l'ai laissé dans mon /home/utilisateur/songbird/

Par contre, je suis en testing (jessie) avec xfce4.10, en i386 et j'ai le paquet murrine-themes qui est installé : http://packages.debian.org/fr/wheezy/murrine-themes

Je n'ai pas testé sur le PC de Bureau qui est en Amd64 et en version stable Wheezy.

Essaie d'installer murrine-themes pour voir.

Hors ligne

#17 14-10-2013 17:04:38

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

Je viens d'essayer d'installer murrine-themes... c'est déjà installé. Donc autre problème.

Le fait qu'il fonctionne en root et pas en user peut être une piste... par contre en mettant le dossier /home/antoine ça change rien, donc c'est pas du à un problème de droits sur le dossier d'installation.

À tout hasard, où peut être cette bibliothèque qui est corrompue, et est-ce que ça risque quelque chose de tenter de la supprimer manuellement ?

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#18 14-10-2013 17:13:10

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

Es tu en i386 ou en amd64?

Hors ligne

#19 14-10-2013 17:22:11

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

Je suis en amd64. Tu me fais d'ailleurs penser qu'il faut que j'essaie en i386 pour voir si ça change quelque chose.

Au passage, j'ai supprimé murrine-themes pour voir, ça réduit la liste :

/usr/local/Songbird/songbird

(songbird-bin:12969): GStreamer-WARNING **: Failed to load plugin '/usr/local/Songbird/gst-plugins/libgstmatroska.so': libbz2.so.1: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type

(songbird-bin:12969): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpython.so': /usr/lib/gstreamer-0.10/libgstpython.so: mauvaise classe ELF : ELFCLASS64

(songbird-bin:12964): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(songbird-bin:12964): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(songbird-bin:12964): Gdk-WARNING **: gdk_window_set_icon_list: icons too large



Ces deux lignes,

(songbird-bin:12969): GStreamer-WARNING **: Failed to load plugin '/usr/local/Songbird/gst-plugins/libgstmatroska.so': libbz2.so.1: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type



et

(songbird-bin:12969): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpython.so': /usr/lib/gstreamer-0.10/libgstpython.so: mauvaise classe ELF : ELFCLASS64



ont l'air d'être les plus importantes. Je continue à chercher de ce coté, si entre temps t'as une idée...


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#20 14-10-2013 17:25:13

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

Et bien moi je suis en i386 et je pense que ça viens de là tout simplement.

j'ai le même problème avec Firefox qui s'installe comme l'archive de songbird.
http://support.mozilla.org/fr/kb/instal … efox-linux

En i386 impeccable et en amd64 impossible à faire fonctionner.

Hors ligne

#21 14-10-2013 17:46:10

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

Ouais bah j'ai essayé sur mon autre laptop, qui est en i386, et ça me donne ça :

antoine@Gnunux:~$ /usr/local/Songbird/songbird

songbird: Cannot execute .



Au moins le amd64 avait la décence de donner des informations. Là, même pas. Je peux aller me gratter.

Pas trop le temps de chercher de ce côté pour l'instant, je m'en occuperai plus tard.


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#22 14-10-2013 21:31:41

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

moi pour lancer songbird en console, je me met dans le répertoire Songbird et j'entre la commande suivante:

./songbird

Hors ligne

#23 14-10-2013 21:33:41

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

Ouais bah ça revient au même.

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#24 14-10-2013 21:35:33

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] Problème de son avec Songbird

bon ben là je sèche. sad

Voilà les message que j'ai mais ça fonctionne.

./songbird

(process:4798): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(songbird-bin:4803): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpython.so': /usr/lib/gstreamer-0.10/libgstpython.so: undefined symbol: PyList_Insert

(songbird-bin:4798): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(songbird-bin:4798): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(songbird-bin:4798): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

Hors ligne

#25 15-10-2013 10:49:38

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Problème de son avec Songbird

J'ai remplacé manuellement le fichier libgstmatroska.so situé dans le répertoire d'installation, qui était soi-disant introuvable, par un fichier trouvé dans /usr/lib/x86_64-linux-gnu/gstreamer-0.10. Ça a changé un peu, mais ça marche pas mieux.
Voilà comment sont maintenant les deux lignes qui m'intéressent :

(songbird-bin:21101): GStreamer-WARNING **: Failed to load plugin '/usr/local/Songbird/gst-plugins/libgstmatroska.so': /usr/local/Songbird/gst-plugins/libgstmatroska.so: mauvaise classe ELF : ELFCLASS64

(songbird-bin:21101): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpython.so': /usr/lib/gstreamer-0.10/libgstpython.so: mauvaise classe ELF : ELFCLASS64



Un peu de recherche me montre que le problème vient du fait que les fichiers libgstmatroska.so et libgstpython.so sont prévus pour un système en amd64, alors que Songbird voudrait ces fichiers prévus pour i386. Sachant que les fichiers en question sont situés dans le répertoire d'installation de Songbird, les remplacer n'affectera pas le système, uniquement Songbird. C'est donc ce que je voudrais faire, mais... où puis-je trouver ces fichiers ?

EDIT : un instant, je cherche sur mon laptop i386.

REEDIT : bon, ça marche pas mieux. Une fois libgstmatroska.so remplacé par le fichier trouvé sur un système i386, j'ai de nouveau l'erreur d'avant (aucun fichier ou dossier de ce type).
Et pour libgstpython.so, j'avais mal lu, il est dans un dossier système, donc je peux pas le remplacer.

Comment faire, donc ?

Dernière modification par Ralph W. Llama (15-10-2013 10:58:22)


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

Pied de page des forums