Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-10-2013 14:55:23

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

[Résolu] Impossible de changer le thème couleur pour Vim

Bonjour,
Je m'initie à vim que je trouvais difficile au départ mais peu à peu les habitudes rentrent. J'ai donc décidé de changer de thème pour avoir un confort visuel. J'ai suivi pleins d'explications sur le web (vu que ça ne marchait pas je recommençais et ça plusieurs fois, je suis même allée jusqu'à désinstaller proprement le tout pour tout remettre, j'y ai passé 2h) mais rien n'y fait.
La situation : la machine en question est sous Debian wheezy avec bureau xfce. J'ai mon fichier de configuration .vimrc à la base de mon home utilisateur et aussi un répertoire .vim. Dans ce répertoire .vim j'ai mis un répertoire colors où j'ai mis le thème molokai.vim trouvé sur internet (j'ai essayé avec d'autres aussi avant).
Dans mon .vimrc j'ai mis quelques lignes pour une personnalisation de base du genre. Entre autres :


set nocompatible
syntax on
set background=dark
 



J'ai donc aussi ajouté :


colorscheme molokai
 



Mais rien ne change. J'ai essayé d'ajouter .vim après molokai. Dans ce cas, vim me déclenche une erreur quand j'essaie de l'utiliser en disant :

 Impossible de trouver le jeu de couleurs molokai.vim


Je n'ai pas d'erreur quand je ne mets pas .vim mais le thème n'est pas modifié. Je ne comprends pas du tout alors que ça semble tout simple, je dois zapper quelque chose.
:-(
Merci pour toute info qui m'aiderait.

Dernière modification par starrygnu (07-10-2013 11:23:00)


---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#2 05-10-2013 15:17:05

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Salut,

Il faut que le colorscheme molokai soit physiquement présent dans ton disque dur. Ça veut dire :

1/ le télécharger depuis cette page
2/ déplacer le fichier (qui doit porter le nom molokai.vim) dans le dossier ~/.vim/colors/
3/ charger le thème en tapant dans vim

:colorscheme molokai



Edit :

Désolé j'ai lu trop rapidement et tu possèdes déjà le fichier.

As-tu essayé dans gvim ?

Dernière modification par Lunatic (05-10-2013 15:26:55)


Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#3 05-10-2013 16:49:48

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Tu as ce problème avec n'importe quel terminal?

YA3HGA-H

Hors ligne

#4 05-10-2013 16:55:23

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Effectivement j'ai téléchargé le thème, pas sur la page que tu indiques mais à un autre endroit. Et je l'ai mis dans ~/.vim/colors
Comme je voulais que le changement soit pris en compte tout le temps dans .vimrc j'ai indiqué :


colorscheme molokai
 


sans : avant puisqu'apparemment les : c'est quand on le fait directement dans vim pour un changement temporaire.

Quant à gvim je n'en ai pas besoin et ne l'ai pas parce que j'utilise vim qu'en console.

J'ai essayé de relancer vim en mettant en commentaire 


syntax on
set background=dark
colorscheme molokai
 


pour voir la différence et quand je relance il n'y en a aucune.
Du coup je pense qu'il y a un problème plus vaste. Comme s'il y avait un autre fichier de config ailleurs qui prenait le pas sur celui là. C'est possible? Je suis sur une session d'un utilisateur, pas sur celle de root.


---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#5 05-10-2013 17:00:10

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Thuban a écrit :

Tu as ce problème avec n'importe quel terminal?



Je l'ai dans n'importe quel terminal quand je suis dans une session graphique et également quand je suis en mode console (Ctrl Alt F1)


---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#6 05-10-2013 19:56:45

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

(Edit : rien. Faut vraiment que je me repose et que je relise attentivement les messages roll)

Re-edit : que renvoie la commande

:set t_Co

Dernière modification par Lunatic (05-10-2013 21:05:01)


Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#7 06-10-2013 13:16:36

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Merci de tes réponses.
Alors le résultat de la commande est :


t_Co=8
 


Je ne sais pas ce que ça veut dire…
roll


---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#8 06-10-2013 13:41:31

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

C'est le nombre de couleurs gérées par vim.

Il faut savoir que tu n'obtiendras pas le même rendu dans un tty (ctrl +alt + F1) et dans un terminal dans une session graphique. Dans le premier cas tu seras limité à 8 couleurs, dans le second, à 256. Je te propose donc, pour le moment, de ne faire tes manipulations que dans un terminal, en session graphique. On verra ensuite.

Tu peux ajouter

set t_Co=256



dans ton .vimrc. Ensuite, relance vim, et exécute :

:runtime syntax/colortest.vim



Tu devrais avoir une liste avec le nom de plusieurs couleurs (darkred, darkgreen, etc.). Il faut vérifier que ces couleurs s'affichent convenablement (par exemple, que darkred et red soient bien deux couleurs différentes). Cela permettra de déterminer si ton vim peut afficher 256 couleurs (n'hésite pas à poster une copie d'écran).

Si jamais tu ne vois pas toutes les couleurs, essaie de lancer vim de la sorte :

TERM=xterm-256color vim



et relance la commande précédente.

Bon courage wink


Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#9 06-10-2013 16:50:50

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

Re : [Résolu] Impossible de changer le thème couleur pour Vim

J'ai fait tout comme tu m'as dit big_smile
Et après quand j'ai la liste des couleurs dans un terminal d'une session graphique je les vois bien toutes distinctement.
Et maintenant j'ai t_Co=256 comme réponse.

Dernière modification par starrygnu (06-10-2013 17:05:53)


---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#10 06-10-2013 17:19:38

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Alors, j'avance un peu. Je suis allée en root dans un fichier vimrc qui est dans /usr/share/vim
Là j'ai commenté quelques lignes qui concernaient l'apparence :

syntax on
set background=dark


Ensuite je suis retournée dans ma session utilisateur. Et là oh miracle molokai fonctionne quand je suis dans le terminal. Par contre si je vais dans un tty, j'ai une couleur bleue claire et c'est très difficile à lire. Alors que juste avant j'avais des couleurs pas très belles mais lisibles.
J'ai essayé alors d'enlever la ligne

set t_Co=256

mais alors tout redevient comme avant même dans la session graphique.
C'est gênant parce que soit j'ai un super affichage dans le terminal de la session graphique et un truc quasi illisible dans le tty soit j'ai les deux qui sont lisibles mais pas beaux!
mad
C'est normal ?

Dernière modification par starrygnu (06-10-2013 17:19:57)


---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#11 06-10-2013 18:04:00

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

C'est ce que je te disais précédemment : tu n'as pas le même nombre de couleurs dans un tty et dans un terminal. Du coup, un thème qui passe très bien dans le second risque de mal passer dans le premier, vu qu'il n'est pas fait pour.

Il suffit d'utiliser des colorschemes différents selon l'environnement.

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#12 06-10-2013 18:21:57

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Bonjour,

Il existe une extension qui permet d'utiliser un colorscheme prévu pour l'interface X11,
sur un terminal. Il ne faut pas en attendre des miracles, mais ça peut être intéressant.

           http://www.vim.org/scripts/script.php?script_id=2390

Peut être, que ce plugin peut te convenir.

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#13 06-10-2013 21:02:56

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Il suffit d'utiliser des colorschemes différents selon l'environnement.


Mais c'est possible de spécifier des colorschemes différents dans le .vimrc selon si je suis dans une session graphique ou pas ?
Sinon intéressant ton site Marie-Lou, je suis allée jeter un coup d'œil.
cool

@enicar
Je vais aller jeter un coup d’œil à ce plugin. Merci pour l'info.


---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#14 06-10-2013 21:31:26

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Tu peux tenter de mettre le nombre de couleurs par défaut de vim à 8, et de passer à 256 si la variable TERM équivaut à xterm-color256, avec un colorscheme souhaité à chaque fois :


t_Co=8
colorscheme ton_colorscheme
if $TERM == "xterm-256color"
  set t_Co=256
  colorscheme ton_colorscheme2
endif
 



J'sais pas si c'est la meilleure solution…

Une précision supplémentaire : la plupart des colorschemes que l'on trouve sont en fait faits pour gvim (pour le savoir, faut les ouvrir et vérifier l'existence de commandes « guifg »)

Dernière modification par Lunatic (06-10-2013 21:45:28)


Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#15 06-10-2013 22:25:15

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

Re : [Résolu] Impossible de changer le thème couleur pour Vim

C'est à dire que s'il y a des commandes « guifg » c'est que c'est pour gvim ou c'est l'inverse?
De toute façon molokai me va très bien à part le souci pour les tty. Les couleurs sont belles et c'est très lisible.
Et je suppose que ça existe des thèmes compatibles tty et terminal session graphique? Si quelqu'un a des noms…
wink

---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#16 06-10-2013 22:35:06

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Oui, si tu vois « guifg », c'est pour gvim. Mais ça ne veut pas dire non plus que ça ne peut pas donner un résultat correct autrement… Faut tester, quoi.

Pour trouver des thèmes qui passeront bien en tty, tu peux faire des recherches en tapant explicitement «  8 colors ». Jellybeans est un des résultats sur lesquels tu peux tomber.

Dernière modification par Lunatic (06-10-2013 22:36:02)


Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#17 07-10-2013 11:22:03

starrygnu
Membre
Lieu : Lille
Distrib. : Debian jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 29-07-2013

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Merci pour toutes ces infos. J'ai plus qu'à faire des esssais.
cool

---- "Quand les gens sont d’accord avec moi, j’ai toujours le sentiment que je dois me tromper."---- (Oscar Wilde)

Hors ligne

#18 07-10-2013 11:25:57

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

De rien. Et si tu cherches des colorschemes, tu peux regarder par là, puisqu'il y en a plus de 400…
Pour faciliter leur utilisation et leur test, tu peux passer par le plugin ScrollColors

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#19 07-10-2013 12:36:37

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Impossible de changer le thème couleur pour Vim

Salut,

Il est possible de donner des options différentes à vim et gvim par exemple en renseignant le .gvimrc

man vim a écrit :

~/.gvimrc      Initialisation de gvim pour votre compte utilisateur.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums