Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-10-2013 20:55:02

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Alsa Renseignement au niveau documentation

Bonsoir,

J'ai suivi la documention :
http://debian-facile.org/doc:materiel:c … epannage?s[]=alsa

Niveau 4ème solution

Un cat /proc/asound/modules

me donnait :

snd_hda _intel par exemple avec des "_"


Dans le /etc/modprobe.d/alsa-base.conf
Je dois ajouter l'option :
options snd-hda-intel  index=1  mais cette fois avec des "-"

Je vu mon erreur car j'avais mis:
options snd_hda_intel  index=1

Mais voilà avec cette "erreur" ça fonctionne pareil.

Vous pourriez m'en dire plus sur le "_" du cat à remplacer par un "-" pour la configuration ?


De plus pour le config où

options snd-usb-audio index=-2  est en index -2 qui voudrait dire si j'ai bien compris une priorité première.
Donc si je rajoute en option:
snd-usb-audio index=0
Ne faudrait-il pas commenter cette ligne  options snd-usb-audio index=-2 ou même mettre 0 à celle-ci ?


Ou tout commenter comme j'ai vu sur un tuto :


# Prevent abnormal drivers from grabbing index 0
#options bt87x index=-2
#options cx88_alsa index=-2
#options snd-atiixp-modem index=-2
#options snd-intel8x0m index=-2
#options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
#options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
#options snd-usb-audio index=-2

#MA CONFIG
option bla bla bla
option bla bla bla
option bla bla bla
 

Dernière modification par golgot200 (19-10-2013 21:07:48)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#2 09-05-2014 12:37:27

Invité-5
Banni(e)

Re : Alsa Renseignement au niveau documentation

Mieux vaut tard que jamais

Vous pourriez m'en dire plus sur le "_" du cat à remplacer par un "-" pour la configuration ?


Il me semble que j'ai suivi les écritures dans le fichier /etc/modprobe.d/alsa-base.conf j'ai mis donc "-" pour l’éviter un sac d'embrouilles.

De plus pour le config où
options snd-usb-audio index=-2  est en index -2 qui voudrait dire si j'ai bien compris une priorité première.
Donc si je rajoute en option:
snd-usb-audio index=0
Ne faudrait-il pas commenter cette ligne  options snd-usb-audio index=-2 ou même mettre 0 à celle-ci ?


Exactement. Bien vu. A part ça je cherche à appliquer la nouvelle méthode ;

options snd slots=snd-usb-audio,snd-hda-intel

dans /etc/modprobe.d/*.conf où * = alsa-base ?

grep usb /etc/modprobe.d/*.conf
/etc/modprobe.d/alsa-base.conf:# Keep snd-usb-audio from beeing loaded as first soundcard
/etc/modprobe.d/alsa-base.conf:options snd-usb-audio index=0

Pied de page des forums