Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-10-2013 19:39:02

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Bug (corrigé): Blender vs Mesa

Salut,
Je tourne sous Wheezy, avec des pilotes libres et une carte radeon R6770:

OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.1.7
OpenGL core profile shading language version string: 1.40




et mon travail est affecté par un bug dans Blender. La sélection d'objet est super lente, manipuler un objet ne pose pas de problème par contre...c'est juste le fait de passer de l'un à l'autre qui est super long.
En fouillant le web je suis tombé sur ce bug qui date de 2011 et qui correspond exactement à mes symptômes:
https://bugs.freedesktop.org/show_bug.cgi?id=34495

A partir du commentaire 60, il semble il y avoir un patch disponible pour corriger le problème, mais il ne semble avoir été inclus que dans la version mesa 9.2.

Donc ma question, quel est le meilleur moyen de demander à l'équipe en charge de mesa de le patcher afin que je puisse utiliser blender correctement avec les pilotes libres.

Les bugs mesa chez Debian sont ici mais ne font pas mention de mon problème:
http://bugs.debian.org/cgi-bin/pkgreport.cgi?src=mesa

Hors ligne

#2 25-10-2013 09:14:24

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Bug (corrigé): Blender vs Mesa

Bon, la compilation d'hier soir a échoué. La différence de version entre le git du sujet et downstream Debian doit être trop importante.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 25-10-2013 10:07:25

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Bug (corrigé): Blender vs Mesa

Ok merci quand même.
Tu peux me dire quel patch tu as pris, et appliqué à quel paquet?
Pour que je puisse ouvrir un bug chez Debian?

Hors ligne

#4 25-10-2013 10:26:21

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Bug (corrigé): Blender vs Mesa

j'ai directement fait un checkout de cette version : http://cgit.freedesktop.org/~ab/mesa/lo … gl_select2 (commentaire 62)

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 25-10-2013 10:45:09

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Bug (corrigé): Blender vs Mesa

Comme kao l'a découvert en demandant aux devs, le bug est corrigé dans mesa 9.2 actuellement dans sid. Cette version devrait descendre dans Jessie dans 8 jours si tout va bien. Cf. http://packages.qa.debian.org/m/mesa.html

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#6 25-10-2013 10:57:35

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Bug (corrigé): Blender vs Mesa

Ok cool, je vais essayer de me pencher sur le pinning pour pouvoir tester ça en avant première. smile

Edit: j'ai fait des tests d'upgrade de mesa, mais il y aurait trop de casse sur les paquets, notamment sur notre cher Gnome smile
Je vais prendre mon mal en patience....

Hors ligne

#7 25-10-2013 17:21:52

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Bug (corrigé): Blender vs Mesa

Bon finalement, il n'a pas été intégré encore à mesa
https://bugs.freedesktop.org/show_bug.cgi?id=34495#c73
C'est un peu dommage parce que plus ils attendent plus ce sera dur de le faire....
En attendant, je vais passer sur les pilotes propriétaires.....pour pouvoir utiliser Blender.
Je suis à un bug d'abandonner ces fichus pilotes, c'est balo.

Hors ligne

#8 25-10-2013 19:35:45

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Bug (corrigé): Blender vs Mesa

Par contre, le dernier commentaire dit que dans la 9.2.1 y'a plus les bugs, pê qu'ils ont été corrigés autrement ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 25-10-2013 19:52:25

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Bug (corrigé): Blender vs Mesa

J'ai vu, c'était peut être deux bugs avec les mêmes symptômes.

Hors ligne

#10 03-11-2013 10:54:11

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Bug (corrigé): Blender vs Mesa

Je confirme la bonne réception de Mesa 9.2.2:

OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.2
OpenGL core profile shading language version string: 1.40
OpenGL version string: 3.0 Mesa 9.2.2
OpenGL shading language version string: 1.30
 



J'ai pu reprendre mes activités sous Blender, les sélections  sont redevenues rapides.
Il semblerait que je ne sois plus affecté par le bug.
Je vais le signaler upstream.

Hors ligne

Pied de page des forums