Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-11-2013 13:27:24

louispolaire
Membre
Distrib. : Siduction
Noyau : Linux 4.1.1-towo.1-siduction-amd64
(G)UI : xfce 4.12
Inscription : 22-08-2013

[RESOLU] problème permission utilisateur

Bonjour,

J'ai un soucis depuis une semaine, mon compte utilisateur n'est plus autorisé à rebooter, shutdown, à monter les disques (en cliquant sur l'icone du disque dans Thunar), à se connecter à un nouveau réseau wifi à lancer gparted ou synaptic depuis le menu des applications (donc besoin du mot de passe root à travers xfce).

Je suis sur siduction, mon systeme est à jour, j'utilise systemd depuis 2 mois et tout allait bien. j'ai bien libpam-systemd installé, et policykit-1...

Quelqu'un a une idée ? Je tourne en rond...

Dernière modification par louispolaire (10-11-2013 14:38:50)


Taisez-vous ! On vous écoute... - Exprimez-vous ! Personne n'écoute...

Hors ligne

#2 09-11-2013 13:52:41

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] problème permission utilisateur

Salut,

C'est arrivé depuis que tu es passé en systemd 204-5 ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 09-11-2013 23:40:09

louispolaire
Membre
Distrib. : Siduction
Noyau : Linux 4.1.1-towo.1-siduction-amd64
(G)UI : xfce 4.12
Inscription : 22-08-2013

Re : [RESOLU] problème permission utilisateur

Non je crois pas que ce soit lié, le problème est apparu la semaine dernière et il me semble que j'ai fait le d-u avec systemd 204-5 bien avant.

peut être une question plus directe : dans quel log chercher des indices supplémentaires pour ce type de pb ?

Taisez-vous ! On vous écoute... - Exprimez-vous ! Personne n'écoute...

Hors ligne

#4 10-11-2013 03:18:45

david96
Invité

Re : [RESOLU] problème permission utilisateur

Par intuition, j'irai voir du côté :

~/.xsession-errors

#5 10-11-2013 13:40:33

louispolaire
Membre
Distrib. : Siduction
Noyau : Linux 4.1.1-towo.1-siduction-amd64
(G)UI : xfce 4.12
Inscription : 22-08-2013

Re : [RESOLU] problème permission utilisateur

Ok c'est bon j'ai trouvé la raison et une (deux en fait) solutions grâce à ça : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=728361

Le problème est apparu avec lightdm 1.8 et libpam-systemd

Si ça vous arrive il y a 2 solutions :

apt-get remove libpam-systemd



ou
commenter la ligne suivante dans /etc/pam.d/common-session :

session optional     pam_systemd.so


Taisez-vous ! On vous écoute... - Exprimez-vous ! Personne n'écoute...

Hors ligne

#6 10-11-2013 13:44:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] problème permission utilisateur

Merci du retour ! smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#7 10-11-2013 13:44:37

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [RESOLU] problème permission utilisateur

Ah oui, j'avais zappé ce truc. Bien joué et merci pour le retour.

    C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 10-11-2013 13:57:30

david96
Invité

Re : [RESOLU] problème permission utilisateur

Rhaaa, il a chipé le chocolat ! mad


smolski a écrit :

Merci du retour ! smile


Je plussoie… Merci Louispolaire cool

#9 10-11-2013 15:36:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] problème permission utilisateur

Ouais mais bon moi j'bosse là !
Y'en a qui ont pas d'moralité ! roll

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#10 10-11-2013 15:58:05

louispolaire
Membre
Distrib. : Siduction
Noyau : Linux 4.1.1-towo.1-siduction-amd64
(G)UI : xfce 4.12
Inscription : 22-08-2013

Re : [RESOLU] problème permission utilisateur

Encore mieux :

garder libpam-systemd installé,

pam-auth-update --force



et selectionner uniquement Unix Authentification.

Les solutions précédentes m'ont causé des soucis avec libGL (plus de cairo-dock :'( ...)


Taisez-vous ! On vous écoute... - Exprimez-vous ! Personne n'écoute...

Hors ligne

#11 10-11-2013 22:39:39

david96
Invité

Re : [RESOLU] problème permission utilisateur

C'est bon à souligner, merci smile

Pied de page des forums