Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-11-2013 02:05:26

lebardix
Adhérent(e)
Lieu : Plan de Cuques
Distrib. : Version 7.9 (wheezy) 64 bits
Noyau : Noyau Linux 3.2.0-4-amd64
(G)UI : gnome 3.4.2 fallback
Inscription : 15-10-2013

[Résolu] gdm autologin ne fonctionne pas sur Samsung R40

bonjour,
Je viens d'installer depuis le meme DVD live debian wheezy deux PC, l'un aspire 1650  et l'autre Samsung R40.
Meme procédure d'installation. Bureau Gnome(Classic)
Avec l'aspire 1650  l'autologin fonctionne sans probleme
Avec le samsung , l'autologin ne fonctionne pas, Gdm Greeter s'affiche et la selection de l'utilisateur se deroule normalement, le bureau s'affiche.

Après analyse des logs, sur le samsung la procédure gdm-simple-slave se termine prématurement
resumé de syslog

Nov 24 22:03:25 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmSlave: Starting slave
...
...
Nov 24 22:03:25 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmServer: Starting X server process: /usr/bin/Xorg :0 -br -verbose -novtswitch -logverbose 7 -core -auth /var/run/gdm3/auth-for-Debian-gdm-DEkCa3/database -nolisten tcp vt7
Nov 24 22:03:25 pc-soun gdm-simple-slave[2923]: DEBUG(+): GdmServer: Opening logfile for server /var/log/gdm3/:0.log
Nov 24 22:03:25 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmServer: Started X server process 2923 - waiting for READY
Nov 24 22:03:25 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmSimpleSlave: Started X server
.... association du reseau..
Nov 24 22:03:29 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmServer: child (pid:2923) done (signal:6)
Nov 24 22:03:29 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmSimpleSlave: server died with signal 6, (Abandon)
Nov 24 22:03:29 pc-soun gdm-simple-slave[2904]: DEBUG(+): slave finished
Nov 24 22:03:29 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmSimpleSlave: Stopping simple_slave
Nov 24 22:03:29 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmSlave: Stopping slave
Nov 24 22:03:29 pc-soun gdm-simple-slave[2904]: DEBUG(+): GdmSlave: Disconnected from display



ensuite la procedure reprend avec gdmgreeter qui me permet de me connecter avec le mot de passe.

une idée sur une piste à chercher ?

Dernière modification par lebardix (26-11-2013 23:54:05)

Hors ligne

#2 26-11-2013 11:52:55

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [Résolu] gdm autologin ne fonctionne pas sur Samsung R40

Salut lebardix,
Comme tu viens de l'installer, as tu fait toutes les mises à jour?
Quelle version de gdm est installé actuellement:

apt-cache policy gdm3



Peut être ton bug est lié à un problème de pilote graphique, mais j'en suis moins sur.
Peux tu nous donner des infos sur ta carte graphique et le pilote que tu utilises?

Hors ligne

#3 26-11-2013 15:56:58

lebardix
Adhérent(e)
Lieu : Plan de Cuques
Distrib. : Version 7.9 (wheezy) 64 bits
Noyau : Noyau Linux 3.2.0-4-amd64
(G)UI : gnome 3.4.2 fallback
Inscription : 15-10-2013

Re : [Résolu] gdm autologin ne fonctionne pas sur Samsung R40

Bonjour,

Voilà je viens de préparer un dossier comparatif entre les 2 machines Acer->OK et Samsung -> KO
Je crois avoir vu le probleme, le premier lancement de X par gdm-slave-simple aborte sur VT7, le log /var/log/gdm3/:0.log.1 indique Server terminated with error (1). Closing log file.    , par la suite le second log cette fois initier par gdm-greeter sur VT8 est correct et permet la poursuite de la connexion manuelle.

la différence entre les 2 logs  apparait dans le diff des 2 fichiers voir http://ogm-techno.org/defaut-gdm3/ko-sa … gdmgreeter

Pour info tu peux trouver les informations comparatives entre les 2 machines http://ogm-techno.org/defaut-gdm3/

Par contre je suis bien incapable de comprendre ce probleme
(II) [KMS] drm report modesetting isn't supported.        |    (II) [KMS] Kernel modesetting enabled. entre les 2 lancement de X

Merci de votre aide

Hors ligne

#4 26-11-2013 16:20:36

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] gdm autologin ne fonctionne pas sur Samsung R40

Salut,

Le pb semble venir de la configuration de la carte radeon. Ça n'est pas gdm qui échoue mais le serveur X.

Je te propose d'aller jeter un coup d'œil sur la page des cartes graphiques ati / radeon sur notre wiki, voire d'essayer d'installer les firmware (comme décrit sur ladite page).

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 26-11-2013 23:51:48

lebardix
Adhérent(e)
Lieu : Plan de Cuques
Distrib. : Version 7.9 (wheezy) 64 bits
Noyau : Noyau Linux 3.2.0-4-amd64
(G)UI : gnome 3.4.2 fallback
Inscription : 15-10-2013

Re : [Résolu] gdm autologin ne fonctionne pas sur Samsung R40

[probleme résolu] en supprimant les pilotes propriétaires comme indiqué dans le wiki

Suppression du pilote propriétaire

Pour éviter tout confit :

aptitude purge '~ifglrx'
rm -f /etc/X11/xorg.conf

merci captnfab wink

Hors ligne

#6 27-11-2013 00:02:36

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] gdm autologin ne fonctionne pas sur Samsung R40

\o/
Merci pour ton retour smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums