Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-11-2013 20:29:25

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Debian sur Acer Aspire v3 772/772G

Bonjour, voici mon rapport d'installation de Debian sur un Acer Aspire v3 772/772G

Installation en mode legacy en dualboot avec w8 de PointLinux (n'étant pas disponible en mode efi):

L'installation marche très bien debian aussi, sauf le réseau (je ne sais toujours pas pourquoi, la carte et le réseau sont reconnus, mais impossible de se connecter).

Quoi qu'il en soit, j'essaye d'installer Debian depuis un net install en mode efi (supporté par wheezy)

Super ça marche, mais quand je boot pas d'interface graphique !
J'instal les drivers nvidia, les firmware nonfree, je met à jour vers le noyaux 3.10 mais toujours pas d'interface graphique (startx: no screen found)
et quand je boot sous 3.10 écran noir !

Du coup je regarde maintenant pour installer lmde (en mode efi) (non pas que je sois fan, mais je suis curieux de voir quels changements y ont été apportés depuis 1 an)

Est-ce que quelqu'un a toute fois une idée sur mes deux problèmes à savoir
- impossible de lancer x, startx me renvoi no screen found
- écran noir quand je charge le noyau 3.10

ça me parraît quand même bizard ce problème. J'ai fais des recherches sur internet mais je n'ai rien trouvé. Je me dis qu'à la limite cela pourrait venir du fait que j'ai une carte GT750M et une HD4600 d'intel, mais le mode console marche ... et surtout sous Point Linux l'interface marchait (cela peut peut être être du que j'avais installé en legacy et non en efi ? )

je vous tiens au courant des évolutions.

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#2 28-11-2013 22:03:14

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Debian sur Acer Aspire v3 772/772G

LMDE marche donc (en mode legacy, l'efi n'étant une fois de plus indisponible) et il me dit que ma carte GT750M n'est pas reconnue.

Après x heures de recherches supplémentaires il semblerait du fait que la GT750M soit une carte récente, seuls les drivers 319 et supérieurs de nvidia la prennent en charge.

Je vais donc mettre à jour les 1000 et quelques paquets sur ma lmde, vérifier que tout fonctionne, essayer de faire marcher ma carte nvidia et quand tout ce-ci sera fait, je pourrais enfin repasser à debian ... avec les dépôts unstable/experimental pour les drivers peut être ?


Mais cependant ce n'est pas normal que la carte d'intel ne fonctionne pas sous debian en mode efi.

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#3 30-11-2013 15:55:53

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Debian sur Acer Aspire v3 772/772G

j'ai installé debian testing et après quelques manips dont je ne me souviens déjà plus (j'ai ajouté acpi_backlight=vendor et nomodeset=0 pour le chargement du noyaux) j'arrive à lancer debian entrer dans la session gnome, ça marhce très bien, internet aussi (filaire et wifi) mais tout ça sur la carte graphique intel (si on peut appeler ça carte graphique).

Ayant nvidia optimus (pour ma carte Gt750M), je me rend compte que cette technologie est affreusement mal pris en charge sous linux.
du coup j'essaye tant bien que mal, mais plutôt mal que bien de faire marcher ma carte nvidia notamment grâce à bumblebee mais aucun succès.

Finalement en tapant la commande:

lspci | grep VGA


il me renvoi uniquement la carte intel

si j'entre lspci j'ai bien la carte nvidia avec quelque chose comme:

01:00.0 3D controller: Nvidia ... GK107M ... (rev ff)



est-ce quelqu'un a déjà réussit à faire marcher une telle config sur son ordi ?


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#4 30-11-2013 17:46:58

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Debian sur Acer Aspire v3 772/772G

je commence à peut près à comprendre le fonctionnement de cette technologie.

En créant le fichier /etc/X11/xorg.conf je faisait crasher la config > après sa suppression (tout en gardant bumblebee, nvidia-driver ... installés) j'arrive à nouveau à lancer debian en mode graphique (sur la carte intel). (Je dois toujours ajouter acpi_backlight=vendor à la ligne de grub lors du lancement.

du coup je fais des test en éxécutant glxgears

primusrun glxgear -info me retourne bien GL_RENDERER = GeForce GT 750M/PCIe/SSE2

mais niveau performance avec et sans primusrun (ou optirun) j'obtiens toujours dans les 300FPS

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#5 30-11-2013 18:04:10

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Debian sur Acer Aspire v3 772/772G

rectification, il semblerait que la limite de fps soit limité à 60 j'ai donc utilisé

vblank_mode=0 optirun glxgears



qui me donne 3200 à 3500 FPS (charge des coeurs: environ 50%) mais quand j'entre:

vblank_mode=0 glxgears


j'ai dans les 8000 FPS (les 4 cœurs aux alentours de 30% de charge)

lorsque glxgears n'est pas lancé le processeur tourne aux alentours de 2% de charge par cœur.

à noter que régulièrement optirun et primusrun n'ouvrent pas la fenêtre glxgears, je doit alors relancer la commande.

Dernière modification par daufinsyd (30-11-2013 18:05:02)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#6 30-11-2013 20:31:53

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Debian sur Acer Aspire v3 772/772G

C'est une bête de course ce truc.

Tu dois être un peu pionnier sur ce genre de config et Debian.

http://www.lesnumeriques.com/ordinateur … /test.html

Hors ligne

#7 01-12-2013 12:42:29

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Debian sur Acer Aspire v3 772/772G

j'ai un model un peu moins puissant (i5-4200M, GT750M & 8Go RAM) mais qui reste très puissant smile

Ça fait maintenant 1 ans et 1 mois (si mes souvenirs sont bon j'ai migré vers Debian en octobre 2012), il me reste encore beaucoup à apprendre sur Debian et ces récents problèmes m'ont appris beaucoup de choses (et pas encore assez puisque tout ne marche pas encore big_smile)

En fait le plus gros problème (du moins j'espère) c'est la technologie nvidia optimus qui change du coup la façon de configurer les drivers (notamment pas de fichier Xorg si non black screen ! smile )

Quand tout marchera j'ajouterai ma démarche ici
https://wiki.debian.org/InstallingDebianOn/Asus/

Peut être aussi prévenir sur le wiki pour les cartes nvidia (et AMD ?) du changement lorsque l'ordinateur est équipé de optimus ?

maintenant j'essaie de régler ce problème d'allulmage de carte à savoir:

lorsque je lance
vblank_mode=0 optirun glxgears

une fois sur deux il m'affiche un problème (par exemple Cannot acces secondarty GPU ....), l'autre fois aucun problème

et atteint les 3500FPS avec une charge des cœurs à 50%
tandis que sans utiliser optirun, il dépasse les 9000 FPS avec une charge des processeurs à 35%

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

Pied de page des forums