Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-12-2013 21:44:06

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

[Non-Résolu] Gnome, un jour peut être

Bonsoir,

J'ouvre ce sujet dans l'espoire qu'un jour, Gnome et surtout ses applications fonctionnent à nouveau correctement sous ma Debian.

Présentation du problème:
Il y a de nombreux mois (à la sortie de wheezy en fait)
j'ai mis à jour ma sid ainsi que celle de mon frère.
> plusieurs applications tels gnome-terminal ne se lançaient plus.

J'ai essayer en vain depuis ce funeste jour de régler le problème, pour arriver à cette situation:

Gnome est totalement inutilisable. De nombreux programmes de Gnome (gedit, nautilus, gnome-terminal, transmission) ne marchent plus du tout et d'autres programmes utilisant la biblio gtk n'ont plus d'îcones sur les boutons (totem par exemple).

(Pour info: mate et ses logiciels marchent)

voici le fichier .xsession-errors
http://ubuntuone.com/2x23BLfe8kgf8dICYthxBW

je n'y connait pas grand chose, mais deux choses ont attirée mon attentions à savoir:


INFO:dispcalGUI:Dispwin: Error - File '_ICC_PROFILE' is not a valid ICC profile or Argyll .cal file
INFO:dispcalGUI:About to open dispwin object on the display
INFO:dispcalGUI:About to clear the calibration
INFO:dispcalGUI:VW195 @ 0, 0, 1440x900: Le profil d'affichage n'a pu être chargé.



et

ValueError: invalid literal for int() with base 10: ''
Gtk-Message: Failed to load module "canberra-gtk-module"



J'ai fait purge gnome* reinstall, supprimer le dossier .gnome2 et encore bien d'autres choses, mais je n'arrive pas à faire marcher gnome et ses applis.


est-ce que quelqu'un a à tout hasard une idée ???

merci,
daufinsyd

Dernière modification par daufinsyd (07-12-2013 19:03:29)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#2 04-12-2013 22:54:23

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Non-Résolu] Gnome, un jour peut être

Whaw, là de suite, je te dirais de continuer ta purge en recherchant tous les paquets contenants "gnome" dans leur nom et en les supprimant puis en faisant des apt-get autoremove par la suite (virer les librairies).

Je n'ai pas cherché à réinstaller Gnome mais c'est ainsi que j'ai procédé pour en éliminer toute trace de mon système.
Ça pourrait te permettre de repartir sur du sain avant réinstall.

Après n'est-ce pas aussi un problème de conflits de versions des paquets (vu que tu es en sid)?

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#3 04-12-2013 23:23:42

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Non-Résolu] Gnome, un jour peut être

Curieux curieux, il y a bien quelques trucs à reprocher à Gnome3 mais là....


Tu as quoi dans des sources.list et compagnie ?

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#4 05-12-2013 18:23:10

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : [Non-Résolu] Gnome, un jour peut être

Oui je vais retenter de tout réinstaller, je pense que je vais m'amuser avec les conflits smile

Il semblerait quand même que chez de nombreuses personnes ayant sid gnome 3.8 marche, si non y aurait déjà eu x discutions à ce sujet mais cela dit c'est vrai qu'il y a des paquets pour la version 3.8 d'autres pour la version 3.10 qui cohabitent.
Ce qui me surprend c'est que je n'ai aucun problème avec mate (certes il est basé sur gnome2, mais sur gnome et gtk quand même).

Je vais aussi essayer cinammon (il est basé sur gnome3 pour les version inférieurs à la 2)

mon sources.list

## wheezy
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib non-free

## wheezy multimedia
# deb http://www.deb-multimedia.org wheezy main non-free
# deb-src http://www.deb-multimedia.org wheezy main non-free

## wheezy security
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

## wheezy updates
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ wheezy-updates main contrib non-free

## wheezy proposed-update
deb http://ftp.fr.debian.org/debian/ wheezy-proposed-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy-proposed-updates main contrib non-free


## wheeze-backports
deb http://ftp.fr.debian.org/debian/ wheezy-backports main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy-backports main contrib non-free

## ==================================================
## Jessie
deb http://ftp.fr.debian.org/debian jessie main contrib non-free

# deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
# deb http://ftp.debian.org/debian/ jessie-propose-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

# deb http://www.deb-multimedia.org jessie main non-free

## ==================================================
## sid
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free

## sid multimedia
deb http://www.deb-multimedia.org sid main non-free
deb-src http://www.deb-multimedia.org sid main non-free

# deb http://ftp.debian.org/debian/ Sid-updates main contrib non-free
# deb-src http://ftp.debian.org/debian/ Sid-updates main contrib non-free

# deb http://security.debian.org/ Sid/updates main contrib non-free
# deb-src http://security.debian.org/ Sid/updates main contrib non-free


## ==================================================
## experimental
deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ experimental main contrib non-free

## experimental multimedia (Seulement pour architecture amd64)
# deb http://www.deb-multimedia.org experimental main

## ==================================================

## Unvanquished
deb http://tartarus.org/ds/unvanquished/pkg unstable main
deb-src http://tartarus.org/ds/unvanquished/pkg unstable main

## Freelan ATTENTION: N'est plus maintenu
#deb http://debian.freelan.org/ sid main
#deb-src http://debian.freelan.org/ sid main
# deb-src http://www.deb-multimedia.org experimental main
## Depôt MultiSystem
# deb http://liveusb.info/multisystem/depot all main

## SpaceFM
deb http://ignorantguru.github.com/debian/ unstable main

#Bluefish
deb http://debian.wgdd.de/debian sid main contrib non-free

#TOR
deb http://deb.torproject.org/torproject.org unstable main

#MATE
deb http://repo.mate-desktop.org/debian wheezy main

#Firefox (Iceweasel) mozilla

deb http://mozilla.debian.net/ experimental iceweasel-aurora
 



C'est vrai que je n'aime pas beaucoup la philosophie de gnome, mais néanmoins le bureau est plutôt beau mais surtout j'aime bien gedit (ainsi que quelques autres programmes liées à gnome) et avoir des icônes pour les buttons sur totem big_smile

Edit: cinnamon m'affiche le même message que gnome,

impossible de charger le profile ....



Re-Edit: après avoir donc purgé tous les paquets contenant gnome (en fait pas tous les paquets, puisque certains comme gedit-common ne l'étaient pas), j'installe gedit, totem, gnome-terminal depuis les dépôts stable:

les logiciels marchent (:D), mais les button n'ont pas d'icônes sad
j'essaie d'installer gedit depuis testing et là gedit ne marche plus (mais gnome-terminal oui)

     
aptitude install -t testing gedit
Supprimer les paquets suivants :                                                
1)     libgtksourceview-3.0-0                                                        

     Mettre à jour les paquets suivants :                                            
2)     gir1.2-gtksource-3.0 [3.4.2-1 (now, stable) -> 3.8.2-1 (testing, unstable)]    
3)     libgtksourceview-3.0-dev [3.4.2-1 (now, stable) -> 3.8.2-1 (testing, unstable)]
 



Ce n'est donc pas *gtksource* qui posent problème (oui je suis fort pour enfoncer les portes ouvertes big_smile )

j'essaie quand même d'installer gedit depuis experimental

      Supprimer les paquets suivants :                                                
1)      libcanberra-gtk3-dev                                                          
2)      libgtk-3-dev                                                                  
3)      libgtksourceview-3.0-dev                                                      

      Mettre à jour les paquets suivants :                                            
4)      libgail-3-0 [3.8.6-1 (now, unstable) -> 3.10.2-1 (experimental)]              
5)      libglib2.0-0-dbg [2.36.4-1 (now, testing, unstable) -> 2.38.1-2 (experimental)]
6)      libglib2.0-bin [2.36.4-1 (now, testing, unstable) -> 2.38.1-2 (experimental)]  
7)      libglib2.0-dev [2.36.4-1 (now, testing, unstable) -> 2.38.1-2 (experimental)]  
8)      libgtk-3-0-dbg [3.8.6-1 (now, unstable) -> 3.10.2-1 (experimental)]            
9)      libgtk-3-bin [3.8.6-1 (now, unstable) -> 3.10.2-1 (experimental)]              

      Laisser les dépendances suivantes non satisfaites :                              
10)     glade recommande libgtk-3-dev



et j'ai

(gedit:21385): libpeas-WARNING **: filebrowser: /usr/lib/x86_64-linux-gnu/gedit/plugins/libfilebrowser.so: undefined symbol: gtk_widget_class_bind_template_child_full

(gedit:21385): libpeas-WARNING **: Error loading plugin 'filebrowser'
gedit: symbol lookup error: gedit: undefined symbol: gtk_menu_button_get_type



Re-Re-Edit: lorsque je lance gedit, il me met à présent

gedit: undefined symbol: gtk_widget_register_window

Dernière modification par daufinsyd (05-12-2013 19:51:07)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#5 05-12-2013 23:07:52

taureau89_9
Adhérent(e)
Lieu : A proximité de LFLA
Distrib. : Debian Testing
Noyau : 4.7.0-1-amd64
(G)UI : Gnome 3.20+1 + gnome-shell 3.22.0-1
Inscription : 16-09-2011

Re : [Non-Résolu] Gnome, un jour peut être

T'es bien sûr d'être vraiment en sid avec un sources.list pareil ?

T'as un fichier preferences ?

CM Asus Sabertooth 990FX, Proc FX 8350, 4 x 8Go DDR3 1866Mhz, GTX 750ti 2Go, DD 2 To Sata 3

Hors ligne

#6 06-12-2013 11:45:45

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : [Non-Résolu] Gnome, un jour peut être

oui je pense

## sid
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free

## sid multimedia
deb http://www.deb-multimedia.org sid main non-free
deb-src http://www.deb-multimedia.org sid main non-free



oui j'ai bien un fichier préférence (je n'y ai pas accès je ne suis pas à la maison, je le poste cet aprèm)
mais en gros c'est Sid > Testing > Stable > Experimental (sauf pour iceweasel/icedove, où c'est experimental en premier)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#7 06-12-2013 19:06:03

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : [Non-Résolu] Gnome, un jour peut être

fichier preferences

Package: *
Pin: release o=Debian,a=unstable,l=Debian
Pin-Priority: 900

Package: *
Pin: release o=Unofficial Multimedia Packages,a=unstable,l=Unofficial Multimedia Packages
Pin-Priority: 900

Package: *
Pin: release o=Debian,a=testing,l=Debian
Pin-Priority: 800

Package: *
Pin: release o=Debian,a=testing,l=Debian-Security
Pin-Priority: 800
 
Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing,l=Unofficial Multimedia Packages
Pin-Priority: 800

Package: *
Pin: release o=Debian,a=stable,l=Debian
Pin-Priority: 500

Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-Priority: 500

Package: *
Pin: release o=Debian,a=stable-updates,l=Debian
Pin-Priority: 500

Package: *
Pin: release o=Unofficial Multimedia Packages,a=stable,l=Unofficial Multimedia Packages
Pin-Priority: 500

Package: *
Pin: release o=Unofficial Multimedia Packages,a=experimental,l=Unofficial Multimedia Packages
Pin-Priority: 1

Package: libreoffice
Pin release o=Debian,a=experimental
Pin-Priority: 450

Explanation: Pinned by apt-listbugs at Wed May 15 05:50:19 +0200 2013
Explanation:   #704123: virtualbox-ose: my debian desktop will be shutdown after i click some links.
Package: virtualbox-ose
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Thu Aug 15 16:06:15 +0200 2013
Explanation:   #702900: needs update for pango 1.7 from experimental
Explanation:   #711587: plymouth: Cannot update initramfs due to pango breakage
Explanation:   #704872: needs update for pango 1.7 from experimental
Explanation:   #702040: needs update for pango 1.7 from experimental
Package: plymouth
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Tue Aug 27 18:28:26 +0200 2013
Explanation:   #720618: non-free license statement in /usr/share/inkscape/icons/inkscape.svg
Package: inkscape
Pin: version 0.48.4-1
Pin-Priority: 1000

Explanation: Pinned by apt-listbugs at Tue Aug 27 18:28:26 +0200 2013
Explanation:   #720968: Enables javascript without asking
Explanation:   #719689: iceweasel completely froze X when typing a URL
Package: iceweasel
Pin: version 22.0-1
Pin-Priority: 1000

Explanation: Pinned by apt-listbugs at Mon Sep 02 12:44:48 +0200 2013
Explanation:   #653582: Segfaults when running ruby-hpricot's test suite on ia64
Package: ruby1.9.1
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #720466: cinnamon: Crashes when opening the menu, using command window or hot corner
Package: cinnamon
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #599523: [update-manager-gnome] wants to downgrade packages without any notice
Package: update-manager-gnome
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #611915: Strange locale problem
Package: simple-scan
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #717240: alacarte empties gnome-applications.menu
Package: alacarte
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #723721: gnome-terminal: colors are swapped
Explanation:   #721489: gnome-terminal: window is blank (no output nor echo) but works
Package: gnome-terminal
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #714585: seahorse: Seahorse consistently crashes after selecting to view by keyring once
Package: seahorse
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #700725: gnome-codec-install fails when called from gstreamer1.0
Package: gnome-codec-install
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #717391: sound-juicer: Refuses to start: “The plugin necessary for file access was not found”
Package: sound-juicer
Pin: version *
Pin-Priority: -30000

Explanation: Pinned by apt-listbugs at Sun Nov 10 13:24:07 +0100 2013
Explanation:   #710565: update-notifier: no update-notifier for xfce anymore?
Package: update-notifier
Pin: version *
Pin-Priority: -30000
 


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#8 06-12-2013 19:55:31

taureau89_9
Adhérent(e)
Lieu : A proximité de LFLA
Distrib. : Debian Testing
Noyau : 4.7.0-1-amd64
(G)UI : Gnome 3.20+1 + gnome-shell 3.22.0-1
Inscription : 16-09-2011

Re : [Non-Résolu] Gnome, un jour peut être

Pour le sources.list et le preferences, ok, je ne pense pas que tes problèmes de gnome viennent de là.

Ils m'inspirent d'autant moins que je suis en testing.
Pour la bonne et simple raison que je trouvais que les problèmes récurrents en sid au moment des mises à jour étaient pesants, ce qui m'a amené à revenir en testing.

Qu'est-ce qui justifie vraiment que tu soies en sid ?

CM Asus Sabertooth 990FX, Proc FX 8350, 4 x 8Go DDR3 1866Mhz, GTX 750ti 2Go, DD 2 To Sata 3

Hors ligne

#9 07-12-2013 13:07:21

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : [Non-Résolu] Gnome, un jour peut être

Eh bien justement depuis hier car eh oui, maintenant c'est AUSSI le son qui ne marche plus, je me demande si je ne vais pas reinstaller une testing.
En revanche, comme tu utilises une testing, est-ce lors des périodes de freeze tu peux facilement mettre à jour les paquets de sid comme:
libreoffice, iceweasel/dove, python, steam et deux trois petites choses dans le genre car c'est pour ça que je suis sous sid, j'aime avoir ce qu'il y a de récent big_smile

Si je suis directement allé sur sid c'est à cause de discutions sur des forum dans lesquels on soulignait le fait qu'un bug sous testing met beaucoup de temps à être résolu (à causes des 10 jours sans bugs de unstable ...) et que lors des périodes de freeze, le système devenait compliqué à débeuguer.

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#10 07-12-2013 15:30:39

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Non-Résolu] Gnome, un jour peut être

Au sujet de ton fichier preferences, tu peux ne garder que les paragraphes concernant la version experimental de libreoffice et la branche experimental des dépôts Multimedia (et les ajouts d'apt-listbugs) pour un comportement identique d'APT.
Comme je l'ai écrit dans un article de Wiki d'un forum cousin  :
« La règle d'or du fichier preferences : Plus ce fichier est court, plus le comportement d'APT sera prévisible ! »

Je vous laisse reprendre le cours normal de la discussion, je n'ai pas utilisé GNOME en profondeur depuis des années et risque d'être d'une aide très limité pour la résolution du problème étudié.

Jouer sous Debian ? Facile !

Hors ligne

#11 07-12-2013 19:02:44

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : [Non-Résolu] Gnome, un jour peut être

j'ai donc installé testing (à la place de unstable), en espérant que Gnome et le son ne bug plus , ... indéfiniment big_smile

« La règle d'or du fichier preferences : Plus ce fichier est court, plus le comportement d'APT sera prévisible ! »


oui oui, j'ai déjà lu cette phrase il y a un an ou un peu plus (lors de ma migration de ubnutu à debian big_smile)

Bon maintenant je vais m'attaquer au sources.list smile

Merci pour votre aide, en éspérant enterrer ce sujet pour toujours smile

Remarque: y a rien de mieux pour m'énerver que l'ordi qui marche pas, mais si y avait pas de bugs, ce serait ennuyeux ! (Nan, en fait sans bug j'essayerais de m'attaquer à un niveau plus élevé de prog sur debian, pour en trouver d'autres big_smile . Ce qui m'embête le plus dans cette histoire c'est que je n'ai pas pu apporter une quelconque aide à la communauté sad )


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#12 07-12-2013 19:16:59

taureau89_9
Adhérent(e)
Lieu : A proximité de LFLA
Distrib. : Debian Testing
Noyau : 4.7.0-1-amd64
(G)UI : Gnome 3.20+1 + gnome-shell 3.22.0-1
Inscription : 16-09-2011

Re : [Non-Résolu] Gnome, un jour peut être

daufinsyd a écrit :

En revanche, comme tu utilises une testing, est-ce lors des périodes de freeze tu peux facilement mettre à jour les paquets de sid comme:
libreoffice, iceweasel/dove, python, steam et deux trois petites choses dans le genre car c'est pour ça que je suis sous sid, j'aime avoir ce qu'il y a de récent big_smile



Aimer ce qui est le plus récent c'est bien, mais c'est aussi aimer aller à la rencontre des problèmes, et c'est ce qui t'arrive.


Personnellement je trouve que le retard de nouveauté des paquets en testing est faible par rapport à une sid, et je n'éprouve pas le besoin d'avoir ce qu'il y a de mieux, mais qui momentanément peut aussi être ce qu'il y a de pire.
On m'a souvent dit que j'aurais plus d'ennuis avec une testing qu'avec une sid, notamment à la fin de la période de freeze.
Je ne l'ai jamais constaté, mais j'ai essayé une sid, et là des ennuis j'en ai eu.
Je ne vois pas pourquoi d'ailleurs ce serait vrai qu'une testing est plus dangereuse qu'une sid.
Debian le dit lui, même, "nous espérons que « testing » soit une version toujours prête à la publication."
Maintenant je sais que les inconditionnels de la sid ne manquent pas, mais moi c'est pas ma tasse de thé.



Par contre, même si ce n'est pas de ma part une activité intense, il m'arrive de compiler.
Et la compilation ne passe pas toujours très bien quand on a des paquets anciens, c'est pourquoi je n'utilise pas la stable.
Si je veux un paquet de la sid, mais c'est très rare, je fais un apt-get install -t unstable nom_du_paquet .


CM Asus Sabertooth 990FX, Proc FX 8350, 4 x 8Go DDR3 1866Mhz, GTX 750ti 2Go, DD 2 To Sata 3

Hors ligne

#13 07-12-2013 19:20:29

taureau89_9
Adhérent(e)
Lieu : A proximité de LFLA
Distrib. : Debian Testing
Noyau : 4.7.0-1-amd64
(G)UI : Gnome 3.20+1 + gnome-shell 3.22.0-1
Inscription : 16-09-2011

Re : [Non-Résolu] Gnome, un jour peut être

daufinsyd a écrit :

j'ai donc installé testing (à la place de unstable), en espérant que Gnome et le son ne bug plus , ... indéfiniment big_smile



Installé ou ça ?

Le sources.list peut convenir, c'est le fichier preferences qui va déterminer si tu es en testing ou sid suivant les priorités.


CM Asus Sabertooth 990FX, Proc FX 8350, 4 x 8Go DDR3 1866Mhz, GTX 750ti 2Go, DD 2 To Sata 3

Hors ligne

#14 07-12-2013 19:35:48

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : [Non-Résolu] Gnome, un jour peut être

taureau89_9 a écrit:
Personnellement je trouve que le retard de nouveauté des paquets en testing est faible par rapport à une sid, et je n'éprouve pas le besoin d'avoir ce qu'il y a de mieux, mais qui momentanément peut aussi être ce qu'il y a de pire.



quand j'ai commencé avec debian, wheezy n'était plus trop loin de sortir, cependant il y avait des paquets qui était pas vraiment à jour.

Je ne vois pas pourquoi d'ailleurs ce serait vrai qu'une testing est plus dangereuse qu'une sid.


moi non plus, ce sont des souvenirs que j'ai de certains forum. Je n'avais pas encore debian à cette époque, pardonnez-moi big_smile

Par contre, même si ce n'est pas de ma part une activité intense, il m'arrive de compiler.

pareil, même si ce n'est pas souvent (généralement, c'est lorsque je tente de faire des paquets debs)

Je ne compte pas utiliser stable, en ce moment ça va encore (quoi que y a déjà des paquets qui ont pris un coup de vieux), mais d'ici quelques mois ...


Installé ou ça ?


Ben sur mon ordi big_smile ?

(oui j'ai mélangé sourceslist et preferences, c'est que cette histoire m'a émotionnellement bouleversée big_smile

Dernière modification par daufinsyd (07-12-2013 19:38:08)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

Pied de page des forums