Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-12-2013 01:10:24

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

flashplugin-nonfree sous wheezy 32 bits - résolu

Bonjour,

j'essaie désespérément d'installer flashplayer sur une wheezy en 32 bits ( athon xp donc pas le choix)

aptitude install flashplugin-nonfree

installe bien  le plugin flash qui est bien reconnu dans les plugins de iceweasel mais qui ne lit pas les vidéos
sous chromium il me dit même que le plugin n'est pas installé alors qu'il apparait bien dans le chrome:plugins hmm

j'ai bien les dépôt contrib et non-free dans mon source.list

un petit coup de main serait le bienvenu, je n'ai aucun soucis de flasplugin sous mes wheezy 64 bits ( déconnez pas j'essaie de passer ma môman à linux alors faudrait pas lui faire peur dès le départ lol )

vous remerciant pour vos conseils

Totophe

Dernière modification par totophe56 (27-12-2013 19:40:30)

Hors ligne

#2 26-12-2013 01:52:10

david96
Invité

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

Yo,

Sous iceweasel, tapes dans la barre d'adresse :

about:plugins

et regardes si tu n'as pas un autre module flash d'installer, auquel cas il faudra faire un choix pour éviter tout conflit.

#3 26-12-2013 07:37:22

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

totophe56 a écrit :

j'essaie de passer ma môman à linux alors faudrait pas lui faire peur dès le départ


C'est une initiative qui reste toujours périlleuse en soit.
En effet, passer sous GNU/Linux c'est aussi adopter un comportement plus responsable devant son outil informatique, pour une personne ne recherchant pas cela, autant mettre un dual boot afin de lui laisser toute liberté d'attitude.

Bon courage totophe56 ! smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 26-12-2013 20:53:32

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

david96 a écrit :

Yo,

Sous iceweasel, tapes dans la barre d'adresse :

about:plugins

et regardes si tu n'as pas un autre module flash d'installer, auquel cas il faudra faire un choix pour éviter tout conflit.



pas de plugin avant installation et après installation :

Plugins activés
Vous trouverez plus d'informations sur les plugins de votre navigateur sur mozilla.org.
Vous trouverez des mises à jour pour les plugins installés sur mozilla.com/plugincheck.
De l'aide pour l'installation des plugins est disponible sur plugindoc.mozdev.org.
Shockwave Flash

    Fichier : libflashplayer.so
    Version : 11,2,202,332
    Shockwave Flash 11.2 r202

Type MIME   Description   Suffixes
application/x-shockwave-flash   Shockwave Flash   swf
application/futuresplash  FutureSplash Player   spl



mais les vidéos ou autres contenus flash ne se lancent pas hmm

je n'ai plus que iceweasel sur ma machine

j'ai fais exactement la même chose sur la petite soeur de cette machine ( athlon xp tout les 2 et debian 32 bits sur l'autre aussi ) et cela fonctionne sans soucis
serait-il possible qu'un matériel mal configuré pourrait poser problème ? j'ai une carte vidéo nvidia sur celle ci qui pose problème, j'ai même essayé l'insta avec seulement la carte intégrée mais pareil

merci pour vos conseils big_smile

@Smolski : nulle gloire à vaincre sans péril tongue suis sur que ça sera encore moins dur à utiliser une fois tout mis en place et ssh pour la maintenance et tout et tout cool

Dernière modification par totophe56 (26-12-2013 20:54:45)

Hors ligne

#5 26-12-2013 22:43:50

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

Bonjour

Vérifies dans Synaptic que tu n'as pas d'autres paquets installés comme gnash, lightspark, swfdec qui pourrait rentraient en conflit avec le paquet flashplugin-nonfree.

A+

Hors ligne

#6 27-12-2013 00:19:02

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

bonjour Slyfox,

avec une recherche avec swf dans synaptic pas de réponse

avec une recherche avec flash dans synaptic :

libquvi-scripts
libquvi7

ces deux là auraient quelque chose à voir avec les contenus flash

sinon

usb-modeswitch
usb-modeswitch-data

qui eux apparemment n'a rien à voir

les deux premiers sont installés en même temps que l'installation de base donc je ne pense pas que ça gène neutral

Hors ligne

#7 27-12-2013 00:53:49

david96
Invité

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

totophe56 a écrit :

david96 a écrit :

Yo,

Sous iceweasel, tapes dans la barre d'adresse :

about:plugins

et regardes si tu n'as pas un autre module flash d'installer, auquel cas il faudra faire un choix pour éviter tout conflit.



pas de plugin avant installation et après installation :


Apparemment si, tu as le module Shockwave Flash (d'Adobe)…

#8 27-12-2013 01:21:28

david96
Invité

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

j'y pense, t'as sûrement le plugin-container, ce dernier peux faire planter flash. Pour le désactiver (histoire de tester) :

  • Dans la barre d’adresse entrer : about:config

  • Accepter le message d’avertissement : « Attention, danger ! »

  • Dans le filtre entrer : dom.ipc.plugins.enabled

  • Puis Double clic pour passer de l’état true à l’état false.

  • Pour terminer fermer et redémarrer Firefox ou Iceweasel.



Source : http://moralles.free.fr/spip.php?article891


Par contre, attention plugin-container à l'avantage de ne pas faire crasher complètement iceweasel, donc bien peser le pour et le contre avant de le désactiver.

Dernière modification par Invité-2 (27-12-2013 01:32:20)

#9 27-12-2013 11:00:56

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

Bonjour,

Est-ce un vieil ordinateur?

Adobe a abandonné la prise en charge des processeurs sans SSE2 avec Linux (on peut vérifier la présence de SSE2 avec la commande "grep ^flags /proc/cpuinfo" les lettres "sse2" devraient apparaître dans la liste) dans une révision mineure de Flashplayer 11. Le lecteur continue à s'installer, mais il plante quand il est appelé. Cela affecte surtout les plus anciens processeurs 32bits d'AMD.



Source: https://wiki.debian.org/fr/FlashPlayer

Hors ligne

#10 27-12-2013 11:31:16

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

Salut,
Je pense effectivement que deuchdeb a identifié le problème smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 27-12-2013 18:44:33

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

captnfab a écrit :

Salut,
Je pense effectivement que deuchdeb a identifié le problème smile



bingo smile

grep ^flags /proc/cpuinfo
flags   : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up




bon ben je vais essayer d'aller chercher une version 10 wink

Hors ligne

#12 27-12-2013 19:39:38

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

voilou ça marche !!

pour ceux que ça intéresserait :

il faut aller chercher la dernière version de flashplayer 10 archivée

http://download.macromedia.com/pub/flashplayer/installers/archive/fp_10.3.183.90_archive.zip
 



ensuite installation, manuelle ( en root ou ajouter sudo s'il est installé chez vous ) :
création du répertoire qui va recevoir le player :

mkdir /usr/lib/flashplugin-nonfree/



décompressez l'archive ( libflasplayer.so se trouve dans l'archive flashplayer_10_3r183_90_linux.tar.gz du répertoire  10_3_r183_90

allez au niveau de libflashplayer.so et :

cp libflashplayer.so /usr/lib/flashplugin-nonfree/libflashplayer.so



ensuite aller créer le répertoire plugins dans le répertoire .mozilla ( répertoire caché dans le home/monprofil =

mkdir /home/monprofil/.mozilla/plugins



on se met dans le répertoire et on y crée le lien symbolique qui permettra à iceweasel de lancer le player

cd /home/monprofil/.mozilla/plugins
ln -s /usr/lib/flashplugin-nonfree/libflashplayer.so libflashplayer.so



par contre je ne pense pas m'avancer en disant que le player ne sera accessible que par le profil "monprofil" et qu'il faudra recréer le lien en cas d'ajout de profils sur le système

merci pour votre aide et bon réveillon du jour de l'an cool

Hors ligne

#13 27-12-2013 19:55:59

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

Oui, cependant, là version 10 n'est pas compatible sur tous les sites, et bien sûr, elle comporte de nombreuses failles de sécurité qui n'ont pas été corrigées. A ce train là, je me demande si utiliser gnash n'est pas une meilleure idée.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#14 27-12-2013 21:27:52

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

captnfab a écrit :

Oui, cependant, là version 10 n'est pas compatible sur tous les sites, et bien sûr, elle comporte de nombreuses failles de sécurité qui n'ont pas été corrigées. A ce train là, je me demande si utiliser gnash n'est pas une meilleure idée.



effectivement Captnfab, ça soulève beaucoup de questions pour la sécurité hmm

malheureusement Gnash n'est pas encore compatible ou plutôt certains jeux en ligne n'ont pas été développés pour être compatibles avec roll

vivement l'avènement du HTML6 qui réglera tout ça et mettra un bon coup de pied au culte  de certains éditeurs qui se soucient peu de certains utilisateurs lol

Hors ligne

#15 27-12-2013 23:57:40

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

Sinon, pour perdre son temps sur le net, y'a plein d'autres manières que les jeux flash smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 28-12-2013 10:01:39

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

J'ai remarqué que les claviers virtuels des banques en ligne sont aussi en flash.  sad

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#17 29-12-2013 00:15:44

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : flashplugin-nonfree sous wheezy 32 bits - résolu

D'accord avec toi Captnfab mais Paskal soulève le soucis que les appis flash sont toujours et encore pour un peu de temps présentes dans des domaines autres que les jeux en ligne

les formations de webmaster dispensent toujours des modules macromedia flash, le développement d'ajax même s'il est de plus en plus présent dans l'interactivité ne permet pas encore de faire des jeux  ou animations aussi poussés que flash ( du moins aussi user-friendly )

ça fait déjà quelques années que je suis des formations en ligne sur le thème appis clients serveurs et les formats open sources sont encore trop rares

par exemple au mois de janvier, petit module swf, suis obligé de mettre en place une VM crosoft sad

Hors ligne

Pied de page des forums