Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-12-2013 00:55:26

pmignon
Membre
Lieu : Lyon
Distrib. : Squeeze
Noyau : 2.6.35-2-686 et amd64
(G)UI : KDE: 4.3
Inscription : 14-06-2008

upgrade squeeze à wheezy

Bonjour,
j'essaye de mettre ma debian à jour et je rencontre qq problemes. Voila comme j'ai procédé en suivant + ou - une page officielle:

root@dynonegro:/opt# dpkg --audit
root@dynonegro:/opt# vi /etc/apt/sources.list   [changements des depot de squeeze pour ceux de wheezy]
root@dynonegro:/opt# apt-get update
root@dynonegro:/opt# apt-get upgrade
 


Puis j'ai essayé d'installer un prgm: pipelight, et voici le message

root@dynonegro:/opt# aptitude install pipelight
Les NOUVEAUX paquets suivants vont être installés :
  acl{a} cabextract{a} colord{a} dconf-gsettings-backend{a} dconf-service{a} desktop-file-utils{a} fonts-liberation{ab} gcc-4.7-base{ab}
  glib-networking{a} glib-networking-common{a} glib-networking-services{a} gsettings-desktop-schemas{a} gvfs-common{a} gvfs-daemons{a} gvfs-libs{a}
  libaacs0{a} libarchive12{a} libasound2-plugins{a} libavcodec53{a} libavutil51{a} libbluray1{a} libcairo-gobject2{a} libcapi20-3{a}
  libcdio-cdda1{a} libcdio-paranoia1{a} libcdio13{a} libcolord1{a} libdconf0{a} libgail-3-0{a} libgd2-xpm{ab} libgdk-pixbuf2.0-0{a}
  libgdk-pixbuf2.0-common{a} libgeoclue0{a} libgmp10{a} libgphoto2-l10n{a} libgtk-3-0{a} libgtk-3-bin{a} libgtk-3-common{a} libgusb2{a} libicu48{a}
  libimobiledevice2{a} libjavascriptcoregtk-3.0-0{a} libjbig0 libjson0{a} liblcms2-2{a} liblzma5{a} libmpg123-0{a} libnettle4{a} libnotify4{a}
  libopenal-data{a} libopenal1{a} libosmesa6{a} libp11-kit0{a} libssl1.0.0{a} libvpx1{a} libwebkitgtk-3.0-0{a} libwebkitgtk-3.0-common{a}
  libx264-123{a} multiarch-support{a} pipelight pipelight-multi{a} ttf-mscorefonts-installer{a} wine-compholio{a} zenity{a} zenity-common{a}
Les paquets suivants seront ENLEVÉS :
  libcddb2{u} libcdio-cdda0{u} libcdio-paranoia0{u} libdvbpsi6{u} libebml0{u} libeggdbus-1-0{u} libgsf-1-114{u} libgsf-1-common{u} libmatroska0{u}
  libpango1.0-common{u} libupnp3{u} libva-x11-1{u} libvlc5{u} libxcb-render-util0{u} vlc-data{u} vlc-nox{u}
Les paquets suivants seront mis à jour :
  cpp-4.4 fontconfig-config gcc-4.4 gcc-4.4-base{b} gvfs gvfs-backends libacl1 libasound2 libatk1.0-0 libattr1 libbluetooth3 libc-bin libc-dev-bin
  libc6 libc6-dev libcairo2 libdvdnav4 libfontconfig1 libgcc1{b} libglib2.0-0 libgnutls26 libgomp1{b} libgpg-error0 libgphoto2-2 libgphoto2-port0
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtk2.0-0 libgtk2.0-bin libjpeg8 libltdl7 libmpfr4 liborc-0.4-0 libpango1.0-0 libpcre3
  libpixman-1-0 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpulse0 librsvg2-2 libschroedinger-1.0-0 libsoup2.4-1
  libstdc++6{b} libtag1-vanilla libtag1c2a libtiff4 libva1 libwmf0.2-7 libx11-6 libxml2 locales policykit-1
53 paquets mis à jour, 65 nouvellement installés, 16 à enlever et 972 non mis à jour.
Il est nécessaire de télécharger 97,2 Mo d'archives. Après dépaquetage, 270 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  libstdc++6: Casse: gcc-4.3 (< 4.3.6-1) mais 4.3.5-4 est installé.
  libgail18: Dépend: libgtk2.0-0 (= 2.20.1-2) mais 2.24.10-2 doit être installé.
  gcc-4.7-base: Casse: gcj-4.4-base (< 4.4.6-9~) mais 4.4.5-2 est installé.
  libgfortran3: Dépend: gcc-4.4-base (= 4.4.5-8) mais 4.4.7-2 doit être installé.
  g++-4.4: Dépend: gcc-4.4-base (= 4.4.5-8) mais 4.4.7-2 doit être installé.
           Dépend: gcc-4.4 (= 4.4.5-8) mais 4.4.7-2 doit être installé.
  libgomp1: Casse: gcc-4.3 (< 4.3.6-1) mais 4.3.5-4 est installé.
  libstdc++6-4.4-dev: Dépend: gcc-4.4-base (= 4.4.5-8) mais 4.4.7-2 doit être installé.
  libpulse-mainloop-glib0: Dépend: libpulse0 (= 0.9.21-3+squeeze1) mais 2.0-6.1 doit être installé.
  libgd2-noxpm: Est en conflit avec: libgd2 qui est un paquet virtuel
                Est en conflit avec: libgd2-xpm mais 2.0.36~rc1~dfsg-6.1 doit être installé.
  libc6-i686: Pré-Dépend: libc6 (= 2.11.3-4) mais 2.13-38 doit être installé.
  libgcc1: Casse: gcc-4.3 (< 4.3.6-1) mais 4.3.5-4 est installé.
  fonts-liberation: Est en conflit avec: ttf-liberation (< 1.07.0-2) mais 1.05.2.20091019-4squeeze1 est installé et a été conservé
  libxml2-dev: Dépend: libxml2 (= 2.7.8.dfsg-2+squeeze8) mais 2.8.0+dfsg1-7+nmu2 doit être installé.
  gcc-4.4-base: Casse: gcj-4.4-base (< 4.4.6-9~) mais 4.4.5-2 est installé.
  libgd2-xpm: Est en conflit avec: libgd2 qui est un paquet virtuel
              Est en conflit avec: libgd2-noxpm mais 2.0.36~rc1~dfsg-5 est installé et a été conservé
  vlc: Dépend: vlc-nox (= 1.1.3-1squeeze6) mais il ne sera pas installé.
  vlc-plugin-notify: Dépend: vlc-nox (= 1.1.3-1squeeze6) mais il ne sera pas installé.
  vlc-plugin-pulse: Dépend: vlc-nox (= 1.1.3-1squeeze6) mais il ne sera pas installé.
  libvlccore4: Dépend: vlc-data (= 1.1.3-1squeeze6) mais il ne sera pas installé.
  librsvg2-common: Dépend: librsvg2-2 (= 2.26.3-1) mais 2.36.1-2 doit être installé.
ouverts : 316 ; fermés : 527 ; reportés : 94 ; en conflit : 130                                                                                .Les actions suivantes permettront de résoudre ces dépendances :

       Supprimer les paquets suivants :                                                                    
1)       akregator                                                                                          
2)       amarok                                                                                            
3)       ark                                                                                                
4)       bsh-gcj                                                                                            
5)       build-essential                                                                                    
6)       camorama                                                                                          
7)       desktop-base                                                                                      
8)       dolphin                                                                                            
9)       dragonplayer                                                                                      
10)      dropbox                                                                                            
11)      evolution                                                                                          
12)      evolution-exchange                                                                                
13)      evolution-plugins                                                                                  
14)      frei0r-plugins                                                                                    
15)      g++                                                                                                
16)      g++-4.4                                                                                            
17)      gcc-4.3                                                                                            
18)      gcj-4.4-base                                                                                      
19)      gcj-4.4-jre                                                                                        
20)      gcj-4.4-jre-headless                                                                              
21)      gcj-4.4-jre-lib                                                                                    
22)      gcj-jre                                                                                            
23)      gcj-jre-headless                                                                                  
24)      gimp                                                                                              
25)      gnome-icon-theme                                                                                  
26)      gnome-media                                                                                        
27)      gnome-user-guide                                                                                  
28)      google-gadgets-qt                                                                                  
29)      gwenview                                                                                          
30)      juk                                                                                                
31)      k3b                                                                                                
32)      k3b-i18n                                                                                          
33)      kaddressbook                                                                                      
34)      kappfinder                                                                                        
35)      kate                                                                                              
36)      kcalc                                                                                              
37)      kde-plasma-desktop                                                                                
38)      kde-standard                                                                                      
39)      kde-window-manager                                                                                
40)      kdebase-apps                                                                                      
41)      kdebase-bin                                                                                        
42)      kdebase-runtime                                                                                    
43)      kdebase-workspace                                                                                  
44)      kdebase-workspace-bin                                                                              
45)      kdelibs5-plugins                                                                                  
46)      kdemultimedia-kio-plugins                                                                          
47)      kdenlive                                                                                          
48)      kdepasswd                                                                                          
49)      kdepim-runtime                                                                                    
50)      kdeplasma-addons                                                                                  
51)      kdesudo                                                                                            
52)      kdewebdev                                                                                          
53)      kdm                                                                                                
54)      kfilereplace                                                                                      
55)      kfind                                                                                              
56)      khelpcenter4                                                                                      
57)      kile                                                                                              
58)      kimagemapeditor                                                                                    
59)      kinfocenter                                                                                        
60)      klinkstatus                                                                                        
61)      klipper                                                                                            
62)      kmail                                                                                              
63)      kmix                                                                                              
64)      knm-runtime                                                                                        
65)      knotes                                                                                            
66)      kommander                                                                                          
67)      konq-plugins                                                                                      
68)      konqueror                                                                                          
69)      konqueror-nsplugins                                                                                
70)      konsole                                                                                            
71)      kopete                                                                                            
72)      korganizer                                                                                        
73)      kscreensaver                                                                                      
74)      kscreensaver-xsavers                                                                              
75)      ksnapshot                                                                                          
76)      ksysguard                                                                                          
77)      ktorrent                                                                                          
78)      kwalletmanager                                                                                    
79)      kwrite                                                                                            
80)      libakonadi-contact4                                                                                
81)      libatlas3gf-base                                                                                  
82)      libblas3gf                                                                                        
83)      libbonoboui2-0                                                                                    
84)      libc6-i686                                                                                        
85)      libcv2.1                                                                                          
86)      libcvaux2.1                                                                                        
87)      libevolution                                                                                      
88)      libgail18                                                                                          
89)      libgcj-bc                                                                                          
90)      libgcj10                                                                                          
91)      libgcj10-awt                                                                                      
92)      libgd2-noxpm                                                                                      
93)      libgfortran3                                                                                      
94)      libgnomecanvas2-0                                                                                  
95)      libgnomeui-0                                                                                      
96)      libgtkhtml-editor0                                                                                
97)      libgtkhtml3.14-19                                                                                  
98)      libhighgui2.1                                                                                      
99)      libhsqldb-java-gcj                                                                                
100)     libk3b6                                                                                            
101)     libk3b6-extracodecs                                                                                
102)     libkcddb4                                                                                          
103)     libkde4-ruby1.8                                                                                    
104)     libkdepim4                                                                                        
105)     libkdewebkit5                                                                                      
106)     libkhtml5                                                                                          
107)     libknotifyconfig4                                                                                  
108)     libkonq5                                                                                          
109)     libkopete4                                                                                        
110)     libkwineffects1a                                                                                  
111)     libkworkspace4                                                                                    
112)     liblapack3gf                                                                                      
113)     libmarblewidget4                                                                                  
114)     libmessagelist4                                                                                    
115)     libokularcore1                                                                                    
116)     libphonon4                                                                                        
117)     libplasma-ruby                                                                                    
118)     libplasma-ruby1.8                                                                                  
119)     libplasma3                                                                                        
120)     libplasmaclock4a                                                                                  
121)     libplasmagenericshell4                                                                            
122)     libprocessui4a                                                                                    
123)     libpulse-mainloop-glib0                                                                            
124)     libqedje0a                                                                                        
125)     libqt4-ruby1.8                                                                                    
126)     libqt4-webkit                                                                                      
127)     libqzion0a                                                                                        
128)     librsvg2-common                                                                                    
129)     libsmokekdecore4-3                                                                                
130)     libsmokekdeui4-3                                                                                  
131)     libsmokekfile3                                                                                    
132)     libsmokekhtml3                                                                                    
133)     libsmokekio3                                                                                      
134)     libsmokeknewstuff2-3                                                                              
135)     libsmokeknewstuff3-3                                                                              
136)     libsmokekparts3                                                                                    
137)     libsmokektexteditor3                                                                              
138)     libsmokekutils3                                                                                    
139)     libsmokenepomuk3                                                                                  
140)     libsmokephonon3                                                                                    
141)     libsmokeplasma3                                                                                    
142)     libsmokeqtwebkit4-3                                                                                
143)     libstdc++6-4.4-dev                                                                                
144)     libvlccore4                                                                                        
145)     libweather-ion4a                                                                                  
146)     libwebkit-1.0-2                                                                                    
147)     libxml2-dev                                                                                        
148)     linux-headers-2.6.32-5-686                                                                        
149)     marble-plugins                                                                                    
150)     network-manager-kde                                                                                
151)     okular                                                                                            
152)     okular-extra-backends                                                                              
153)     openoffice.org-gcj                                                                                
154)     openoffice.org-kde                                                                                
155)     phonon                                                                                            
156)     phonon-backend-xine                                                                                
157)     plasma-dataengines-addons                                                                          
158)     plasma-dataengines-workspace                                                                      
159)     plasma-desktop                                                                                    
160)     plasma-runners-addons                                                                              
161)     plasma-scriptengine-googlegadgets                                                                  
162)     plasma-scriptengine-javascript                                                                    
163)     plasma-scriptengine-python                                                                        
164)     plasma-scriptengine-qedje                                                                          
165)     plasma-scriptengine-ruby                                                                          
166)     plasma-scriptengine-superkaramba                                                                  
167)     plasma-scriptengine-webkit                                                                        
168)     plasma-scriptengines                                                                              
169)     plasma-wallpapers-addons                                                                          
170)     plasma-widget-folderview                                                                          
171)     plasma-widget-lancelot                                                                            
172)     plasma-widgets-addons                                                                              
173)     plasma-widgets-workspace                                                                          
174)     polkit-kde-1                                                                                      
175)     python-glade2                                                                                      
176)     python-gnome2                                                                                      
177)     python-gnomekeyring                                                                                
178)     python-gtk2                                                                                        
179)     python-kde4                                                                                        
180)     python-notify                                                                                      
181)     python-numpy                                                                                      
182)     python-qt4                                                                                        
183)     python-webkit                                                                                      
184)     rhythmbox                                                                                          
185)     rhythmbox-plugins                                                                                  
186)     sweeper                                                                                            
187)     system-config-printer                                                                              
188)     systemsettings                                                                                    
189)     vlc                                                                                                
190)     vlc-plugin-notify                                                                                  
191)     vlc-plugin-pulse                                                                                  
192)     yelp                                                                                              

       Conserver les paquets suivants dans leur version actuelle :                                          
193)     fonts-liberation [Non installé]                                                                    

       Laisser les dépendances suivantes non satisfaites :                                                  
194)     bsh recommande bsh-gcj                                                                            
195)     dkms recommande linux-headers-686-pae | linux-headers-amd64 | linux-headers-generic | linux-headers
196)     dpkg-dev recommande build-essential                                                                
197)     libc6 recommande libc6-i686                                                                        
198)     librsvg2-2 recommande librsvg2-common                                                              
199)     ttf-mscorefonts-installer recommande fonts-liberation                                              
200)     kdenlive recommande frei0r-plugins                                                                
201)     kdenlive-data recommande kdenlive                                                                  
202)     ktorrent-data recommande ktorrent (>= 4.0.2-1)                                                    
203)     konq-plugins-l10n recommande konq-plugins (>= 4:4.2.4)                                            
204)     gnome-media-common recommande gnome-media                                                          
205)     libgimp2.0 recommande gimp                                                                        
206)     linux-image-2.6.32-5-686 recommande libc6-i686                                                    
207)     gimp-data recommande gimp                                                                          
208)     libkio5 recommande kdelibs5-plugins (= 4:4.4.5-2+squeeze3)                                        
209)     kscreensaver-xsavers recommande kde-window-manager                                                
210)     plasma-desktop recommande kdebase-workspace                                                        
211)     kdebase-apps recommande kinfocenter (>= 4:4.4.5-2)                                                
212)     kile recommande okular | evince | gv                                                              
213)     libkhtml5 recommande kdelibs5-plugins (= 4:4.4.5-2+squeeze3)                                      
214)     okular-extra-backends recommande okular                                                            
215)     kscreensaver recommande kde-window-manager                                                        
216)     kscreensaver recommande kscreensaver-xsavers (= 4:4.4.5-1)                                        
217)     libkopete4 recommande kopete (= 4:4.4.5-2+squeeze1)                                                
218)     evolution recommande evolution-plugins                                                            
219)     evolution recommande yelp                                                                          
220)     amarok recommande kdemultimedia-kio-plugins (>= 4:4.2.0)                                          
221)     amarok-common recommande amarok (>= 2.4.1-1~bpo60+1)                                              
222)     vlc recommande vlc-plugin-pulse (= 1.1.3-1squeeze6)                                                
223)     evolution-common recommande evolution                                                              
224)     kdebase-workspace-bin recommande plasma-scriptengines                                              
225)     konqueror recommande konqueror-nsplugins (= 4:4.4.5-2)                                            
226)     konqueror recommande dolphin                                                                      
227)     k3b recommande libk3b6-extracodecs                                                                


Accepter cette solution ? [Y/n/q/?] q
Abandon de tous les efforts pour rechercher une solution à ces dépendances.
Abandon.



Donc j'en conclu que y a un pb de mise a jour de squeeze vers wheezy, mais  comme j'utilise normalement aptitude et pas apt-get
j'ai essayé :

root@dynonegro:/opt# aptitude safe-upgrade
Résolution des dépendances...                
ouverts : 414142 ; fermés : 425557 ; reportés : 52 ; en conflit : 108                                                                          oterminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
Abandon
 



mais sans succées comme vous voyez.
Bref j'ai essayé de rechanger mon source.list vers squeeze de remettre a jour avec aptitude update, puis aptitude safe-upgrade, puis recommencer pour le changement vers wheezy, mais ça ne change rien ...
Je vois pas ce qui se passe ... sad  si j'ai utilisé a tort apt-get au lieu de aptitude ...  J'ai l'impression qu'il y a plein de dépendance qui ne sont pas satisfaites ...  si j'accepete d'effacer tous les paquets proposé, j'aurai plus rien sur mon systeme ... Bref je suis hébété hagard ... sans intuitions ... Est-ce que vos lanternes sauraient m'éclairer ?

Merci
Pierre.

Hors ligne

#2 30-12-2013 06:18:43

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : upgrade squeeze à wheezy

Salut pmignon,
Tu n'as pas envisagé de faire une install de wheezy plutôt qu'une mise à jour de squeeze à wheezy?
Pour ce faire, tu sauvegardes tes paquiets actuellement installés avec :

$dpkg --get-selections > listepkg


et tu install ta wheezy sur ta partition racine en conservant ta partition /home
Pour restaurer tes anciens paquets

dpkg --set-selections < listepkg


apt-get dselect-upgrade


Vu tous les conflits de dépendances et les incompatibilités que tu peux être amené à résoudre en passant d'une version oldstable à stable, tu gagnerais peut-être du tmps à faire une install plutôt q'une mise à jour.
De plus il y a de forte chance qu'une partie des paquets que tu utilisais avec ta squeeze soit obsolète pour wheezy
PS=Si tu optes pour une install pense également à sauvegarder ton dossier /etc voir aussi /var

Dernière modification par nifseg (30-12-2013 06:33:23)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#3 30-12-2013 08:38:55

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : upgrade squeeze à wheezy


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 30-12-2013 14:18:19

pmignon
Membre
Lieu : Lyon
Distrib. : Squeeze
Noyau : 2.6.35-2-686 et amd64
(G)UI : KDE: 4.3
Inscription : 14-06-2008

Re : upgrade squeeze à wheezy

merci pour vos réponses.
Smolski j'avais deja lu cette page mais elle ne me dit pas pourquoi l'upgrade avec pat-get s'est passée sans probleme, alors que l'installation d'un nouveau programe me dit qu'il y a plein de dépendance non résolues ...
J'esperais aussi passer par un upgrade, pas une nouvelle install c'est pour ça que j'ai fait ce post, mais si c'est la derniere solution et la plus simple alors je vais me résoudre à l'utiliser ...
je tente quand meme, d'autres idées ?

Hors ligne

#5 30-12-2013 14:27:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : upgrade squeeze à wheezy

Je subodore quel e meta paquet gnome demande à être modifié dans son contenu.
Perso, j'accepterai car au pire, tu en seras quitte pour une réinstallation complète.
Sauvegarde ce qui est important pour toi, comme pour une réinstallation.

La commande aptitude te permet de lister tous tes logiciels installés :
Voir : liste sav des paquets installés - aptitude-create. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#6 30-12-2013 18:49:49

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : upgrade squeeze à wheezy

Est ce que tu as lu la note de publication de wheezy? Ce manuel t'explique la marche à suivre pour passer d'une stable à une autre.
Tu le trouveras sur le site officiel de Debian.
Pour commencer fait un peu de ménage dans tes paquets installés

deborphan | xargs aptitude remove


Tu pointes sur wheezy dans ton source.list et suivi de "aptitude update"
Et commence par mettre à jour les paquets les plus importants de ton système:
-aptitude et apt;
-initramfs-tools;
-Ton bootloader;
-La bibliothèque "libc6";
-udev;
-et le noyau souhaité.
Après avoir mit à jour ces paquets cruciaux tu peux passer à la mise à jour de ton système entier


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#7 31-12-2013 02:30:17

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : upgrade squeeze à wheezy

Attention avec la commande deborphan quand même, je conseille de tester avec un aptitude -s remove avant de faire le aptitude remove smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 31-12-2013 03:41:07

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : upgrade squeeze à wheezy

Ouais entièrement d'accord avec toi captain. C'est plus sage de faire un test avant d'executer cette commande.
J ai complètement zappé se paramètre

Dernière modification par nifseg (31-12-2013 03:42:02)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#9 01-01-2014 02:03:33

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : upgrade squeeze à wheezy

Autant corriger le problème avec apt-get avant de commencer à (dés)installer de nouveaux paquets, ce n'est pas une bonne idée de commencer à mettre le boxon quand APT déraille.
Que te renvoient les deux commandes suivantes ?

cat /etc/apt/sources.list
apt-get upgrade

Dernière modification par vv222 (01-01-2014 02:08:39)


Jouer sous Debian ? Facile !

Hors ligne

#10 03-01-2014 00:49:05

pmignon
Membre
Lieu : Lyon
Distrib. : Squeeze
Noyau : 2.6.35-2-686 et amd64
(G)UI : KDE: 4.3
Inscription : 14-06-2008

Re : upgrade squeeze à wheezy

Bon j'ai pas eu la patience d'attendre j'ai fait un ré-install a partir du CD  ... hmm Un peu bourrin je sais  lol
M'enfin c'est trop tard et ça me parraissait le plus simple. Mais je crois en effet que le probleme venait d'un probleem avec pat-get ...
Merci quand meme !

Hors ligne

#11 03-01-2014 00:57:40

david96
Invité

Re : upgrade squeeze à wheezy

J'ai souvent fait cette méthode bourrin. C'est vrai que les mises à niveau, c'est toujours un moment de pure allégresse (ironie inside big_smile )

#12 03-01-2014 00:59:24

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : upgrade squeeze à wheezy

je dois avouer que je le faisais avant mais que dernièrement j'ai migrer sans réinstaller 4 pc smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#13 03-01-2014 01:06:24

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : upgrade squeeze à wheezy

Mais c'est tellement désespérant/frustrant pour le helper, qui voit la solution et tente de la communiquer, quand un demandeur d'aide capitule ainsi ! Mais bon, c'est une phase de l'apprentissage aussi. smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#14 04-01-2014 15:08:22

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : upgrade squeeze à wheezy

captnfab a écrit :

Mais c'est tellement désespérant/frustrant pour le helper, qui voit la solution et tente de la communiquer, quand un demandeur d'aide capitule ainsi !


À qui le dis-tu  ? big_smile

Je casse (et répare) APT sur une base presque hebdomadaire, autant dire que je ne réinstalle jamais pour une mise-à-jour bancale, et que j'ai déjà vu quasiment tous les types de plantages qu'apt-get/aptitude/dpkg sont capables de nous pondre.

Comme ce sujet est clos, je vais m'adresser ici non pas au demandeur d'aide mais aux courageux bénévoles qui sont venus donner un coup de main : en cas de problème avec APT, et quel que soit le-dit problème, la solution n'est JAMAIS d'installer/désinstaller de nouveaux paquets "en aveugle".
En clair, tant que vous n'avez pas les retours de quelques situations de base ("apt-get upgrade" ici, "apt-get install -f" dans les cas hors mise-à-jour), conseiller des manipulations impliquant la modification de l'état d'APT ne fera qu'aggraver le problème.

Deuxième point important : aptitude est génial pour la gestion des dépendances au quotidien, mais seul apt-get est fiable pour la résolution de situations d'APT en vrac.
Les suggestions d'aptitude sont prévues pour être pertinentes sur un système fonctionnel, mais sur un système cassé elles ne font qu'ajouter au joyeux bordel ambiant wink
apt-get par contre est bête, et c'est ce qu'on cherche ici : il fait ce qu'on lui dit, rien de plus, rien de moins.

-----

Voilà, fin de la leçon, j'espère que vous avez pris des notes…


Jouer sous Debian ? Facile !

Hors ligne

#15 04-01-2014 15:26:38

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : upgrade squeeze à wheezy

Je suis d'accord: quand le gestionnaire de paquet râle, la première chose à faire, c'est de résoudre ce problème, avant de tenter de réinstaller quelque paquet que ce soit.

Après, tu es un peu dur avec aptitude, il permet aussi parfois de trouver des compromis intéressant et moins violents qu'apt-get. Mais bon, je pense que nous sommes d'accord là dessus aussi smile

Ça me fait penser qu'un petit tuto sur « j'ai cassé apt/dpkg, comment faire pour m'en sortir » pourrait être cool comme référence !

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 04-01-2014 17:00:41

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : upgrade squeeze à wheezy

captnfab a écrit :

Ça me fait penser qu'un petit tuto sur « j'ai cassé apt/dpkg, comment faire pour m'en sortir » pourrait être cool comme référence !


J'y travaille, j'y travaille...
Enfin, pour le moment je projette surtout de commencer à me décider à m'y mettre.

Le problème sur ce sujet est que les situations sont très variées, et sans solution "miracle".

Mais je vais prendre le temps de casser APT sur ma Sid et de tenter de rédiger quelques situations-types.
Le premier point à mon avis étant l'utilisation correcte d'apt-get pour situer le problème, plutôt que la recherche en aveugle en appliquant au hasard des solutions ne correspondant pas au problème...

Bon, va y a avoir du boulot alors j'arrête de radoter et je commence à réfléchir wink


Jouer sous Debian ? Facile !

Hors ligne

#17 04-01-2014 17:06:57

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : upgrade squeeze à wheezy

Le fait que les situations sont nombreuses n'importe pas pourvu qu'on les ajoute par la suite.
Peut-être qu'une première résolution puis une seconde puis de compléter dans l'temps le fera ? smile

Ainsi, le tuto sera déjà là et applicable.

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#18 04-01-2014 17:15:40

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : upgrade squeeze à wheezy

Oui, c'est ce que je pensais, une page qui répertorie les différents cas (au fur et à mesure) et que l'on compléterait.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums