Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-01-2014 20:40:46

sechanbask
Membre
Inscription : 14-10-2009

Migration de squeeze à wheezy sur un NAS

Bonjour et bonne année à tous,

Je possède un NAS Dlink DNS320 sur lequel j'ai installé une debian 6 (en plus du système de base). Je tente de le mettre à jour mais...

# uname -a
Linux lc-nas 2.6.22.18 #23 Wed May 25 15:48:30 CST 2011 armv5tejl GNU/Linux



# apt-get update
# apt-get upgrade



j'ai modifié le source.list :


deb http://ftp.fr.debian.org/debian/ wheezy main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ wheezy main non-free contrib

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free


 



et j'ai relancé

# apt-get update


# apt-get upgrade


WARNING: this version of the GNU libc requires kernel version
2.6.26 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
  apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg : erreur de traitement de /var/cache/apt/archives/libc6_2.13-38_armel.deb (--unpack) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
configured to not write apport reports
                                      Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libc6_2.13-38_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



J'ai bien essayé de changer mon source.list avec lenny, puis

# apt-get update



puis comme conseillé dans le message d'erreur :

# apt-get install -t lenny linux-image-2.6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet linux-image-2.6 est un paquet virtuel fourni par :
  linux-image-2.6.26-2-versatile 2.6.26-29
  linux-image-2.6.26-2-orion5x 2.6.26-29
  linux-image-2.6.26-2-ixp4xx 2.6.26-29
  linux-image-2.6.26-2-iop32x 2.6.26-29
Vous devez explicitement sélectionner un paquet à installer.

E: Le paquet « linux-image-2.6 » n'a pas de version susceptible d'être installée



Mais je ne sais pas vraiment quoi choisir... voilà ce que j'ai comme cpu :

# cat /proc/cpuinfo
Processor   : ARM926EJ-S rev 1 (v5l)
BogoMIPS   : 796.26
Features   : swp half thumb fastmult edsp
CPU implementer   : 0x56
CPU architecture: 5TE
CPU variant   : 0x2
CPU part   : 0x131
CPU revision   : 1
Cache type   : write-back
Cache clean   : cp15 c7 ops
Cache lockdown   : format C
Cache format   : Harvard
I size      : 16384
I assoc      : 4
I line length   : 32
I sets      : 128
D size      : 16384
D assoc      : 4
D line length   : 32
D sets      : 128

Hardware   : Feroceon-KW
Revision   : 0000
Serial      : 0000000000000000

Hors ligne

#2 09-01-2014 21:06:16

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Tape la commande "lscpu"

lscpu



Et si tu veux savoir quel noyau tu utilises actuellement tape :

uname -r



Ton processeur est est type "arm"

Dernière modification par nifseg (09-01-2014 21:19:53)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#3 09-01-2014 21:16:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Migration de squeeze à wheezy sur un NAS

après l'update, pour migrer il faut le dist-upgrade.
On update avant de modifier la source et après on fait que des dist-upgrade.
Voir le principe de la migration en détail :
Migrer de A à Z - Attention, vals manuel est suceptible de prendre une crise en ouvrant ce tuto là ! wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 09-01-2014 21:22:57

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

pfff, n'importe quoi moi. Il est en train de migrer et je lui dis de taper des commandes
J'ai la tête dans les nuages.Le réveil est tjs difficile!!
roll

Dernière modification par nifseg (09-01-2014 21:24:28)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#5 10-01-2014 23:32:17

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

smolski > J'ai suivi la documentation officielle http://www.debian.org/releases/stable/p … ng.fr.html. Et j'ai voulu faire la mise à jour en 2 temps : 4.4.4. Mise à niveau minimale du système

et donc ça coince et je ne peux pas réparer mon erreur :

# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  libc6
Paquets suggérés :
  glibc-doc
Les paquets suivants seront mis à jour :
  libc6
1 mis à jour, 0 nouvellement installés, 0 à enlever et 126 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/4 219 ko dans les archives.
Après cette opération, 827 ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
Préconfiguration des paquets...
(Lecture de la base de données... 9604 fichiers et répertoires déjà installés.)
Préparation du remplacement de libc6 2.11.3-4 (en utilisant .../libc6_2.13-38_armel.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.26 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
  apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg : erreur de traitement de /var/cache/apt/archives/libc6_2.13-38_armel.deb (--unpack) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
configured to not write apport reports
                                      Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libc6_2.13-38_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



nifseg > J'avais bien compris que mon CPU était de type ARM, mais le support de ce type de CPU a changé depuis 1 ou 2 debian et maintenant d'après ce que j'ai compris, il existe plusieurs branches : http://www.debian.org/ports/arm/

J'ai essaie de suivre tes indications mais le système et un peu particulier:

# lscpu
lscpu: error: /sys filesystem is not accessable.

Hors ligne

#6 11-01-2014 23:31:26

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

T'as visiblement un soucis au niveau de la libc6
Dans un premier temps essai

dpkg --configure -a


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#7 12-01-2014 11:41:42

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

nifseg > voilà ce que me donne ta commande :

# dpkg --configure -a
dpkg : des problèmes de dépendances empêchent la configuration de locales :
 locales dépend de glibc-2.13-1 ; cependant :
  Le paquet glibc-2.13-1 n'est pas installé.
dpkg : erreur de traitement de locales (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 locales
 



Je ne vois pas trop pourquoi mes locales poseraient problème :

# locale
LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
 

Hors ligne

#8 12-01-2014 15:02:46

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Ce ne sont pas les locales qui posent problème.
Pour configurer les locales ton système t'informe qui lui manque le paquet "glibc-2.13-1"
Donc install "glibc-2.13-1" :

apt-get install glibc-2.13-1


Puis reconfigure tes paquets :

dpkg --configure -a


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#9 12-01-2014 15:14:18

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

nifeg> je n'ai lancé que le première commande qui me retourne une erreur semble-t-il lié au noyau puisqu'il me demande d'installé une image :

# apt-get install glibc-2.13-1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « libc6 » au lieu de « glibc-2.13-1 »
Paquets suggérés :
  glibc-doc
Les paquets suivants seront mis à jour :
  libc6
1 mis à jour, 0 nouvellement installés, 0 à enlever et 126 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 4 219 ko dans les archives.
Après cette opération, 827 ko d'espace disque seront libérés.
Réception de : 1 http://ftp.fr.debian.org/debian/ wheezy/main libc6 armel 2.13-38 [4 219 kB]
4 219 ko réceptionnés en 2s (1 465 ko/s)
Préconfiguration des paquets...
(Lecture de la base de données... 9604 fichiers et répertoires déjà installés.)
Préparation du remplacement de libc6 2.11.3-4 (en utilisant .../libc6_2.13-38_armel.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.26 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
  apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg : erreur de traitement de /var/cache/apt/archives/libc6_2.13-38_armel.deb (--unpack) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
configured to not write apport reports
                                      Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libc6_2.13-38_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#10 12-01-2014 15:26:47

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

En fait dans ce message, il t'est demandé de modifier ton sources.list et d'y ajouter le dépôt de Lenny.
D'installer le noyau de Lenny adéquate:

apt-get install -t lenny linux-image-2.6


Pour pouvoir mettre à jour ta distrib

Dernière modification par nifseg (12-01-2014 15:37:33)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#11 12-01-2014 15:30:32

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Mais tu fais une mise à jour à partir de squeeze ou lenny?
C'est étrange qu'apt te demande d'installer un noyau provenant de Lenny si tu étais sur squeeze
Et quelle est la version précise du noyau que tu utilisais?

Dernière modification par nifseg (12-01-2014 15:32:59)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#12 12-01-2014 16:18:20

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

nifeg > Je pense que le système est ancien et mise à jour pas forcément de manière très conventionnelle. Il semble que je sois bien squeeze :

# cat /etc/issue
Debian GNU/Linux 6.0 \n \l
 



Comme indiqué dans mon premier poste, j'ai changé mon source.list :

# deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official amd64 NETINST Binary-1 20131215-04:55]/ wheezy contrib main non-free

#deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official amd64 NETINST Binary-1 20131215-04:55]/ wheezy contrib main non-free


deb http://archive.debian.org/debian/ lenny contrib main non-free

deb http://ftp.fr.debian.org/debian/ wheezy main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ wheezy main non-free contrib

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
 



puis j'ai lancé sans retour erreur :

# apt-get update



et enfin

# apt-get install -t lenny linux-image-2.6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet linux-image-2.6 est un paquet virtuel fourni par :
  linux-image-2.6.26-2-versatile 2.6.26-29
  linux-image-2.6.26-2-orion5x 2.6.26-29
  linux-image-2.6.26-2-ixp4xx 2.6.26-29
  linux-image-2.6.26-2-iop32x 2.6.26-29
Vous devez explicitement sélectionner un paquet à installer.

E: Le paquet « linux-image-2.6 » n'a pas de version susceptible d'être installée



Le support pour arm a dû évoluer mais je ne sais pas lequel choisir pour poursuivre...

Hors ligne

#13 12-01-2014 16:28:13

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Le paquet linux-image-2.6 est un paquet virtuel
Essai :

apt-get install -t lenny linux-image-2.6.26-2-iop32x


Jai un doute sur le noyau que tu dois utilisé
Si cette premère commande te renvoie un erreur tape :

apt-get install -t lenny linux-image-2.6.26-2-ixp4xx

Dernière modification par nifseg (12-01-2014 16:36:01)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#14 12-01-2014 16:53:29

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

aie

# apt-get install -t lenny linux-image-2.6.26-2-iop32x
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libc6 : Dépend: libc-bin (= 2.11.3-4) mais 2.13-38 devra être installé
 linux-image-2.6.26-2-iop32x : Dépend: initramfs-tools (>= 0.55) mais ne sera pas installé ou
                                        yaird (>= 0.0.13) mais il n'est pas installable ou
                                        linux-initramfs-tool
 locales : Dépend: glibc-2.13-1
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).

Hors ligne

#15 12-01-2014 17:03:13

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Bon attends on va repartir de zéro!
Si t'es sur que ton install est une squeeze, on va renseigner squeeze dans ton sources.list
Installer le bon noyau et faire la mise à jour de squeeze puis ensuite faire la migration
Avant tout commence par :

apt-get --purge remove linux-image-2.6.26-2-iop32x


suivi d'un :

apt-get autoremove


avant de valider cette commande par "Oui" renvoi moi le message pour être sur que tu ne supprime rien d'important

Ensuite commente la ligne du dépot lenny dans ton sources.list et renseigne le dépôts de squeeze
As tu déjà migrer certains programmes sous wheezy?
Si ce n'est pas le cas c'est tant mieux et dans ce cas commente égalemnt les dépôts de wheezy par un # devant

Dernière modification par nifseg (12-01-2014 17:13:27)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#16 12-01-2014 18:21:15

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

nifeg > ça commence pas trop bien

# apt-get --purge remove linux-image-2.6.26-2-iop32x
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet linux-image-2.6.26-2-iop32x n'est pas installé, et ne peut donc être supprimé
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 libc6 : Dépend: libc-bin (= 2.11.3-4) mais 2.13-38 devra être installé
 locales : Dépend: glibc-2.13-1
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
root@lc-nas:~# apt-get autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc6 : Dépend: libc-bin (= 2.11.3-4) mais 2.13-38 est installé
 locales : Dépend: glibc-2.13-1
E: Dépendances manquantes. Essayez d'utiliser l'option -f.



Pour info j'avais mis à jour squeeze, puis tenter une mise jour minimale comme décrit sur mon premier post, quelques paquets de wheezy ont été installé les autres sont bloqués.

Hors ligne

#17 12-01-2014 18:23:09

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Tape :

apt-get -f install


pour régler les pb de dépendances


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#18 12-01-2014 19:01:23

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

ça régle les dépendance mais le noyau vient encore gâcher la fête :


# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  libc6
Paquets suggérés :
  glibc-doc
Les paquets suivants seront mis à jour :
  libc6
1 mis à jour, 0 nouvellement installés, 0 à enlever et 126 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/4 219 ko dans les archives.
Après cette opération, 827 ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
Préconfiguration des paquets...
(Lecture de la base de données... 9604 fichiers et répertoires déjà installés.)
Préparation du remplacement de libc6 2.11.3-4 (en utilisant .../libc6_2.13-38_armel.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.26 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
  apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg : erreur de traitement de /var/cache/apt/archives/libc6_2.13-38_armel.deb (--unpack) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
configured to not write apport reports
                                      Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libc6_2.13-38_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#19 12-01-2014 19:07:29

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Est ce que tu as de nouveau accès au commande de la console?
Essayer de nouveau de tapez :

uname -a


Pour être certain du noyau actuellement utilisé


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#20 12-01-2014 19:13:28

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

# uname -a
Linux lc-nas 2.6.22.18 #23 Wed May 25 15:48:30 CST 2011 armv5tejl GNU/Linux

Hors ligne

#21 12-01-2014 19:18:57

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

J'ai bien peur que ton nas ne soit pour le moment pas compatible avec le noyau inclus dans wheezy!
Quels sont les paquets que tu as réussi à mettre à jour sous wheezy?
Etant donné que tu as déjà migré certains paquets,il faudrait tenter d'upgrader ton noyau, initramfs-tools, grub, libc6, et udev
As tu commenté par un "#" ton dépôt lenny dans le sources.list et décommenté les dépôts de wheezy comme suggéré dans le post n°15?

Dernière modification par nifseg (12-01-2014 19:22:45)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#22 12-01-2014 19:26:59

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

Pour le noyau, j'ai l'impression de arm s'est séparé en plusieurs branches, mais du coup laquelle prendre ?

je ne sais plus quels paquets ont été mise à jour, est-ce que la commande suivante peut te répondre :

# zcat /var/log/apt/history.log.1.gz
 


si oui voilà ce que j'ai pu mettre à jour :


Start-Date: 2014-01-06  21:32:21
Commandline: apt-get upgrade
Upgrade: netcat-traditional:armel (1.10-38, 1.10-40), libc-bin:armel (2.11.3-4, 2.13-38), traceroute:armel (2.0.15-1, 2.0.18-3), openssh-blacklist-extra:armel (0.4.1, 0.4.1+nmu1), ncurses-base:armel (5.7+20100313-5, 5.9-10), liblocale-gettext-perl:armel (1.05-6, 1.05-7+b1), install-info:armel (4.13a.dfsg.1-6, 4.13a.dfsg.1-10), libnfnetlink0:armel (1.0.0-1, 1.0.0-1.1), diffutils:armel (3.0-1, 3.2-6), libpam-runtime:armel (1.1.1-6.1+squeeze1, 1.1.3-7.1), logrotate:armel (3.7.8-6, 3.8.1-4), xauth:armel (1.0.4-1, 1.0.7-1), perl-base:armel (5.10.1-17squeeze6, 5.14.2-21+deb7u1), groff-base:armel (1.20.1-10, 1.21-9), login:armel (4.1.4.2+svn3283-2+squeeze1, 4.1.5.1-1), libtext-charwidth-perl:armel (0.04-6, 0.04-7+b1), isc-dhcp-client:armel (4.1.1-P1-15+squeeze8, 4.2.2.dfsg.1-5+deb70u6), tcpd:armel (7.6.q-19, 7.6.q-24), insserv:armel (1.14.0-2, 1.14.0-5), dash:armel (0.5.5.1-7.4, 0.5.7-3), tasksel-data:armel (2.88, 3.14.1), readline-common:armel (6.1-3, 6.2+dfsg-0.1), locales:armel (2.11.3-4, 2.13-38), bsdutils:armel (2.17.2-9, 2.20.1-5.3), cpio:armel (2.11-4, 2.11+dfsg-0.1), base-passwd:armel (3.5.22, 3.5.26), cron:armel (3.0pl1-116, 3.0pl1-124), openssh-blacklist:armel (0.4.1, 0.4.1+nmu1), findutils:armel (4.4.2-1+b1, 4.4.2-4), manpages:armel (3.27-1, 3.44-1), isc-dhcp-common:armel (4.1.1-P1-15+squeeze8, 4.2.2.dfsg.1-5+deb70u6), sensible-utils:armel (0.0.4, 0.0.7), debianutils:armel (3.4, 4.3.2), net-tools:armel (1.60-23, 1.60-24.2), sed:armel (4.2.1-7, 4.2.1-10), adduser:armel (3.112+nmu2, 3.113+nmu3), lsb-base:armel (3.2-23.2squeeze1, 4.1+Debian8+deb7u1), tar:armel (1.23-3, 1.26+dfsg-0.1), debian-archive-keyring:armel (2010.08.28+squeeze1, 2012.4), libtext-iconv-perl:armel (1.7-2, 1.7-5), tasksel:armel (2.88, 3.14.1), sysvinit-utils:armel (2.88dsf-13.1+squeeze1, 2.88dsf-41+deb7u1), tzdata:armel (2013d-0squeeze1, 2013h-0wheezy1), gpgv:armel (1.4.10-4+squeeze4, 1.4.12-7+deb7u3), grep:armel (2.6.3-3+squeeze1, 2.12-2), debconf:armel (1.5.36.1, 1.5.49), sysv-rc:armel (2.88dsf-13.1+squeeze1, 2.88dsf-41+deb7u1), debconf-i18n:armel (1.5.36.1, 1.5.49), libc6:armel (2.11.3-4, 2.13-38), gzip:armel (1.3.12-9+squeeze1, 1.5-1.1), hostname:armel (3.04, 3.11), gnupg:armel (1.4.10-4+squeeze4, 1.4.12-7+deb7u3), mawk:armel (1.3.3-15, 1.3.3-17)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2014-01-06  21:32:57
 



comme c'est un système à part, est-ce qu'il est possible de le chrooter (si c'est bien le terme) de le remettre d'aplomb et le remettre dans le NAS ?

Hors ligne

#23 12-01-2014 19:48:48

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Déjà ce que je trouve étonnant c'est que la commande uname retourne un noyau 2.6.22.18 alors que le noyau par défaut sous squeeze est 2.6.32-xxx
En ce qui concerne les noyaux pour arm il y a sous squeeze le noyau "linux-image-2.6.32-5-ixp4xx" et le "linux-image-2.6.32-5-iop32x".
Je te conseille de downgrader les paquets que tu as migré en wheezy en squeeze et de faire la mise à jour des derniers paquets de squeeze.
Et ensuite voir pour une migration vers wheezy. Mais pour sa il faut être certain que ton nas est bien supporté par wheezy et à vrai dire j'en doute

Dernière modification par nifseg (12-01-2014 19:51:43)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#24 12-01-2014 21:53:42

sechanbask
Membre
Inscription : 14-10-2009

Re : Migration de squeeze à wheezy sur un NAS

Je ne sais pas comment faire pour downgrader.

Avant de vouloir migrer, j'ai fait la mise à jour des paquets squeeze.

Hors ligne

#25 12-01-2014 22:04:31

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Migration de squeeze à wheezy sur un NAS

Pour downgrader il faut que tu rajoutes les dépôts squeeze si ce n'est pas déjà fait.
Ensuite:

apt-get update


pour prendre en compte la modification de ton sources.list

Après tu tapes

apt-cache policy nom-du-paquet


pour connaitre toutes le versions de chaque paquets que tu as migrés sous wheezy
Exemple pour le paquet traceroute :

apt-cache policy traceroute



Suite à ça, tu installes les paquets en précisant leur version(squeeze)

Dernière modification par nifseg (12-01-2014 22:12:48)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

Pied de page des forums