Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-10-2008 16:39:06

Piero
Membre
Inscription : 14-03-2008

Freeze sous Lenny

Yop,
Salut à tous,

J'ai un petit problème qui me dépasse sur un portable ou je viens d'installer une lenny.
De temps a autre, l'écran se bloque complètement, et au redémarrage il faut que je force la vérification de ma partition /home (en ext2) pour pouvoir redémarer.... (en fait je force pas, mais je dois la faire à la main fsck -y)

Le problème est surtout que je ne sais pas vraiment tirer les infos de mon /var/log...
voici un bout qui semble correspondre à un plantage :

Oct 19 16:02:37 sac-a-malice kernel: [ 1497.748322] ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 18 (level, low) -> IRQ 18
Oct 19 16:02:37 sac-a-malice kernel: [ 1497.748765] firmware: requesting iwlwifi-3945-1.ucode
Oct 19 16:02:37 sac-a-malice kernel: [ 1497.754389] ACPI: PCI interrupt for device 0000:05:00.0 disabled
Oct 19 16:04:39 sac-a-malice kernel: [ 1619.808322] ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 18 (level, low) -> IRQ 18
Oct 19 16:04:39 sac-a-malice kernel: [ 1619.808764] firmware: requesting iwlwifi-3945-1.ucode
Oct 19 16:04:39 sac-a-malice kernel: [ 1619.813661] ACPI: PCI interrupt for device 0000:05:00.0 disabled
Oct 19 16:06:41 sac-a-malice kernel: [ 1741.884315] ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 18 (level, low) -> IRQ 18
Oct 19 16:06:41 sac-a-malice kernel: [ 1741.884756] firmware: requesting iwlwifi-3945-1.ucode
Oct 19 16:06:41 sac-a-malice kernel: [ 1741.889576] ACPI: PCI interrupt for device 0000:05:00.0 disabled
Oct 19 16:09:45 sac-a-malice syslogd 1.5.0#5: restart.
Oct 19 16:09:45 sac-a-malice kernel: klogd 1.5.0#5, log source = /proc/kmsg started.
Oct 19 16:09:45 sac-a-malice kernel: [    0.000000] Initializing cgroup subsys cpuset
Oct 19 16:09:45 sac-a-malice kernel: [    0.000000] Initializing cgroup subsys cpu
Oct 19 16:09:45 sac-a-malice kernel: [    0.000000] Linux version 2.6.26-1-686 (Debian 2.6.26-5) (waldi@debian.org) (gcc version 4.1.3 20080623 (prerelease) (Debian 4.1.2-23)) #1 SMP Wed Sep 10 16:46:13 UTC 2008


Et si je ne suis pas trop con, j'aurais un problème avec le wifi (dont je ne me sers pas pour l'instant et que je n'ai d'ailleurs pas cherché à configurer...)

si quelqu'un peut m'aider un peu, ce serait vraiment chouette!
Merci
Ciao
Pier

Hors ligne

#2 19-10-2008 17:07:30

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Freeze sous Lenny

Bonjour,
Quelle version du kernel as-tu ? (lance la commande "uname -a" pour le savoir et copies ici le résultat obtenu).

Juste après un freeze, et sans tenter de redémarrer avec "fsck", loges toi en console virtuelle, (en utilisant les touches "Ctrl+Alt+F2" par exemple, pour être dans un terminal vc2) puis lance la commande suivante, (en simple utilisateur)

dmesg | tail -n 800 > dmesg.txt

puis passe en mode graphique, si c'est possible sans plantage, (Ctrl+Alt+F7) ouvres le fichier dmesg.txt obtenu avec un éditeur de textes (gedit, scite, geany, ce que tu veux), copies le contenu sur http://pastebin.com et donne nous le lien (ne copies pas ici, ce serait illisible, car trop long).

Mon hypothèse : une 'salade irq'. Si c'est ça, il se peut qu'une option noapic et/ou nolapic sur la ligne du kernel résolve ça.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#3 19-10-2008 17:44:25

Piero
Membre
Inscription : 14-03-2008

Re : Freeze sous Lenny

Merci de ta réponse;

Alors pour le kernel c'est 2.6.26-1-686.

Par contre je me suis un peu mal exprimé, quand je dis freeze, c'est un blocage total de l'ordi. Impossible de faire quoi que ce soit. Plus aucune réponse du clavier ni de quoi que ce soit, et je suis obliger d'arrêter l'ordi comme un bourrin avec le bouton de démarage...

Mais du coup voici ce que j'ai comme résultat de "tail -n 800 /var/log/messages"
(j'ai l'impression que ça revient un peu au même comme commande et que ça me met une partie de la session en cours et de celle d'avant?)

La session en cours commence à 467. Par contre je n'arrive pas à avoir plus en arrière que ça dans la session qui s'est bloqué juste avant.

à plus

Hors ligne

#4 19-10-2008 19:38:07

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Freeze sous Lenny

Re,

Cela ne revient pas du tout au même comme commande. Là ou /var/log/messages donne les messages du système, dmesg donne les messages du noyau.

http://www.linux-kheops.com/doc/man/man … esg.8.html

Alors quand tu lances un dmesg juste après un boot, tu vas forcément obtenir un message complet, très très long à lire, et surtout, dans la commande que je t'ai donnée, j'étais sûre de pouvoir trouver les messages de Monsieur le Kernel juste avant le freeze de ta machine. (Et oui, j'avais bien compris que plus rien ne répondait, d'ailleurs il m'est arrivé la même chose durant des lustres, avant que je ne trouve noacpi et noapic comme solution).

Dans ton cas, il n'y a pas de salade d'IRQ, mais une suite de messages relative au module pour le wifi, précédée d'une suite de messages relative au "handler". Et comme je vois ce message, je lis "Redhat" : tu ne te serais pas trompé de distro ou de forum ? tongue

Pour rebooter, tu peux utiliser les Sysrq au lieu du bouton, même en cas de freeze total ça fonctionne, si c'est configuré.

Comment le configurer ? Comme expliqué ici.

Comment l'utiliser ? Sur le clavier, tenir simultanément les touches suivantes (attention il faut des grands doigts !)

Alt+Shift+ImprÉcranSyst+r  (faire ceci en premier, cette option passe les évènements clavier au noyau)

Pour la suite, je vais résumer "Alt+Shift+ImprÉcranSyst" par l'appellation SysRq:

SysRq+e (stoppe le processus des applis, je crois)

SysRq+i

ajoutons:
SysRq+l (L minuscule)

le tout donne: SysRq +r e i (en résumé, c'est pour se rappeler dans quel ordre : rei, comme un roi) + l

Si rien n'y fait, au final, tuer le kernel:

SysRq+b et là, ça doit rebooter (sans toucher au bouton de la tour).

Plus d'informations ici:
http://fr.wikipedia.org/wiki/Magic_SysRq_key

(Note en particulier:
"b redémarre immédiatement le système. Cette fonctionnalité peut provoquer des pertes de données : ce qui est en mémoire cache n'est pas écrit sur les disques ; cette fonctionnalité est beaucoup plus radicale que le Ctrl-Alt-Delete de Microsoft ou que le Ctrl+Alt+Del de Linux." de là, l'intérêt d'utiliser en premier la suite de touche r e i +l

Je te conseille de faire des recherches sur tout ou partie du message suivant:

Oct 19 16:20:13 sac-a-malice kernel: [  656.372321] ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 18 (level, low) -> IRQ 18

et du message suivant:
Oct 19 16:19:59 sac-a-malice dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.interface_mtu

Ah je vois que tu as fait une pause entre le freeze et le reboot ? tongue

Oct 19 16:54:28 sac-a-malice kernel: [ 2711.397658] ACPI: PCI interrupt for device 0000:05:00.0 disabled
Oct 19 17:25:39 sac-a-malice syslogd 1.5.0#5: restart.


Un peu après le reboot, je lis ce message qui me semble être une indication intéressante:
Oct 19 17:25:40 sac-a-malice kernel: [    9.032002] pci 0000:00:1d.7: EHCI: BIOS handoff failed (BIOS bug?) 01010001

ehci est un module pour un certain type d'USB (1.1 ou 2.0 je ne sais jamais... il y a ehci_hcd et uhci_hcd).

Pourquoi ne pas regarder s'il existe une mise à jour pour le BIOS de la carte mère de ta machine ? Bien des fois une mise à jour de BIOS règle des problèmes qui semblent insolubles.


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#5 19-10-2008 22:00:47

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Freeze sous Lenny

Bonsoir,

En complément de ce qu'à donné Mélodie, je vois ces deux lignes:

#513.  ACPI: BIOS bug: multiple APIC/MADT found, using 0
#514.  ACPI: If "acpi_apic_instance=2" works better, notify linux-acpi@vger.kernel.org


Ces lignes suggèrent d'essayer de passer le paramètre acpi_apic_instance=2 au noyau au boot.
A essayer, sans certitude aucune.

@+

Hors ligne

#6 19-10-2008 22:25:55

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Freeze sous Lenny

tux12 a écrit :

Ces lignes suggèrent d'essayer de passer le paramètre acpi_apic_instance=2 au noyau au boot.
A essayer, sans certitude aucune.


Mais c'est une excellente idée, je n'avais même pas remarqué ce conseil dans le message de dmesg.


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#7 20-10-2008 15:41:12

Piero
Membre
Inscription : 14-03-2008

Re : Freeze sous Lenny

Merci a vous deux pour vos réponses.
Bon c'est un peu sur la limite de mes capacités informatiques, alors je ne suis pas sûr de tout bien comprendre, mais en tout cas, ça me pousse à apprendre!

D'abord sorry pour la sortie de commande, quand on ne sait pas on fait bêtement ce qui est demandé, promis je le ferais plus...

alors ici le dernier reboot en date avec dmesg
car même les combinaisons magiques données ci-dessus  ne donne pas de réponse....

Sinon, je suis bien sous debian et je pense sur le bon forum ;-) et j'étais aussi bien étonné de voir ces lignes. Mais en la mettant dans google, on tombe sur plein de gens avec des problèmes de wifi, toutes distribs confondues...

Je viens d'essayer de donner l'info "acpi_apic_instance=2" au noyau (cad je l'ai rajouté à la suite de root, vmlinuz et initrd dans grub, c'est bien ça qu'il fallait faire?) et pour l'instant, ça semble vouloir fonctionner...

[EDIT : En fait ça a bloqué juste après que j'ai envoyer ce message, et j'ai mis 3 plombes à redémarrer. Impossible d'utiliser PrtSc/Alt, puis freeze lors de la séquence de démarrage, à "setting internal clock" ou au niveau de gdm...]

Bon, j'ai tout de même plus l'impression de faire de la magie noire que quelque chose de vraiment rationnel; alors je vais de ce pas bouffer un peu de manuel, et je reviens vous dire si le problème est définitivement réglé!

Encore merci
Pier

Dernière modification par Piero (20-10-2008 16:29:42)

Hors ligne

#8 20-10-2008 17:14:43

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Freeze sous Lenny

Bonjour,

Oui, pour le paramètre à passer au boot, tu avais bien compris. Mais ça me paraît pire qu'au départ, et ton expérience va dans le même sens.

Une recherche avec la chaîne "firmware: requesting iwlwifi-3945-1.ucode" (premier log) indique un bug du 2.6.24 mais comme tu es sur un 2.6.26, je suppose que tu es en testing, qui intègre d'après la discussion du lien précédent le firmware nécessaire. Vérifie que le paquet firmware-iwlwi est installé.

Pour que ce paquet soit disponible, Il faut que tu ais inclut la section "non-free" dans ton sources.list.
Si tu dois inclure cette section, n'oublie pas de faire un apt-get ou aptitude update pour la prise en compte.

@+

Hors ligne

#9 20-10-2008 20:10:35

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Freeze sous Lenny

Piero a écrit :

Bon c'est un peu sur la limite de mes capacités informatiques, alors je ne suis pas sûr de tout bien comprendre, mais en tout cas, ça me pousse à apprendre!


Maintenant que je le sais, je n'hésiterai pas à en rajouter une couche. wink

Bon, j'ai tout de même plus l'impression de faire de la magie noire que quelque chose de vraiment rationnel; alors je vais de ce pas bouffer un peu de manuel, et je reviens vous dire si le problème est définitivement réglé!


Oui en effet, car :

Je viens d'essayer de donner l'info "acpi_apic_instance=2" au noyau (cad je l'ai rajouté à la suite de root, vmlinuz et initrd dans grub, c'est bien ça qu'il fallait faire?) et pour l'instant, ça semble vouloir fonctionner...


Non, uniquement à la fin de la ligne de boot du kernel, dans /boot/grub/menu.lst alors ôte ce que tu as fait, et fais-le bien !  smile

(Si tu ne sais pas, cherche sur le web ou bien demandes, n'essaie pas "au pif" sans comprendre et sans notions).

alors ici le dernier reboot en date avec dmesg
car même les combinaisons magiques données ci-dessus  ne donne pas de réponse....


Ah oui, mais est-ce configuré ?

moi-même a écrit :

Comment le configurer ? Comme expliqué ici.


tuxce de archlinux.fr a écrit :

pour le problème du blocage avec juste la souris qui bouge, tu peux éviter un reset matériel en activant l'option sysrq dans /etc/sysctl.conf:

kernel.sysrq = 1


pour la prise en compte sans redemarrage:

echo 1 > /proc/sys/kernel/sysrq


puis lors d'un blocage: shift+alt+sysrq+r passe le évenements clavier directement au noyau et un ctrl+alt+f1 devient possible.


C'est à dire que dans le fichier /etc/sysctl.conf tu changes la valeur de kernel.sysrq de 0 à 1 (ce qui veut aussi dire "vrai") avant de lancer la commande "echo 1 > /proc/sys/kernel/sysrq" pour que ça soit utilisable immédiatement sans redémarrage.


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#10 24-10-2008 21:44:28

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Freeze sous Lenny

Bonjour Piero,

Mélodie et moi n'avons pas la même interprétation de tes propos. big_smile
Mélodie à compris que tu avais ajouté l'option au fichier /boot/grub/menu.list.
Pour ma part, j'ai cru comprendre que tu avais rajouté l'option en éditant la ligne de boot de grub (touche e) lors du démarrage du système.

A toi de voir donc ce qu'il en est réellement.
@+

Hors ligne

Pied de page des forums