Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-02-2014 00:29:42

carmenidza
Membre
Inscription : 01-02-2014

clavier non reconnue dès la première page d'install

salut,
quand je lance une usb d'install de debian, j'arrive à la première page qui demande graphique install, expert mode ... mais là le clavier ne répond pas; ce n'est pas un clavier usb.
j'ai pu contourner ce problème enallant dans le bios et en disable usb legacy; ca prend pas en compte l'usb au démmarage (ce que j'en ai compris). sauf que ben j'utilise une usb pour installer debian, donc pas démarrage usb. j'ai déja essayer le cd mais ca rate à chaque fois, y a un fichier qui n'arrive pas à se copier ou à s'installer.
ce que j'ai pu faire est d'installer ubuntu, qui a un genre d'autorun qui se lance direct sans demander si faut un expert mode ou graphique ou autre. sauf que je ne veux pas ubuntu (qui par ailleur est inutilisable avec un ordi de 700 mb ram)
j'ai essayé le live cd debian mais pareil, il demande le clavier au début
donc tout ca dure depuis une semaine (ca prend la journée pour télécharger uneversion), et je sèche,


lematériel est un amd athlon 3200+  2ghz
700mb de ram,
ce qui est installé actuellement est  un dual boot windoz/ubuntu (wheezy) (faute de mieux)
pareil pour le grub, quand j'active usb legacy le clavier ne répond pas au grub, quand je désactive l'usb au démarrage, je peux naviguer dans le grub;


voila, en gros, si quelqu'un-e a une idée, je suis preneur,
bon il reste l'installation par le réseau (mais je ne sais pas faire)

Hors ligne

#2 01-02-2014 09:32:16

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : clavier non reconnue dès la première page d'install

Bonjour et bienvenue sur le forum  smile

carmenidza a écrit :

j'ai essayé le live cd debian mais pareil, il demande le clavier au début


Peux-tu préciser ?

Et ton clavier, il est branché sur une prise clavier ou mixte ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 01-02-2014 10:21:24

carmenidza
Membre
Inscription : 01-02-2014

Re : clavier non reconnue dès la première page d'install

merci


j'ai essayé le live debian i386, gnome, (debian-live-7.2-i386-gnome-desktop.iso) en pensant qu'il démrerait comme ubuntu directement sans passage par la case choix des options

le clavier est branché sur prise clavier (violette, ps/2) et la souris sur usb. meme endébranchant la souris c'est pareil.

j'ai vu que ce problème de clavier était sur la page des problèmes fréquents de wheezy sur amd64,

Hors ligne

#4 01-02-2014 10:33:22

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : clavier non reconnue dès la première page d'install

paskal a écrit :

Bonjour et bienvenue sur le forum  smile

carmenidza a écrit :

j'ai essayé le live cd debian mais pareil, il demande le clavier au début


Peux-tu préciser ?


Quelles sont les lignes affichées avant, si il y en a ?

carmenidza a écrit :

j'ai vu que ce problème de clavier était sur la page des problèmes fréquents de wheezy sur amd64,


Peux-tu passer un lien ?  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 01-02-2014 10:52:08

carmenidza
Membre
Inscription : 01-02-2014

Re : clavier non reconnue dès la première page d'install

vla le lien, c'est en bas de page qaund ca parle de uefi

http://www.debian.org/releases/wheezy/debian-installer/


les ligne affichées avant;

alors y a la première page où il dit que y a 700mb de ram, qu'il détecte de l'usb le cdrom et le disque dur,
oui debian live est en usb (j'ai plus de cd vierge, et il fait 1go)
ensuite y a le boot menu
- live (486)
-live failsafe
-live 686
-live failsafe
-installe
.........

bon là j'ai pas de clavier, alors que si j'entre directement au bios j'ai le clavier

Hors ligne

#6 01-02-2014 11:01:35

carmenidza
Membre
Inscription : 01-02-2014

Re : clavier non reconnue dès la première page d'install

oups,dsl,  bon c'est pas le bon lien,

http://doc.ubuntu-fr.org/clavier_usb_grub

je me suis "inspiré" de ca, mais c'estvrai que ca n'a pas vraiment l'air de correspondre, dans le bios j'ai dans usb configuration la case "legacy usb support" , j'ai le chois entre disable (donc j'ai le clavier mais pas d'usb au démarrage), enable (j'ai l'usb mais pas le clavier)

Hors ligne

#7 01-02-2014 11:07:23

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : clavier non reconnue dès la première page d'install

Ton lien concerne les claviers usb.

carmenidza a écrit :

ce n'est pas un clavier usb.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 01-02-2014 11:17:59

carmenidza
Membre
Inscription : 01-02-2014

Re : clavier non reconnue dès la première page d'install

oui,

en gros quand j'active usb legacy dans le bios j'ai pas de clavier (non usb), mais juste le temps du démarrage,
quand je le désactive j'ai le clavier (non usb), mais d'install usb,
ca se voit quand ca passe au grub un coup ya le clavier et quand l'usb est activée y a pas le clavier

Hors ligne

#9 01-02-2014 11:37:35

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : clavier non reconnue dès la première page d'install

De ce que j'en sais, l'usb legacy n'est nécessaire que si tu boot sur un périphérique usb non reconnu autrement.

AMHA, il faut le désactiver et examiner les autres problèmes.

Qu'est-ce que ça donne en netinstall ? http://debian-facile.org/doc:install:install_minimale

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#10 01-02-2014 12:47:14

carmenidza
Membre
Inscription : 01-02-2014

Re : clavier non reconnue dès la première page d'install

c'est pareil, avec la netinstall
à l'installeur boot menu pas de clavier et donc pas moyen d'aller plus loin

si je désactive legacy usb, il ne boot pas sur usb, du moins dans le boot priority du bios il ne propose pas de booter sur usb sauf si j'active usb legacy

est ce que c'est possible de configurer une debain d'installation sur usb en lui demandant de booter directement sur install sans passer par les options de boot? donc configurer l'installeur avant?

Hors ligne

#11 01-02-2014 14:53:58

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : clavier non reconnue dès la première page d'install

À ma connaissance, on ne peut pas by-passer le bios.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#12 01-02-2014 15:21:02

carmenidza
Membre
Inscription : 01-02-2014

Re : clavier non reconnue dès la première page d'install

re:
alors y a le presseding, ce que je viens de voir c'est que on peut configurer le debian-installer,
j'avoue pour moi là tout de suite c'est un peu trop d'info d'un coup, j'ai essayer avec  http://www.instalinux.com , de créer un iso,  mais l'iso n'a pas marché (erreur pxe:e53 , un truc du genre), en gros ce que je voudrais c'estlancer l'install sans qu'il me demande  quel version je veux ou quoi, juste qu'il commence l'installation, à partir d'une usb,

merci

Hors ligne

#13 02-02-2014 00:37:28

carmenidza
Membre
Inscription : 01-02-2014

Re : clavier non reconnue dès la première page d'install

re,
en fait dans le dossir isolinux de la clé d'instal il faut changer isolinux.cfg ; dans ce fichier mettre timeout 1 (0 est la valeur qui désactive timeout), sauf que la je peux pas le changer, la clé est en read only,

Hors ligne

#14 04-02-2014 13:31:24

carmenidza
Membre
Inscription : 01-02-2014

Re : clavier non reconnue dès la première page d'install

problème de clavier résolu, ou enfin plutot outrepassé,

donc il s'agit de changer le isolinux.cfg; ce que j'ai fait c'est de copier tout le contenu dela clé,sur l'espace user de l'ordi, ensuite change le isolinux.cfg, ensuite recréer un autre .iso avec le nouveau contenu avec l'application, imagisogen , ensuite le re mettre dans la clé en bootable,chose que je n'ai pas réussi à faire avec dd,  donc j'ai fait avec unetbootin qui est un logiciel d'installation d'un iso linux sur une clé usb.

bon ensuite je crois que unetbootin met le timeout de isolinux.cfg de fait à 10 seconde, donc pas besoin de mettre au clavierquoi que ce soit comme choix  debianinstalleur,

bon là c'est pour ce post, mais l'install ne veut quand meme pas se lancer, ben du coup un prochain post. merci à paskal pour le coup de main

Hors ligne

#15 04-02-2014 13:45:21

MicP
Invité

Re : clavier non reconnue dès la première page d'install

Pour la copie par "dd" de l'image ISO, il faut être bien sûr et certain du nom de fichier de périphérique auquel la clef USB cible a été associé.

En supposant que ce nom de fichier de périphérique soit : "/dev/sdb",
et que le nom du fichier image ISO soit "monImageISO",
et que l'utilisateur soit dans la liste des utilisateurs du groupe "floppy",
Il faudrait d'abord "dé-mounter" la clef au cas où elle ait été "mountée" automatiquement,
et entrer la commande :

dd if=monImageISO of=/dev/sdb bs=2M; sync



EDIT: J'ai modifié la commande suite à la remarque de captnfab dans le post suivant. Merci à lui smile

Dernière modification par MicP (04-02-2014 13:58:20)

#16 04-02-2014 13:52:56

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : clavier non reconnue dès la première page d'install

@micp: tu sais que cette commande peut être lancée en user si l'utilisateur est dans le groupe floppy ?
Ça évite notamment d'effacer le disque dur par erreur.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#17 04-02-2014 13:54:13

MicP
Invité

Re : clavier non reconnue dès la première page d'install

Merci pour la remarque pleine de bon sens: je corrige de suite.
smile

#18 04-02-2014 19:37:47

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : clavier non reconnue dès la première page d'install

@carmenidza : merci du retour, je ne t'ai pas beaucoup aidé.  sad

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums