Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-02-2014 10:55:35

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

[résolu] paquet cassé sous jessie

Bonjour a tous


os : testing (jessie)
pc :  asus N750JV-T5131H

j'ai voulu installer avec synaptic le paquet suivant :
gstreamer0.10-ffmpeg
Quand on clique sur ce paquet pour installation on a : impossible d'appliquer les changements. Réparez d'abors les paquets cassés.
et en bas :
117 paquets listés, 1765 installés, 1 cassé. 1 à installer/mettre a jour, 0 à désinstaller; 385 kb seront utilisés


Si quelqu'un peut me donner une explication
Merci

Dernière modification par nounours (17-02-2014 09:18:11)


N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#2 15-02-2014 11:10:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [résolu] paquet cassé sous jessie

Bonjour,

que donne :

apt-get check


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 15-02-2014 11:14:31

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [résolu] paquet cassé sous jessie

Salut,
Au passage, cela arrive principalement lorsque
- on utilise un dépôt autre que quelui de notre distro (autre que wheezy par exemple si on est en stable)
- ou on a interrompu l'installation de force

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#4 15-02-2014 11:20:21

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : [résolu] paquet cassé sous jessie

paskal a écrit :

Bonjour,

que donne :

apt-get check



Résultat :
root@asus:/home/jb# apt-get check
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
root@asus:/home/jb#


N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#5 15-02-2014 11:36:02

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [résolu] paquet cassé sous jessie

et :

dpkg -C


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#6 15-02-2014 18:38:32

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : [résolu] paquet cassé sous jessie

en réponse à paskal
root@asus:/home/jb# dpkg -C
root@asus:/home/jb# dpkg -c
dpkg-deb : erreur : --contents prend exactement un paramètre

Taper dpkg-deb --help pour obtenir une aide à propos de la manipulation des fichiers *.deb ;
Taper dpkg --help pour obtenir une aide sur l'installation et la désinstallation des paquets.
root@asus:/home/jb#

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#7 15-02-2014 18:49:47

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [résolu] paquet cassé sous jessie

Décidément, bon une dernière :

aptitude search ~b


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 15-02-2014 19:53:08

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : [résolu] paquet cassé sous jessie

réponse à paskal
root@asus:/home/jb# aptitude search ~b
root@asus:/home/jb#

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#9 15-02-2014 20:03:32

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [résolu] paquet cassé sous jessie

Bon, on ne trouve pas le paquet cassé, tant pis.
Tu vas passer :

apt-get install -f


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#10 16-02-2014 09:44:08

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : [résolu] paquet cassé sous jessie

Réponse à paskal
je vais essayer ta commande ce soir. Je ne pense pas qu'il y a un paquet cassé installé. Dans synaptic il y a un filtre qui permet de chercher les paquets cassés et la on ne trouve pas. J'ai l'impression que le paquet cassé est contenu dans le paquet gstreamer0.10-ffmpeg qui ne s'est pas installé (message erreur tout en haut du post).


J'ai voulu installer gstreamer0.10-ffmpeg pour voir les vidéo de pluzz et je vois que ce paquet n'est pas utile dans ce cas là. j'ai noté le paquet qui est indispensable pour voir pluzz, si quelqu'un veut savoir.


A quoi sert finalement gstreamer0.10-ffmpeg ?.

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#11 16-02-2014 09:54:04

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [résolu] paquet cassé sous jessie

nounours a écrit :

A quoi sert finalement gstreamer0.10-ffmpeg ?.


packages.debian.org a écrit :

Ce greffon GStreamer gère un grand nombre de formats de compression audio et vidéo grâce à la bibliothèque FFmpeg. Le greffon contient les éléments de GStreamer permettant de décoder plus de 90 formats (AVI, MPEG,OGG, Matroska, ASF…), de démultiplexer plus de 30 formats et de convertir les espaces de couleur.


Après, quant à savoir dans quels cas on peut s'en passer ou pas, je l'ignore.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#12 16-02-2014 17:50:54

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : [résolu] paquet cassé sous jessie

Réponse à paskal
suite application :

apt-get install -f


root@asus:/home/jb# apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
root@asus:/home/jb#


N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#13 16-02-2014 17:53:58

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [résolu] paquet cassé sous jessie

Ok, que donne :

aptitude install gstreamer0.10-ffmpeg -s


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#14 16-02-2014 21:36:07

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : [résolu] paquet cassé sous jessie

Réponse à paskal
Suite application :

aptitude install gstreamer0.10-ffmpeg -s



root@asus:/home/jb# aptitude install gstreamer0.10-ffmpeg -s
Les NOUVEAUX paquets suivants vont être installés :
  gstreamer0.10-ffmpeg{b}
0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 184 ko d'archives. Après dépaquetage, 385 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
gstreamer0.10-ffmpeg : Dépend: libavcodec53 (>= 5:0.8-2~) qui est un paquet virtuel ou
                                 libavcodec-extra-53 (>= 5:0.8-2~) qui est un paquet virtuel
                        Dépend: libavformat53 (>= 5:0.8-2~) qui est un paquet virtuel
                        Dépend: libavutil51 (>= 5:0.8-2~) qui est un paquet virtuel
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     gstreamer0.10-ffmpeg [Non installé]                     



Accepter cette solution ? [Y/n/q/?]


N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#15 16-02-2014 21:48:02

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [résolu] paquet cassé sous jessie

Salut

Apparemment, ce paquet n'est pas installable à l'heure actuelle hmm Je ne suis pas sur, mais il me semble me rapeller que ffmpeg est en cours de suppression et remplacé par libav

Edit : je viens de vérifier et je suis maintenant certain. Déjà sous wheezy, ffmpeg est un paquet de transition. Donc, sous Jessie, il n'existe plus smile

apt-get install libav-tools


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#16 16-02-2014 22:55:57

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [résolu] paquet cassé sous jessie

bendia a écrit :

Donc, sous Jessie, il n'existe plus smile


Pour l'instant.
D'aucuns parlent de packager ffmpeg (depuis le fork ffmpeg/libav, c'était libav qui étaient empaquetté dans le paquet ffmpeg).


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#17 17-02-2014 08:34:26

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [résolu] paquet cassé sous jessie

@nounours: tu peux vérifier maintenant que synaptic ne râle plus, en principe.  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#18 17-02-2014 09:16:53

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : [résolu] paquet cassé sous jessie

ça maaaaaarcheeeeeeeeeeeeeeee !!!!!!


Synaptic n'a pas râlé pour installer libave-tools

Merci à tous paskal le matelot et les autres.

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#19 17-02-2014 13:16:52

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [résolu] paquet cassé sous jessie

smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums