Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-03-2014 13:13:56

Ksama
Membre
Distrib. : Debian
Noyau : Linux 3.2.0-4-amd64
(G)UI : KDE
Inscription : 18-03-2014

Problème de WiFi

Bonjour,

J'ai installé Debian (amd64) sur mon PC Portable.
Ma carte wifi est une Intel Corporation Centrino Wireless-N 135.

J'ai donc installé le firmware :

apt-get install firmware-iwlwifi



Lorsque j'essaye de me connecter, le wifi bloque sur "Waiting for authorization" puis passe à "Not connected".
Parfois, le wifi est "Unavailable".

Merci d'avance.

Hors ligne

#2 18-03-2014 13:22:16

louispolaire
Membre
Distrib. : Siduction
Noyau : Linux 4.1.1-towo.1-siduction-amd64
(G)UI : xfce 4.12
Inscription : 22-08-2013

Re : Problème de WiFi

Bonjour Ksama,

Est ce que tu pourrais poster le résultat de ces 3 commandes (en root toutes les 3)?

iwconfig
rfkill list
lsmod | grep iw



si tu n'as pas rfkill d'installé installe le :

apt-get install rfkill

Dernière modification par louispolaire (19-03-2014 00:12:57)


Taisez-vous ! On vous écoute... - Exprimez-vous ! Personne n'écoute...

Hors ligne

#3 18-03-2014 13:29:24

Ksama
Membre
Distrib. : Debian
Noyau : Linux 3.2.0-4-amd64
(G)UI : KDE
Inscription : 18-03-2014

Re : Problème de WiFi

Bonjour louispolaire,

Merci de ta réponse.
Voici les résultats des commandes :

# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
eth0      no wireless extensions.
 



# rfkill list
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
 



# lsmod | grep iw
iwlwifi               166761  0
mac80211              192806  1 iwlwifi
cfg80211              137243  2 mac80211,iwlwifi
 

Hors ligne

#4 18-03-2014 13:58:38

louispolaire
Membre
Distrib. : Siduction
Noyau : Linux 4.1.1-towo.1-siduction-amd64
(G)UI : xfce 4.12
Inscription : 22-08-2013

Re : Problème de WiFi

Ok pas de problème ici...

Est ce que tu utilises network-manager ?

on va regarder les logs :

dmesg | grep 'iwlwifi\|cfg80211\|mac80211\|wlan0'

Dernière modification par louispolaire (19-03-2014 00:13:12)


Taisez-vous ! On vous écoute... - Exprimez-vous ! Personne n'écoute...

Hors ligne

#5 18-03-2014 14:00:57

Ksama
Membre
Distrib. : Debian
Noyau : Linux 3.2.0-4-amd64
(G)UI : KDE
Inscription : 18-03-2014

Re : Problème de WiFi

Oui j'utilise network-manager.

Dans les logs il n'y a que cette ligne en boucle :

[ 4513.791075] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
 



Avec ce qu'il y a entre [ ] qui change.

Dernière modification par Ksama (18-03-2014 14:01:08)

Hors ligne

#6 18-03-2014 14:28:59

louispolaire
Membre
Distrib. : Siduction
Noyau : Linux 4.1.1-towo.1-siduction-amd64
(G)UI : xfce 4.12
Inscription : 22-08-2013

Re : Problème de WiFi

d'après ce que je peux lire ça peut etre un pb avec la carte wifi. tu arrives à la faire fonctionner sous un autre OS ?

tu peux essayer :

echo "options iwlwifi 11n_disable=1" > /etc/modprobe.d/iwlwifi-hack.conf


puis un reboot


Taisez-vous ! On vous écoute... - Exprimez-vous ! Personne n'écoute...

Hors ligne

#7 18-03-2014 14:32:50

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Problème de WiFi

As tu regardé ceci: https://wiki.debian.org/fr/iwlwifi

Hors ligne

#8 18-03-2014 19:02:53

Invité-5
Banni(e)

Re : Problème de WiFi

louispolaire # 6 à écrit ;

tu arrives à la faire fonctionner sous un autre OS ?


Bonne question  smile

Hors Sujet. Croyez-moi, croyez-moi pas, un jour je suis tombé sur on ordi portable avec wlan désactivé dans le bios, par j'en sais quel miracle.H.S

Courage.

#9 18-03-2014 19:37:40

Ksama
Membre
Distrib. : Debian
Noyau : Linux 3.2.0-4-amd64
(G)UI : KDE
Inscription : 18-03-2014

Re : Problème de WiFi

Elle fonctionne correctement sur Windows 8.1

Cette après-midi, elle fonctionnait correctement à l'IUT (sous Debian), je rentre chez moi, même problème.
Est-il possible que cela soit lié au fait que je branche un câble ethernet, puis que je le retire pour tester le wifi ?

deuchdeb, oui j'ai regardé, c'est l'explication que j'ai suivi pour l'installer.

Dernière modification par Ksama (18-03-2014 19:38:58)

Hors ligne

#10 18-03-2014 20:23:31

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Problème de WiFi

Salut,

Ksama a écrit :

Est-il possible que cela soit lié au fait que je branche un câble ethernet, puis que je le retire pour tester le wifi ?


Hum, ça parait peu probable. Si ça fonctionne sur un autre réseau wi-fi, alors ta carte n'est pas en cause, c'est probablement une mauvaise configuration de ta connexion.
Je vois que tu as KDE, tu utilises l'applet de connexion pour la paramétrer? Est-ce que ça peut-être un mot de passe mal renseigné ou encore un mauvais choix dans le type de sécurité (WEP passphare, WEP hexa, WPA etc...) ?


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#11 18-03-2014 20:34:09

louispolaire
Membre
Distrib. : Siduction
Noyau : Linux 4.1.1-towo.1-siduction-amd64
(G)UI : xfce 4.12
Inscription : 22-08-2013

Re : Problème de WiFi

ok donc ça peut aussi venir du réseau chez toi ..

au cas où, n'y aurait il pas un espace dans l'ESSID de ton wifi ? e.g. :"Livebox Maison"

sinon ça peut etre lié a la config dhcp, a un filtrage sur ta box... va voir dans les options de ta box. mais là je dois avouer que je manque d'info pour t'aider.

normalement quand tu retire le cable ethernet ça devrais bien se passer avec Network Manager, au pire tu peux faire un :

/etc/init.d/networking restart


Taisez-vous ! On vous écoute... - Exprimez-vous ! Personne n'écoute...

Hors ligne

#12 18-03-2014 21:09:44

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème de WiFi

@louispolaire
Edite ton post11 pour voir comment écrire une commande root sur le forum.
Et regarde ensuite ce tuto chocolatesque :
Voir le tuto : Le code, ça pique moins les yeux en couleur

Youpiiiiiiiiiie lol

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums