Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-03-2014 14:09:49

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Kega Fusion

Est-ce que Kega Fusion (c'est un émulateur pour la Mega Drive) marche pour Debian ?

Il y a sur le site officiel une version Linux, ça me donne 3 fichiers dont un exécutable, mais il ne se passe rien quand on double-clique dessus.

Dernière modification par gio (24-03-2014 14:10:08)

Hors ligne

#2 24-03-2014 14:18:38

luxer
Membre
Distrib. : jessie/testing/sid--siduction
Noyau : 3.12-x-686-pae GCC4.8 (i686-linux-gnu)
(G)UI : xfce-4.10.0-5
Inscription : 12-02-2010

Re : Kega Fusion

as tu essayer "mess" qui se trouves dans les dépots debian ?

sinon il y as aussi "dgen" qui est aussi dans les dépots !

Dernière modification par luxer (24-03-2014 14:19:54)


Si Beethoven vivait encore il utiliserait lmms sur Debian

Hors ligne

#3 24-03-2014 14:28:22

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Kega Fusion

Bonjour

En lançant l'exécutable en console

./Fusion



J'obtiens

./Fusion: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory



Il semble donc que le programme recherche une bibliothèque non présente. Il semble qu'elle n'existe pas sous Debian donc, je dirais que ça aura du mal à fonctionner (ou alors avec force bidouilles)

La solution proposée par luxer semble donc la plus adaptée. D'une manière générale, utiliser les paquets des dépôts est toujours préférable smile


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#4 24-03-2014 14:34:00

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : Kega Fusion

J'avais l'habitude d'utiliser Kega Fusion sous Windows, alors je pensais continuer...si ce n'est pas possible, tant pis !

Sinon, y a t-il Gens ? Si oui, comment l'installer ? (J'ai télécharger un .deb)
EDIT: Bon j'ai trouvé. tongue

Dernière modification par gio (24-03-2014 14:41:34)

Hors ligne

#5 24-03-2014 14:40:29

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Kega Fusion

Il semblerait que oui mais pas à partir des dépôts

https://wiki.debian.org/fr/Emulator

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#6 24-03-2014 14:52:43

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : Kega Fusion

Par contre si quelqu'un sait comment on peut changer la taille de la fenêtre sous Gens ? big_smile

Hors ligne

#7 24-03-2014 16:50:18

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Kega Fusion

Exclusivement en 32 bit, il me semble. Il faut donc obligatoirement la lib32, donc mettre en multiarch.
Mais je ne suis pas sûr.

Dernière modification par golgot200 (24-03-2014 16:58:54)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#8 24-03-2014 18:17:13

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Kega Fusion

J'ai compilé dgen sdl 1.32 et fait le paquet deb
Les sources du Gui tkgen 1.1.1 et compilation et une installation directe. ( avec checkinstall pas moyen de sortir le Deb)

L'émulateur se lance bien  en 64 sans rajout des lib32
Je teste maintenant les réglages smile

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#9 24-03-2014 18:39:43

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Kega Fusion

Et ben, il y a longtemps que je voulais cette émulateur et un Gui ( pas terrible ce Gui mais bon pour les réglages, c'est top)
Tout est fonctionnel sans rajout sur une 64.  smile

Dernière modification par golgot200 (24-03-2014 18:40:26)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#10 24-03-2014 22:24:14

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Kega Fusion

Sous Gens  c'est Graphics, tu coches OpenGL et tu vas dans OpenGL Resolution et tu mets ce que tu veux. wink

Tu as quelle version de Gens ou Gens/GS, moi j'ai trouvé une version  "gens_2.15.5-gs-m6-1_amd64.deb" pour squeeze qui passe bien sur Wheezy. Les versions au dessus, les  libs ne passe pas.


Sega.png

Dernière modification par golgot200 (24-03-2014 22:33:01)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#11 25-03-2014 17:45:58

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : Kega Fusion

golgot200 a écrit :

Sous Gens  c'est Graphics, tu coches OpenGL et tu vas dans OpenGL Resolution et tu mets ce que tu veux. wink

Bin non justement, ça n'marche pas.
Ma version c'est Gens/GS r7 git: master/909e81d9

Hors ligne

#12 25-03-2014 18:34:46

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Kega Fusion

Désolé, je ne peux pas t'aider, la 2.17  ne s'installe pas sur Wheezy en 64, même avec les lib32, problème avec xdg-utils.

Dernière modification par golgot200 (25-03-2014 18:35:55)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#13 25-03-2014 19:40:38

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Kega Fusion

@gio: c'est pas graphics/backend/opengl puis graphics/opengl-resolution/celle que tu veux ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#14 25-03-2014 20:40:25

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Kega Fusion

Bon, j'ai installé une version R7 trouvée sur Getdeb. hmm
Car, pas moyen de compiler le bouzin, mauvaise architecture !!!

http://www.ubuntuupdates.org/package/ge … eb/gens-gs

http://archive.getdeb.net/ubuntu/pool/g … 5_i386.deb
http://archive.getdeb.net/ubuntu/pool/g … 5_i386.deb



Et bien captnfab à raison, c'est graphics/backend/opengl puis graphics/opengl-resolution/  et magie le changement de résolution fonctionne wink

Opengl_SDL.png

Dernière modification par golgot200 (25-03-2014 20:48:01)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#15 25-03-2014 21:05:21

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Kega Fusion

Sonic++ tongue

En ce moment j'essaye de faire un petit programme qui importe les niveaux de sonic3&Knuckles vers OpenSurge (développement de OpenSonic)

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums