Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-05-2014 22:25:43

jerome73
Membre
Inscription : 14-08-2013

[packaging] OpenSankoré – Paquet Debian Wheezy

Bonjour,
ceci est un appel à contributeur.
Il s'agit du logiciel de tableau interactif OpenSankoré (http://open-sankore.org/fr).
L'équipe de développement, très réactive intègre régulièrement nombre de fonctionnalité. Ell est très à l'écoute de  la communauté des utilisateurs.
Se  consacrant pleinement au développement, elle n'arrive, pour le moment  à «empaqueter»   que pour   Debian Squeeze et Ubuntu 12.04.

OpenSankoré version Squeeze s'installe bien sous Wheezy, avec toutefois une bidouille:
Il faut juste auparavant aller chercher dans les dépôt de Debian6 puis installer à la main une dépendance :
http://ftp.de.debian.org/debian/pool/ma … _amd64.deb
http://ftp.de.debian.org/debian/pool/ma … 4_i386.deb
En effet, comme il est dit dans le tutoriel (http://www.cbp.ens-lyon.fr/emmanuel.que … sur_wheezy)
s'appuie sur la 1.0.0.» OpenSSL 0.9.8 se trouve dans les dépôts de Debian6.

Si quelqu'un a déjà empaqueté OpenSankoré pour Wheezy (32 et 64bits), ou souhaite le faire, n'hésitez pas à contacter les développeurs.
L'adoption de OpenSankoré comme solution logicielle pour les tableaux numérique bloque parfois à cause de cette difficulté.
Or DebianEdu/Skolelinux est à présent basé sur la dernière Debian stable, Wheezy
( http://maintainer.skolelinux.org/debian … manual.pdf ).

Par avance, merci

Jérôme

Dernière modification par jerome73 (26-05-2014 22:43:05)


Debian stable Wheezy64+Gnome3/Gnome-Shell+Kernel3.10-0.bpo.3-amd64(→pour gérer correctement IvyBridge) - Clevo W540EU - IntelCore i3-3110M 2x2 cores IvyBridge - 2.5GHz - 3Mo cache - HD4000 - 35W - 4GoRam - PCI-E Wifi Intel 6235 Wifi802 300Mb + Bluetooth4.0

Hors ligne

#2 27-05-2014 07:27:21

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [packaging] OpenSankoré – Paquet Debian Wheezy

Je déplace dans la section "Contribuer ..."  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 27-05-2014 16:06:03

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [packaging] OpenSankoré – Paquet Debian Wheezy

Et si tu fais un retro-portage ou Backport à l’envers avec les sources de squeeze. On fait toujours de sid ou testing vers stable mais pourquoi pas de oldstable vers stable.
Ca peut être marrant d'essayer. smile

https://debian-facile.org/doc:mentors:retroportage

Hors ligne

#4 27-05-2014 16:37:03

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [packaging] OpenSankoré – Paquet Debian Wheezy

Salut jerome73,

Alors, ta «petite» bidouille, comme tu dis, consiste à installer une vieille version de la libssl, qui est au centre de la majorité des opérations de chiffrement et sécurisation, en particulier dans les réseaux.

Pour faire un paquet Debian pour Wheezy, il y a deux possibilités. La première est d'inclure la libssl9.8 dans le paquet, et la seconde est de porter opensankoré pour qu'il utilise une version à jour d'openssl (ou n'utilise pas openssl du tout).

La première à 0 chance d'être acceptée dans les dépôts Debian officiels, parce que Debian n'accepte en général pas les inclusions de libs dans les paquets, en particulier quand les libs sont liés à la sécu, et encore plus si la lib est dans une vieille version smile

Il reste donc la deuxième possibilité, qui est de porter le code d'opensankoré vers une version à jour d'openssl, ou vers une autre lib.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 30-05-2014 11:23:55

jerome73
Membre
Inscription : 14-08-2013

Re : [packaging] OpenSankoré – Paquet Debian Wheezy

tout à fait :-)
puisque que la «bidouille» permet d'installer open-sankoré, c'est qu'il  faudrait peut-être seulement  «simplement» lier le code d'open-sankoré à libssl1.0.0 (version de wheezy). Mais, ça, je na sais pas faire :-(

Jérôme

Remarque : libssl est la lib' qui a posé des problèmes de sécurité récemment me semble-t-il. Sa version sous squeeze (libssl0.9.8) a été mise à jour pour corriger la faille, comme sous wheezy (libssl1.0.0 )

Debian stable Wheezy64+Gnome3/Gnome-Shell+Kernel3.10-0.bpo.3-amd64(→pour gérer correctement IvyBridge) - Clevo W540EU - IntelCore i3-3110M 2x2 cores IvyBridge - 2.5GHz - 3Mo cache - HD4000 - 35W - 4GoRam - PCI-E Wifi Intel 6235 Wifi802 300Mb + Bluetooth4.0

Hors ligne

#6 30-05-2014 11:27:27

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [packaging] OpenSankoré – Paquet Debian Wheezy

Oui, la vieille version de la libssl a également été mise à jour dans Debian, squeeze étant encore supportée. Mais l'équipe de sécurité refuserait d'avoir à corriger la même faille à divers endroits smile

Sinon, où est le paquet source Debian (avec le répertoire debian/ et tout) du paquet opensankoré ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 01-06-2015 00:43:55

lebardix
Adhérent(e)
Lieu : Plan de Cuques
Distrib. : Version 7.9 (wheezy) 64 bits
Noyau : Noyau Linux 3.2.0-4-amd64
(G)UI : gnome 3.4.2 fallback
Inscription : 15-10-2013

Re : [packaging] OpenSankoré – Paquet Debian Wheezy

bonsoir,
Je viens rejoindre ce sujet.
Il me semble nécessaire d'obtenir un paquet pour ce logiciel.
J'utilise aujourd'hui pour 2 écoles la distribution debian-edu SkoleLinux (40PC) et cette application rentrerai très bien dans les objectifs d'une distribution spécifique Écoles en complétant le produit d'un TNI (Tableau Numérique Interactif) et surtout de tout un arsenal éducatif Open Source.

Donc en cherchant j'ai trouvé des packages debian de la version 2.5.0 http://ftp.open-sankore.org/previousRel … u%202.5.0/ 
qui s'installe sans problème sur une wheezy (debian-edu) (manque une dépendance à phonon pour la video)
Pour les sources, j'ai vu ce document semble-t-il ancien http://dev.open-sankore.org/xwiki/bin/v … Repository

Mais j'ai posé la question sur l'assistance d'OpenSankoré

----------------------------------------------

Mise à jour par : Marc Ferraton, 21 mai 16:30

Vous proposez encore des packages deb pour une version de Debian ancienne, ne serait-il pas important de proposer cette application (formidable) pour Debian stable ( a minima wheezy, et meme prévoir portage pour Jesie )
Il est difficile de garder les versions plus maintenues pour des problemes de sécurité, parfois de matériel, parfois d'évolution des autres applications.
Merci de prendre en considération cette requête, peut-être en l'inscrivant auprès de la communauté Debian, un developpeur en prendrait en charge la "simple" création du package ....


------------------
Envoyé de : http://open-sankore.org/fr


pour laquelle j'ai reçu cette réponse

----------------------------------------------

Mise à jour par : Francois Bocquet, 28 mai 10:20

Bonjour,
Merci de cette proposition.
Nous n'avons pas trouvé à ce jour de packageur officiel susceptible de pousser les paquets sur Debian pour cette application qui n'apparait donc ni dans les distributions Debian ni dans les distribution Ubuntu :-(
Peut être faudrait il modifier (purifier ?) certaintes parties de code pour que ce soit possible (je crois qu'il y a un soucis avec des polices de mémoire).
Si vous avez des pistes, n'hésitez pas à me les proposer.
Bien cordialement.

fbocquet@xxxxxxxxxx



Je me sens bien incapable de réaliser un tel paquet, et donc je lance une bouteille à la mer smile, si quelqu'un peut  s'atteler à une telle tache, je lui communiquerai le mail de Mr Bocquet, et bien-sûr participerai, dans la mesure de mes connaissances, à ces travaux, et aussi d'en faire la publicité auprès des créateurs de la distro SkoleLinux européenne.

J'ai préparé une station de présentation SkoleLinux - OpenSankoré en utilisant un simple rétroprojecteur et une tablette "Wacom Bamboo Pad" remplissant les 2 fonctions (digitaliseur avec stylet, et touchpad avec les doigts - SANS-FIL ) en interface pour l'instituteur et les enfants. J'envisage aussi un pointeur plus interactif sur le Tableau (videoprojeté) avec une console WII expérimentée par ailleurs, mais déjà le Bamboo est très pratique.

Hors ligne

#8 25-07-2015 17:03:08

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [packaging] OpenSankoré – Paquet Debian Wheezy

Bonjour,

Quand vous voulez qu'un programme soit packagé pour Debian, vous voudrez récupérer les toutes dernières sources, et tenter de les compiler directement chez vous, dans votre distribution Debian (sid par exemple), de préférence dans une installation dédiée au développement.

Voici les dernières sources disponibles pour Open Sankoré:
https://github.com/Sankore/Sankore-3.1

c'est une 3.1. C'est sur Github, vous pouvez donc au choix cloner, ou récupérer le fichier zip (en bas de la barre latérale à droite). Il y a aussi un dépôt sur gitorious. Je suggère de ne pas vous compliquer et de prendre la version de github.

Si vous parvenez à la compiler dans votre système, vous aurez déjà fait un pas en direction de la création d'un paquet. À suivre ?

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

Pied de page des forums