Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-05-2014 10:18:52

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

caractères spéciaux [résolu]

Bonjour

Il y a quelques mois je pouvais écrire les trois lettres danoises avec mon clavier azerty (de portable acer) et je crois bien aussi avec mon bépo.
Maintenant je ne le peux plus. J'arrive à faire æ et ø, en minuscule et majuscule sur les deux claviers, mais pas å.

Donc comment je fais pour écrire cette foutue lettre facilement svp ? Il est à noter que taper la lettre en console m'intéresse peu, mais la taper instinctivement en environnement de bureau et partout de la même façon, oui ! Dans un éditeur texte, sur internet… Et de manière pérenne !

À cet égard, la nouvelle disposition de des caractères æ et ø sur azerty est pertinente : aujourd'hui, alt gr + a ou o sur azerty, et hop ! Avant c'était z, g et h de mémoire…

Dernière modification par 22decembre (02-06-2014 21:34:19)

Hors ligne

#2 30-05-2014 10:28:54

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : caractères spéciaux [résolu]

Salut,
Qu'as-tu changé pour que le comportement change ?
Et comment faisais-tu avant ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 02-06-2014 08:10:15

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : caractères spéciaux [résolu]

Moi-même, j'ai rien changé (blague...). En fait, le changement a dû passer dans une des mise à jour.

Avant, les lettres æ, ø et aa (a avec un rond) étaient faites par alt-gr + z, g et h (ou f ?) si je me souviens bien. Il se trouve que je suis de plus en plus doué en danois, donc je vais avoir de plus en plus besoin de ces trois lettres...

Hors ligne

#4 02-06-2014 09:04:05

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Jessie 8.x & Backports
Noyau : Noyau Linux 3.16.0-4-686-pae
(G)UI : Xfce 4.10 & Mate 1.8.1
Inscription : 30-06-2008

Re : caractères spéciaux [résolu]

salut,

si ton info distri n'est plus à jour,
tu es sous quelle version de debian et quel environnement?

sous wheezy et xfce clavier eeepc asus«««««altgr+h=ð

                                                                altgr+g=æ
             
                                                                altgr+z=å

                                                                altgr+s=ø

                                                                altgr+l=Ô

Dernière modification par mksmn (02-06-2014 09:05:06)


Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#5 02-06-2014 09:07:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : caractères spéciaux [résolu]

Dans son info distri 22decembre est sur jessie. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 02-06-2014 10:09:55

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : caractères spéciaux [résolu]

Ce qui importe ici, c'est la disposition utilisée.
Que donne ?

setxkbmap -query


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 02-06-2014 10:50:12

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : caractères spéciaux [résolu]

10:43:00 stephane@luciole:~ $ setxkbmap -query
rules:      evdev
model:      pc105
layout:     fr
options:    terminate:ctrl_alt_bksp

Hors ligne

#8 02-06-2014 10:57:20

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : caractères spéciaux [résolu]

Donc tu utilises la variante par défaut.
L'ancienne variante par défaut était oss si je me souviens bien.
Tu peux tenter un

setxkbmap fr oss


Et voir si ça colle avec ce que tu avais avant.
Tu peux aussi de faire à la nouvelle variante et utiliser les nouveaux raccourcis pour faire ces lettres smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 02-06-2014 19:26:52

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : caractères spéciaux [résolu]

Je préfère me faire à la nouvelle. Mais il me manque la combinaison pour faire le a avec un rond (et aussi en majuscule). Comment fait-on cette lettre ? Enfin, comment on trouve comment on fait la lettre ?

Hors ligne

#10 02-06-2014 19:56:31

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : caractères spéciaux [résolu]

J'ai l'impression que c'est AltGr-Shift-^ qui donne un ° mort.
Donc AltGr-Shift-^ + a

À voir dans le /ush/share/X11/xkb/symbols/fr

Sinon, tu dois pouvoir forcer une combinaison de ton choix, genre AltGr-z via le fichier .XCompose, ou via xmodmap, mais ça devient plus technique.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 02-06-2014 21:04:52

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : caractères spéciaux [résolu]

å et Å => ouais c'est ça ... ça va être rigolo de s'en souvenir, et de faire la majuscule aussi ! Merci !

Hors ligne

#12 02-06-2014 21:30:07

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : caractères spéciaux [résolu]


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums