Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-05-2014 17:28:01

manu0123456
Membre
Distrib. : Debian Wheeezy 7.5
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4
Inscription : 30-05-2014

luks ne marche pas avec fichier keyfile - Résolu

je suis sous wheezy, avec 4 partitions cryptées + swap
j'ai complètement réinstallé récemment.
depuis la réinstallation, j'arrive à manipuler les partitions en ligne de commande ainsi qu'avec palimpsest (gnome-disk-utility)
quand je veux automatiser avec l'utilisation d'u fichier contenant le mot de passe, j'obtiens systématiquement le message d'erreur "Aucune clé n'est disponible avec cette phrase secrète."
j'ai ce message d'erreur aussi bien au démarrage qu'avec "cryptsetup luksOpen"  ou "cryptsetup luksAddKey"
Pourriez vous m'aider à résoudre ce problème ?
merci

Dernière modification par manu0123456 (03-06-2014 19:29:28)

Hors ligne

#2 30-05-2014 17:35:43

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : luks ne marche pas avec fichier keyfile - Résolu

Salut,
D'après le man, pour que cryptsetup lise depuis l'entré standard, il faut lui donner « - » comme fichier contenant les clés.
De plus, il ne faut pas confondre les clés et les passphrases smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 30-05-2014 18:19:21

manu0123456
Membre
Distrib. : Debian Wheeezy 7.5
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4
Inscription : 30-05-2014

Re : luks ne marche pas avec fichier keyfile - Résolu

Quand je fais

root@debian-manu:/# cryptsetup luksOpen /dev/sda1 SSD_crypte
Saisissez la phrase secrète pour /dev/sda1 : mot_de_passe
root@debian-manu:/#


ça marche très bien, la partition est ouverte.
par contre, si je fais :

root@debian-manu:/# echo "mot_de_passe" > /etc/luks-keys/SSD_crypte.key
root@debian-manu:/# cryptsetup luksOpen /dev/sda1 SSD_crypte --key-file=/etc/luks-keys/SSD_crypte.key
Aucune clé n'est disponible avec cette phrase secrète.
root@debian-manu:/#


ça ne marche pas.
Dans mon ancienne configuration, cela marchait très bien.

de la même manière, si je fais

root@debian-manu:/# cryptsetup luksAddKey /dev/sda1 --key-file=/etc/luks-keys/SSD_crypte.key
Aucune clé n'est disponible avec cette phrase secrète.
root@debian-manu:/#


j'obtiens le même message d'erreur

j'ai changé les droits d'accès et répertoire du fichier "mot de passe", j'ai regardé avec retour chariot et sans dans le fichier, mais rien à faire

Hors ligne

#4 30-05-2014 18:29:32

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : luks ne marche pas avec fichier keyfile - Résolu

Et tout fonctionne quand tu es en mode interactif ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 30-05-2014 18:35:50

manu0123456
Membre
Distrib. : Debian Wheeezy 7.5
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4
Inscription : 30-05-2014

Re : luks ne marche pas avec fichier keyfile - Résolu

oui,
après si il faut monter tout le système à la mano après démarrage, c'est pas top...

Dernière modification par manu0123456 (30-05-2014 18:39:11)

Hors ligne

#6 30-05-2014 19:27:07

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : luks ne marche pas avec fichier keyfile - Résolu

Je pense que captnfab a tout dis dans son premier post: clé != passphrase
essaye simplement d'ajouter une clé  mais  sans  --key-file=/etc/luks-keys/SSD_crypte.key
ça devrait marcher.

Hors ligne

#7 03-06-2014 19:28:38

manu0123456
Membre
Distrib. : Debian Wheeezy 7.5
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4
Inscription : 30-05-2014

Re : luks ne marche pas avec fichier keyfile - Résolu

ça y est, ça marche.
merci

Hors ligne

#8 03-06-2014 19:36:08

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : luks ne marche pas avec fichier keyfile - Résolu

si ça marche de ton coté, pourrais tu prendre 5 minutes pour donner ton avis sur ce que j'ai écrit ici:
http://debian-facile.org/viewtopic.php?id=9101

cela permettrait de compléter le tuto et l'ajouter dans le wiki

Hors ligne

Pied de page des forums