Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-07-2014 17:01:35

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

[resolu] Failed to process /etc/kernel/postinst.d

Bonjour,

root@debian:/# dpkg-reconfigure linux-image-3.2.0-4-amd64
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
mkinitramfs: MODULES dep requires mounted sysfs on /sys
update-initramfs: failed for /boot/initrd.img-3.2.0-4-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-4-amd64.postinst line 696.
root@debian:/#



donc, après ceci :
http://debian-facile.org/viewtopic.php?pid=93988#p93988
où je raconte :

après avoir installé un dual boot via secure remix Ubuntu et W7, j'essaye d'installer Debian 7.5.0, toujours en dual boot avec W7, sur un LVM chiffré.
l'installation de grub2 s'étant terminée par des erreurs, j'ai continué l'installation sans grub2. l'installer a dit que c'était fait :-)


j'ai rebooté à partir d'un live cd debian 750 et chrooté sur l'installation en suivant ça :


et la fin du topo m'amène à la réponse du début.

une idée ?

merci d'avance.
cordialement.
debianux.

Dernière modification par debianux (04-07-2014 16:38:06)

Hors ligne

#2 02-07-2014 18:13:35

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

par ailleurs :

root@debian:/# dpkg-reconfigure initramfs-tools
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: /boot/initrd.img-3.2.0-4-amd64 has been altered.
update-initramfs: Cannot update. Override with -t option.
root@debian:/#

root@debian:/# dpkg --configure -a
root@debian:/#


et

root@debian:/# mkdir tmp/initramfs
root@debian:/# cd tmp/initramfs
root@debian:/tmp/initramfs# cd /boot
root@debian:/boot# ls
config-3.2.0-4-amd64  initrd.img-3.2.0-4-amd64  sys
dev         lost+found    System.map-3.2.0-4-amd64
grub          proc      vmlinuz-3.2.0-4-amd64
root@debian:/boot# cd tmp/initramfs
bash: cd: tmp/initramfs: Aucun fichier ou dossier de ce type
root@debian:/boot# cd ../
root@debian:/# cd tmp/initramfs
root@debian:/tmp/initramfs# gunzip -c /boot/initrd.img-3.2.0-4-amd64 | \
> cpio -i -d -H newc --no-absolute-filenames
16797 blocs
root@debian:/tmp/initramfs# ls | less


bin
conf
etc
init
lib
lib64
run
sbin
scripts
~
~
~
~
~
~
~
~
~
~
~
~
~
~
 


comprenne qui pourra :-)

Hors ligne

#3 02-07-2014 20:10:24

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu] Failed to process /etc/kernel/postinst.d

Salut,

Au hasard, tu n'aurais pas une partition /boot pleine ?
Que donne ?

df -h /boot


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#4 02-07-2014 22:11:24

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

salut captnfab !

root@debian:/# df -h /boot
Sys. fich.     Taille Util. Dispo Uti% Monté sur
-                1,8G   13M  1,7G   1% /boot
root@debian:/#
 

Hors ligne

#5 02-07-2014 22:18:19

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu] Failed to process /etc/kernel/postinst.d

Yo,
Pas un problème d'espace donc. smile

mkinitramfs: MODULES dep requires mounted sysfs on /sys
update-initramfs: failed for /boot/initrd.img-3.2.0-4-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-4-amd64.postinst line 696.


Ce message indique qu'il faut monter /sys dans le chroot avant de lancer de reconfigure.
Il indique ensuite que la reconfiguration a échoué, peut-être à cause de cela.
Tu devrais réessayer en montant /sys.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#6 04-07-2014 09:18:00

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

Bonjour captnfab,
ce que j'ai monté jusqu'ici :

root@debian:~# mount /dev/mapper/gvdeb750wheezy-lv_slash_racine /mnt/system
root@debian:~# mount /dev/mapper/gvdeb750wheezy-lv_home /mnt/system/home
root@debian:~# mount /dev/mapper/gvdeb750wheezy-lv_tmp /mnt/system/tmp
root@debian:~# mount /dev/mapper/gvdeb750wheezy-lv_var /mnt/system/var
root@debian:~# mount /dev/mapper/gvdeb750wheezy-lv_usr /mnt/system/usr
root@debian:~# mount /dev/sda6 /mnt/system/boot
root@debian:~# mount -o bind /dev /mnt/system/dev
root@debian:~# mount -o bind /proc /mnt/system/proc
root@debian:~# chroot /mnt/system
 


pour le /sys j'ai un doute : est-ce un bind comme pour '/dev' ou plutôt  '/sys' qui ferait partie de l'installation dans 'gvdeb750wheezy' ?
d'un autre côté, c'est la même version de debian qui est utilisée, ce qui me laisserait penser que c'est le même 'sys'.

Hors ligne

#7 04-07-2014 10:12:11

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

actuellement, étant chrooté sur l'installation en lvm :

root@debian:/# ls
bin   etc   lib       media  proc  sbin     sys  var
boot  home    lib64       mnt    root  selinux  tmp  vmlinuz
dev   initrd.img  lost+found  opt    run   srv      usr


il y a bien un 'sys' dans la partition racine montée.

root@debian:/# mount
/dev/mapper/gvdeb750wheezy-lv_slash_racine on / type ext4 (rw,relatime,errors=remount-ro,user_xattr,barrier=1,data=ordered)
/dev/mapper/gvdeb750wheezy-lv_home on /home type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
/dev/mapper/gvdeb750wheezy-lv_tmp on /tmp type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
/dev/mapper/gvdeb750wheezy-lv_usr on /usr type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
/dev/mapper/gvdeb750wheezy-lv_var on /var type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
tmpfs on /dev type tmpfs (rw,relatime,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
none on /run type tmpfs (rw,nosuid,relatime,size=402840k,mode=755)
root@debian:/#
 


pas le bon 'sys' ? au bon endroit ?

Hors ligne

#8 04-07-2014 11:04:21

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu] Failed to process /etc/kernel/postinst.d

Salut,
Dans le post ci-dessus, tout semble bon. Tu as essayé de regérérer l'initrd ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 04-07-2014 14:25:04

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

root@debian:/# dpkg-reconfigure linux-image-3.2.0-4-amd64
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
mkinitramfs: MODULES dep requires mounted sysfs on /sys
update-initramfs: failed for /boot/initrd.img-3.2.0-4-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-4-amd64.postinst line 696.
root@debian:/# dpkg-reconfigure linux-image-3.2.0-4-amd64
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
mkinitramfs: MODULES dep requires mounted sysfs on /sys
update-initramfs: failed for /boot/initrd.img-3.2.0-4-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-4-amd64.postinst line 696.
root@debian:/# dpkg-reconfigure initramfs-tools
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: /boot/initrd.img-3.2.0-4-amd64 has been altered.
update-initramfs: Cannot update. Override with -t option.
root@debian:/#
 

Hors ligne

#10 04-07-2014 14:39:28

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

n'aurions-nous pas progressé ?
j'ai 're-monté' 'sys' et à part un pb de 'locale', il semble qu'il ait trouvé les partitions, notamment w...

root@debian:/# exit
exit
root@debian:~# mount -t sysfs /sys /mnt/system/sys
root@debian:~# chroot /!n
-bash: !n: event not found
root@debian:~#
root@debian:~# chroot /mnt/system
root@debian:/# dpkg-reconfigure linux-image-3.2.0-4-amd64
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
  LANGUAGE = (unset),
  LC_ALL = (unset),
  LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
  LANGUAGE = (unset),
  LC_ALL = (unset),
  LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
  LANGUAGE = (unset),
  LC_ALL = (unset),
  LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
  LANGUAGE = (unset),
  LC_ALL = (unset),
  LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
Generating grub.cfg ...
Found background image: .background_cache.png
Found linux image: /boot/vmlinuz-3.2.0-4-amd64
Found initrd image: /boot/initrd.img-3.2.0-4-amd64
Found Windows Recovery Environment (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
root@debian:/#
 

Hors ligne

#11 04-07-2014 14:45:04

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

modif des 'locales'

root@debian:/# locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
C.UTF-8
POSIX
fr_FR.utf8
root@debian:/# export LANGUAGE=fr_FR.utf8
root@debian:/# export LANG=fr_FR.utf8
root@debian:/# export LC=fr_FR.utf8
root@debian:/# locale-gen fr_FR.utf8
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.
root@debian:/# dpkg-reconfigure locales
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.
root@debian:/#
 


'à rebooter !'

Hors ligne

#12 04-07-2014 14:47:22

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

juste avant, une vérif des locales :

root@debian:/# dpkg-reconfigure locales
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.
root@debian:/# dpkg-reconfigure linux-image-3.2.0-4-amd64
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
Generating grub.cfg ...
Found background image: .background_cache.png
Found linux image: /boot/vmlinuz-3.2.0-4-amd64
Found initrd image: /boot/initrd.img-3.2.0-4-amd64
Found Windows Recovery Environment (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
root@debian:/#
 


super :-)

Hors ligne

#13 04-07-2014 14:58:12

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

démontage et verif de ce qui est monté :

root@debian:/# exit
exit
root@debian:~# umount /mnt/system/home
root@debian:~# umount /mnt/system/tmp
root@debian:~# umount /mnt/system/var
root@debian:~# umount /mnt/system/usr
root@debian:~# umount /mnt/system/dev
root@debian:~# umount /mnt/system/proc
root@debian:~# umount /mnt/system/sys
root@debian:~# umount /mnt/system/boot
root@debian:~# umount /mnt/system
root@debian:~# cryptsetup luksClose gvdeb750wheezy
Device gvdeb750wheezy is not active.
root@debian:~# mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=501797,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=402840k,mode=755)
/dev/sr0 on /lib/live/mount/medium type iso9660 (ro,noatime)
/dev/loop0 on /lib/live/mount/rootfs/filesystem.squashfs type squashfs (ro,noatime)
tmpfs on /lib/live/mount/overlay type tmpfs (rw,relatime)
tmpfs on /lib/live/mount/overlay type tmpfs (rw,noatime,mode=755)
aufs on / type aufs (rw,relatime,si=5a9e741bd267514b,noxino)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=805660k)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sdb1 on /media/9016-4EF8 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0077,codepage=cp437,iocharset=utf8,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks)
/dev/sr1 on /media/Debian wheezy 20140505-04:14 type iso9660 (ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks)
root@debian:~#
 


j'espère n'avoir rien oublié :-)

Hors ligne

#14 04-07-2014 16:37:38

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] Failed to process /etc/kernel/postinst.d

en voilà un de résolu :-)
1/ redémarrage impeccable avec mister grub aux commandes : debian does run !
2/ redémarrage sur w7 : mode 'sans échec' : y arrive pas smile
3/ redémarrage sur w7 partition recovery : 'can't open C:\recovery.dat : un comble...
4/ redémarrage sur w7 mode 'normal' : succès.

et là, retour sur debian : confort !
merci pour le coup de main :-)
cordialement
debianux

Hors ligne

#15 04-07-2014 17:43:52

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu] Failed to process /etc/kernel/postinst.d

\o/

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums