Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-07-2014 11:53:36

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

[Résolu]installer Löve sous wheezy

Bonjour,
Je vois sur le site Löve qu'il existe un paquet pour ubuntu 14.04...
Pour Wheezy j'ai téléchargé le tarball :  love-0.9.1-linux-src.tar.gz
Après décompression, dans le mode d'emploi, on trouve:
./platform/unix/automagic
Les sous répertoires platform et unix existent bien; mais pas de fichier d'automatics ???
Par ailleurs pour installer :
Debian Wheezy
Install the following packages (using aptitude or apt):
aptitude install build-essential automake libtool libphysfs-dev libsdl-dev libopenal-dev liblua5.1-0-dev libdevil-dev libmodplug-dev libfreetype6-dev libmpg123-dev libvorbis-dev libmng-dev libxpm-dev libxcursor-dev libXxf86vm-dev

Afterwards, just build it like it is mentioned below, but passing the --with-lua=lua option to ./configure

If you want or need to use LuaJIT, you will need to either backport the Debian packaged from Jessie, or build it from the upstream source.
Mais "below": ds 3) Building
Linux
Use the automagic script to generate the configure file and then run configure and make as usual.
./platform/unix/automagic
./configure
make

Peut-être on peut installer Löve si on est pas fou, mais ça aide un peu !! tongue
Merci pour un peu d'aide

Dernière modification par gargamel79 (10-07-2014 09:54:55)

Hors ligne

#2 10-07-2014 09:54:02

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]installer Löve sous wheezy

Je me réponds à moi-même !
Je suis sur wheesy avec bureau xfce : la recherche avec synaptic n'est pas toujours évidente...
Quoiqu'il en soit le paquet existe bel et bien, donc pas besoin de se prendre la tête avec un
tarball obsolète.

Dernière modification par gargamel79 (10-07-2014 09:59:15)

Hors ligne

#3 10-07-2014 10:40:52

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]installer Löve sous wheezy

Sinon, il y a apt qui permet de chercher avec des expressions régulières

apt-cache search ^love
 


love - 2D game development framework based on Lua and OpenGL
love-dbg - 2D game development framework - debugging symbols
love-doc - 2D game development framework - documentation


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#4 10-07-2014 11:15:41

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy et jessie
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]installer Löve sous wheezy

Tu as raison, rien de tel que la ligne de commande ! Tous ces outils graphiques, ça marche quand ça a le temps ...

Hors ligne

Pied de page des forums