Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-07-2014 19:45:05

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Bonjour,

C'est mon premier poste ici (et sur un forum tout court d'ailleurs!). Merci d'avance pour votre accueil -:)

Le problème concerne l'impression avec une canon MP220 utilisée sous debian wheezy 64, avec cups et le driver MP220 de printer-driver-gutenprint.

Lorsque je lance une impression, celle-ci démarre (plus ou moins laborieusement), puis plus ça va plus elle ralentit, avant de s'arrêter généralement avant la fin de la page, imprimante plantée. 

J'ai essayé le driver de la MP110 ... rien.
Je ne peux pas essayer le driver propriétaire canon, il n'existe pas pour la MP220.

Par contre, si l'impression est lancée depuis mon "vieux" pc 32 bits (sous wheezy lui aussi), pas de problème.
De même, (honte à moi!), l'impression ne pose pas de problème depuis le PC 64 bits sous windoz.

Le problème est donc bien localisé sur le driver 64 bits.

J'essayerai bien de faire tourner le driver 32bits gutenprint  en multiarch sur 64 bits, mais je ne sais pas comment faire.

Quelqu'un a-t-il une idée?

Merci smile

Dernière modification par papy-tux (26-08-2014 10:29:21)

Hors ligne

#2 26-07-2014 20:00:51

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Bonjour et bienvenue  smile

Tu devras activer la prise en charge de l'architecture 32 bits :

dpkg --add-architecture i386
apt-get update

ensuite, essaye d'installer le paquet indiquant i386 probablement :

dpkg -i paquet_i386.deb
aptitude install -f

Si tu as un doute, reviens faire le point.  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 26-07-2014 23:15:35

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Bonsoir,

Merci pour ce retour rapide. Voilà ce que cela a donné :

L'architecture 32 bits était déjà en place. Donc ok

J'ai ensuite essayé


root@Asus:/home/philippe#dpkg -i printer-driver-gutenprint:i386
 



La réponse :

dpkg:erreur de traitement de printer-driver-gutenprint:i386 (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 printer-driver-gutenprint:i386



?????? Poutant, la version 32 bits est bien présente :

i   printer-driver-gutenprint       - Pilotes d'imprimantes pour CUPS          
p   printer-driver-gutenprint:i386  - Pilotes d'imprimantes pour CUPS  



J'ai tout de même tenté : :

aptitude install -f



La réponse (extrait ):

Les paquets suivants seront ENLEVÉS :        
  libgl1-nvidia-glx{u} libgl1-nvidia-glx:i386{u}
  libgl1-nvidia-glx-i386:i386{u} libnvidia-ml1{u} libxnvctrl0{u}
  nvidia-settings{u} nvidia-support{u}
 



J'ai accepté....

Le paquet 386 n'est toujours pas installé.

J'ai réessayé en enlevant au préalable le paquet printer-driver-gutenprint d'origine (64 bits) . Les réponses sont les mêmes.....

Je suis à bout d'idées!

Bon, la nuit portera peut-être conseil smile

Hors ligne

#4 26-07-2014 23:23:27

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Tu as bien fait l'update ?
Après, vu que le paquet est dans le dépôt main, procède plutôt ainsi :

apt-get install printer-driver-gutenprint:i386


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 27-07-2014 21:51:07

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Je viens de faire les manips suivantes :

aptitude update && aptitude upgrade



Puis,

aptitude install printer-driver-gutenprint:i386



Cela affiche un très grand nombre de problèmes de dépendances non solubles autrement qu'à la main. Je n'ai pas continué.

J'ai purgé le "plus évident" :

aptitude purge printer-driver-all ghostprint-cups



Maintenant j'obtiens pour :

aptitude install printer-driver-gutenprint:i386



Les NOUVEAUX paquets suivants vont être installés :
  ghostscript-cups:i386{a} libcupsimage2:i386{a} libgutenprint2:i386{a}
  perl:i386{ab} perl-base:i386{ab} printer-driver-gutenprint:i386
0 paquets mis à jour, 6 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 7 017 ko d'archives. Après dépaquetage, 24,5 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 perl : Est en conflit avec: perl:i386 mais 5.14.2-21+deb7u1 doit être installé.
 perl:i386 : Dépend: perl-modules:i386 (>= 5.14.2-21+deb7u1) qui est un paquet virtuel
             Dépend: libbz2-1.0:i386 mais il ne sera pas installé.
             Est en conflit avec: perl mais 5.14.2-21+deb7u1 est installé.
 perl-base : Est en conflit avec: perl-base:i386 mais 5.14.2-21+deb7u1 doit être installé.
 perl-base:i386 : Est en conflit avec: perl-base mais 5.14.2-21+deb7u1 est installé.
Impossible de trouver une solution à ces dépendances ! Abandon…
Les NOUVEAUX paquets suivants vont être installés :
  ghostscript-cups:i386{a} libcupsimage2:i386{a} libgutenprint2:i386{a}
  perl:i386{ab} perl-base:i386{ab} printer-driver-gutenprint:i386
0 paquets mis à jour, 6 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 7 017 ko d'archives. Après dépaquetage, 24,5 Mo seront utilisés.
Il n'a pas été possible de résoudre ces dépendances. Vous pouvez les résoudre vous-même ou taper « n » pour quitter.
Les paquets suivants ont des dépendances non satisfaites :
 perl : Est en conflit avec: perl:i386 mais 5.14.2-21+deb7u1 doit être installé.
 perl:i386 : Dépend: perl-modules:i386 (>= 5.14.2-21+deb7u1) qui est un paquet virtuel
             Dépend: libbz2-1.0:i386 mais il ne sera pas installé.
             Est en conflit avec: perl mais 5.14.2-21+deb7u1 est installé.
 perl-base : Est en conflit avec: perl-base:i386 mais 5.14.2-21+deb7u1 doit être installé.
 perl-base:i386 : Est en conflit avec: perl-base mais 5.14.2-21+deb7u1 est installé.
Faut-il résoudre ces dépendances manuellement ? [N/+/-/_/:/?]
 



Je ne sais pas à quoi servent les paquets perl ni si je peux les enleverb sans tout casser.

Merci de ton aide

Hors ligne

#6 27-07-2014 21:55:49

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Malheureusement, rien sad
printer-driver-gutenprint:i386 n'est pas installable sans casser le système.

Si tu veux installer un cups 32 bits, il va te falloir faire un chroot dans ton système, c'est à dire installer une Debian 32bits dans un dossier (voir debootstrap / chroot / etc.) smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 27-07-2014 22:12:44

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Bonsoir,

hum....

Je vais déjà installer une 32 bits sur le PC 64 bits et vérifier que l'impression s'effectue correctement.

Est-ce que une fois "le chroot ou /et debootstrap" installé (je vois vaguement le principe, mais je ne pratique pas!), le fonctionnement sera transparent pour faire une impression (sans ligne de commande ou autre manip)?

Merci

Hors ligne

#8 27-07-2014 22:21:25

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Euh, je pense… dans une certaine mesure… du moment que tu as bien fait en sorte que le cups du chroot soit lancé automatiquement… je l'espère… smile
CUPS reste un peu incompréhensible pour moi smile Et le peu que j'en comprends, les pilotes d'imprimantes proprio m'indiquent que je n'ai rien compris.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 29-07-2014 20:10:42

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Contrairement  à  ce que j'espérais, l'imprimante ne fonctionne pas mieux sur le PC 64 bits avec wheezy 32 bits.. Je déclare forfait!

Merci à tous ceux qui m'ont aidé! smile

PS comment fait-on pour marqué le post comme résolu?

Hors ligne

#10 29-07-2014 23:44:01

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Salut,
En l'occurrence, le post n'est pas « résolu » mais « abandonné » smile
Tu édites le premier message du fil, il y a un champ Sujet.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 30-07-2014 08:43:26

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

papy-tux a écrit :

Je déclare forfait!

Peut-être est-ce un peu tôt pour cela, non ?
D'autant plus que ce type de problème a pu être résolu par ailleurs (sur ubuntu).

Si tu n'es pas allergique à l'anglais, je t'invite à faire une recherche avec les mots clés :

debian +canon +MP220 +slow

Les premiers résultats sont déjà intéressants.  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#12 30-07-2014 23:29:50

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

1 - Recherche sur internet :

debian +canon +MP220 +slow



ne m'a donné qu'un retour. En avais-tu d'autres?

Résultats de recherche

    The Canon PIXMA Linux blog, for all Canon PIXMA all-in-ones
    mp610.blogspot.com/Traduire cette page
    4 mai 2009 - Maybe you experienced this particular error message while trying to install the cnij_usb Canon printer driver for your PIXMA, on recent CUPS ..

Je retombe toujours sur les mêmes sites et j'ai l'impression de tourner en rond (pour ne pas dire en bourrique!)

2 - Sinon, j'ai essayé différents drivers gutenprint MP210, M240, MP260 : le résultat est toujours le même.

Au début, l'interface est reconnue et la première impression se passe bien (la feuille s'imprime rapidement jusqu' au bout).

# ls /dev/usb/lp*
/dev/usb/lp0 (ou lp1 selon le port USB)
 



A partir de la deuxième impression, plus rien et l'interface USB est  plantée.

# ls /dev/usb/lp*
ls: impossible d'accéder à /dev/usb/lp*: Aucun fichier ou dossier de ce type
 



S'il y avait un moyen de réinitialiser l'interface (et l'imprimante), je pense que cela réglerait une partie du problème....

Hors ligne

#13 26-08-2014 10:39:17

papy-tux
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : xfwm4
Inscription : 22-05-2014

Re : Problème driver imprimante MP220 64 bits / 32 bits - Abandon

Pour info, j'ai téléchargé la version démo (un mois) du logiciel Turboprint. Le logiciel est plutôt bien fait. Impression sans problème avec mon imprimante (MP220). 
Dommage que ce soit un logiciel non libre et payant.

Je ferme le post.

Merci beaucoup à paskal et capntfab pour leur réactivité et propositions. smile

Hors ligne

Pied de page des forums