Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-12-2008 20:47:18

Sky-X-Wind
Membre
Inscription : 13-12-2008

[Réglé]probleme de dependance (flash player)

Bonsoir, je suis nouveau sur debian et suis un peu perdu.
J'essai d'installer flash player mais que ce soit apres installation de la r1 ou de la r5 (etch) j'obtient toujours un probleme de dependance.
j'ai lu sur internet qu'il fallait mettre a jour l'ordinateur mais le mien l'est déjà.

Dernière modification par Sky-X-Wind (15-12-2008 08:04:02)

Hors ligne

#2 14-12-2008 21:17:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Réglé]probleme de dependance (flash player)

Bonsoir, quel navigateur utilises-tu ?

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 14-12-2008 21:17:43

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

iceweasel

Hors ligne

#4 14-12-2008 21:25:57

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]probleme de dependance (flash player)

Bonsoir et bienvenue sur DF

Peut être un problème de sources.list? peux tu nous le coller stp?

Hors ligne

#5 14-12-2008 21:37:32

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

bonsoir,
merci de m'aider
#
# deb cdrom:[Debian GNU/Linux 4.0 r5 _Etch_ - Official i386 DVD Binary-1 20081023-23:00]/ etch contrib main

deb cdrom:[Debian GNU/Linux 4.0 r5 _Etch_ - Official i386 DVD Binary-1 20081023-23:00]/ etch contrib main

deb http://ftp.fr.debian.org/debian/ etch main
deb-src http://ftp.fr.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib

Hors ligne

#6 14-12-2008 21:57:35

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

Salut

Il manque certaines choses dans ton fichiers sources.list. En voici un bon :

## etch
deb http://ftp.fr.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ etch main contrib non-free
#debian-marillat
deb http://www.debian-multimedia.org etch main
deb-src http://www.debian-multimedia.org etch main
# security
deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free


Il faut ajouter les dépôts contrib et non-free.

Le dépôt debian-multimedia permet d'installer le paquer flashplayer-mozilla pour avoir flash dans Iceweasel. Tu peux aussi ajouter le dépôt etch-backports pour installer le paquet flashplugin-nonfree. C'est à ton choix.

deb http://www.backports.org/debian etch-backports main contrib non-free


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 14-12-2008 22:10:50

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

j'ai un problème maintenant quand j'ouvre le gestionnaire de paquet synaptic.
impossible de localiser la liste des paquets sources http://ftp.fr.debian.org etch/contrib Packages...
Sachant que je viens a peine d'installer debian, c'est normal que le sources.list est mauvais?
ps: j'ai toujours le probleme de dependance

Dernière modification par Sky-X-Wind (14-12-2008 22:12:23)

Hors ligne

#8 14-12-2008 22:13:52

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

Il doit y avoir une erreur d'écriture dans ton fichier, un espace de trop ou quelque chose du genre. Postes ton nouveau fichier sources.list.

P.S. Il ne doit pas y avoir de barre oblique entre etch et contrib.

P.S. #2 : une fois ton fichier sources.list modifier, as-tu cliqué sur Recharger dans Synaptic pour tenir compte des changements ?

Dernière modification par martinux_qc (14-12-2008 22:18:01)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 14-12-2008 22:27:18

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

enlever les / n'a rien changé

## etch
deb http://ftp.fr.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ etch main contrib non-free
#debian-marillat
deb http://www.debian-multimedia.org etch main
deb-src http://www.debian-multimedia.org etch main
# security
deb http://security.debian.org/ etch updates main contrib non-free
deb-src http://security.debian.org/ etch updates main contrib non-free
deb http://www.backports.org/debian etch-backports main contrib non-free

Hors ligne

#10 14-12-2008 22:34:15

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

Regardes le dépôt security, il faut écrire etch/updates

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#11 14-12-2008 22:35:41

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

J'ai toujours un probleme mais il semblerait que ca vienne de la ligne [...]security.debian.org...
selon synaptic
Dans le message d'erreur il n'y a que des liens en security.....

Hors ligne

#12 14-12-2008 22:39:34

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

En effet, c'est ce que je viens de souligner. Nos messages se sont croisés.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#13 14-12-2008 22:39:38

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

ok plus de message d'erreur au lancement de synaptik mais j'en ai toujours un quand je tente de recharger
c'est un probleme avec la source multimedia
(je n'ai pas la cle publique) -_-' j'y comprend rien
et toujours le message
error: Dependency is not satisfiable: libatk1.0-0
quand jetente d'installer flashplayer.deb

Dernière modification par Sky-X-Wind (14-12-2008 22:46:32)

Hors ligne

#14 14-12-2008 22:44:33

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

OK. Installe le paquet debian-multimedia-keyring puis refait une recharge.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#15 14-12-2008 22:49:29

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

voila! plus qu'un message d'erreur
la clé publique pour http://www.backports.org etch-backports Release n'est pas disponible

Hors ligne

#16 14-12-2008 22:51:33

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

flashplayer.deb c'est quel paquet au juste, dans quel dépôt?

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#17 14-12-2008 22:52:27

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

fje l'ai téléchargé directement du site adobe

Hors ligne

#18 14-12-2008 22:53:21

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

Il faut installe le paquet debian-backports-keyring pour la clé public.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#19 14-12-2008 22:54:35

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

Sky-X-Wind a écrit :

fje l'ai téléchargé directement du site adobe


Je t'ai donné le nom de 2 paquets pour installer flash. Prends un de ceux-là, pas le deb sur le site adobe.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#20 14-12-2008 22:59:40

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

ok merci tout va bien maintenant.
mais comment ca se fait que mon sources.list n'était pas correct àl'installation?en tout cas merci a tous

Hors ligne

#21 14-12-2008 23:05:21

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Réglé]probleme de dependance (flash player)

À l'installation, tu as un fichier sources.list de base. C'est à toi à le compléter selon tes besoins. Par exemple, pour installer des paquets non libres comme Flashplayer ou le pilote NVIDIA pour le 3D par exemple.

En complément.  Lu sur debian.org

Nous fournissons de plus des paquets qui ne peuvent pas être distribués dans l'archive principale (« main ») de Debian pour des raisons légales ou à cause de leurs licences trop restrictives. Ils sont rangés dans des sections séparées comme suit :

Contrib
    Les paquets de cette section sont eux-mêmes libres (avec l'accord du propriétaire du copyright), mais dépendent de paquets ne l'étant pas.
Non-Free
    Les paquets de cette section possèdent soit des licences très onéreuses, ou des licences qui restreignent leurs usages ou encore des licences qui restreignent leurs redistributions.


Il en va de même des paquets pris sur debian-multimedia.

Dernière modification par martinux_qc (14-12-2008 23:13:04)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#22 14-12-2008 23:18:52

Sky-X-Wind
Membre
Inscription : 13-12-2008

Re : [Réglé]probleme de dependance (flash player)

et en ajoutant une ligne en main contrib non free, on s'inscrits aux trois depot ou alors il faut un lien en main un lien en contrib...?

Hors ligne

#23 15-12-2008 02:31:57

Chris
Membre
Lieu : Bourgogne
Distrib. : Jessie 64
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : kde
Inscription : 15-11-2008

Re : [Réglé]probleme de dependance (flash player)

smile BonjourSky-X-Win, et bienvenue sur Debian-facile, bonjour à tous,

Je pense qu'un peu de diplomatie ne fait pas de mal.

Tu poses plusieurs problèmes en même temps, qui doivent être débrouillés les uns après les autres.

a) Le sources.list appelle à lui seul un fil. (voir les liens donnés ). Y consacrer une petite semaine d'apprentissage ne me semble pas un luxe. d'autant plus que c'est un point crucial pour la qualité et la stabilité de ton système.
b) les clés de cryptage un autre fil.
c) la pertinence des paquets debian maintenus par la communauté plutôt que ceux des des acteurs non libres un troisième

Pour les flash player, c'est il me semble, l'un des points faibles actuels des linux : rien de comparable à ce qu'on trouve pour win. (Qu'on me corrige si je dis une ânerie. Et surtout qu'on m'indique le player le plus abouti...). Actuellement, j'ai un son impeccable mais une image sur 4...par rapport à ce que j'avais sous win.

Une solution bancale consiste à télécharger les videos les + interessantes, éventuellement avec http://keepvid.com, pour les regarder tranquillement hors ligne. Si c'est juste du son (deezer &Co), no problemo.

d) la maîtrise d'un OS aussi riche que Debian te demandera de la patience et du doigté. A toi de voir si c'est ton truc.

Bonne continuation:)

Hors ligne

#24 16-12-2008 00:03:23

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Réglé]probleme de dependance (flash player)

Bonsoir

Il me semble que la version linux en est au même point que celle de windows maintenant en ce qui concerne flashplayer, non? (je me trompe peut être, je n'ai plus windows depuis bien longtemps big_smile)

En tout cas, chez moi la version qui se trouve dans les dépots (10) fonctionne parfaitement, magnifiquement bien même comparé a swfdec (ce que je regrette très fortement)

Ensuite je continuerais par un petit conseil pour Sky-X-Wind, regarde toujours via synaptic ou apt avant de télécharger des logiciels, cela t'évitera beaucoup de prise de tête wink

Bonne soirée!

Hors ligne

#25 16-12-2008 02:13:49

Chris
Membre
Lieu : Bourgogne
Distrib. : Jessie 64
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : kde
Inscription : 15-11-2008

Re : [Réglé]probleme de dependance (flash player)

Bonjour Sky-X-Wind, bonjour Palmito, bonjour à tous,

Si c'est pas résolu, c'est pas résolu... hmm
En ce qui me concerne, j'ai suivi avec intérêt, comme probablement d'autres newbies, ce fil. parce que jusqu"à maintenant, flash sous linux, c'est pour moi assez galère. Rien de convaincant.

Certes, j'ai peu de mémoire vive, mais Debian n'a pas jusqu'ici été convaincant quand à la bonne gestion des ressources, malgré sa flatteuse réputation. Désolé de l'avouer, mais j'ai connu mieux avant.

Maintenant, comme disait Dolto (parmi d'autres...), le contraire de l'amour, ce n'est pas la haine. C'est l'indifférence. Et à ce niveau, certains OS me laissent totalement indifférent...:cool:

Ceci dit, c'est peut-être une question de choix du bon player : plugin ? Gnash ? Flash player ?

J'ai choisi de faire mes premières armes sous Etch &half, pour des raisons de stabilité, d'apprentissage, etc... Bien sûr, j'ai très envie de mixer les versions, et de faire un tour du côté de Sid. Mais c'est encore un poil tôt en ce qui concerne le paramétrage des priorités par exemple. (je veux dire s'il faut comprendre ce que l'on fait, sans recopier bêtement).

Du coup, je ne trouve pas la version 10 du flash player.

Palmito, voudrais-tu préciser où tu l'as trouvée ? (backports de Etch ? Testing ? Site fabricant ?) Et préciser s'il faut une bête de course avec une mémoire d'éléphant pour la faire tourner proprement.

Merci pour nous.  smile

Hors ligne

Pied de page des forums