Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-08-2014 17:17:24

Philibre
Membre
Lieu : Sud de la France
Distrib. : Debian testing (+ qqs paquets d'unstable)
Noyau : Linux 3.14-2-amd64
(G)UI : Xfce 4.10
Inscription : 01-08-2014

Serveur X lancé sur TTY2 (au lieu de TTY5)

Bonjour.

Depuis une mise à jour récente (fin juillet me semble-t-il), au démarrage le serveur X est lancé sur TTY2, au lieu de TTY5 (comme configuré*) ou TTY7 (comme préconfiguré). Mise à jour du système d'init semble-t-il (systemd v208-6 est installé).

Quelqu'un sait où/comment corriger ça ? Merci d'avance !

* : ayant l'habitude d'avoir le serveur X sur TTY5, 4 consoles texte me suffisant, j'ai désactivé les lignes correspondant à TTY5-6 dans /etc/inittab :

# /sbin/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
#  <id>:<runlevels>:<action>:<process>
#
# Note that on most Debian systems tty7 is used by the X Window System,
# so if you want to add more getty's go ahead but skip tty7 if you run X.
#

1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
#5:23:respawn:/sbin/getty 38400 tty5
#6:23:respawn:/sbin/getty 38400 tty6

Hors ligne

#2 11-08-2014 20:48:22

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Serveur X lancé sur TTY2 (au lieu de TTY5)

Le comportement par défaut de systemd est d’ouvrir la session X sur le premier TTY disponible.
Pour passer outre, j’ai pris l’habitude avant de lancer ma session graphique de passer sur les différents TTY (Alt+F1, Alt+F2, etc.) pour les réserver (après avoir été affiché une fois, un TTY est réservé). De cette façon systemd lancera ma session graphique sur le premier TTY disponible, c’est-à-dire hors du champ d’action de ceux que j’ai déjà affiché au moins une fois.

inittab par contre n’est pas lu par systemd, le réglage des terminaux se fait dans un autre fichier dont je n’ai plus le nom en tête (probablement sous /etc/systemd/).
Je reviendrai donner le nom du fichier en question quand je serai repassé sur une de mes machines avec systemd.

Jouer sous Debian ? Facile !

Hors ligne

#3 16-08-2014 12:56:57

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Serveur X lancé sur TTY2 (au lieu de TTY5)

Plop,
Mhh, on dirait que NAutoVTs=6 et ReserveVT=6 du fichier /etc/systemd/logind.conf permettent ça, non ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#4 16-08-2014 15:21:10

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Serveur X lancé sur TTY2 (au lieu de TTY5)

La variable NAutoVTs définit le nombre de terminaux à utiliser (ceux accessibles via Ctrl + Alt + Fn), ReserveVT définit un de ces terminaux qui est en permanence réservé (la session graphique ne peut pas se lancer par dessus).
Je ne connais par contre pas de variable servant à forcer la session graphique à se lancer sur un terminal particulier.

Jouer sous Debian ? Facile !

Hors ligne

#5 16-08-2014 17:57:42

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Serveur X lancé sur TTY2 (au lieu de TTY5)

Avec lightdm, il y a une option minimum-vt=7. Pour les autres DM, voir dans la configuration…

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums