Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-08-2014 15:04:05

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

différence apt-get upgrade et gpk-update viewer

Bonjour,


Je suis en train de voir que j'ai beaucoup de mises à jour et pourtant ça ne semble pas passer avec apt-get upgrade.
j'ai lancer l'utilitaire graphique de mise à jour "outil de mise à jour de paquet" et lui me propose l'installation des mises à jour.

Du coup, je souhaiterai connaitre la différence entre les 2 méthodes

apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  base-passwd cpp cpp-4.9 cups-filters cups-filters-core-drivers fakeroot gcc gcc-4.9 gcc-4.9-base gcc-4.9-base:i386
  gnome-settings-daemon gnome-sushi gparted gsettings-desktop-schemas gstreamer0.10-plugins-bad handbrake inkscape kpcli libasan1
  libatomic1 libbit-vector-perl libcairo-perl libcilkrts5 libclone-perl libcommon-sense-perl libcrypt-openssl-bignum-perl
  libcrypt-openssl-rsa-perl libcrypt-rijndael-perl libdate-calc-xs-perl libfile-fcntllock-perl libgcc-4.9-dev libgcc1 libgcc1:i386
  libgd-perl libgfortran3 libgl1-nvidia-glx libgl1-nvidia-glx:i386 libglib-perl libgnome2-canvas-perl libgnome2-gconf-perl
  libgnome2-perl libgnome2-vfs-perl libgnome2-wnck-perl libgomp1 libgoo-canvas-perl libgstreamer-plugins-bad0.10-0
  libgtk2-imageview-perl libgtk2-perl libgtk2-unique-perl libhtml-parser-perl libitm1 libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-3.0-0 libjson-xs-perl liblocale-gettext-perl liblsan0 libmono-corlib4.5-cil libmono-data-tds4.0-cil
  libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-posix4.0-cil libmono-security4.0-cil libmono-sqlite4.0-cil
  libmono-system-configuration4.0-cil libmono-system-core4.0-cil libmono-system-data-datasetextensions4.0-cil libmono-system-data4.0-cil
  libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil libmono-system-runtime-serialization4.0-cil
  libmono-system-security4.0-cil libmono-system-transactions4.0-cil libmono-system-xml-linq4.0-cil libmono-system-xml4.0-cil
  libmono-system4.0-cil libmouse-perl libnet-dbus-perl libnet-ssleay-perl libnm-gtk-common libnm-gtk0 libpam-systemd libpango-perl
  libpoppler-glib8 libproc-processtable-perl libquadmath0 libsnmp30 libstdc++6 libstdc++6:i386 libsub-name-perl libsystemd-daemon0
  libsystemd-journal0 libsystemd-login0 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtsan0 libubsan0 libudev1
  libudev1:i386 libuuid-perl libvirt-bin libvirt0 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libxml-libxml-perl libxml-parser-perl
  linux-headers-amd64 linux-image-amd64 metacity metacity-common mono-4.0-gac mono-gac mono-runtime mplayer2 nautilus nautilus-data
  network-manager network-manager-gnome nvidia-alternative nvidia-driver nvidia-kernel-dkms nvidia-settings nvidia-vdpau-driver parted
  perl perl-base perl-modules perlmagick poppler-utils python-libvirt python-soappy python-twisted-core python-twisted-web
  qemu-system-common qemu-system-x86 rsyslog systemd sysvinit udev upower virtualbox virtualbox-dkms virtualbox-qt vlc vlc-nox
  xfce4-power-manager xfce4-power-manager-data xfce4-systemload-plugin xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-modesetting xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-nvidia
  xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa
  xserver-xorg-video-vmware
0 mis à jour, 0 nouvellement installés, 0 à enlever et 174 non mis à jour.

Hors ligne

#2 29-08-2014 15:26:34

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : différence apt-get upgrade et gpk-update viewer

Salut

Peut-être que cet utilitaire fais l'équivalent de

apt-get dist-upgrade


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 29-08-2014 16:02:14

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : différence apt-get upgrade et gpk-update viewer

ça doit être ça

 apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libass4 libgeoclue0 libgnome-bluetooth11 libgnome-desktop-3-7 libgsoap4 libmozjs185-1.0 libparted0debian1 libpoppler44 libupower-glib1
  libwpd-0.9-9 libwpg-0.2-2 python-fpconst
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Fait
Les paquets suivants seront ENLEVÉS :
  libgjs0c libmetacity-private0a libperl5.18 libvtv0 qemu-keymaps sysvinit-core
Les NOUVEAUX paquets suivants seront installés :
  docutils-common docutils-doc firmware-linux-free geoclue-2.0 init libalgorithm-c3-perl libass5 libcapture-tiny-perl libcgi-pm-perl
  libclass-c3-perl libclass-c3-xs-perl libdata-optlist-perl libdata-password-perl libdata-section-perl libdebconfclient0 libepoxy0
  libfakeroot libfcgi-perl libgeocode-glib0 libgjs0e libgnome-desktop-3-10 libgsoap5 libgweather-3-6 libgweather-common libjansson4
  liblognorm1 libmetacity-private1 libmodule-build-perl libmodule-signature-perl libmozjs-24-0 libmro-compat-perl libndp0
  libpackage-constants-perl libpaper-utils libparams-util-perl libparted-fs-resize0 libparted2 libpcre3:i386 libperl5.20
  libpod-readme-perl libpoppler46 libregexp-common-perl libselinux1:i386 libsoftware-license-perl libsub-exporter-perl
  libsub-install-perl libterm-readline-gnu-perl libtext-template-perl libupower-glib2 libvirt-clients libvirt-daemon
  libvirt-daemon-system libxen-4.4 linux-headers-3.14-2-amd64 linux-headers-3.14-2-common linux-image-3.14-2-amd64 mono-runtime-common
  mono-runtime-sgen python-characteristic python-defusedxml python-docutils python-pyasn1 python-pyasn1-modules python-roman
  python-service-identity python-wstools systemd-sysv
Les paquets suivants seront mis à jour :
  base-passwd cpp cpp-4.9 cups-filters cups-filters-core-drivers fakeroot gcc gcc-4.9 gcc-4.9-base gcc-4.9-base:i386
  gnome-settings-daemon gnome-sushi gparted gsettings-desktop-schemas gstreamer0.10-plugins-bad handbrake inkscape kpcli libasan1
  libatomic1 libbit-vector-perl libcairo-perl libcilkrts5 libclone-perl libcommon-sense-perl libcrypt-openssl-bignum-perl
  libcrypt-openssl-rsa-perl libcrypt-rijndael-perl libdate-calc-xs-perl libfile-fcntllock-perl libgcc-4.9-dev libgcc1 libgcc1:i386
  libgd-perl libgfortran3 libgl1-nvidia-glx libgl1-nvidia-glx:i386 libglib-perl libgnome2-canvas-perl libgnome2-gconf-perl
  libgnome2-perl libgnome2-vfs-perl libgnome2-wnck-perl libgomp1 libgoo-canvas-perl libgstreamer-plugins-bad0.10-0
  libgtk2-imageview-perl libgtk2-perl libgtk2-unique-perl libhtml-parser-perl libitm1 libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-3.0-0 libjson-xs-perl liblocale-gettext-perl liblsan0 libmono-corlib4.5-cil libmono-data-tds4.0-cil
  libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-posix4.0-cil libmono-security4.0-cil libmono-sqlite4.0-cil
  libmono-system-configuration4.0-cil libmono-system-core4.0-cil libmono-system-data-datasetextensions4.0-cil libmono-system-data4.0-cil
  libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil libmono-system-runtime-serialization4.0-cil
  libmono-system-security4.0-cil libmono-system-transactions4.0-cil libmono-system-xml-linq4.0-cil libmono-system-xml4.0-cil
  libmono-system4.0-cil libmouse-perl libnet-dbus-perl libnet-ssleay-perl libnm-gtk-common libnm-gtk0 libpam-systemd libpango-perl
  libpoppler-glib8 libproc-processtable-perl libquadmath0 libsnmp30 libstdc++6 libstdc++6:i386 libsub-name-perl libsystemd-daemon0
  libsystemd-journal0 libsystemd-login0 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtsan0 libubsan0 libudev1
  libudev1:i386 libuuid-perl libvirt-bin libvirt0 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libxml-libxml-perl libxml-parser-perl
  linux-headers-amd64 linux-image-amd64 metacity metacity-common mono-4.0-gac mono-gac mono-runtime mplayer2 nautilus nautilus-data
  network-manager network-manager-gnome nvidia-alternative nvidia-driver nvidia-kernel-dkms nvidia-settings nvidia-vdpau-driver parted
  perl perl-base perl-modules perlmagick poppler-utils python-libvirt python-soappy python-twisted-core python-twisted-web
  qemu-system-common qemu-system-x86 rsyslog systemd sysvinit udev upower virtualbox virtualbox-dkms virtualbox-qt vlc vlc-nox
  xfce4-power-manager xfce4-power-manager-data xfce4-systemload-plugin xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-modesetting xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-nvidia
  xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa
  xserver-xorg-video-vmware
174 mis à jour, 67 nouvellement installés, 6 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 203 Mo dans les archives.
Après cette opération, 241 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
 

Hors ligne

Pied de page des forums