Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-09-2014 21:02:14

hamster
Membre
Inscription : 30-01-2014

probleme de mot de passe avec gnome ppp

hello

Voici le log de mes tentatives de connexion avec gnome ppp :

$ gnome-ppp

(gnome-ppp:5719): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-ppp:5719): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
WVCONF: /home/hirondelle/.wvdial.conf
GNOME PPP: Connexion en cours...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.61
GNOME PPP: STDERR: --> Cannot set information for serial port.
GNOME PPP: STDERR: --> Initializing modem.
GNOME PPP: STDERR: --> Sending: ATZ
GNOME PPP: STDERR: ATZ
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Modem initialized.
GNOME PPP: STDERR: --> Please enter password (or empty password to stop):
<CENSORED>



Sur la derniere ligne, il met le vrai mot de passe, en clair, que j'ai evidamment censuré. Il reste bloqué indefiniement comme ca. Je ne comprend pas quel est ce mot de passe qu'il essaye vainement d'envoyer, vu qu'a ce moment la il n'a pas encore composé le n° de telephone.

Au contraire les connexions avec wvdial fonctionnent :

# wvdial
--> WvDial: Internet dialer version 1.61
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT0860469900
--> Waiting for carrier.
ATDT0860469900
CONNECT 42667
--> Carrier detected.  Waiting for prompt.
~<CENSORED>~
--> PPP negotiation detected.
--> Starting pppd at Mon Sep  8 20:33:29 2014
--> Pid of pppd: 5942
--> Using interface ppp0
--> pppd: [7f]
--> pppd: [7f]
--> pppd: [7f]
--> pppd: [7f]
--> pppd: [7f]
--> pppd: [7f]
--> local  IP address 212.85.135.145
--> pppd: [7f]
--> remote IP address 10.1.1.1
--> pppd: [7f]
--> primary   DNS address 80.67.172.5
--> pppd: [7f]
--> secondary DNS address 80.67.172.2
--> pppd: [7f]



J'ai fait :
chmod  og+x /usr/sbin/pppd
chmod -R og+rw /etc/ppp
comme indiqué dans cette page :
http://doc.ubuntu-fr.org/gnome-ppp

Voici mon /etc/wvdial.conf :


[Dialer Defaults]
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Phone = 0860469900
ISDN = 0
Username = <CENSORED>
Init1 = ATZ
Password = <CENSORED>
Modem = /dev/ttyUSB0
Baud = 115200



Et mon ~/.wvdial.conf :


[Dialer Defaults]
Modem = /dev/ttyUSB0
ISDN = off
Modem Type = Analog Modem
Baud = 115200
Init = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 =
Init4 =
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone = 0860469900
Phone1 =
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 1
Dial Command = ATM1L3DT
Ask Password = on
Password =
Username = <CENSORED>
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = off
Idle Seconds = 0
Auto DNS = on
;Minimize = off
;Dock = off
;Do NOT edit this file by hand!



J'ai un modem externe branché avec un adaptateur USB/serie. Je suis sous wheezy avec le bureau mate. J'ai essayé de reinstaller gnome-ppp et wvdial, sans succes. J'ai aussi remarqué que si j'essaye de me connecter 2 fois d'affilee avec gnome-ppp, la premiere fois il me sort le log ci dessus, mais la 2e il dit autre chose (voir en fin de log) :

$ gnome-ppp

(gnome-ppp:6054): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-ppp:6054): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
WVCONF: /home/hirondelle/.wvdial.conf
GNOME PPP: Connexion en cours...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.61
GNOME PPP: STDERR: --> Cannot set information for serial port.
GNOME PPP: STDERR: --> Initializing modem.
GNOME PPP: STDERR: --> Sending: ATZ
GNOME PPP: STDERR: ATZ
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Modem initialized.
GNOME PPP: STDERR: --> Please enter password (or empty password to stop):
<CENSORED>
GNOME PPP: STDERR: Caught signal 2:  Attempting to exit gracefully...
GNOME PPP: Connexion en cours...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.61
GNOME PPP: STDERR: --> Cannot open /dev/ttyUSB0: Device or resource busy
GNOME PPP: STDERR: --> Cannot open /dev/ttyUSB0: Device or resource busy
GNOME PPP: STDERR: --> Cannot open /dev/ttyUSB0: Device or resource busy
GNOME PPP: Unable to KILL wvdial process!



Il faut fermer gnome-ppp et le relancer pour liberer /dev/ttyUSB0

Merci de votre aide.

Hors ligne

Pied de page des forums