Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-10-2014 08:43:14

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

[Résolu] GTX 850 M pas detectée sous Kali

Bonjour tout le monde.
Je m excuse déjá pour avoir polluer le post d'autrui.

J en profite pour saluer toute l equipe et les membres en esperant pouvoir aider autant qu être aider par la communauté.

Mon problème: je possède un Asus N550JK.
J ai changé le HDD par un SSD. J ai installé Kali uniquement dessus. Tout marche plutot bien sauf la partie graphique. J ai beau vouloir installer le driver de ma GTX850M par url ou apt, il ne me la detecte jamais. Nvidia-detect idem. J ai planté quelque fois mon interface graphique à cause du xorg.conf mais heureusement je le backup à chaque fois.

J ai lu dans le précedent tuto que passer à la version Sid pourrait arranger le problème. Mon but est que ma carte graphique fonctionne (bumblebee est deja installé). Je m en fiche un peu de Gnome 3, c est surtout pour certain logiciel 3D (étudiant MMI) et accessoirement un jeu ou deux.

Dernière modification par sadik (10-10-2014 22:17:09)

Hors ligne

#2 08-10-2014 11:32:42

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

Bonjour,

sadik a écrit :

Je m excuse déjá pour avoir polluer le post d'autrui.

Pas de soucis. En effet, l'utilisation du forum est facilitée par la création d'un fil par problème.  smile

sadik a écrit :

J ai beau vouloir installer le driver de ma GTX850M par url ou apt, il ne me la detecte jamais.

Pourrais-tu détailler la procédure employée et les éventuels messages reçus alors ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 08-10-2014 11:38:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GTX 850 M pas detectée sous Kali


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 08-10-2014 13:19:02

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Je vais essayer d'être plus précis dans mes explications à l'avenir.

J'ai essayer cette méthode, la plus logique qui me semblait sur le moment : télécharger le driver sur le site Nvidia, et l'installer.

Téléchargement ici : http://www.nvidia.fr/download/driverRes … x/78502/fr // Je télécharge donc le pilote : NVIDIA-Linux-x86_64-340.46.run
Lors de l'installation, il me dit qu'il ne voit aucun GPU prit en charge par ce driver. Etant un peu tête de cochon, je continu quand même et généralement.
Biensur, au redemarrage, ecran noir avec le petit tiret blanc (ça porte un nom ?) qui clignote.
ctrl + alt + f1 // root + mdp // et je reconfigure xorg.conf pour récuperer mon interface graphique.

Bien que ça n'est rien de logique, j'ai retenter l'experience avec une installation en 32bits, en suivant un tuto.
Le nom du driver était sensiblement différent, mais toujours télécharger sur Nvidia, puis executer avec un script.
Driver : NVIDIA-Linux-x86-343.22.run
Script :


!/bin/bash
service gdm3 stop
dpkg --add-architecture i386
apt-get update
apt-get install ia32-libs
chmod 755 NVIDIA*.run
./NVIDIA*.run
reboot    
 


Conclusion : même finalité.

Il y a eut également ce tuto : http://linuxg.net/how-to-install-nvidia … x-systems/
Même finalité.

Bref, je pense pas me rappeler tout ce que j'ai essayer ces 6 derniers jours.
Pour le descriptif de mon problème : mon ordinateur "détect mal" ma carte graphique, et je pense que ca bloque pour l'installation.


root@kali:~# lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell Integrated Graphics Controller [8086:0416] (rev 06)
 



root@kali:~# lspci -vnn | egrep 'VGA|3D'
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
01:00.0 3D controller [0302]: NVIDIA Corporation Device [10de:1391] (rev ff) (prog-if ff)
 



root@kali:~# nvidia-detect
No NVIDIA GPU detected.
 



Voici quelques retours de commande qui pourraient vous aider :


root@kali:~# apt-get install mesa-utils
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
mesa-utils est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
 



root@kali:~# glxinfo | grep ^OpenGL
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
 



Entraideur content ? wink

J'essayerai de fournir plus d'information sur mon système dans la journée, je manque un peu de temps là.
N'hésitez pas à commenter mes explications, ça m'aide de savoir bien expliquer.

PS : Promis je vous ferai des fenêtres de code plus joli que cela la prochaine fois.

Et surtout, merci d'avant big_smile

Hors ligne

#5 08-10-2014 13:49:17

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Avec cette techno de double carte/chipset graphique Nvidia-Intel, il n'y a pas "Bumblebee ?

https://wiki.debian.org/Bumblebee#Installation


Ahh, mea-culpa, je vois qu'il est déjà installé..... Donc le problème est d'un autre ordre ....

Dernière modification par yoshi (08-10-2014 13:50:56)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#6 08-10-2014 19:08:49

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Question bête.
N'est ce pas le même problème que sur ce topic ?
Bien que cette persone voulait surtout l'accès a Gnome 3, mais la cause semble similaire

http://debian-facile.org/viewtopic.php?id=8209

J'ai repris plusieurs point de ce dernier. Notamement sur :


usermod -G $USER bumblebee
 



Kali étant uniquement en root, j'essaie d'ajouter l'utilisateur "#root", même si ca me parait tiré par les cheveux.
Bumblebee ne proteste pas.
Je continu sur la lignée du topic, mais là, ça bloque :


root@kali:~# glxgears
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
root@kali:~# optirun glxgears
Xlib:  extension "GLX" missing on display ":0.0".
primus: fatal: broken GLX on main X display
 



Au point où j'en suis, autant aller plus loin dans le topic.


root@kali:~# grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log
[     6.226] (II) Module intel: vendor="X.Org Foundation"
[     6.226]  compiled for 1.12.3.902, module version = 2.19.0
[     6.226]  Module class: X.Org Video Driver
--
[     6.227] (II) Module vesa: vendor="X.Org Foundation"
[     6.227]  compiled for 1.12.1, module version = 2.3.1
[     6.227]  Module class: X.Org Video Driver
 



En espérant que cela ouvre une piste.

Hors ligne

#7 08-10-2014 19:27:16

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

Vu les nombreux essais, je te ferais la même réponse qu'à Vega : https://debian-facile.org/viewtopic.php … 066#p99066
Sans garantie toutefois.  hmm

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 08-10-2014 20:47:03

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

On a peut-être mis le doigt sur quelque chose.


root@kali:~# apt-get install bumblebee bumblebee-nvidia primus
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet bumblebee-nvidia n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « bumblebee-nvidia » n'a pas de version susceptible d'être installée
 



J'ai bien bumblebee qui s'installe, mais pas bumblebee-nvidia.
Je vais regarder la doc et me renseigner voir si il existe une alternative ou un moyen de le télécharger par url.

Dernière modification par sadik (08-10-2014 20:47:56)

Hors ligne

#9 08-10-2014 20:53:19

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

Le paquet bumblebee-nvidia n'est présent que dans wheezy-backports, jessie et sid.

Pour kali, vois https://forums.kali.org/showthread.php? … ed-Laptops

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#10 08-10-2014 21:00:28

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

C'était plus vicieux que cela, vu que j'avais le depot wheezy-backports main et pas le contrib.
J'ai donc fait un update, l'install et un reboot.
J'ai eut un message comment quoi je devrais configurer mon xorg.conf pour l'utilisation du driver Nvidia.
Dans les paramètres système, il me détecte ça en carte graphique : Gallium 0.4 on llvmpipe (LLVM 0x209)

Hors ligne

#11 08-10-2014 21:06:48

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

D'après le lien, il te faut aussi non-free.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#12 08-10-2014 21:22:10

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

J'ai put ajouter le dépôt non free même si j'ai encore planté l'interface graphique lol
Le problème vient biensur du fichier xorg.conf que je ne configure pas correctement.
Je me base sur ce tuto : https://wiki.debian.org/fr/NvidiaGraphi … #configure
Mais je dois me tromper sur :


Section "Device"
        Identifier "My GPU"
        Driver "nvidia"
EndSection
 



J'ai remplacé "My GPU" par "GTX 850 M" puis en second essai par "NVIDIA" mais ça ne marche toujours pas.

Une idée ?

Hors ligne

#13 08-10-2014 21:30:05

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

Sur le lien que je t'ai passé, il y a 2 fichiers de conf (autres que xorg.conf) à régler.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#14 08-10-2014 21:48:02

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Ca va me prendre un moment, je vois qu'il faut aussi des manip pour les CUDA.
Je posterai mes résultats demain si j'ai pas le temps ce soir.
Merci beaucoup pour l'aide déjà, on avance bien wink

Hors ligne

#15 08-10-2014 21:54:25

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

Heu, je ne sais pas si tu as besoin de CUDA ...

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#16 08-10-2014 22:00:54

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Ah ... bon je le ferai en dernier. Et pour VirtualGl ?

Hors ligne

#17 08-10-2014 22:07:21

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

sadik a écrit :

Et pour VirtualGl ?

Je n'en suis pas convaincu, d'après http://doc.ubuntu-fr.org/bumblebee
Mais, franchement, j'ai du mal à y voir clair.  hmm


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#18 08-10-2014 22:09:28

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Bon,j'ai suivi tout le tuto jusqu'à l'installation CUDA que je laisse de côté.
J'ai rebooter ma machine, mais je retombe sur la console me demandant mon login.
En gros : pas d'interface graphique.
Ca doit être facile à récupérer en reconfigurant mon xorg.conf, mais ça change pas mon problème.

Hors ligne

#19 08-10-2014 22:12:15

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

Dans le xorg.conf, tu dois avoir le GPU (qui sert ordinairement).

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 08-10-2014 22:18:06

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Une petite précision qui à surrement son importance.
Quand je parle de xorg.conf, le vrai nom du fichier de configuration est dans /etc/X11/xorg.conf.d/20-nvidia.conf
Bon, en même temps je ne l'ai pas inventé, c'est dans le tuto pour l'installation du driver.

Autre détail qui me chiffonne d'avantage : /etc/X11/xorg.conf..nvidia-xconfig-original
Qu'est ce donc ? Et pourquoi est il vide ?

Je vais essayer de me renseigner.

C'est quand même compliqué tout ca hmm

Hors ligne

#21 08-10-2014 22:20:54

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Autre chose.
En mode console, quand je tape : startx, il me retourne l'erreur : Fatal server error : no screens found.
A tout hasard ....

Hors ligne

#22 08-10-2014 22:29:53

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

sadik a écrit :

Autre détail qui me chiffonne d'avantage : /etc/X11/xorg.conf..nvidia-xconfig-original
Qu'est ce donc ? Et pourquoi est il vide ?

C'est la sauvegarde du fichier "usine" pour revenir en arrière en cas de modifs catastrophiques.
Dommage qu'il soit vide.  sad


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#23 08-10-2014 22:31:33

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Ah ah, je me suis pourrit la vie tout seul !


# mkdir /etc/X11/xorg.conf.d
# echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf
 


Attention, cette configuration cassera Xorg sur les systèmes dotés d'un processeur Optimus. Pour ces matériels, voir plutôt la page Bumblebee.

lol je l'ai supprimé et mon interface graphique est revenu. Je vais tester si le reste marche.

Hors ligne

#24 08-10-2014 22:32:37

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali


root@kali:~# optirun glxspheres64
[  143.777666] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[  143.777767] [ERROR]Aborting because fallback start is disabled.
 



Rien à faire.

Hors ligne

#25 08-10-2014 22:39:47

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Le problème peut il venir de GRUB ?

Cette ligne me semble suspecte.

GRUB_CMDLINE_LINUX_DEFAULT="quiet nouveau.modeset=0"

Normalement, elle devrait ressembler à ça selon ton dernier lien :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Et il demande même de la modifier en :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rcutree.rcu_idle_gp_delay=1"

Je te dis ce que ça donne dans quelque minute.

Hors ligne

Pied de page des forums