Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 08-10-2014 22:44:47

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Aucun changement suite à la modification dans le fichier Grub.

Hors ligne

#27 08-10-2014 23:14:00

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Victoire !!!
J'ai suivis un lien sur un des tuto que tu m'avais envoyé.
https://forums.kali.org/showthread.php? … #post35420
C'est un update du fameux tuto, il y a peu de difference mais la commande optirun glxspheres64 fonctionne !
Un grand pas en avant, merci !

Hors ligne

#28 09-10-2014 08:46:45

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

cool
Et tu as des fichiers  /etc/bumblebee/bumblebee.conf et /etc/bumblebee/xorg.conf.nvidia ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#29 09-10-2014 10:24:01

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Oui il fallait rajouter trois fois rien dedans. Je te mettrai le détail dans la journée si tu veux mais tout est expliquer dans le tuto. J ai aussi lancé l installation des CUDA. Je te dirai le resultat final ce soir ou fim d aprem

Hors ligne

#30 09-10-2014 11:18:15

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GTX 850 M pas detectée sous Kali

sadik a écrit :

mais tout est expliquer dans le tuto


Il est préférable que les informations contenues dans les tutos ne soient pas centralisées dans un seul site mais dans plusieurs, permettant ainsi une plus grande réactivité pour les mises à jour qui les concernent, d'où l'ajout dans le tuto df en plus que dans le site en lien.

Merci de ton retour smile

Dernière modification par smolski (09-10-2014 13:08:36)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#31 09-10-2014 11:27:07

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

smolski a écrit :

... d'où l'ajout dans le tuto df.

Dans la généralité, je partagerais tout à fait ton point de vue.
Mais dans le cas présent, le risque est de se heurter aux particularités de Kali.
Je suis plus pour laisser une procédure dans le forum, avant de tester comment elle est transposable.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#32 09-10-2014 13:10:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GTX 850 M pas detectée sous Kali

Ah woui, y faudrait donc plutôt la mettre dans l'atelier ou mieux, dans une page utilisateur créée par sadik.
smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#33 09-10-2014 14:39:47

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

Bonne idée.  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#34 10-10-2014 08:38:30

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Le problème est encore loin d être resolu.
Même si optirun fait tourner glxsphere64, c est tout.
A vrai dire je n ai pas le temps de poursuivre cette recherche.
Je suis étudiant et j ai vite besoin d avoir un système opérationnel. Je vais donc devoir mettre un windows puis remettre Kali en machine virtuelle.
Je ferai un post pour mon retour d experience tout de même.

Hors ligne

#35 10-10-2014 12:17:30

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Kali ne veut pas me lacher.
Dans un premier temps desolé des prochains posts qui seront ecrits avec mon téléphone portable.
Je suis tomber sur leprogramme nvidia dans mes onglets.
Au demarrage il me demande d utiliser la commande:


nvidia-xconfig
 


Depuis biensur, interface graphique plantée.
Quand je veux lancer startx, il me dit: no screen found.
Quelqu un pourrait me screen son xorg.conf ?
De préférence une personne avec une carte Nvidia.

Hors ligne

#36 10-10-2014 12:51:23

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GTX 850 M pas detectée sous Kali

Il est probable que kali diffère de nos debian sur ce point.
Pour générer un xorg tout neuf à tenter ce tuto :
Créer un xorg de base

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#37 10-10-2014 13:46:36

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

le wiki Debian a écrit :

Attention : Si vous avez choisi d'installer le paquet bumblebee-nvidia et sa dépendance le pilote nvidia, pendant la post-installation, vous verrez un message d'avertissement qui vous dit que vous devez créer un fichier xorg.conf pour utiliser le pilote propriétaire nvidia. Ce message ne s'adresse qu'aux utilisateurs qui n'utilisent pas Optimus, c'est-à-dire qui ont un système avec seulement une carte graphique Nvidia. Ne laissez pas debconf créer un fichier xorg.conf et n'exécutez pas nvidia-xconfig ! (Ce message apparaît toujours quand vous installez les paquets nvidia à partir des dépôts mais actuellement, il ne détecte pas les utilisateurs d'Optimus/bumblebee. Voir 735049 pour une courte explication.)

C'est un peu le désert post-atomique, là.  mad

Essaye de voir déjà sans le fichier xorg.conf (renomme-le).


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#38 10-10-2014 14:27:12

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Je m en occupe ce soir.
Je vous tiens au courant.

Hors ligne

#39 10-10-2014 18:43:29

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

J'ai renommé mon fichier xorg.conf, et j'ai recuperé l'interface  graphique, ce qui va me permettre de vous envoyer ça :


root@kali:~/NVIDIA_CUDA-6.0_Samples/1_Utilities/deviceQuery# optirun ./deviceQuery
./deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "GeForce GTX 850M"
  CUDA Driver Version / Runtime Version          6.5 / 6.0
  CUDA Capability Major/Minor version number:    5.0
  Total amount of global memory:                 2048 MBytes (2147352576 bytes)
  ( 5) Multiprocessors, (128) CUDA Cores/MP:     640 CUDA Cores
  GPU Clock rate:                                902 MHz (0.90 GHz)
  Memory Clock rate:                             1001 Mhz
  Memory Bus Width:                              128-bit
  L2 Cache Size:                                 2097152 bytes
  Maximum Texture Dimension Size (x,y,z)         1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
  Maximum Layered 1D Texture Size, (num) layers  1D=(16384), 2048 layers
  Maximum Layered 2D Texture Size, (num) layers  2D=(16384, 16384), 2048 layers
  Total amount of constant memory:               65536 bytes
  Total amount of shared memory per block:       49152 bytes
  Total number of registers available per block: 65536
  Warp size:                                     32
  Maximum number of threads per multiprocessor:  2048
  Maximum number of threads per block:           1024
  Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
  Max dimension size of a grid size    (x,y,z): (2147483647, 65535, 65535)
  Maximum memory pitch:                          2147483647 bytes
  Texture alignment:                             512 bytes
  Concurrent copy and kernel execution:          Yes with 1 copy engine(s)
  Run time limit on kernels:                     Yes
  Integrated GPU sharing Host Memory:            No
  Support host page-locked memory mapping:       Yes
  Alignment requirement for Surfaces:            Yes
  Device has ECC support:                        Disabled
  Device supports Unified Addressing (UVA):      Yes
  Device PCI Bus ID / PCI location ID:           1 / 0
  Compute Mode:
     < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.0, NumDevs = 1, Device0 = GeForce GTX 850M
Result = PASS
 


Comme quoi, les CUDA fonctionnent bien apparament, ainsi que ma carte graphique.
Récapitulons les problèmes :
- Tout pas accès a ma carte graphique malgrès sont installation et son fonctionnement sous glxsphere64


root@kali:~# optirun glxspheres64
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GTX 850M/PCIe/SSE2
229.620174 frames/sec - 256.256114 Mpixels/sec
233.975176 frames/sec - 261.116297 Mpixels/sec
234.746409 frames/sec - 261.976993 Mpixels/sec
234.198730 frames/sec - 261.365782 Mpixels/sec
233.554224 frames/sec - 260.646514 Mpixels/sec
231.220780 frames/sec - 258.042391 Mpixels/sec
 


Egalement : Parametre => Système => Détail m'indique aucune carte graphique. (pas même gallium).
J'ai pas encore trouvé de solution dans Nvidia X Server Setting (on sait jamais XD )
Chose étrange aussi, Playonlinux ne trouve aucune lib32 ou lib64. Je vais regarder dans les configurations si je peux y remédier.

Donc, ma carte graphique est normalement bien installée, mais mon ordinateur ne sait pas comment l'utiliser.

Hors ligne

#40 10-10-2014 18:59:24

Invité-5
Banni(e)

Re : [Résolu] GTX 850 M pas detectée sous Kali

Kali ou pas, quelle idée d'installer le fichier .run?

citation a écrit :

Donc, ma carte graphique est normalement bien installée, mais mon ordinateur ne sait pas comment l'utiliser.


Voilà le résultat.

#41 10-10-2014 19:04:16

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GTX 850 M pas detectée sous Kali

Ah oui, le .run !
C'est effectivement plutôt déconseillé pour le libre. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#42 10-10-2014 19:10:57

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Desolé de suivre les tuto hmm

Hors ligne

#43 10-10-2014 19:24:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GTX 850 M pas detectée sous Kali

Je viens de regarder dans le wiki df on ne parle pas d'installer un pilote .run. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#44 10-10-2014 19:32:37

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] GTX 850 M pas detectée sous Kali

Merci de lire les fils en entier, derien : le .run n'a rien à voir ici car nvidia a été purgé avant d'installer bumblebee-nvidia.  roll

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#45 10-10-2014 19:55:36

Invité-5
Banni(e)

Re : [Résolu] GTX 850 M pas detectée sous Kali

Tu es sûr que c'est le bon topic, mon grand.

#46 10-10-2014 19:58:20

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

J'ai juste suivis ce tuto : https://forums.kali.org/showthread.php? … #post35420

Now the install
cd ~
./NVIDIA*.run --dkms -z

Accept the EULA
Select yes to register the kernel module with DKMS
No to libs (unless you want them)
Ok to acknowledge the website libs
The install will take place
Do not run X-Config. Select NO.
The installer will close.

Je ne vois pas qu'on le purge ensuite, mais après peut etre que je le lis mal. J'ai essayer de suivre tout cela dans l'ordre.
Mais bon.

Hors ligne

#47 10-10-2014 20:03:12

Invité-5
Banni(e)

Re : [Résolu] GTX 850 M pas detectée sous Kali

C'est ne pas ta faute, les tutoriels et surtout des conseilleurs dans différentes forums sur cette planète disent parfois n'importe quoi.

#48 10-10-2014 20:09:16

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GTX 850 M pas detectée sous Kali

Il y a pollution d'un post d'entraide là...
Restons dans le sujet et non dans les à-côtés de celui-ci.

Si vous pouvez conseiller sur la suite que doit entreprendre le demandeur au point où il en est maintenant, ça l'fait et seulement cela, merci smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#49 10-10-2014 20:23:55

sadik
Membre
Distrib. : Kali
Noyau : Linux 3.14
(G)UI : Gnome
Inscription : 07-10-2014

Re : [Résolu] GTX 850 M pas detectée sous Kali

Je propose ceci : formatage complet.
Je remets kali normalement, voir mieux peut-etre je mets une debian.
Ca permettrait de repartir sur une base saine.

Hors ligne

#50 10-10-2014 20:54:32

Invité-5
Banni(e)

Re : [Résolu] GTX 850 M pas detectée sous Kali

@sadik; tu peux lire => http://fr.docs.kali.org/introduction-fr … kali-linux

Si vous cherchez une distribution de Linux pour apprendre la base, Kali Linux n’est pas pour vous. Nous vous suggérons dans ce cas soit Debian, soit Ubuntu.

Dernière modification par Invité-5 (10-10-2014 20:55:18)

Pied de page des forums