Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-10-2014 11:30:43

Neurotek
Membre
Distrib. : Wheezy 7.6
Noyau : 3.16-0.bpo.2-amd64
(G)UI : Gnome 3.4.2
Inscription : 05-10-2014

Optimus "cannot access secondary GPU"

Salut !

Je viens vous poser mon problème lié à optimus.

La commande:

optirun glxgears -info



Me renvoie:

[ 2506.454992] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 2506.455066] [ERROR]Aborting because fallback start is disabled.
 



J'ai installé bumblebee une fois avec le wiki de debian facile, qui m'a pas installé les drivers nvidia (en le suivant à la lettre), pour preuve, j'avais aucun retour suite à la commande:

dpkg -l | grep nvidia



De plus, comme je serai amené à utiliser quelques applications 32 via optimus, j'ai suivi le tutoriel qui était proposé sur la page officiel du projet -de plus la page a été mise à jour très récemment-:
https://wiki.debian.org/Bumblebee

Résultat ?

En utilisant cette commande:

sudo dpkg --add-architecture i386 && sudo apt-get update && sudo apt-get install -t wheezy-backports bumblebee-nvidia primus primus-libs:i386



Tout s'installe, bumblebee, les drivers nvidias et j'ajoute mon utilisateur courant au groupe bumblebee, aucun souci ici. Pour vérifier si j'ai bien les drivers nvidia d'installer, je relance la commande:

dpkg -l | grep nvidia



Qui cette fois me retourne:

ii  bumblebee-nvidia                        3.2.1-4~bpo70+1                    amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
ii  glx-alternative-nvidia                  0.4.1~bpo70+1                      amd64        allows the selection of NVIDIA as GLX provider
ii  libgl1-nvidia-glx:amd64                 319.82-1~bpo70+2                   amd64        NVIDIA binary OpenGL libraries
ii  libgl1-nvidia-glx:i386                  319.82-1~bpo70+2                   i386         NVIDIA binary OpenGL libraries
ii  libgl1-nvidia-glx-i386                  319.82-1~bpo70+2                   i386         NVIDIA binary OpenGL 32-bit libraries
ii  libnvidia-ml1:amd64                     319.82-1~bpo70+2                   amd64        NVIDIA Management Library (NVML) runtime library
ii  nvidia-alternative                      319.82-1~bpo70+2                   amd64        allows the selection of NVIDIA as GLX provider
ii  nvidia-driver                           319.82-1~bpo70+2                   amd64        NVIDIA metapackage
ii  nvidia-glx                              319.82-1~bpo70+2                   amd64        transition to nvidia-driver
ii  nvidia-installer-cleanup                20131102+1~bpo70+1                 amd64        cleanup after driver installation with the nvidia-installer
ii  nvidia-kernel-common                    20131102+1~bpo70+1                 amd64        NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms                      319.82-1~bpo70+2                   amd64        NVIDIA binary kernel module DKMS source
ii  nvidia-settings                         319.72-1~bpo70+1                   amd64        tool for configuring the NVIDIA graphics driver
ii  nvidia-support                          20131102+1~bpo70+1                 amd64        NVIDIA binary graphics driver support files
ii  nvidia-vdpau-driver:amd64               319.82-1~bpo70+2                   amd64        NVIDIA vdpau driver
ii  xserver-xorg-video-nvidia               319.82-1~bpo70+2                   amd64        NVIDIA binary Xorg driver
 



J'ai donc lancé:

optirun glxgears -info



Qui me renvoyait:

[ 2506.454992] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 2506.455066] [ERROR]Aborting because fallback start is disabled.
 



J'ai donc suivi l'aide proposé, en modifiant mon fichier bumblebee.conf situé à /etc/bumblebee/bumblebee.conf en remplaçant "KernelDriver=nvidia" en "KernelDriver=nvidia-current" suivi d'un:

sudo service bumblebeed restart


Qui me retourne:

[ ok ] Restarting bumblebeed: bumblebeed.
 



Je retente optirun glxgears, j'ai toujours la même erreur signifiant qu'il n'y a pas accès au 2em GPU. J'ai tenté également de remplacer la ligne driver= en driver=nvidia, sans plus de résultat, j'ai decommenté la ligne du BusID dans le xorg.conf.nvidia situé à /etc/bumblebee/xorg.conf.nvidia, toujours sans grand succès non plus, mais là, je m'y attendais, c'était plus du désespoir qu'autre chose. SI vous auriez des idées à me proposer, je suis preneur, je tourne un peu en rond, j'ai tenté de redémarrer session, machine, daemon bumblebee, sans que ça change quoique ce soit au message présent.

Info complémentaire:

pidof bumblebeed
4368



lsmod | grep bbswitch
bbswitch               12866  0
 



lsmod | grep nvidia


Ca me renvoie rien du tout.

grep -i nvidia /var/log/Xorg.0.log


Ca me renvoie rien du tout aussi.

glxinfo | grep OpenGL
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL version string: 3.0 Mesa 8.0.5
OpenGL shading language version string: 1.30
OpenGL extensions:
 



Mon fichier sources.list

# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 CD Binary-1 20140$

#deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 CD Binary-1 201407$

deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib non-free

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main

## backports
deb http://ftp.fr.debian.org/debian/ wheezy-backports main contrib non-free
 



Le souci est le même si je passe sur un ancien noyau tel que le: 3.2.0-4-amd64.

Voilà. Je vous remercie de votre attention.

Dernière modification par Neurotek (11-10-2014 11:43:58)

Hors ligne

#2 24-10-2014 02:16:57

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Optimus "cannot access secondary GPU"

Amha surtout concernant Nvidia :

1) Ajouter le dépot backport si ce n'est pas fait.
2) Tout désinstaller proprement, surtout Nvidia qui ne supporte pas les bouts d'install qui traînent.
3) installer le paquet bumblebee si on souhaite le driver "nouveau" ou bumblebee-nvidia si on souhaite le driver proprio et laisser faire le système.

Avant c'était un peu galère à installer, maintenant dans Jessie c'est censé s'installer tout seul et dans wheezy le paquet des backport marchent bien sur mes PC.

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

Pied de page des forums