Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-01-2017 23:11:09

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

[Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Bonjour,

J'ai besoin de switcher régulièrement entre deux configurations de clavier (azerty et qwertz) en mode graphique sous BUNSENLAB.

Sous Debian j'avais un petit applet dans la barre des tâches me permettant de faire cela. Je ne trouve pas son nom et comment l'installer dans ma nouvelle distrib'

Quelqu'un(e) serait en mesure de m'éclairer là-dessus ?

Merci beaucoup !

Macl.

Dernière modification par Maclight (23-01-2017 01:48:43)


L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#2 07-01-2017 23:44:35

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

une solution sans ajouter d'applet
tu va dans /etc/X11/xorg.conf.d/  (si le dossier xorg.conf.d n'éxiste pas tu peux le créer)
dans ce dossier tu créé un fichier 30-keyboard.conf

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fr,us"
        Option "XkbModel" "pc105"
  Option "XKBVARIANT" "oss,"
        Option "XkbOptions" "grp:ctrl_shift_toggle"
EndSection



tu te déconnecte de ta session graphique et tu reco
par la combinaison de touche ctrl + shift tu passe de azerty à qwerty

sinon je me demande si ce que tu cherche comme applet ce n'est pas gxkb


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#3 07-01-2017 23:57:22

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

**gxkb** ne donne rien (l'applet ne s'affiche pas après redémarrage, outre une indication sur le clavier paramétré mais seulement sur l'écran de log. Mais après avoir désinstaller/purgé correctement gxkb cette indication : fr_FR.utf8 est toujours là. Etait-elle là avant la manip sans que je ne l'ai remarquée ?)

Ta solution ctrl + shift est excellente, par contre je dois passer sur un clavier QWERTZ (suisse) et non pas QWERTY.
Est-ce que je créé le fichier en mettant "ch" au lieu de "us" seulement ?
Ne faut-il pas "installer" préalablement cette disposition de clavier ?

En tous cas on se rapproche et je te remercie, une fois de plus !

L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#4 08-01-2017 00:02:16

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

remplace "us" par "ch" en effet, je n'avais pas fait attention que tu voulais du qwertz désolé neutral


par contre, regarde si tu n'as pas de raccourcis clavier qui utilise la combinaison de touche ctrl + shift, sinon tu va changer de clavier à chaque fois que tu utiliseras ces raccourcis tongue

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#5 08-01-2017 00:05:55

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Ça marche, c'est vraiment bluffant !!

Effectivement il suffit dans ton fichier de remplacer "us" par "ch" et le tour est joué.

Alors là j'avoue que je suis dépassé par la puissante de nos petites machines et de tes réponses ! Il y a tout dedans, il suffit de savoir le demander.

Néanmoins, si quelqu'un en sait plus à propos de l'applet (sous Bunsenlab je précise !)

Bye

Maclight

L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#6 08-01-2017 00:16:51

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

hummm
en testant gxkb j'ai bien un drapeau qui s'affiche dans mon panel, si je clique dessus il passe du drapeau us au russe (bon ça me passe le clavier de us à russe donc moins facile de comprendre ce que j'écris tongue)

pour que gxkb soit lancé à l'ouverture de ta session tu dois l'ajouter à ton fichier ~/.config/openbox/autostart

gxkb &


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#7 08-01-2017 00:37:01

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

bon pour l'info gxkb fonctionne bien
tu garde ton fichier de config clavier 30-keyboard.conf
tu supprime juste la ligne

Option "XkbOptions" "grp:ctrl_shift_toggle"



tu installe gxkb
tu vas dans ~/.config/gxkb/ et tu édite le fichier gxkb.conf

[xkb config]
group_policy=2
default_group=0
never_modify_config=false
model=pc105
layouts=fr,ch
variants=oss,
toggle_option=grp:alt_shift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp
compose_key_position=
 


(au passage je suis parti du principe que le pc n'est pas un portable donc clavier classique 105 touches, c'est à adapter à ton clavier bien sur tongue)

tu ajouts gxkb &  dans ton fichier ~/.config/openbox/autostart
et voila tu as ton icône de drapeau pour switch ton clavier smile

(bon faudra te créer ton icône drapeau suisse que tu mettras dans /usr/share/gxkb/flags/   wink


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#8 20-01-2017 18:56:45

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Bonjour à tous.tes,

Je me retrouve à nouveau avec un problème de clavier !

Je n'ai pas testé la solution gxkb proposée par Severian car la solution ctrl+shift me convenait tout-à-fait et a bien fonctionné jusqu'à aujourd'hui :
J'ai voulu paramétrer comme clavier par défaut le suisse (qwertz) avant le français (azerty), de sorte à n'avoir pas besoin de faire mon ctrl+shift à chaque allumage du PC (en effet mon clavier principal est le suisse).

Dans mon fichier /etc/X11/xorg.conf.d/30-keyboard.conf, j'ai simplement inversé le "fr,ch" en "ch,fr", mais depuis (après redémarrage), je 'nai plus ni clavier français ni clavier suisse, je suis à présent en qwerty. J'ai rechangé le fichier pour remettre les valeurs de base en "fr,ch" comme auparavant mais cela n'a rien changé, je suis bel et bien bloqué en qwerty et je ne sais quoi faire.

Une idée ?
Et d'ailleurs comment paramètre-t-on son clavier principal (qwertz, c'est-à-dire suisse en ce qui me concerne) ?

Merci beaucoup !

L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#9 21-01-2017 12:54:24

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Personne pour m-aider

desole pas de ponctuation et des fautes mais je suis bloque en qwerty sans savoir comment passer simplement en qwertz

L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#10 21-01-2017 13:00:30

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Dpkg-reconfigure keyboard-configuration

Dernière modification par lagrenouille (21-01-2017 13:00:51)


Le bon boot,c'est le boot qui refuse de booter sur windows
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#11 21-01-2017 13:04:48

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Maclight a écrit :

Bonjour à tous.tes,

Je me retrouve à nouveau avec un problème de clavier !

Je n'ai pas testé la solution gxkb proposée par Severian car la solution ctrl+shift me convenait tout-à-fait et a bien fonctionné jusqu'à aujourd'hui :
J'ai voulu paramétrer comme clavier par défaut le suisse (qwertz) avant le français (azerty), de sorte à n'avoir pas besoin de faire mon ctrl+shift à chaque allumage du PC (en effet mon clavier principal est le suisse).

Dans mon fichier /etc/X11/xorg.conf.d/30-keyboard.conf, j'ai simplement inversé le "fr,ch" en "ch,fr", mais depuis (après redémarrage), je 'nai plus ni clavier français ni clavier suisse, je suis à présent en qwerty. J'ai rechangé le fichier pour remettre les valeurs de base en "fr,ch" comme auparavant mais cela n'a rien changé, je suis bel et bien bloqué en qwerty et je ne sais quoi faire.

Une idée ?
Et d'ailleurs comment paramètre-t-on son clavier principal (qwertz, c'est-à-dire suisse en ce qui me concerne) ?

Merci beaucoup !


je pense savoir pourquoi
tu peux quand même donner le résultat de

cat /etc/X11/xorg.conf.d/30-keyboard.conf




Edit:
pour t'aider, dans un premier temps tu peux faire

setxkbmap ch


ça te permettra d'avoir le clavie qwertz pour faire tes manips wink

Dernière modification par Severian (21-01-2017 13:15:21)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#12 21-01-2017 13:16:13

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Salut Severian

cat /etc/X11/xorg.conf.d/30-keyboard.conf
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fr,ch"
        Option "XkbModel" "pc105"
  Option "XKBVARIANT" "oss,"
        Option "XkbOptions" "grp:ctrl_shift_toggle"
EndSection
 



Tout semble bon pourtant, mais je suis bel et bien en qwerty.
Il faudrait que je fasse le tour de tous les fichiers de configuration de clavier, non ?


L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#13 21-01-2017 13:23:10

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

salut smile
c'est cette ligne qui pose problème

  Option "XKBVARIANT" "oss,"



connais tu la "variant" de ton clavier

legacy          ch: German (Switzerland, legacy)
de_nodeadkeys   ch: German (Switzerland, eliminate dead keys)
de_sundeadkeys  ch: German (Switzerland, Sun dead keys)
fr              ch: French (Switzerland)
fr_nodeadkeys   ch: French (Switzerland, eliminate dead keys)
fr_sundeadkeys  ch: French (Switzerland, Sun dead keys)
fr_mac          ch: French (Switzerland, Macintosh)
de_mac          ch: German (Switzerland, Macintosh)


tu dois mettre la "variant" suisse avant la française si tu mets le clavier ch avant fr
par exemple pour la suisse romande

  Option "XKBVARIANT" "fr,oss,"

Dernière modification par Severian (21-01-2017 13:24:19)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#14 21-01-2017 13:42:54

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Je desespere, j'ai fait ces changements dans ces deux fichiers mais en vain :

monsieursuper@petaouchnok:~$ cat /etc/X11/xorg.conf.d/30-keyboard.conf
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "ch,fr"
        Option "XkbModel" "pc105"
  Option "XKBVARIANT" "fr,oss,"
        Option "XkbOptions" "grp:ctrl_shift_toggle"
EndSection
monsieursuper@petaouchnok:~$ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="ch,fr"
XKBVARIANT="fr,oss,"
XKBOPTIONS="grp:ctrl_shift_toggle"

BACKSPACE="guess"
 


L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#15 21-01-2017 13:54:28

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

que renvoie

 cat /var/log/Xorg.0.log | grep kb


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#16 21-01-2017 14:05:21

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Ca nous donne ca :

cat /var/log/Xorg.0.log | grep kb
[     7.792] (**) Option "xkb_rules" "evdev"
[     7.792] (**) Option "xkb_model" "pc105"
[     7.792] (**) Option "xkb_layout" "ch,fr"
[     7.792] (**) Option "xkb_variant" "fr,oss,"
[     7.792] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.812] (**) Option "xkb_rules" "evdev"
[     7.812] (**) Option "xkb_model" "pc105"
[     7.812] (**) Option "xkb_layout" "ch,fr"
[     7.812] (**) Option "xkb_variant" "fr,oss,"
[     7.812] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.813] (**) Option "xkb_rules" "evdev"
[     7.813] (**) Option "xkb_model" "pc105"
[     7.813] (**) Option "xkb_layout" "ch,fr"
[     7.813] (**) Option "xkb_variant" "fr,oss,"
[     7.813] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.814] (**) Option "xkb_rules" "evdev"
[     7.814] (**) Option "xkb_model" "pc105"
[     7.814] (**) Option "xkb_layout" "ch,fr"
[     7.814] (**) Option "xkb_variant" "fr,oss,"
[     7.814] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.873] (**) Option "xkb_rules" "evdev"
[     7.873] (**) Option "xkb_model" "pc105"
[     7.873] (**) Option "xkb_layout" "ch,fr"
[     7.873] (**) Option "xkb_variant" "fr,oss,"
[     7.873] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.874] (**) Option "xkb_rules" "evdev"
[     7.874] (**) Option "xkb_model" "pc105"
[     7.874] (**) Option "xkb_layout" "ch,fr"
[     7.874] (**) Option "xkb_variant" "fr,oss,"
[     7.874] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.874] (**) Option "xkb_rules" "evdev"
[     7.874] (**) Option "xkb_model" "pc105"
[     7.874] (**) Option "xkb_layout" "ch,fr"
[     7.874] (**) Option "xkb_variant" "fr,oss,"
[     7.874] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.876] (**) Option "xkb_rules" "evdev"
[     7.876] (**) Option "xkb_model" "pc105"
[     7.876] (**) Option "xkb_layout" "ch,fr"
[     7.876] (**) Option "xkb_variant" "fr,oss,"
[     7.876] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.877] (**) Option "xkb_rules" "evdev"
[     7.877] (**) Option "xkb_model" "pc105"
[     7.877] (**) Option "xkb_layout" "ch,fr"
[     7.877] (**) Option "xkb_variant" "fr,oss,"
[     7.877] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.967] (**) Option "xkb_rules" "evdev"
[     7.967] (**) Option "xkb_model" "pc105"
[     7.967] (**) Option "xkb_layout" "ch,fr"
[     7.967] (**) Option "xkb_variant" "fr,oss,"
[     7.967] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
[     7.968] (**) Option "xkb_rules" "evdev"
[     7.968] (**) Option "xkb_model" "pc105"
[     7.968] (**) Option "xkb_layout" "ch,fr"
[     7.968] (**) Option "xkb_variant" "fr,oss,"
[     7.968] (**) Option "xkb_options" "grp:ctrl_shift_toggle"
 



Merci encore pour ton temps et ton expertise ! De mon cote je commence a bien maitriser le qwerty a l'aveugle ! hmm


L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#17 21-01-2017 14:10:34

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

hummm

 cat /var/log/Xorg.0.log | grep EE



sinon je ne vois pas non plus le souci (peut être la "," à la fin de XKBVARIANT="fr,oss," (après oss )

sinon essais de commenter (ajouter # en début de ligne) XKBVARIANT="fr,oss,"


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#18 21-01-2017 15:08:11

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Alors :

cat /var/log/Xorg.0.log | grep EE
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     7.599] (EE) AIGLX: reverting to software rendering
 



J'ai par ailleurs essaye d'enlever la virgule apres oss dans /etc/X11/xorg.conf.d/30-keyboard.conf et dans /etc/default/keyboard et j'ai aussi mit le # en debut de ligne. Apres redemarrage, dans chacun des deux cas rien n'a change !

Je viens de tenter de remettre avec le clavier francais en premier, comme a l'origine dans /etc/X11/xorg.conf.d/30-keyboard.conf et dans /etc/default/keyboard mais cela ne change rien. Je precise que je redemarrage bien l'ordi a chaque changement...

Le probleme est donc ailleurs...

Est-ce que quelqu'un connait la commande pour relancer le script post installation sous Bunsenlab ? de mömoire il me semble que l'on peut configurer la clavier à ce moment là, mais sans certitude (on peut le faire peut-être seulement pendant l'installation) ?

Dernière modification par Maclight (21-01-2017 15:32:22)


L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#19 21-01-2017 16:04:37

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Maclight a écrit :

Est-ce que quelqu'un connait la commande pour relancer le script post installation sous Bunsenlab ? de mömoire il me semble que l'on peut configurer la clavier à ce moment là, mais sans certitude (on peut le faire peut-être seulement pendant l'installation) ?



post #10, réponse de lagrenouille wink


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#20 21-01-2017 16:11:44

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Severian a écrit :

Maclight a écrit :

Est-ce que quelqu'un connait la commande pour relancer le script post installation sous Bunsenlab ? de mömoire il me semble que l'on peut configurer la clavier à ce moment là, mais sans certitude (on peut le faire peut-être seulement pendant l'installation) ?



post #10, réponse de lagrenouille wink



J'ai essaye ca ne marche pas, ca modifie seulement le fichier /etc/default/keyboard donc sans plus de succes que moi quand je le fait manuellement.
D ailleurs ce n est pas de ce script que je voulais parler.


L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#21 21-01-2017 16:20:29

Maclight
Membre
Distrib. : Bunsenlab Hydrogen (sur Debian Jessie)
Noyau : linux 3.16.0-4-amd64
(G)UI : Openbox
Inscription : 06-01-2017

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Je donne une precision qui peut etre a son importance : le clavier du PC portable que je cherche a parametrer est un azerty (que je n'utilise pas ou extr^emement rarement).
J'utilise des claviers en USB (sans fil) qui eux sont en QWERTZ (Suisse).

L'ordinateur remplacera jamais l'homme... Il est pas assez con ! (Brève de comptoir, Jean-Marie Gourio)

Sites amis, ici et ici.

Hors ligne

#22 21-01-2017 16:44:27

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.8.0-0.bpo.2-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

hummm ça ne va pas être loin de dépasser mes connaissances neutral

peut être une dernière manip
tu renomme le fichier /etc/X11/xorg.conf.d/30-keyboard.conf pour qu'il ne soit plus actif

mv /etc/X11/xorg.conf.d/30-keyboard.conf /etc/X11/xorg.conf.d/30-keyboard.conf.bak


suivi d'une reconfiguration du clavier

dpkg-reconfigure console-data
dpkg-reconfigure keyboard-configuration
service keyboard-setup restart


bref c'est repartir du début, mais ça me semble préférable pour que tu puisse au moins retrouver un clavier utilisable wink
sinon regarde cette page
https://wiki.debian.org/fr/Keyboard


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#23 21-01-2017 18:27:57

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-2-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Bonsoir

sous le bureau Mate j ai un petit FR en haut a gauche ou je peu switcher entre plusieurs configuration.
actuellement j'ai fr et fr2 (fr2 est ma configuration personnalisé , fr français obsolet de  l installation de jessie )
ça fait pas avancé le problème  roll
(je suis sans xorg.conf , j utilise l utilitaire de configuration du clavier de Mate )

Hors ligne

#24 21-01-2017 18:31:44

Croutons
Membre
Distrib. : Handylinux 2.5 vers debian 8.6
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

Bonjour

Maclight a écrit :

J'utilise des claviers en USB (sans fil) qui eux sont en QWERTZ (Suisse).


J'ai trouvé des infos qui pourront sûrement d'aider
https://wiki.debian.org/fr/Keyboard

Hors ligne

#25 21-01-2017 18:34:26

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-2-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu!] Changement de config clavier Bunsenlab/Debian +applet bureau

j qi qjout2 en DE je suis en auertz  (allemand/suise/français/suisse )
en fr2 je suis en azerty (en DE la configuration ci dessus )
j'ai switché en live sur mon post wink

Dernière modification par robert2a (21-01-2017 18:40:37)

Hors ligne

Pied de page des forums