Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-06-2017 19:15:35

Rathorian
Membre
Inscription : 16-03-2012

[Résolu] [Numlock] Debian Stretch KDE Plasma 5.28

Bonjour à tous,

Je viens d'installer sur mon pc fixe en dual-boot Windows/Linux, la toute dernière version de Debian (Stretch).

Tout fonctionne bien après quelques configurations de la partie graphique sauf le verrouillage du pavé numérique.
Le paquet "numlockx" est bien installé est voici le retour de "/etc/default/numlock" :

cat /etc/default/numlockx
# Configuration file for numlockx

# State of numlog on start of X session
# Accepts following options:
#  auto - turns numlock on unless ran on laptop
#  on - turns numlock on
#  off - turns numlock off
#  keep - does not change numlock state
#  toggle - toggles numlock state
NUMLOCK=auto


J'ai recherché pas mal de chose sur internet ou de nombreux sujets parle d'une condition qui est :

# Active le pavé numérique au démarrage
if [ -x /usr/bin/numlockx ]; then
        /usr/bin/numlockx on
fi


J'ai essayé de mettre cette condition dans plusieurs fichiers, genre "/etc/X11/Xsession" mais aussi dans "/etc/X11/xinit/xinitrc" mais il y a rien à faire. Je n'arrive pas à activer le "VerrNum" au démarrage, avant la connexion d'un utilisateur.

Auriez-vous une idée pour résoudre ce petit problème ?

Merci beaucoup
Bonne soirée

Dernière modification par Rathorian (19-06-2017 22:13:23)

Hors ligne

#2 18-06-2017 21:25:29

Otrebla
Membre
Distrib. : Debian Stretch 9.0
Noyau : Linux 4.9.0-3-amd64
(G)UI : Xfce 4.12.3
Inscription : 05-01-2017

Re : [Résolu] [Numlock] Debian Stretch KDE Plasma 5.28

Bonjour,

Je suis passé exactement par les mêmes recherches et mêmes essais infructueux.

Numlock ne m'a servi à rien.

Pour ma part, j'ai réinstallé LDMconf qui n'avait pas été installé par défaut lorsque je suis passé à stretch. LDMconf permet d'activer le pavé numérique automatiquement au démarrage du système. Cela a fonctionné du premier coup!

Évidement j'utilise le bureau xfce qui inclut LightDM.

Je ne connais pas KDE, mais je suppose que la solution doit se trouver dans la configuration de kdm.

J'espère que cela t'aide un peu.

A+

Hors ligne

#3 18-06-2017 22:39:55

Rathorian
Membre
Inscription : 16-03-2012

Re : [Résolu] [Numlock] Debian Stretch KDE Plasma 5.28

Bonsoir,

Merci pour ton retour d'expérience.
Le seul inconvénient, c'est que LDMconf est pour LightDM, non ?

J'avoue ne pas connaître.

En tout cas, je trouve rien !

Hors ligne

#4 18-06-2017 22:54:31

yoshi
Membre
Lieu : Normandie
Distrib. : ArchLinux / PCLinuxOS / Salix
Noyau : 4.11.6 / 4.11.7 / 4.4.38
(G)UI : Plasma5 / Plasma 5 / XFCE 4.12
Inscription : 05-03-2014

Re : [Résolu] [Numlock] Debian Stretch KDE Plasma 5.28

Pour KDE, pas besoin d'aller bidouiller un quelconque fichier de config de SDDM (le DM de plasma 5, KDM n'existe plus.)

Il suffit d'aller dans "configuration du système" puis "périphériques d'entrée" puis "clavier" et verrouillage numérique au démarrage  de Plasma,
cliquer sur "activer" puis "appliquer". C'est tout.

Dernière modification par yoshi (18-06-2017 22:56:00)


ArchLinux KDE Plasma 5.10.3 / PCLinuxOS KDE Plasma 5.10.2 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
PCLinuxOS KDE Plasma 5.10.2 sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
Salix 14.2 XFCE 4.12.3+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#5 18-06-2017 23:22:08

Rathorian
Membre
Inscription : 16-03-2012

Re : [Résolu] [Numlock] Debian Stretch KDE Plasma 5.28

Je me sens un peu idiot pour le coup.

Je suis allez voir ça et effectivement il y a bien une option "Verrouillage numérique de plasma" qui était sur "Laisser en l'état".

Je l'ai activé, appliqué les changements, changé différents types de clavier mais ça ne fonctionne toujours pas. Mon clavier est un Logitech K120.

??

Hors ligne

#6 19-06-2017 15:47:09

pili36
Membre
Lieu : Lille
Distrib. : Debian stretch / Raspbian Jessie
Noyau : 4.9_amd64 / 3.16_armhf
(G)UI : Kde / Lxde
Inscription : 03-11-2009

Re : [Résolu] [Numlock] Debian Stretch KDE Plasma 5.28

Bonjour

Si tu souhaites activer le verr Num dès le gestionnaire de connexion, il s'agit de sddm par défaut pour kde, il faut créer un fichier sddm.conf dans le dossier etc

nano /etc/sddm.conf


Dedans tu inseres

[General]
Numlock=On



Au cas où tu utiliserais un autre gestionnaire de connexion, voici un lien qui explique comment faire pour chaque gestionnaire de connexion
https://doc.ubuntu-fr.org/numlockx

Dernière modification par pili36 (19-06-2017 15:49:52)


Debian stretch amd64, Kde, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Stretch amd64, (pour Steam), Kde, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#7 19-06-2017 22:15:05

Rathorian
Membre
Inscription : 16-03-2012

Re : [Résolu] [Numlock] Debian Stretch KDE Plasma 5.28

pili36 a écrit :

Bonjour

Si tu souhaites activer le verr Num dès le gestionnaire de connexion, il s'agit de sddm par défaut pour kde, il faut créer un fichier sddm.conf dans le dossier etc

nano /etc/sddm.conf


Dedans tu inseres

[General]
Numlock=On



Au cas où tu utiliserais un autre gestionnaire de connexion, voici un lien qui explique comment faire pour chaque gestionnaire de connexion
https://doc.ubuntu-fr.org/numlockx


Marche à la perfection.
Merci smile

Hors ligne

Pied de page des forums