Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-07-2017 12:24:42

Brutus
Membre
Inscription : 01-07-2017

[RESOLU] Installation de paquets offline

Bonjour,

J'ai installé Debian 9 sur mon ordinateur dépourvu de port RJ45, autrement dit je n'ai pas l'accès à internet pour installer les paquets de base, notamment en ce qui concerne les paramètres réseau.

Ainsi au premier démarrage, il m'est impossible de lancer un apt-update car les liens du sources.list pointent vers aucun fichier local (que des URL debian.org).

Je souhaiterais ainsi avoir une réponse à la question suivante : est-il possible de récupérer les paquets de base nécessaires à la configuration de ma carte réseau sans avoir à me connecter directement à internet depuis cet ordinateur ?

Je précise que je dispose en parallèle d'un ordinateur connecté à internet et d'une clé USB.

Merci d'avance.

Dernière modification par Brutus (01-07-2017 19:25:49)

Hors ligne

#2 01-07-2017 12:51:53

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [RESOLU] Installation de paquets offline

Bonjour smile
Oui c'est possible de télécharger et installer avec

dpkg -i nomdudriver.deb


Quel est le retour de

lspci -k | grep -i network -A 2

Hors ligne

#3 01-07-2017 13:04:17

Brutus
Membre
Inscription : 01-07-2017

Re : [RESOLU] Installation de paquets offline

Merci beaucoup pour votre réponse super rapide.

La commande me renvoie :

3a:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
  Subsystem: Bigfoot Networks, Inc. QCA6174 802.11ac Wireless Network Adapter
  Kernel driver in use: ath10k_pci
  Kernel modules: ath10k_pci



Cela signifie que les drivers sont déjà installés ? Dans ce cas, comment configurer ma connexion internet pour pouvoir effectuer les updates ?

Hors ligne

#4 01-07-2017 13:09:35

Brutus
Membre
Inscription : 01-07-2017

Re : [RESOLU] Installation de paquets offline

Voilà ce que j'obtiens en lançant un atp update :

root@logpi:~# apt-get update
Err:1 http://security.debian.org/debian-security stretch/updates InRelease
  Ne parvient pas à résoudre « security.debian.org »
Err:2 http://deb.debian.org/debian stretch InRelease
  Ne parvient pas à résoudre « deb.debian.org »
Err:3 http://deb.debian.org/debian strech-update InRelease
  Ne parvient pas à résoudre « deb.debian.org »
Lecture des listes de paquets... Fait
W: Impossible de récupérer http://security.debian.org/debian-security/dists/stretch/updates/InRelease  Ne parvient pas à résoudre « security.debian.org »
W: Impossible de récupérer http://deb.debian.org/debian/dists/stretch/InRelease  Ne parvient pas à résoudre « deb.debian.org »
W: Impossible de récupérer http://deb.debian.org/debian/dists/strech-update/InRelease  Ne parvient pas à résoudre « deb.debian.org »
W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Dernière modification par Brutus (01-07-2017 13:09:48)

Hors ligne

#5 01-07-2017 13:24:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] Installation de paquets offline

Bonjour Brutus,

Le pilote ath10k_pci requiert quelques firmwares non libres, comme le montre le retour de :

modinfo ath10k_pci | grep 6174

firmware:       ath10k/QCA6174/hw3.0/board-2.bin
firmware:       ath10k/QCA6174/hw3.0/board.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-4.bin
firmware:       ath10k/QCA6174/hw2.1/board-2.bin
firmware:       ath10k/QCA6174/hw2.1/board.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-5.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-4.bin


Ces fameux firmwares sont fournis par le paquet firmware-atheros est-il installé ?

apt-cache policy firmware-atheros

firmware-atheros:
  Installé : 20161130-3
  Candidat : 20161130-3
 Table de version :
 *** 20161130-3 500
        500 http://ftp.fr.debian.org/debian stretch/non-free amd64 Packages
        100 /var/lib/dpkg/status


Probablement non, aussi dois-tu le télécharger depuis ta machine connectée, puis l'installer depuis ta clé USB :

wget http://ftp.fr.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-atheros_20161130-3_all.deb


Vérifier la somme de contrôle SHA256 est de bon ton :

sha256sum firmware-atheros_20161130-3_all.deb

98ecdada8228a647007a816a30daec33436bb58e53057b5e8f8ad45b9a85b881  firmware-atheros_20161130-3_all.deb


Puis comme l'a déjà expliqué chalu :

dpkg -i firmware-atheros_20161130-3_all.deb


En cas de difficulté pour la configuration de la connexion précise le bureau installé.

Dernière modification par èfpé (01-07-2017 14:24:42)

Hors ligne

#6 01-07-2017 13:55:37

Brutus
Membre
Inscription : 01-07-2017

Re : [RESOLU] Installation de paquets offline

Merci beaucoup pour cette réponse.

Après l'avoir téléchargé, j'ai installé le paquet sur ma machine :

root@logpi:/media/brutus/D21E-EB27# dpkg -i firmware-atheros_20161130-3_all.deb
Sélection du paquet firmware-atheros précédemment désélectionné.
(Lecture de la base de données... 125817 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de firmware-atheros_20161130-3_all.deb ...
Dépaquetage de firmware-atheros (20161130-3) ...
Paramétrage de firmware-atheros (20161130-3) ...
root@logpi:/media/brutus/D21E-EB27#apt-cache policy firmware-atheros
firmware-atheros:
  Installé : 20161130-3
  Candidat : 20161130-3
 Table de version :
 *** 20161130-3 500
        100 /var/lib/dpkg/status



Cependant j'ai toujours le même problème lorsque que je veux lancer l'update. Mon bureau est GNOME.

Hors ligne

#7 01-07-2017 14:01:42

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Installation de paquets offline

As-tu redémarré le système ou rechargé le module ?

modprobe -r ath10k_pci
modprobe ath10k_pci

Dernière modification par raleur (01-07-2017 14:01:54)

Hors ligne

#8 01-07-2017 14:08:24

Brutus
Membre
Inscription : 01-07-2017

Re : [RESOLU] Installation de paquets offline

Super, ça marche ! Merci beaucoup.

J'ai redémarré le système et j'ai ensuite pu me connecter à mon réseau. Tout semble parfaitement fonctionner.

Bon week end !

Hors ligne

#9 01-07-2017 14:39:34

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Hors ligne

Pied de page des forums