Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-10-2017 18:51:49

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

ntpdate

Bonjour,
sur un raspberry pi avec raspbian stretch d'installer.(et j'ai les mêmes problème avec mon pc en debian stretch)
Comme il n'y a pas de piles, la date et l'heure ne sont conservées.
donc, j'ai installé

apt install ntp ntpdate



et


ntpdate


ntpdate[6883]: no servers can be used, exiting  


  j'ai remplacé  les serveurs dans /etc/ntp.conf par ceux là:
server 0.pool.ntp.org
server 1.pool.ntp.org
server 2.pool.ntp.org
server 3.pool.ntp.org



mais idem

avec

ntpdate-debian


ntpdate[6921]: the NTP socket is in use, exiting




j'ai essayé ceci:

service ntp stop




et recommencé avec ntpdate-debian et idem
 

pour voir, j'ai voulu installer 'installer ntpdate sur ma debian stretch, et les mêmes réponses
si vous avez une idée, merci d'avance

Edit à toto :
Modifié les balises Commande pour séparer la ligne de commande de son retour.

Dernière modification par solar66 (11-10-2017 13:20:44)

Hors ligne

#2 12-10-2017 12:46:42

èfpé
Membre
Inscription : 10-07-2016

Re : ntpdate

Bonjour,

Outre le fait que l'installation de ntpdate n'est pas nécessaire, l'utilisation que tu en fais est erronée :

ntpdate server


Est la syntaxe correcte... par ailleurs, ntpdate-debian se base sur /etc/default/ntpdate wink

systemctl status ntp

● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp)
   Active: active (running) since jeu. 2017-10-12 12:10:00 CEST; 8min ago
  Process: 21918 ExecStop=/etc/init.d/ntp stop (code=exited, status=0/SUCCESS)
  Process: 22038 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ntp.service
           └─22045 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 105:113


ntpdate pool.ntp.org

12 Oct 12:19:00 ntpdate[22515]: the NTP socket is in use, exiting


ntpdate-debian

12 Oct 12:20:00 ntpdate[22520]: the NTP socket is in use, exiting


systemctl stop ntp


ntpdate pool.ntp.org

12 Oct 12:21:00 ntpdate[22538]: adjust time server 195.154.41.195 offset 0.009106 sec


ntpdate-debian

12 Oct 12:22:00 ntpdate[22540]: adjust time server 129.250.35.250 offset -0.000256 sec


Quoi qu'il en soit, tu peux désinstaller ntpdate et démarrer ntpd avec le paramètre -g :

nano /etc/default/ntp

NTPD_OPTS='-g'


N'hésite surtout pas à lire le man pour ntpd, ntpdate et ntpdate-debian, ou au moins ça.

Dernière modification par èfpé (12-10-2017 12:48:42)

Hors ligne

#3 12-10-2017 18:33:22

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : ntpdate

ok merci pour ta réponse;
j'ai donc désinstallé ntpdate
j'ai bien: NTPD_OPTS='-g'
dans /etc/default/ntp

sudo ntpd -g  ne change rien


/etc/init.d/ntp start
[ ok ] Starting ntp (via systemctl): ntp.service.
 




et


systemctl status ntp
● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp; generated; vendor preset: enabled)
   Active: active (running) since Tue 2017-10-10 22:39:11 CEST; 31min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 447 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ntp.service
           └─491 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 112:117

oct. 10 22:41:57 thierry ntpd[491]: Listen normally on 6 wlan0 [fe80::285f:85d1:3a0e:a076%3]:123
oct. 10 22:42:02 thierry ntpd[491]: Listen normally on 7 wlan0 172.16.0.4:123
oct. 10 22:53:17 thierry ntpd[491]: Listen normally on 8 enxb827eb44e191 [fe80::1414:d730:83bd:aa3e%2]:123
oct. 10 22:53:25 thierry ntpd[491]: Listen normally on 9 enxb827eb44e191 172.16.0.3:123
oct. 10 22:53:25 thierry ntpd[491]: 51.255.141.154 local addr 172.16.0.4 -> 172.16.0.3
oct. 10 22:53:25 thierry ntpd[491]: 178.33.126.120 local addr 172.16.0.4 -> 172.16.0.3
oct. 10 22:53:25 thierry ntpd[491]: 37.187.2.84 local addr 172.16.0.4 -> 172.16.0.3
oct. 10 22:53:25 thierry ntpd[491]: 91.134.237.119 local addr 172.16.0.4 -> 172.16.0.3
oct. 10 22:54:05 thierry ntpd[491]: Deleting interface #6 wlan0, fe80::285f:85d1:3a0e:a076%3#123, interface stats: received=0, sent=0, dropped=0, active_time=728 secs
oct. 10 22:54:05 thierry ntpd[491]: Deleting interface #7 wlan0, 172.16.0.4#123, interface stats: received=0, sent=32, dropped=0, active_time=723 secs
 

Hors ligne

#4 12-10-2017 18:58:42

èfpé
Membre
Inscription : 10-07-2016

Re : ntpdate

Re-,

OK ; ça veut dire quoi « sudo ntpd -g ne change rien » ? que retournent les commandes :

sudo systemctl stop ntp && sudo ntpd -gq

et en cas d'échec,

sudo sntp -S pool.ntp.org


Tu as du réseau par ailleurs ? wlan0 et enxMAC forment un drôle de mélange neutral

edit: correction, l'option -s (sous Debian 8) de 'sntp' devient -S sous Debian 9.

Dernière modification par èfpé (13-10-2017 11:28:42)

Hors ligne

#5 12-10-2017 22:53:23

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : ntpdate


OK ; ça veut dire quoi « sudo ntpd -g ne change rien » ?


et bien, cette commande me donne aucun résultat, et l'heure ne change pas.


pi@thierry:~ $ sudo ntpd -g
pi@thierry:~ $
 




sudo systemctl stop ntp && sudo ntpd -gq
11 Oct 00:29:33 ntpd[16824]: ntpd 4.2.8p10@1.3728-o Sat Oct  7 14:29:08 UTC 2017 (1): Starting
11 Oct 00:29:33 ntpd[16824]: Command line: ntpd -gq
11 Oct 00:29:33 ntpd[16824]: proto: precision = 0.677 usec (-20)
11 Oct 00:29:33 ntpd[16824]: Listen and drop on 0 v6wildcard [::]:123
11 Oct 00:29:33 ntpd[16824]: Listen and drop on 1 v4wildcard 0.0.0.0:123
11 Oct 00:29:33 ntpd[16824]: Listen normally on 2 lo 127.0.0.1:123
11 Oct 00:29:33 ntpd[16824]: Listen normally on 3 enxb827eb44e191 172.16.0.3:123
11 Oct 00:29:33 ntpd[16824]: Listen normally on 4 lo [::1]:123
11 Oct 00:29:33 ntpd[16824]: Listen normally on 5 enxb827eb44e191 [fe80::1414:d730:83bd:aa3e%2]:123
11 Oct 00:29:33 ntpd[16824]: Listening on routing socket on fd #22 for interface updates

 


cette commande reste bloquée, et je suis obligé de faire: ctrl+c  pour fermer

et,


sudo sntp -s pool.ntp.org
sntp 4.2.8p10@1.3728-o Sat Oct  7 14:25:26 UTC 2017 (1)
kod_init_kod_db(): Cannot open KoD db file /var/db/ntp-kod: No such file or directory

 



et pour répondre à ta dernière remarque:

Tu as du réseau par ailleurs ? wlan0 et enxMAC forment un drôle de mélange neutral


le raspberry pi 3 a la wifi intégrée, et comme le signal est assez mauvais je me suis branché par câble, et désactivé la wifi; ceci explique peut-être cela

Hors ligne

#6 13-10-2017 08:03:45

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : ntpdate

Bonjour

ntp sur une configuration par défaut ne fourni l heure que sur 127.0.0.1 . (en local sur la machine )
mais il écoute sur tous les réseaux disponible en IPV4 et IPV6

ton  raspberry pi 3 est en IP fixe ou dhcp ? (il est alimenté (en service ) occasionnellement ou en permanence ? ).
tu a pas une option pour installer une pile de sauvegarde sur ce matériel ?

il existe une mise a l heure par systemd et dhcp-client (je n utilise plus ntp ou ntp-date) mais il faut avoir un serveur dhcpd et un serveur de temps sur le réseau local.
je sais pas si une box par exemple peu donner l heure a ses clients

nota : je pense que dans ton cas c'est la différence entre l heure réelle et l heure de ton  raspberry pi 3 (si il repasse a 01/01/1970 par exemple ).
le nombre de réseau (sous réseau)  actif est sans importance, du moment que la passerelle est connu , il ira chercher le serveur de temps déclaré dans la configuration et servira 127.0.0.1 (localhost) pour mise a l heure (si tu a rien modifié)
tu a la possibilité de voir le fichier /var/log/syslog (log de ntp) et si tu le met en service les logs dans /var/log/ntp/  (au début du fichier de configuration )
voir la configuration du fichier /etc/ntp.conf

un exemple par dhcp-client (dans le syslog ) sans ntp ou ntp-date


Oct 13 08:06:43 debian21 systemd-timesyncd[717]: Synchronized to time server 192.xxx.xxx.xxx:123 (192.xxx.xxx.xxx).
 

Dernière modification par robert2a (13-10-2017 08:12:47)

Hors ligne

#7 13-10-2017 14:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : ntpdate

Bonjour,

robert2a a écrit :

ntp sur une configuration par défaut ne fournit l'heure que sur 127.0.0.1 (en local sur la machine) mais il écoute sur tous les réseaux disponibles en IPv4 et IPv6.


Par défaut, sur un système Debian, le daemon installé par le paquet ntp (ntpd) interroge « également » le pool debian.pool.ntp.org dès qu'il est démarré/exécuté (tout comme ntpdate-debian, d'ailleurs), et corrige l'heure système (au-delà des fameuses 1000 secondes, via l'option -g) en une dizaine de secondes. Exemple avec une horloge système en retard d'un mois et une heure :

sudo ntpd -gq

13 Sep 07:53:00 ntpd[16226]: ntpd 4.2.8p10@1.3728-o Sat Sep 23 19:02:38 UTC 2017 (1): Starting
13 Sep 07:53:00 ntpd[16226]: Command line: ntpd -gq
13 Sep 07:53:00 ntpd[16226]: proto: precision = 0.161 usec (-22)
13 Sep 07:53:00 ntpd[16226]: Listen and drop on 0 v6wildcard [::]:123
13 Sep 07:53:00 ntpd[16226]: Listen and drop on 1 v4wildcard 0.0.0.0:123
13 Sep 07:53:00 ntpd[16226]: Listen normally on 2 lo 127.0.0.1:123
13 Sep 07:53:00 ntpd[16226]: Listen normally on 3 enp3s6 192.168.1.2:123
13 Sep 07:53:00 ntpd[16226]: Listen normally on 4 lo [::1]:123
13 Sep 07:53:00 ntpd[16226]: Listen normally on 5 enp3s6 [fe80::f7db:dea0:d975:3e9c%2]:123
13 Sep 07:53:00 ntpd[16226]: Listening on routing socket on fd #22 for interface updates
13 Sep 07:53:01 ntpd[16226]: Soliciting pool server 217.91.44.17
13 Sep 07:53:02 ntpd[16226]: Soliciting pool server 185.41.243.30
13 Sep 07:53:02 ntpd[16226]: Soliciting pool server 51.15.142.60
13 Sep 07:53:03 ntpd[16226]: Soliciting pool server 95.81.173.155
13 Sep 07:53:03 ntpd[16226]: Soliciting pool server 185.103.216.7
13 Sep 07:53:03 ntpd[16226]: Soliciting pool server 62.210.106.105
13 Sep 07:53:04 ntpd[16226]: Soliciting pool server 91.121.205.56
13 Sep 07:53:04 ntpd[16226]: Soliciting pool server 151.80.124.104
13 Sep 07:53:04 ntpd[16226]: Soliciting pool server 212.47.249.141
13 Sep 07:53:04 ntpd[16226]: Soliciting pool server 138.68.46.177
13 Sep 07:53:05 ntpd[16226]: Soliciting pool server 213.136.86.203
13 Sep 07:53:05 ntpd[16226]: Soliciting pool server 163.172.139.21
13 Sep 07:53:05 ntpd[16226]: Soliciting pool server 163.172.225.159
13 Sep 07:53:06 ntpd[16226]: Soliciting pool server 45.33.48.4
13 Sep 07:53:06 ntpd[16226]: Soliciting pool server 62.210.5.240
13 Sep 07:53:07 ntpd[16226]: Soliciting pool server 69.195.159.158
13 Sep 07:53:07 ntpd[16226]: Soliciting pool server 2a03:7220:8081:2900::1
13 Oct 08:53:14 ntpd[16226]: ntpd: time set +2595605.222599 s
ntpd: time set +2595605.222599s
 


sudo systemctl start ntp


ntpq -pn

     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 0.debian.pool.n .POOL.          16 p    -   64    0    0.000    0.000   0.000
 1.debian.pool.n .POOL.          16 p    -   64    0    0.000    0.000   0.000
 2.debian.pool.n .POOL.          16 p    -   64    0    0.000    0.000   0.000
 3.debian.pool.n .POOL.          16 p    -   64    0    0.000    0.000   0.000
-62.210.106.105  145.238.203.14   2 u    2   64    1   32.711    0.526   2.226
 83.137.225.123  193.79.237.14    2 u    -   64    1   39.413   -1.776   1.265
 193.136.164.4   131.188.3.222    2 u    1   64    1   91.499    8.444   4.949
-195.154.174.209 145.238.203.14   2 u    1   64    1   37.705    3.194   4.017
 62.210.5.240    192.53.103.104   2 u    -   64    1   40.278    0.140   0.975
 162.23.41.55    .MRS.            1 u    -   64    1   39.883   -1.620   0.566
 195.154.41.195  193.190.230.66   2 u    1   64    1   37.514    3.566   3.112
+176.9.1.211     161.62.157.173   3 u    1   64    1   49.553    1.460   3.066
*88.191.250.97   140.38.34.166    3 u    1   64    1   34.306    1.582   2.926
 45.79.167.181   108.61.73.243    3 u    -   64    1  112.146   -7.627   0.167
 91.134.237.119  162.23.41.56     2 u    1   64    1   39.228    1.852   2.118
+217.79.179.106  192.53.103.104   2 u    1   64    1   43.253    1.927   1.954
-192.36.143.130  .PPS.            1 u    1   64    1   65.234   -0.394   1.571
+94.23.0.110     162.23.41.55     2 u    1   64    1   33.633    2.882   1.380
 79.142.192.130  47.187.174.51    2 u    1   64    1   73.639   -2.274   0.929
 94.23.210.194   213.251.128.249  2 u    1   64    1   31.584   -1.851   0.371
 


systemctl status ntp

● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp; generated; vendor preset: enabled)
   Active: active (running) since Wed 2017-09-13 07:56:00 CEST; 4 weeks 2 days ago
     Docs: man:systemd-sysv-generator(8)
  Process: 16426 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/ntp.service
           └─16436 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 118:123


robert2a a écrit :

il existe une mise à l'heure par systemd et dhcp-client (je n'utilise plus ntp ou ntpdate) mais il faut avoir un serveur dhcpd et un serveur de temps sur le réseau local.


Par défaut, sur un système Debian, le service systemd-timesyncd, qui se comporte en client SNTP, interroge le pool debian.pool.ntp.org dès qu'il est démarré ou activé, et corrige l'heure système en moins d'une seconde... exemple avec une horloge système en retard d'un mois et une heure :

sudo systemctl start systemd-timesyncd


systemctl status systemd-timesyncd

● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
  Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: active (running) since Fri 2017-10-13 09:25:00 CEST; 42s ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 18609 (systemd-timesyn)
   Status: "Synchronized to time server 92.222.227.225:123 (0.debian.pool.ntp.org)."
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/systemd-timesyncd.service
           └─18609 /lib/systemd/systemd-timesyncd


robert2a a écrit :

c'est la différence entre l'heure réelle et l'heure de ton raspberry pi 3 (s'il repasse au 01/01/1970 par exemple).


Si le service systemd-timesyncd est activé/démarré, ce sont la date et l'heure au moment de l'extinction de la machine qui servent de référence au démarrage suivant :

man systemd-timesyncd a écrit :

systemd-timesyncd is a system service that may be used to synchronize the local system clock with a remote Network Time Protocol server. It also saves the local time to disk every time the clock has been synchronized and uses this to possibly advance the system realtime clock on subsequent reboots to ensure it monotonically advances even if the system lacks a battery-buffered RTC chip.


Ceci pourrait le rendre particulièrement adapté à la situation, a priori, encore faut-il disposer, du moins dans la configuration par défaut, d'une « connectivité » réseau (internet, pas limitée au réseau local) et d'un résolveur DNS fiables (attention, unbound plante si l'heure système/matérielle a plus de 24 heures de retard sur l'heure UTC), ce qui n'est peut-être pas le cas ici ; les retours des commandes :

timedatectl

et

ping -c 4 debian-facile.org


Seraient pour le moins intéressants, du coup... force et courage (sic) !

Dernière modification par èfpé (13-10-2017 16:54:42)

Hors ligne

#8 14-10-2017 08:47:06

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : ntpdate

[

ton  raspberry pi 3 est en IP fixe ou dhcp ?
dhcp, il me semble

il est alimenté (en service ) occasionnellement ou en permanence ?
il le sera occasionnellement

tu a pas une option pour installer une pile de sauvegarde sur ce matériel ?
non


timedatectl
      Local time: mer. 2017-10-11 06:36:14 CEST
  Universal time: mer. 2017-10-11 04:36:14 UTC
        RTC time: n/a
       Time zone: Europe/Paris (CEST, +0200)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no

 




ping -c 4 debian-facile.org
PING debian-facile.org (151.80.145.212) 56(84) bytes of data.
64 bytes from debian (151.80.145.212): icmp_seq=1 ttl=54 time=1285 ms
64 bytes from debian (151.80.145.212): icmp_seq=2 ttl=54 time=867 ms
64 bytes from debian (151.80.145.212): icmp_seq=3 ttl=54 time=737 ms
64 bytes from debian (151.80.145.212): icmp_seq=4 ttl=54 time=756 ms

--- debian-facile.org ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3020ms
rtt min/avg/max/mdev = 737.373/911.962/1285.547/221.360 ms, pipe 2



ce raspberry est aussi en réseau local par l'intermédiaire d'un routeur (d'ailleurs, je le commande avec mon pc debian stretch.
et donc ne serait-il pas possible qu'il récupère l'heure de ce pc?
ce raspberry doit être utilisé pour de la video surveillance; et donc l'heure est indispensable

Hors ligne

#9 14-10-2017 09:16:42

èfpé
Membre
Inscription : 10-07-2016

Re : ntpdate

Re-,

OK ; le RTT est digne d'une connexion bas débit, mais cela n'explique pas pourquoi l'heure système est désynchronisée... que retournent les commandes :

systemctl status systemd-timesyncd

systemctl status ntp

cat /etc/systemd/timesyncd.conf


Il est tout à fait envisageable de synchroniser le RPi sur une machine du réseau local, celle-ci devra idéalement être en IP fixe et disposer d'un serveur de temps correctement configuré, ntp.

Dernière modification par èfpé (14-10-2017 19:16:42)

Hors ligne

#10 14-10-2017 09:47:16

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : ntpdate

Bonjour
je donne le retour des commandes de èfpé pour un de mes clients


systemctl status systemd-timesyncd
 


retour


● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendo
  Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: active (running) since Fri 2017-10-13 19:58:50 CEST; 13h ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 1459 (systemd-timesyn)
   Status: "Synchronized to time server 192.168.10.1:123 (192.168.10.1)."
    Tasks: 2 (limit: 19660)
   CGroup: /system.slice/systemd-timesyncd.service
           └─1459 /lib/systemd/systemd-timesyncd
 



je n'ai pas ntp installé sur le client


systemctl status ntp
 


retour


Unit ntp.service could not be found.
 


le fichier de conf


cat /etc/systemd/timesyncd.conf
 


retour


#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See timesyncd.conf(5) for details.

[Time]
#NTP=
#FallbackNTP=0.debian.pool.ntp.org 1.debian.pool.ntp.org 2.debian.pool.ntp.org 3.debian.pool.ntp.org
 



a la fin on voit qu il est peut etre possible d utiliser un serveur externe (a voir avec la documentation )
nota : j'utilise un serveur ntp local uniquement parce que j'ai de nombreux clients , éviter une multitude de synchro de l heure sur le net , alors que la , le trafic reste sur le réseau local , le serveur se met a l heure et distribue aux clients qui le demande.
ce qui n'est pas ton cas
si tu n'a que deux machines un serveur externe peut etre possible , a voir avec èfpé smile

Hors ligne

#11 14-10-2017 10:14:42

èfpé
Membre
Inscription : 10-07-2016

Re : ntpdate

Re-,

@robert2a : du coup, aucune configuration du client ne serait nécessaire (du fait de systemd-networkd) ? par ailleurs, ta machine serveur de temps est en IP fixe ou pas ?

Dernière modification par èfpé (14-10-2017 10:16:42)

Hors ligne

#12 14-10-2017 10:36:01

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : ntpdate

je suis en dhcp-client donc ça demande réflexion , j'ai une annonce du serveur de temps sur mon serveur dhcpd (je peu vérifier sur la configuration )
tu vois que mon fichier de configuration "timesyncd.conf"  n'est pas renseigné


[Time]
#NTP=
#FallbackNTP=0.debian.pool.ntp.org 1.debian.pool.ntp.org 2.debian.pool.ntp.org 3.debian.pool.ntp.org
 


mais le script de dhcp-client (dans le dossier /etc/dhcp/ tu trouvera les différents scripts )  fait son job avec systemd

d'ou ma proposition de tenter directement d'utiliser le script "timesyncd.conf"
nota : il y a deux façon d'utiliser dhcp , normale ou par réservation d'adresse sur une box ou sur dhcpd (pour garder toujours la meme)
donc pas obligatoire d'etre en IP fixe dans le fichier "interfaces"

dans mon cas oui le serveur est en IP fixe (serveur DNS , dhcpd) , tous les clients en dhcp

pour répondre a ta question , je sais pas , pas testé mais il me semble que oui , voir la documentation de "timesyncd.conf"

ps : voila comment  dhcpd annonce mon serveur de temps au client (dans dhcpd.conf)


option ntp-servers 192.168.10.1;
 


donc je suis pas du tout dans la configuration de systemd tout seul et jamais testé
dhcp-client utilise le script "timesyncd" et sur le serveur il a créer un script "ntp" qui n'existe pas sur les clients (ceci dans /etc/dhcp/dhclient-exit-hooks.d/ )

nota : sur mes clients la mise a l'heure fonctionne au démarrage (une synchro a l init du système )  , je n'ai rien pour tester avec systemd  et surtout le comportement sans pile pour conserver l'heure . (grosse différence entre l heure UTC et du système )
j'ai lu ton #7
si j ai une machine dispo , faire un test sans pile et hors de mon sous réseau voir ce qui se passe , mais je sais que debian n'est pas content quand  il voit une différence entre "l heure (date)" des fichiers et l heure du système au démarrage de la machine.

une autre question que je me pose , ntp garde en permanence l heure a jour du système (dans le cas de machine qui ne sont que rarement redémarré ) avec dhcp-client je ne suis pas certain que ce soit le cas (je ne vois qu une mise a l'heure au démarrage du système après dans les logs je ne voit plus rien ).

si ça peu peu faire avancer le souci , si j ai l occasion de tester je posterai le résultat
je connais pas non plus le matériel , si il est possible de l éteindre sans couper l alimentation (pour garder l heure) comme sur un PC (il resterai le cas d une coupure secteur ou le système perd l heure )

j' ajoute le retour de ces commandes


timedatectl
 


le retour =>  NTP synchronized: yes  , mes clients restent a l heure .........


      Local time: sam. 2017-10-14 11:16:17 CEST
  Universal time: sam. 2017-10-14 09:16:17 UTC
        RTC time: sam. 2017-10-14 09:16:17
       Time zone: Europe/Paris (CEST, +0200)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no
 


le ping


 ping -c 4 debian-facile.org
 


retour


PING debian-facile.org (151.80.145.212) 56(84) bytes of data.
64 bytes from debian-facile.org (151.80.145.212): icmp_seq=1 ttl=52 time=34.1 ms
64 bytes from debian-facile.org (151.80.145.212): icmp_seq=2 ttl=52 time=34.5 ms
64 bytes from debian-facile.org (151.80.145.212): icmp_seq=3 ttl=52 time=34.3 ms
64 bytes from debian-facile.org (151.80.145.212): icmp_seq=4 ttl=52 time=34.4 ms

--- debian-facile.org ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 34.191/34.397/34.589/0.145 ms
 


le ping du serveur ntp (autre avantage , l heure peut etre pas précise mais tous les clients ont la meme , moins de latence sur un réseau local )


 ping -c 4 192.168.10.1
 


retour


PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
64 bytes from 192.168.10.1: icmp_seq=1 ttl=64 time=0.415 ms
64 bytes from 192.168.10.1: icmp_seq=2 ttl=64 time=0.415 ms
64 bytes from 192.168.10.1: icmp_seq=3 ttl=64 time=0.388 ms
64 bytes from 192.168.10.1: icmp_seq=4 ttl=64 time=0.414 ms

--- 192.168.10.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3056ms
rtt min/avg/max/mdev = 0.388/0.408/0.415/0.011 ms
 

Dernière modification par robert2a (14-10-2017 12:18:33)

Hors ligne

#13 14-10-2017 12:55:30

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : ntpdate


OK ; le RTT est digne d'une connexion bas débit, mais cela n'explique pas pourquoi l'heure système est désynchronisée...  :

hé oui, dans mon trou perdu; je n'ai droit qu'au satellite; c'est cher et une connexion de m....


systemd-timesyncd.service changed on disk. Run 'systemctl daemon-reload


● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendo
  Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: inactive (dead)
Condition: start condition failed at Wed 2017-10-11 08:02:46 CEST; 1min 20s ago
           └─ ConditionFileIsExecutable=!/usr/sbin/ntpd was not met
     Docs: man:systemd-timesyncd.service(8)
 




systemctl status ntp


● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp; generated; vendor preset: enabled)
   Active: active (running) since Wed 2017-10-11 08:02:49 CEST; 2min 44s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 469 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ntp.service
           └─523 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 112:117

oct. 11 08:02:49 thierry ntpd[523]: Listen normally on 3 lo [::1]:123
oct. 11 08:02:49 thierry ntpd[523]: bind(20) AF_INET6 fe80::1414:d730:83bd:aa3e%
oct. 11 08:02:49 thierry ntpd[523]: unable to create socket on enxb827eb44e191 (
oct. 11 08:02:49 thierry ntpd[523]: failed to init interface for address fe80::1
oct. 11 08:02:49 thierry ntpd[523]: Listening on routing socket on fd #20 for in
oct. 11 08:02:50 thierry ntpd[523]: bind(23) AF_INET6 fe80::1414:d730:83bd:aa3e%
oct. 11 08:02:50 thierry ntpd[523]: unable to create socket on enxb827eb44e191 (
oct. 11 08:02:50 thierry ntpd[523]: failed to init interface for address fe80::1
oct. 11 08:02:52 thierry ntpd[523]: Listen normally on 6 enxb827eb44e191 [fe80::
oct. 11 08:02:56 thierry ntpd[523]: Listen normally on 7 enxb827eb44e191 172.16.

 




cat /etc/systemd/timesyncd.conf



#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See timesyncd.conf(5) for details.

[Time]
#NTP=
#FallbackNTP=0.debian.pool.ntp.org 1.debian.pool.ntp.org 2.debian.pool.ntp.org 3.debian.pool.ntp.org

 







Il est tout à fait envisageable de synchroniser le RPi sur une machine du réseau local, celle-ci devra idéalement être en IP fixe et disposer d'un serveur de temps correctement configuré, ntp

je ne pense pas avoir une IP fixe;

Edit à toto :
Modifié les balises Commande pour séparer la ligne de commande de son retour.

Hors ligne

#14 14-10-2017 15:36:09

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : ntpdate

je pense qu il faut commencer par configurer ton réseau
donner une description de ta passerelle "internet" et expliquer pourquoi tu n'a pas d IPv4

chez moi le retour du serveur ntp sur une debian 9.4
dans le /var/log/syslog


Oct 14 15:15:53 debian1 systemd[1]: Stopped LSB: Start NTP daemon.
Oct 14 15:15:53 debian1 systemd[1]: Starting LSB: Start NTP daemon...
Oct 14 15:15:53 debian1 ntpd[5887]: ntpd 4.2.8p10@1.3728-o Sat Sep 23 19:02:38 UTC 2017 (1): Starting
Oct 14 15:15:53 debian1 ntpd[5887]: Command line: /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 115:122
Oct 14 15:15:53 debian1 ntp[5880]: Starting NTP server: ntpd.
Oct 14 15:15:53 debian1 systemd[1]: Started LSB: Start NTP daemon.
Oct 14 15:15:53 debian1 ntpd[5890]: proto: precision = 0.144 usec (-23)
Oct 14 15:15:53 debian1 ntpd[5890]: Listen and drop on 0 v6wildcard [::]:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen and drop on 1 v4wildcard 0.0.0.0:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 2 lo 127.0.0.1:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 3 eth0 192.168.1.10:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 4 eth1 192.168.10.1:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 5 lo [::1]:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 6 eth0 [fe80::beee:7bff:fe1c:c693%2]:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 7 eth1 [fe80::beee:7bff:fe1c:c694%3]:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listening on routing socket on fd #24 for interface updates
 


aprés un restart de ntp


service ntp restart
 


pour lire le syslog


cat /var/log/syslog
 


le retour de la commande systemctl status ntp


systemctl status ntp
 



● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp; generated; vendor preset: enabled)
   Active: active (running) since Sat 2017-10-14 15:15:53 CEST; 2min 56s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 5869 ExecStop=/etc/init.d/ntp stop (code=exited, status=0/SUCCESS)
  Process: 5880 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/ntp.service
           └─5890 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 115:122

oct. 14 15:15:53 debian1 ntpd[5890]: proto: precision = 0.144 usec (-23)
oct. 14 15:15:53 debian1 ntpd[5890]: Listen and drop on 0 v6wildcard [::]:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen and drop on 1 v4wildcard 0.0.0.0:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 2 lo 127.0.0.1:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 3 eth0 192.168.1.10:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 4 eth1 192.168.10.1:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 5 lo [::1]:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 6 eth0 [fe80::beee:7bff:fe1c:c693%2]:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 7 eth1 [fe80::beee:7bff:fe1c:c694%3]:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listening on routing socket on fd #24 for interface updates
 



tu vois qu'a la différence de chez toi les socket sont bien créer (en IPv4 et IPv6)


Oct 14 15:15:53 debian1 systemd[1]: Stopped LSB: Start NTP daemon.
Oct 14 15:15:53 debian1 systemd[1]: Starting LSB: Start NTP daemon...
Oct 14 15:15:53 debian1 ntpd[5887]: ntpd 4.2.8p10@1.3728-o Sat Sep 23 19:02:38 UTC 2017 (1): Starting
Oct 14 15:15:53 debian1 ntpd[5887]: Command line: /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 115:122
Oct 14 15:15:53 debian1 ntp[5880]: Starting NTP server: ntpd.
Oct 14 15:15:53 debian1 systemd[1]: Started LSB: Start NTP daemon.
Oct 14 15:15:53 debian1 ntpd[5890]: proto: precision = 0.144 usec (-23)
Oct 14 15:15:53 debian1 ntpd[5890]: Listen and drop on 0 v6wildcard [::]:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen and drop on 1 v4wildcard 0.0.0.0:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 2 lo 127.0.0.1:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 3 eth0 192.168.1.10:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 4 eth1 192.168.10.1:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 5 lo [::1]:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 6 eth0 [fe80::beee:7bff:fe1c:c693%2]:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listen normally on 7 eth1 [fe80::beee:7bff:fe1c:c694%3]:123
Oct 14 15:15:53 debian1 ntpd[5890]: Listening on routing socket on fd #24 for interface updates


service ntp restart
root@debian1:/home/robert# nano /var/log/syslog
root@debian1:/home/robert# systemctl status ntp
● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp; generated; vendor preset: enabled)
   Active: active (running) since Sat 2017-10-14 15:15:53 CEST; 2min 56s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 5869 ExecStop=/etc/init.d/ntp stop (code=exited, status=0/SUCCESS)
  Process: 5880 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/ntp.service
           └─5890 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 115:122

oct. 14 15:15:53 debian1 ntpd[5890]: proto: precision = 0.144 usec (-23)
oct. 14 15:15:53 debian1 ntpd[5890]: Listen and drop on 0 v6wildcard [::]:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen and drop on 1 v4wildcard 0.0.0.0:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 2 lo 127.0.0.1:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 3 eth0 192.168.1.10:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 4 eth1 192.168.10.1:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 5 lo [::1]:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 6 eth0 [fe80::beee:7bff:fe1c:c693%2]:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listen normally on 7 eth1 [fe80::beee:7bff:fe1c:c694%3]:123
oct. 14 15:15:53 debian1 ntpd[5890]: Listening on routing socket on fd #24 for interface updates
 


donc commencer par expliquer comment est ton réseau , qui te fourni une IPv6 (et pourquoi pas d IPv4)

pourquoi tu a ce genre de message


oct. 11 08:02:49 thierry ntpd[523]: unable to create socket on enxb827eb44e191 (
oct. 11 08:02:49 thierry ntpd[523]: failed to init interface for address fe80::1
oct. 11 08:02:49 thierry ntpd[523]: Listening on routing socket on fd #20 for in
 


ou il manque la fin de chaque ligne
je comprends rien , ceci correspond au nom de ta carte réseau ?  =>  enxb827eb44e191
l'échec de la création du socket explique pourquoi ntp ne fonctionne pas

la je pense que ça dépasse mes compétences réseau (et sur le matériel )

Hors ligne

#15 14-10-2017 17:20:20

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : ntpdate

comme je le disais, j'ai un pc avec debian stretch et ma raspberry pi avec raspbian stretch (distribution Debian spécialement conçue pour Raspberry Pi).
les 2 fonctionnent en réseau local.
la date et l'heure sont bonnes sur le pc (c'est surement pris sur le bios); et les commandes précédemment demandées n'affichent pas les mêmes résultats:
sur le pc:

systemctl status systemd-timesyncd


sur le pc:

● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendo
  Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: inactive (dead)
Condition: start condition failed at Fri 2017-10-13 07:28:50 CEST; 1 day 9h ago
     Docs: man:systemd-timesyncd.service(8)



et sur raspberry:

Warning: systemd-timesyncd.service changed on disk. Run 'systemctl daemon-reload
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendo
  Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: inactive (dead)
Condition: start condition failed at Wed 2017-10-11 08:24:08 CEST; 26min ago
           └─ ConditionFileIsExecutable=!/usr/sbin/ntpd was not met
     Docs: man:systemd-timesyncd.service(8)



systemctl status ntp
sur pc:
● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp; generated; vendor preset: enabled)
   Active: active (running) since Fri 2017-10-13 07:29:02 CEST; 1 day 9h ago
     Docs: man:systemd-sysv-generator(8)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/ntp.service
           └─796 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 119:125

et sur raspberry:
● ntp.service - LSB: Start NTP daemon
   Loaded: loaded (/etc/init.d/ntp; generated; vendor preset: enabled)
   Active: active (running) since Wed 2017-10-11 08:24:11 CEST; 32min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 455 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ntp.service
           └─507 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 112:117

oct. 11 08:24:11 thierry ntpd[507]: Listen normally on 3 lo [::1]:123
oct. 11 08:24:11 thierry ntpd[507]: bind(20) AF_INET6 fe80::1414:d730:83bd:aa3e%2#123 flags 0x11 failed: Cannot assign requested address
oct. 11 08:24:11 thierry ntpd[507]: unable to create socket on enxb827eb44e191 (4) for fe80::1414:d730:83bd:aa3e%2#123
oct. 11 08:24:11 thierry ntpd[507]: failed to init interface for address fe80::1414:d730:83bd:aa3e%2
oct. 11 08:24:11 thierry ntpd[507]: Listening on routing socket on fd #20 for interface updates
oct. 11 08:24:12 thierry ntpd[507]: bind(23) AF_INET6 fe80::1414:d730:83bd:aa3e%2#123 flags 0x11 failed: Cannot assign requested address
oct. 11 08:24:12 thierry ntpd[507]: unable to create socket on enxb827eb44e191 (5) for fe80::1414:d730:83bd:aa3e%2#123
oct. 11 08:24:12 thierry ntpd[507]: failed to init interface for address fe80::1414:d730:83bd:aa3e%2
oct. 11 08:24:14 thierry ntpd[507]: Listen normally on 6 enxb827eb44e191 [fe80::1414:d730:83bd:aa3e%2]:123
oct. 11 08:24:18 thierry ntpd[507]: Listen normally on 7 enxb827eb44e191 172.16.0.3:123

cat /etc/systemd/timesyncd.conf
sur pc:
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See timesyncd.conf(5) for details.

[Time]
#NTP=
#FallbackNTP=0.debian.pool.ntp.org 1.debian.pool.ntp.org 2.debian.pool.ntp.org 3.debian.pool.ntp.org

et sur raspberry:
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See timesyncd.conf(5) for details.

[Time]
#NTP=
#FallbackNTP=0.debian.pool.ntp.org 1.debian.pool.ntp.org 2.debian.pool.ntp.org 3.debian.pool.ntp.org


ps: je ne sais pas trop pourquoi des lignes étaient incomplètes précédemment


et cette commande me semble intéressante:
timedatectl
sur pc:
Local time: sam. 2017-10-14 17:13:06 CEST
  Universal time: sam. 2017-10-14 15:13:06 UTC
        RTC time: sam. 2017-10-14 15:13:06
       Time zone: Europe/Paris (CEST, +0200)
Network time on: yes
NTP synchronized: no
RTC in local TZ: no

sur raspberry:
Local time: mer. 2017-10-11 09:17:49 CEST
  Universal time: mer. 2017-10-11 07:17:49 UTC
        RTC time: n/a
       Time zone: Europe/Paris (CEST, +0200)
Network time on: yes
NTP synchronized: yes
RTC in local TZ: no

Edit à toto :

On utilise les balises Commande et autres du forum non pour seulement faire joli mais pour que les posts soient plus faciles à lire par tous, ainsi ils fonctionnent en tant que mini tuto pour tous les visiteurs à chaque problème posé ici.
Pour mettre des codes simples, tu peux utiliser la balise Autre code quand ce n'est pas une commande mais juste un retour ou une configuration.

Corrigé la première commande, à toi de corriger les suivantes de ce ce post.

Hors ligne

#16 14-10-2017 17:46:42

èfpé
Membre
Inscription : 10-07-2016

Re : ntpdate

Re-,

OK ; tu as installé bind9 ? ce n'était pas indispensable... ma faute je me suis mal exprimé. Peux-tu essayer de le désinstaller, ainsi que ntp (cela simplifierait le débogage) ? Puis redémarrer le service systemd-timesyncd :

sudo systemctl restart systemd-timesyncd

timedatectl

systemctl status systemd-timesyncd


Le retour de la commande 'ping machin' montre que les noms sont correctement résolus, donc sauf pare-feu kibloctou mal configuré, je ne vois pas pourquoi la synchronisation ne fonctionnerait pas... Tu peux également, donner les retours de :

cat /etc/network/interfaces

cat /etc/resolv.conf


ip link

ip route


sudo dmesg | grep renamed


Afin que l'on comprenne un peu mieux la configuration du réseau sur le RPi.

Il y a peut-être des trucs propres à Raspbian et/ou la connexion satellite sad

Dernière modification par èfpé (14-10-2017 18:06:42)

Hors ligne

#17 14-10-2017 17:53:03

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : ntpdate

@solar66 voir le tuto de l'utilisation des balises du forum en choco là :
Voir le tuto : Le code, ça pique moins les yeux en couleur smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#18 14-10-2017 18:00:49

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : ntpdate

comme je faisait des comparaisons entre 2 ordi, cela me semblait plus probant de faire ainsi

Hors ligne

#19 14-10-2017 18:23:00

solar66
Membre
Distrib. : debian stretch
Noyau : Linux 4-9-0-3-amd64
(G)UI : xfce
Inscription : 23-08-2016

Re : ntpdate

OK ; tu as installé bind9 ? ce n'était pas indispensable...


non, bind9 n'est pas installé, par contre j'ai: bind9-host et libbind9-140

lorsque je supprime ntp, le fichier /etc/ntp.conf reste en place. si je le renomme (au cas où) et que je réinstalle ntp, il ne se recrée pas; est ce normal?

Hors ligne

#20 14-10-2017 19:04:42

èfpé
Membre
Inscription : 10-07-2016

Re : ntpdate

Re-,

Concernant /etc/ntp.conf (et les fichiers de configuration en général), ce que tu constates, est la fort subtile différence entre 'remove' et 'purge' ; quant au reste, tu ne fais pas beaucoup d'efforts pour nous aider à t'aider, je passe donc volontiers la main. Dommage de ne pas avoir ouvert cette discussion dans la section appropriée du forum, avec un titre un tout petit peu plus explicite. Bonne continuation.

Note : on trouve quand même des modules RTC pour RPi à partir de 3 euros, sur le web roll

Dernière modification par èfpé (14-10-2017 19:14:42)

Hors ligne

#21 14-10-2017 23:38:42

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : ntpdate

en regardant un peu la configuration de dhcpd6.conf ces 2 options posent problème pour ntp (un bug ou une erreur de ma part )


option dhcp6.name-servers 3ffe:501:ffff:100:200:ff:fe00:3f3e;
option dhcp6.domain-search "test.example.com","example.com";
 


cela me donne ceci (pour les deux socket en ipv6 (eth0 et eth1)


Oct 14 22:32:07 debian1 ntpd[1022]: unable to create socket on eth1 (7) for fe80::beee:7bff:fe1c:c694%3#123
Oct 14 22:32:07 debian1 ntpd[1022]: failed to init interface for address fe80::beee:7bff:fe1c:c694%3
 


a la fin du démarrage de la machine une commande "service ntp restart" et tout est correct
si je commente les deux lignes de dhcpd6.conf le problème n'existe plus (ces lignes ont été renseigné avec les bonnes valeur , ci dessus c'est le fichier par défaut , qui ne pose pas problème si pas commenté )

juste pour le signaler , je vois pas le rapport entre ntp et dhcpd6 , et pourquoi de relancer ntp remet tout en ordre  tongue
bref je n'utilise pas l IPv6 mais les programmes comme ntp , dhcpd et le réseau en général oui  , faut faire avec   roll

je suis entré surement du coté obscur de la chose  roll   lol

nota : dhcpd a toujours bien fonctionné (il ne lance que l IPv4 )


isc-dhcp-server[892]: Starting ISC DHCPv4 server: dhcpd
 

Dernière modification par robert2a (14-10-2017 23:43:04)

Hors ligne

Pied de page des forums