Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-12-2017 17:21:34

francois69610
Membre
Inscription : 16-03-2017

problème de son

Bonjour,

raspberry PI 3 sous stretch n’a pas de son
j’ai installé le son de la façon suivante

Avant de lancer startx :
Utilisez le SuperUser (après chaque reboot) ou utilisez sudo avant chaque commande

sudo su
Installez l’utilitaire de mise à jour du Firmware
apt-get install ca-certificates git-core binutils
wget https://raw.github.com/Hexxeh/rpi-updat … rpi-update
cp rpi-update /usr/local/bin/rpi-update
chmod +x /usr/local/bin/rpi-update

Mettez le Firmware à jour
sudo rpi-update
Dans config.txt : décommentez « hdmi_drive=2 »
nano /boot/config.txt

Installez ALSA, MPlayer et PulseAudio (toute la commande sur une seule ligne)
apt-get install mplayer mplayer-gui alsa-base alsa-utils pulseaudio mpg123

apt-get install mplayer mplayer-gui alsa-base
  alsa-utils pulseaudio mpg123

Ajoutez le module audio module au noyau
modprobe snd_bcm2835
echo 'snd_bcm2835'  >>  /etc/modules

Configurez le driver ALSA avec n prenant pour valeur :  Sortie Analogique = 1,
Sortie  HDM I = 2 (Auto=0 non recommandé !)
amixer cset numid=3 n
Remplacez asound.conf par :
nano /etc/asound.conf
pcm.!default {
    type hw
    card 0
}
ctl.!default {
    type hw
    card 0
}
Rebootez le Raspberry Pi
Test de l’audio sans ALSA
cd /opt/vc/src/hello_pi/
./rebuild.sh
cd hello_audio
Testez la sortie analogique (sur la prise jack)
./hello_audio.bin
Testez la sortie audio HDMI
./hello_audio.bin 1

Test de l’audio avec ALSA
Testez la sortie analogique (sur la prise jack)
amixer cset numid=3  1
speaker-test  -t  sine  -f   600

pendant  un moment cela a fonctionné puis plus rien
impossible de le réinstaller
avez vous une idée
merci
salutations

Hors ligne

Pied de page des forums