Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-08-2019 17:04:35

gonzoleri
Membre
Lieu : Provence Alpes
Distrib. : Debian testing Bullseye/Sid
Noyau : Linux 4.19.0-1-amd64
(G)UI : Gnome-Classic
Inscription : 24-12-2017
Site Web

Supprimer traces Virtualbox + linux-headers-4.19.0-1-amd64 manquant

Bonjour DF :-)

Après 2 journées de recherche et de tests divers, je ne parviens toujours pas à installer virtualbox. C'était avant d'avoir vu cette page recensant les paquets de virtualbox disponibles pour Bullseye/Sid :
https://packages.debian.org/search?keyw … ection=all

Je compte m'approvisionner depuis l'adresse ci-dessus, après avoir supprimé si possible toute trace de virtualbox antérieure...

En fait, sur ma Bullseye/Sid (Linux debian 4.19.0-1-amd64 #1 SMP Debian 4.19.12-1 (2018-12-22) x86_64 GNU/Linux), il y a eu 3 essais.

Téléchargement depuis le site de Virtualbox.

Essai 1 :

root@debian:~# dpkg -i virtualbox-6.0_6.0.10-132072~Ubuntu~bionic_amd64.deb


Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.
The distribution packages containing the headers are probably:
    linux-headers-amd64 linux-headers-4.19.0-1-amd64



   

root@debian:~# apt install linux-headers-amd64



root@debian:~# apt install linux-headers-4.19.0-1-amd64


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet linux-headers-4.19.0-1-amd64
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-headers-4.19.0-1-amd64 »
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-headers-4.19.0-1-amd64 »


Le linux-headers requis n'est plus disponible.

root@debian:~# apt install linux-headers-4.9.0-10-amd64


Toujours pas...   

root@debian:~# apt install linux-headers-4.9.0-10-all-amd64


Essaye encore...
   

root@debian:~# apt install dkms build-essential linux-headers-`uname -r`


(Message m'informant de l'impossibilité d'aboutir à l'installation car « linux-headers-4.19.0-1-amd64 » est manquant).

Voilà pour le 1er essai. Le 2ème n'a pas été davantage couronné de succès :

Essai 2 :

root@debian:/home/hubert# chmod +x VirtualBox-6.0.10-132072-Linux_amd64.run



root@debian:/home/hubert# chown hubert:staff VirtualBox-6.0.10-132072-Linux_amd64.run



Ensuite, je me suis ajouté dans '/etc/sudoers.d':

login    ALL=(ALL) ALL



hubert@debian$ sudo VirtualBox-6.0.10-132072-Linux_amd64.run


Installing VirtualBox to /opt/VirtualBox...



Encore un échec, même messages d'erreur "Please install the Linux kernel "header"

# /sbin/vboxconfig


M'apprend que les dépendances ne sont pas satisfaites

Essai 3 :
Téléchargement de virtualbox (6.0.10-dfsg-3) pour Sid
      (depuis https://packages.debian.org/sid/virtualbox )
Edit : Ensuite, je me suis demandé s'il n'aurait pas mieux fallu prendre la version pour Testing Bullseye


# dpkg -i virtualbox_6.0.10-dfsg-3_amd64.deb


dpkg: concernant virtualbox_6.0.10-dfsg-3_amd64.deb contenant virtualbox :
 virtualbox entre en conflit avec virtualbox-6.0
  « virtualbox-6.0 » (version « 6.0.10-132072~Ubuntu~bionic ») est présent ainsi que « installé ».



J'ai obtenu le même message que précédemment :

Please install the Linux kernel "header" files matching the current kernel...
...............................................................................
There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.  If your system is using EFI Secure Boot you may need to sign the
kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load
them. Please see your Linux system's documentation for more information.



Enlevé les traces que j'ai pu trouver de virtualbox, celles dans /usr/bin/, /usr/lib/, /usr/share/,  même celles présentes dans .config et dans /opt

Et ensuite :

root@debian:~# whereis kvm


kvm: /usr/bin/kvm /usr/share/man/man1/kvm.1.gz



root@debian:~# rm -r /usr/bin/kvm



root@debian:~# rm -r /usr/share/man/man1/kvm.1.gz



Juste après un redémarrage :

root@debian:~# rmmod kvm_intel



root@debian:~# rmmod kvm



Au cours du redémarrage suivant :
Accompagnée de WARNING, encore cette suite de FAILED :

................................................................
FAILED to start vboxweb-service.service
FAILED to start vboxalloonetrl-services.service
FAILED to start vboxautostart-service.service
..........................................................................



Je n'ai pas davantage su tirer profit de dmesg, celui-ci n'ayant pas affiché de WARNING ni de FAILED (alors que j'ai pu constater de visu leur présence).


root@debian:~# dmesg --kernel


....................................................................
[    0.067941] Booting paravirtualized kernel on bare hardware
....................................................................




root@debian:~# dmesg --syslog


....................................................................
[    1.887159] usb usb2: Manufacturer: Linux 4.19.0-1-amd64 ehci_hcd
....................................................................




Après d'autres recherches, je ne sais plus trop quoi faire...

Comment supprimer ces traces qui bloquent tout nouvel essai d'installation ? Ce qui me permettrait peut-être d'installer le paquet pour Sid.

Merci d'avance !

Dernière modification par gonzoleri (05-08-2019 18:34:40)


Packard Bell EasyNote TE - Intel(R)B815 - Intel HG Graphics
Autre système utilisé : Guix System 1.0-1 (Dual Boot avec Debian)
«Pratiquez aléatoirement des actes de gentillesse et de beauté insensée.» Anne Herbert

Hors ligne

Pied de page des forums