Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-02-2015 02:07:33

Neuromancien
Membre
Inscription : 03-02-2015

[RESOLU] No boot disk has been detected

Bonjour,

J'ai installé Debian Jessie sur un PC COMPAQ 100-440nf. L'installation s'est bien passée mais au redémarrage j'obtiens l'erreur suivante :

ERROR: No boot disk has been detected or the disk has failed

Dernière modification par Neuromancien (10-02-2015 14:15:46)

Hors ligne

#2 06-02-2015 09:27:11

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [RESOLU] No boot disk has been detected

tu a bien installé grub sur le bon disque ?
au demarrage ton bios voit le disque ?

tu n a que debian jessie ou en double boot avec win ?

Hors ligne

#3 06-02-2015 11:26:09

Neuromancien
Membre
Inscription : 03-02-2015

Re : [RESOLU] No boot disk has been detected

Bonjour,

Au cours de l'installation, j'ai supprimé les 4 partitions existantes (sauvegarde Windows, EFI + 2 partitions NTFS). Je n'ai pas de double boot : je ne conserve que Jessie.

Voici la configuration du BIOS :

Ordre de démarrage
Sources de démarrage UEFI : désactivé
Sources de démarrages héritées :
Lecture de CD-ROM/ DVD ATAPI
Disque dur SATAO

Configuration d'amorçage sécurisé
Assistance pour ancien équipement : activé
Amorçage sécurisé : désactivé
Amorçage rapide : désactivé



Je n'avais pas eu d'erreur lors de l'installation de GRUB.


J'ai essayé de réinstaller en mode de récupération, mais cette fois ça donne une erreur :

Impossible d'installer GRUB dans /dev/sda
L'exécution de grub-install /dev/sda a échoué/

Cette erreur est fatale.

Dernière modification par Neuromancien (06-02-2015 11:26:38)

Hors ligne

#4 06-02-2015 12:44:58

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [RESOLU] No boot disk has been detected

J'ai eu le même problème, tu peux regarder ici pour les contournements que j'ai trouvé: https://debian-facile.org/viewtopic.php?id=10351

Hors ligne

#5 06-02-2015 16:05:08

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [RESOLU] No boot disk has been detected

je me trompe peut etre mais il y a UFI et UEFI ; un est une securité disque , l autre remplace le mbr par une partition UEFI.

le disque est marquée , et seul la carte mere d origine peut  utiliser ce disque sinon il est illisible (et on ne peut ecrire format ne fonctionne pas)

le fait de detruire la partition (et la partition UEFI) detruit cet clé , certain bios on la possibilité de gerer cet clé (effacer creer sauvegarder etc ....  la clé).

un disque utilisé avec windows 8 sur une machine est inutilisable autrement si il n est pas initialisé (comme sorti d usine ).

ça fait un bout de temps que je n ai plus de soucis de ce genre depuis l abandon de win.

ps: en general dans le bios il y a un truc comme : key geré yes ; key chargé yes  (dans un sous menu de l UEFI )
si tu arrette la gestion des clé mais que le disque en a une active ça bug

Hors ligne

#6 06-02-2015 16:52:16

Neuromancien
Membre
Inscription : 03-02-2015

Re : [RESOLU] No boot disk has been detected

Finalement j'ai complètement réinstallé Debian en mode EFI en recréant une partition EFI et il démarre bien. smile

Par contre, lorsqu'on déclare une partition EFI dans l'outil de partitionnement de l'installateur, il ne permet pas de la formater en FAT32, ce qui provoque ensuite une erreur. J'ai du passer par la ligne de commande pour le faire...

Hors ligne

Pied de page des forums