Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-08-2015 17:00:34

Aty
Membre
Distrib. : Debian 8 Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 22-08-2015

[Résolu] Problème entre Iceweasel et flash

Bonjour,
j'ai un problème avec Iceweasel et flash sous debian Jessie, lorsque j'ouvre une page contenant du contenu flash Iceweasel se ferme spontanément et sans confirmation.


J'ai tenté diverses solutions à se problème, d'abord Gnash mais le problème à persisté.
J'ai installé Chromium qui ne rencontre presque aucun problème avec flash : par exemple les vidéos youtube fonctionnent nickel mais si je veux en lire une sur un site autre que youtube ça peut ou non fonctionner. De plus youtube depuis Chromium semble fonctionner même après désinstallation de Gnash... Ce navigateur c'est un peu le mystère ^^


Bref, je veux retourner sous Iceweasel car je le préfère. Du coup j'ai tenté cette manip : https://debian-facile.org/viewtopic.php?id=10265
Sauf que ça bloque au moment de la commande

cmake ..


-- checking for optional dependencies
--   no libpulse found (optional)
--   no jack found (optional)
-- checking for modules 'libavcodec;libavutil;libva;libva-x11;vdpau'
--   package 'libavcodec' not found
--   package 'libavutil' not found
--   package 'libva' not found
--   package 'libva-x11' not found
--   package 'vdpau' not found
CMake Error at /usr/share/cmake-3.0/Modules/FindPkgConfig.cmake:341 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.0/Modules/FindPkgConfig.cmake:395 (_pkg_check_modules_internal)
  CMakeLists.txt:115 (pkg_check_modules)


-- Performing Test HAVE_AVPixelFormat
-- Performing Test HAVE_AVPixelFormat - Failed
-- Performing Test HAVE_AV_PIX_FMT_VDPAU
-- Performing Test HAVE_AV_PIX_FMT_VDPAU - Failed
-- Performing Test HAVE_AVCodecID
-- Performing Test HAVE_AVCodecID - Failed
-- Performing Test HAVE_AVCodecContext_get_buffer2
-- Performing Test HAVE_AVCodecContext_get_buffer2 - Failed
-- Performing Test HAVE_AVVDPAUContext
-- Performing Test HAVE_AVVDPAUContext - Failed
-- Looking for av_frame_alloc
-- Looking for av_frame_alloc - not found
-- Looking for av_frame_free
-- Looking for av_frame_free - not found
-- Looking for avcodec_free_context
-- Looking for avcodec_free_context - not found
-- Configuring incomplete, errors occurred!
See also "/home/guillaume/freshplayerplugin/build/CMakeFiles/CMakeOutput.log".
See also "/home/guillaume/freshplayerplugin/build/CMakeFiles/CMakeError.log".
 




Vu les erreurs j'en déduis qu'il me manque libavcodec libavutil libva libva-x11 vdpau sauf que les installer avec apt-get ne fonctionne pas sad

apt-get install libav libavcodec libva libva-x11 vdpau libavutil


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libav
E: Impossible de trouver le paquet libavcodec
E: Impossible de trouver le paquet libva
E: Impossible de trouver le paquet libva-x11
E: Impossible de trouver le paquet vdpau
E: Impossible de trouver le paquet libavutil
 




J'imagine qu'il doit manquer quelque chose dans mon source.list, le voici :

#

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150606-15:28]/ jessie main

deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150606-15:28]/ jessie main

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main

deb http://ftp.de.debian.org/debian jessie-backports main
deb-src http://ftp.de.debian.org/debian jessie-backports main

deb http://http.debian.net/debian jessie-backports main
deb-src http://http.debian.net/debian jessie-backports main

deb http://http.debian.net/debian jessie main contrib non-free
deb-src http://http.debian.net/debian jessie main contrib non-free

deb http://http.debian.net/debian jessie-updates main contrib non-free
deb-src http://http.debian.net/debian jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free
 




J'ai essayé de mettre un maximum d'info,
Merci de votre aide smile

Dernière modification par Aty (23-08-2015 14:58:06)

Hors ligne

#2 22-08-2015 17:55:46

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Problème entre Iceweasel et flash

Salut,

Et en passant par le lecteur html5 ? -> https://www.youtube.com/html5?hl=fr
Plus de flash !
smile

édition :

dans ton /etc/apt/sources.list, tu peux commenter = mettre un # devant la ligne cdrom  ( sinon, il va chercher les paquets sur le cd d'installation, et pas dans les dépôts à jour ! ) :

deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150606-15:28]/ jessie main


C'est pour ça que apt-get ne trouve pas les paquets que tu veux installer !

les lignes deb-src ne te sont peut être pas utiles : https://debian-facile.org/doc:systeme:a … ou-sources

et si tu as besoin de paquets non libre, il y a les dépôts contrib et non-free : https://debian-facile.org/doc:systeme:a … ourceslist

et bienvenue ! cool

Dernière modification par nono47 (22-08-2015 18:30:34)

Hors ligne

#3 22-08-2015 19:43:58

Aty
Membre
Distrib. : Debian 8 Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 22-08-2015

Re : [Résolu] Problème entre Iceweasel et flash

Merci de ta réponse nono,

Le lecteur youtube en html5 ça peut être sympa sauf que Iceweasel crash systématiquement lorsqu'il y a du flash sur une page... Pour le moment je n'ai pas trouvé d'info sur internet concernant ce bug
EDIT : j'ai tenté une désinstallation, reboot puis réinstallation de Iceweasel ça n'a rien donné.

J'ai commenté la ligne deb cdrom mais ça ne résout pas le soucis. Je pense que trouver le dépôt dans lequel se trouvent ces paquets permettrait de résoudre le soucis, si quelqu'un le connaît ^^


Merci de ton aide !

Dernière modification par Aty (22-08-2015 21:12:41)

Hors ligne

#4 23-08-2015 02:23:06

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Problème entre Iceweasel et flash

Salut Aty

On retrouve sur le wiki des info concernant freshplayerplugin : Demander à Iceweasel d’utiliser le plugin flash de Chromium

Sinon pour ta compilation et les paquets qui posent problème : libav libavcodec libva libva-x11 vdpau libavutil et bien ajoute -dev à la fin de chaque paquet et ça devrait mieux aller.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 23-08-2015 08:42:15

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu] Problème entre Iceweasel et flash

Aty a écrit :

Bonjour,
j'ai un problème avec Iceweasel et flash sous debian Jessie, lorsque j'ouvre une page contenant du contenu flash Iceweasel se ferme spontanément et sans confirmation.





Et bien, je vois que je ne suis plus le seul.


Je précise aussi que mon plantage se faisait aussi bien avec flah ou sans (html5)
J'ai par contre les lib installées.
Je n'ai plus de plantage en utilisant Firefox 40.0.2 ( téléchargement de l'archive sur leur site)

Ou peut-être chez moi, un problème de mémoire sur une de mes barrêtes ( changée maintenant) ...

Aty, essaies de désactiver "Utiliser l'accélération graphique" dans les options du navigateur pour voir  wink

Dernière modification par golgot200 (23-08-2015 08:46:25)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

En ligne

#6 23-08-2015 14:57:35

Aty
Membre
Distrib. : Debian 8 Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome
Inscription : 22-08-2015

Re : [Résolu] Problème entre Iceweasel et flash

Salut à tous,

golgot200 a écrit :


Je n'ai plus de plantage en utilisant Firefox 40.0.2 ( téléchargement de l'archive sur leur site)



Je ne savais pas qu'on pouvait installer firefox sur debian malgré Iceweasel, du coup c'est ce que j'ai fait, ça fonctionne nickel ! Enfin débarrassé d'Iceweasel smile


Merci à tous pour vos réponse, mon problème est résolu smile

Hors ligne

#7 24-08-2015 08:16:55

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Problème entre Iceweasel et flash

Salut,

Sinon, pour avoir iceweasel à jour, il y a le dépôt mozilla_debian .
Pour l'utiliser, c'est ici -> http://mozilla.debian.net/

Hors ligne

#8 24-08-2015 12:59:32

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [Résolu] Problème entre Iceweasel et flash

@nono47

Bonjour,

j'ai aussi testé cette version et va savoir pourquoi, sur mon système  elle plantait aussi et sur un autre pc tout roulait. Donc dur dur de se faire dépanner et rien dans les logs hmm

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

En ligne

#9 25-08-2015 10:21:53

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Problème entre Iceweasel et flash

Salut golgot,

Peut-être en le lançant depuis un terminal :

iceweasel


pour avoir les logs d'erreur .
hmm

Hors ligne

#10 03-09-2015 16:49:16

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Problème entre Iceweasel et flash

Flash ça sent de plus en plus le sapin.

Firefox le bloque par défaut, et suite au problème de sécurités avec la tonne de pub en Flash infectées, Chrome bloque maintenant les pubs en flash.

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#11 04-09-2015 09:33:16

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Problème entre Iceweasel et flash

Et c'est tant mieux !

Flash


un mouchard de plus à chaque fois qu"il apparaît ( vie privée ... Flash cookie )
+
une lourdeur prohibitive sur un ordinosaure ( vive la planète ! )
+
une licence juridique privatrice ( cf gnash qui n'a pas eu sa chance )
+
Y'a plus de version pour linux depuis la Saint Glinglin ( mais y'en a pour android ... )  , de toute façon, même à jour, c'est une faille de sécurité ...
+
Un obstacle à l'élaboration d'un internet libre et accessible !

Dernière modification par nono47 (04-09-2015 09:52:30)

Hors ligne

Pied de page des forums