Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-04-2016 10:39:59

jenramac
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0-4-amd64
(G)UI : Gnome3 / Cinamon
Inscription : 29-03-2016

Mélange amd64 et i386 - empêcher la désinstallation quasi-globale

Bonjour à tous et toutes.

Suite à mes aventures avec mes deux dépôts, je continue à vouloir faire fonctionner Kega (émulateur megadrive), il me faut installer la libgtk2.0-0:i386 malheureusement il me faudrait désinstaller 593 paquets, tout ce qui concerne Gnome et les programmes l'utilisant, je suppose que c'est dû au fait que ces paquets utilisent la libgtk2.0-0 en 64 bits (je pensai naïvement que gnome3 utilisait la libgtk3, quelle candeur de ma part!!).

Donc si je valide, apparemment  au revoir mon interface graphique et les programmes associés.... sad

N'existe-t-il pas un moyen de conserver mes paquets en disant que pour eux c'est la version x64 et de ne faire que l'installation de la version i386 de la libgtk2.0-0:i386 et ses dépendances?

Bonne journée.

Hors ligne

#2 01-04-2016 10:54:20

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : Mélange amd64 et i386 - empêcher la désinstallation quasi-globale

il n'y aurait pas une histoire d'ajout d'architecture à faire ?
je reprends le tuto de skype qui fonctionne uniquement en 32bits

Vérifiez si vous êtes sur une distribution 32bits ou 64bits

dpkg --print-architecture


Si la commande vous affiche i386 vous êtes en 32bits, si elle vous affiche amd64 vous êtes en 64bits.

    Si vous êtes en 64bits, vérifiez que les sources multiarch pour i386 sont disponibles :

dpkg --print-foreign-architectures



Si la commande affiche i386, passez à l'étape suivante, sinon, tapez les lignes suivantes :

dpkg --add-architecture i386



je ne sais pas si ça va t'aider neutral


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#3 01-04-2016 11:06:02

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Mélange amd64 et i386 - empêcher la désinstallation quasi-globale

donne nous le retour du terminal pour avoir plus d'info.

En ligne

#4 01-04-2016 11:12:23

jenramac
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0-4-amd64
(G)UI : Gnome3 / Cinamon
Inscription : 29-03-2016

Re : Mélange amd64 et i386 - empêcher la désinstallation quasi-globale

Bonjour,

Suite à Dépôts amd64 et i386 en dépôts local en même temps, tout semble bien configuré, je suis bien en amd64 et l'architecture i386 est prise en compte.

Je viens de trouver un paquet kega-fusion soi-disant amd64 sur launchpad ICI mais il me renvoie également des problèmes car il s'attend à trouver les libs i386! (Pourquoi marquer un paquet amd64 si il a besoin également des i386 ?!!)

Je ne tiens pas à devoir faire fonctionner gnome en 32 bits juste pour jouer à de vieux jeux megadrive!

Actuellement j'utilise DGen qui fonctionne bien mais il paraît que Kega est le top.... et puis ça me permet d'apprendre!

Bonne journée.

Hors ligne

#5 01-04-2016 11:15:47

jenramac
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0-4-amd64
(G)UI : Gnome3 / Cinamon
Inscription : 29-03-2016

Re : Mélange amd64 et i386 - empêcher la désinstallation quasi-globale

dpkg --print-foreign-architectures


amd64


dpkg --print-foreign-architectures


i386

Hors ligne

#6 01-04-2016 12:19:38

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Mélange amd64 et i386 - empêcher la désinstallation quasi-globale

Bonjour jenramac

pour l'émulateur mégadrive j'utilisais gens quand j'étais qu'en i386. Comme toi, j'ai bataillé pour trouver le meilleur compromis sur amd64 sans avoir à mettre les libs i386.
dgen en cli des dépôts va bien et mieux encore : Mednafen  qui est superbe émulateur  + mednaffe le  GUI  facile à compiler  et générer le Deb par checkinstall    wink

Le CLI


apt-get install mednafen
 



les sources du GUI (mednaffe)
https://sites.google.com/site/amatcoder … /downloads

La compilation:
https://github.com/AmatCoder/mednaffe/b … uilding.md

Mon Deb perso
http://sd-1.archive-host.com/membres/up … _amd64.deb

1459505959.png


F5 = SAVE
F7 = LOAD

wink

Dernière modification par golgot200 (01-04-2016 12:48:41)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#7 01-04-2016 13:39:25

jenramac
Membre
Distrib. : Debian Jessie 8.3
Noyau : 3.16.0-4-amd64
(G)UI : Gnome3 / Cinamon
Inscription : 29-03-2016

Re : Mélange amd64 et i386 - empêcher la désinstallation quasi-globale

MERCI!

Exactement, ce que je désirais!

En plus, j'avais installé medafen mais je l'avais oublié en me battant avec MESS.

Merci beaucoup pour ton deb du GUI, parce que configuré ma manette PS2, je le voyais long, long....

Je pars le sourire aux lèvres pour profiter du week-end!

Hors ligne

#8 01-04-2016 14:32:12

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Mélange amd64 et i386 - empêcher la désinstallation quasi-globale

Pas de quoi smile

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

Pied de page des forums