Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-06-2016 15:24:05

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

[Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Bonjour,

Severian a résolu le "bug" lié à l'arrivée de Firefox en remplacement de Iceweasel https://debian-facile.org/viewtopic.php?id=14353, donc je tente de faire la maj sur mon système.
Et là, paf !

apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 hunspell-fr-classical : Est en conflit avec: myspell-fr mais 1.4-26 devra être installé
E: Paquets défectueux
 


Je regarde à quoi correspondent mes 2 paquets perturbateurs à l'aide de Synaptic, dont voilà la description :

myspell-fr (non installé)
This is a French dictionary, to be used with myspell,
version 3.1.04 and following. The dictionary contains roughly
50,000 roots, which expand to about 220,000 words.

This is the Martin Boyer and Hydro-Quebec version.
You may prefer to use the GUTenberg version installed by the
myspell-fr-gut package.



hunspell-fr-classical 1.5.2.1(installé, le paquet hunspell-fr 1.5.2.1 aussi)
This dictionary is a superset of the "modern" dictionary (from the
hunspell-fr-modern package), to which it adds alternative spellings (some
which are still widely used, some others which are being phased out).

For an overview of the available French dictionaries, see the description of
the hunspell-fr package.



Je ne sais pas trop quoi faire : désinstaller hunspell pour myspell me semble inapproprié ; mon système est en langage français "du pays du pinard et du fromage" et pas en langage français "du pays de la poutine et du sirop d'érable".
Et aussi j'ai plutôt l'impression que hunspell est lié à libre-office (à moins que j'ai mal compris) et non à Firefox roll

Bref, j'ai besoin de vos conseils histoire de comprendre cette erreur big_smile

Dernière modification par Mercredi (12-06-2016 22:56:46)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#2 12-06-2016 15:54:12

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Bjr,

Tabarnak, t'aurais pas un conflit entre hunspell-fr et hunspell-fr-classical ?
Chez ouam:

apt-cache depends hunspell-fr-classical


hunspell-fr-classical
  Dépend: dictionaries-common
  Suggère: hunspell
  Est en conflit avec: hunspell-fr-comprehensive
  Est en conflit avec: hunspell-fr-modern
  Est en conflit avec: hunspell-fr-revised
  Est en conflit avec: myspell-fr
  Est en conflit avec: myspell-fr-gut
  Casse: hunspell-fr
  Remplace: hunspell-fr


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 12-06-2016 16:14:07

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Salut Phlinux smile
On dirait bien que oui.

apt-cache depends hunspell-fr-classical


hunspell-fr-classical
  Dépend: dictionaries-common
  Suggère: hunspell
  Est en conflit avec: hunspell-fr-comprehensive
  Est en conflit avec: hunspell-fr-modern
  Est en conflit avec: hunspell-fr-revised
  Est en conflit avec: myspell-fr
  Est en conflit avec: myspell-fr-gut
  Casse: hunspell-fr
  Remplace: hunspell-fr
 


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#4 12-06-2016 16:33:26

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

En charchant les dépendances de libreoffice (méta paquet) :
Iceweasel, Firefox, et myspell-dictionnary sont indiquées dans les dépendances suggérées.

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#5 12-06-2016 16:53:32

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

essaie avec aptitude pour voir ce qu'il te dit.

Hors ligne

#6 12-06-2016 17:04:57

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

aptitude upgrade


Résolution des dépendances…                            
Les NOUVEAUX paquets suivants vont être installés :
  firefox-esr{a} firefox-esr-l10n-fr{a}
Les paquets suivants seront mis à jour :
  iceweasel iceweasel-l10n-fr
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
  myspell-fr myspell-fr-gut
2 paquets mis à jour, 2 nouvellement installés, 86 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o/44,2 Mo d'archives. Après dépaquetage, 295 Mo seront libérés.
Voulez-vous continuer ? [Y/n/?]


Avec aptitude la màj se fait sans les paquets recommandés.
Dans le doute j'ai préféré abandonner la maj (pas l'habitude de aptitude) mais j'ouvre ma VM de test pour voir ce que ça donne (comme ça si je casse tout, c'est pas grave tongue )


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#7 12-06-2016 18:52:55

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

essaie avec

apt-get --no-install-recommends upgrade

Hors ligne

#8 12-06-2016 19:24:49

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

apt-get --no-install-recommends upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  iceweasel iceweasel-l10n-fr
0 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
 



Sinon avec aptitude dans une machine virtuelle, Firefox s'installe (sans myspell) mais présente quelques bizarreries d'affichage.
Genre ça :
1465752039.jpg
Parfois ça s'affiche bien pendant 1 ou 2 seconde et puis ça repart en vrac dès que fais défiler la page.
Je suis un peu limite en puissance matérielle pour la VM, mais avant l'affichage était lent mais correct.


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#9 12-06-2016 20:58:46

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Mercredi a écrit :

apt-get --no-install-recommends upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  iceweasel iceweasel-l10n-fr
0 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
 



Sinon avec aptitude dans une machine virtuelle, Firefox s'installe (sans myspell) mais présente quelques bizarreries d'affichage.
Genre ça :
http://pix.toile-libre.org/upload/img/1465752039.jpg
Parfois ça s'affiche bien pendant 1 ou 2 seconde et puis ça repart en vrac dès que fais défiler la page.
Je suis un peu limite en puissance matérielle pour la VM, mais avant l'affichage était lent mais correct.


regarde https://www.debian.org/security/2016/dsa-3600

Transition packages for the iceweasel packages are provided which automatically upgrade to the new version. Since new binary packages need to be installed, make sure to allow that in your upgrade procedure (e.g. by using "apt-get dist-upgrade" instead of "apt-get upgrade").


c'est le coté plus "doux" d'apt-get upgrade face à apt upgrade ou aptitude upgrade


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#10 12-06-2016 21:09:30

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

je pense que ça vient de la VM.

Hors ligne

#11 12-06-2016 21:56:12

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Severian a écrit :

regarde https://www.debian.org/security/2016/dsa-3600

Transition packages for the iceweasel packages are provided which automatically upgrade to the new version. Since new binary packages need to be installed, make sure to allow that in your upgrade procedure (e.g. by using "apt-get dist-upgrade" instead of "apt-get upgrade").


c'est le coté plus "doux" d'apt-get upgrade face à apt upgrade ou aptitude upgrade


apt-get dist-upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les NOUVEAUX paquets suivants seront installés :
  firefox-esr firefox-esr-l10n-fr
Les paquets suivants seront mis à jour :
  iceweasel iceweasel-l10n-fr
2 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/44,2 Mo dans les archives.
Après cette opération, 9 358 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]


Là pas de paquet cassé en vue smile Je me jette à l'eau et je reviens vous dire si ça mouille lol

@nlQnutn, il y a en effet de grande chance que ça vienne de la vm, surtout en voyant les mesures "rapidité" de Phlinux sur un autre post, Firefox 45 aurait encore pris un peu de lenteur hmm


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#12 12-06-2016 22:01:12

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

perso j'ai pris l'option de sauvegarder le dossier user/.mozilla

puis de purger iceweasel
ensuite d'installer firefox

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#13 12-06-2016 22:38:14

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

effectivement tu peux sauvegarder ton profil.

Hors ligne

#14 12-06-2016 22:44:35

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Installation Firefox ok.
Au premier lancement il a figé avec 2 onglets ouverts, j'ai dû tuer le processus pour le fermer.
Du coup j'ai redémarré Jessie, sait-on jamais, puis lancé Firefox depuis le terminal pour voir si quelque chose ne lui plaît pas.

1465762576327    addons.productaddons    ERROR    Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]


En extensions, j'ai choco-DF, uBlock Origin et Decentraleyes. Je testerai tout à l'heure de les désactiver pour voir. Edit : désactivés un par un ou les 3 ensembles, l'erreur revient donc ça ne vient pas des extentions.

Sinon tous mes favoris et réglages ont bien été conservés sauf le moteur de recherche par défaut qui est revenu à Google au lieu de Qwant.
Ça rame un peu selon les sites mais aujourd'hui j'ai un débit pourri donc je ne me fie pas trop à l'impression de lenteur.

La bonne nouvelle : je peux lire les vidéos sur Daily motion (je ne pouvait plus suite à une maj précédente de Iceweasel) cool

Severian a écrit :

puis de purger iceweasel


Je crois qu'il va falloir que je le fasse ; j'ai eu ces messages pendant la maj :

dpkg : avertissement : impossible de supprimer l'ancien répertoire  « /etc/iceweasel/searchplugins/common » : Le dossier n'est pas vide
dpkg : avertissement : impossible de supprimer l'ancien répertoire  « /etc/iceweasel/searchplugins/locale/en-US » : Le dossier n'est pas vide
dpkg : avertissement : impossible de supprimer l'ancien répertoire  « /etc/iceweasel/searchplugins/locale » : Le dossier n'est pas vide
dpkg : avertissement : impossible de supprimer l'ancien répertoire  « /etc/iceweasel/searchplugins » : Le dossier n'est pas vide
dpkg : avertissement : impossible de supprimer l'ancien répertoire  « /etc/iceweasel/profile/chrome » : Le dossier n'est pas vide
dpkg : avertissement : impossible de supprimer l'ancien répertoire  « /etc/iceweasel/profile » : Le dossier n'est pas vide
dpkg : avertissement : impossible de supprimer l'ancien répertoire  « /etc/iceweasel/pref » : Le dossier n'est pas vide
dpkg : avertissement : impossible de supprimer l'ancien répertoire  « /etc/iceweasel » : Le dossier n'est pas vide



Petite question bonus, j'ai un vague souvenir de mes débuts ici qui déconseillait d'utiliser dist-upgrade or tu parles d'un côté "plus doux", tu veux dire que c'est le gestionnaire apt-get qui est plus doux que les autres, et pas la commande apt-get dist-upgrade ?

Dernière modification par Mercredi (12-06-2016 22:54:15)


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#15 12-06-2016 23:06:45

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

je ne retrouve pas dans le wiki le tableau qui compare les commande ...

dans mes souvenirs
apt-get upgrade = aptitude safe-upgrade
apt-get dist-upgrade = aptitude upgrade ou aptitude full-upgrade ou apt upgrade

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#16 13-06-2016 09:05:14

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Merci Severian, il faudra que je prenne d'étudier les différences entre apt, apt-get et aptitude.
J'ai pris l'habitude d'utiliser apt parce que .... c'est plus court tongue (pas taper)

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#17 13-06-2016 12:19:49

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Hors ligne

#18 13-06-2016 12:50:59

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#19 13-06-2016 13:19:28

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Sauvegarder ~/.mozilla, purger IW , installer FF est une bonne idée, mais après, tu as fais quoi t-est-ce ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#20 13-06-2016 13:32:56

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

j'ai remis mon dossier .mozilla, et fait une petite vérif de about:config

mis à part ça, rien
peut de différence avec iceweasel, si ce n'est que j'ai supprimer les langues anglaise dans préférences/contenu (ça avait tendance à préférer l'anglais sur certain sites neutral)

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#21 13-06-2016 13:44:18

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Merci. C'est logique comme démarche, mais comme ça c'est net et précis

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#22 13-06-2016 18:16:37

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : [Résolu] Maj Iceweasel Firefox, les paquets ne peuvent être installés

Merci pour les liens smile
Je ne connaissais pas wajig, à essayer en VM si je veux installer un truc qui n'est pas dans les dépôts.

Sinon j'ai eu pareil pour les préférences linguistiques.

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

Pied de page des forums