Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-02-2017 21:16:20

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

[Résolu] Terminal inaccessible !?

Bonjour,

Et bien la règle du jamais 2 sans 3 est en train à nouveau de se vérifier roll
après
https://debian-facile.org/viewtopic.php?id=17054
puis
https://debian-facile.org/viewtopic.php?id=17056

...me voici à nouveau ici pour faire suite à mon premier post.
J'ai procédé à une réinstallation complète (que j'ai recommencé 3 fois de suite (ouf) avec le même souci à propos de mon terminal.

Les paquets du terminal de Gnome sont installés, mais lui même reste inaccessible.
Il mouline en barre des tâches et n'apparaît jamais.J'ai procédé à sa purge puis sa réinstallation sans succès.

> Il faut dire que lors de mes trois installation, pourtant avec l'ISO officielle (http://cdimage.debian.org/debian-cd/cur … 86/iso-cd/) j'ai eu un message me signifiant que la liste des paquets sélectionnés (l'environnement bureau Gnome + le serveur SSH) n'avait pas été intallé.
J'ai donc terminé les installation pour me retrouver sans interface graphique, que j'ai ensuite installé grâce à ce lien https://wiki.debian.org/fr/DebianGnome

je fais donc pour l'instant avec Xterm, mais l'interface n'est pas très sexy ;o(

une idée peut-être ?

Dernière modification par debi1 (26-02-2017 14:42:55)

Hors ligne

#2 26-02-2017 08:46:26

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Terminal inaccessible !?

Bonjour:)
Tu avais une connexion internet au moment de l'installation ?
Tu es sûr de l'intégrité de l'ISO utilisée ?

Hors ligne

#3 26-02-2017 11:13:12

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

Bonjour,

installation1 en filaire
installation 2 en wifi
installation en filaire

vérification faite de l'intégrité de l'ISO.

Ce qui m'étonne c'est que les paquets soient présents mais que gnome-terminal ne se lance pas.
A part Xterm et dans une session gnome connais-tu un autre terminal ?.

Hors ligne

#4 26-02-2017 11:30:37

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Terminal inaccessible !?

Bonjour
tu a installé jessie a partir du dernier iso disponible ?
c'est un DVD1 ou net-install ?
comment ce passe l installation ?
choix du lieu , clavier etc ...
détection du réseau (tu est en dhcp ? ) éviter par wifi et préférer en filaire.
la détection du réseau se termine correctement ?
choix du dépot debian correct ?
choix des logiciels (par défaut c'est le bureau gnome ,tu n'a rien a cocher ou décocher )
l installation des paquets se termine bien ?
l'installation de grub ? (oui si tu arrive sur le bureau smile  )
synaptic fonctionne et pour les mises a jour il te dit quoi ?
ton sources.list est t il correct ?
nota : la console graphique qui s'ouvre pas , terminal administrateur et terminal gnome ?  (seulement Xterm fonctionne )

Hors ligne

#5 26-02-2017 11:40:25

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

tu a installé jessie a partir du dernier iso disponible ?
> oui, url dans mon premier post

c'est un DVD1 ou net-install ?
> usb netinstall

comment ce passe l installation ?
tout est ok sauf au moment de la sélection des paquets (que je n'avais jamais eu dans mes inslalation précédentes (même sous debian 8)): je ne sais plus les libellés exacts mais il y a le choix entre les environnements debian, gnome, kde, etc, ainsi qu'un serveur ssh, serveur web ...
gnome-desktop n'est pas sélectionné par défaut !?

choix du lieu , clavier etc ...
> tout est OK à l'installation, mais ensuite lorsque je me logge je me rends compte que les paramètres ne sont pas tous passés. D'ailleurs, si je fait un "dpkg-reconfigure locales" je n'ai pas accès à l'environnement (bleu) des paramètres de langues.

détection du réseau (tu est en dhcp ? ) éviter par wifi et préférer en filaire.
> DHCP et filaire après avoir tenté en wifi.

la détection du réseau se termine correctement ?
> oui

choix du dépot debian correct ?
> oui le fr

choix des logiciels (par défaut c'est le bureau gnome ,tu n'a rien a cocher ou décocher )
> voir ce que j'explique dans une de tes questions ci-dessus. Non sélectionné par défaut !?

l installation des paquets se termine bien ?
> oui excepté donc le message juste avant l'installation de grub qui me prévient que n'ont pas été installé toutes les applis sélectionnés (cf. bureau)

l'installation de grub ? (oui si tu arrive sur le bureau smile  )
> installation OK mais pas la couche graphique Gnome puis gnome-desktop n'a pas été installé.

synaptic fonctionne et pour les mises a jour il te dit quoi ?
> oui, il ne réagit pas négativement

ton sources.list est t il correct ?
> OUI

nota : la console graphique qui s'ouvre pas , terminal administrateur et terminal gnome ?  (seulement Xterm fonctionne )

Hors ligne

#6 26-02-2017 11:52:53

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Terminal inaccessible !?

comment, avec quoi as-tu fait la clé USB ?
Pour le bureau moi j'ai aussi coché Gnome comme dans cette capture https://debian-facile.org/images//file- … 65b64e.png

Hors ligne

#7 26-02-2017 11:56:56

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

Clef USB en ligne de commande
Pour le bureau, j'ai procédé aux même choix.

Hors ligne

#8 26-02-2017 12:00:49

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

Je pencherai pour un paquet manquant ?!

J'ai procédé à l'installation de l'environnement via https://wiki.debian.org/fr/DebianGnome
en suivant la proc. "Installez le méta-paquet "Environnement de bureau de GNOME""

Ne me manquerait-il pas un paquet ou deux https://packages.debian.org/search?keywords=gnome ?
Je suis en train d'en faire le tour en me basant sur l'installation de mon PC fixe.

Hors ligne

#9 26-02-2017 12:12:27

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Terminal inaccessible !?

tu peut aussi avec l utilitaire de gnome (journaux system ) voir ce que le syslog te dit quand tu tente d'ouvrir une console.
nota : si tu le laisse ouvert il te donne les messages a mesure qu ils apparaissent

Dernière modification par robert2a (26-02-2017 12:13:25)

Hors ligne

#10 26-02-2017 12:13:36

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

tu veux parler du "monitor system" ou de quel autre utilitaire ?

Hors ligne

#11 26-02-2017 12:14:08

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

OK, "Journeaux systeme" je regard...

Hors ligne

#12 26-02-2017 12:16:20

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Terminal inaccessible !?

Tu as essayé de réinstaller gnome-terminal ?
Peut être lancer gnome-terminal depuis un terminal xterm pour voir les erreurs affichées.

Hors ligne

#13 26-02-2017 12:17:23

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Terminal inaccessible !?

tu te place sur "syslog"  et tu essaie d ouvrir une console admin ou user

Dernière modification par chalu (26-02-2017 12:21:23)

Hors ligne

#14 26-02-2017 12:23:12

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

..........
Feb 26 11:21:21 ux31 dleyna-renderer-service[6703]: [Network filtering settings]
Feb 26 11:21:21 ux31 dleyna-renderer-service[6703]: Enabled : F
Feb 26 11:21:21 ux31 dleyna-renderer-service[6703]: Entries: (null)
Feb 26 11:21:21 ux31 org.gnome.Terminal[1091]: Non UTF-8 locale (ANSI_X3.4-1968) is not supported!
Feb 26 11:21:21 ux31 gnome-terminal.desktop[6699]: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 8
Feb 26 11:21:22 ux31 dleyna-renderer-service[6703]: New media server /com/intel/dLeynaRenderer/server/0
Feb 26 11:21:22 ux31 dleyna-renderer-service[6596]: dLeyna: Exit
..............



Ce serait à priori un pb:
Feb 26 11:21:21 ux31 org.gnome.Terminal[1091]: Non UTF-8 locale (ANSI_X3.4-1968) is not supported!

J'ai essayé de modifié via l'interface "all settings" mais rien à faire ... comment faire en ligne de commande ?

Hors ligne

#15 26-02-2017 12:24:32

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Terminal inaccessible !?

Pardon robert2a : j'ai modifié ton message en pensant que c'était le mien !
J'ai corrigé et je jure ne pas avoir pris quelque produit que ce soit lol

Hors ligne

#16 26-02-2017 12:36:21

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

si je lance dans xterm

dpkg-reconfigure locales



perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr",
        LC_ALL = (unset),
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
dpkg-query: package 'locales' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: locales is not installed



et donc je n'ai pas la fenêtre captive tu terminal qui se lance... quel autre moyen ai-je pour modifier ces locales ?

Hors ligne

#17 26-02-2017 12:46:00

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Terminal inaccessible !?

chalu a écrit :

Pardon robert2a : j'ai modifié ton message en pensant que c'était le mien !
J'ai corrigé et je jure ne pas avoir pris quelque produit que ce soit lol



pas grave  wink

@debi1

il y a un problème sur ton installation de jessie mais je comprend pas pourquoi  roll

en console (avec Xterm ) un apt-get update , upgrade et dist-upgrade te dit que ton installation est a jour ?

nota : je sais pas si le sources.list a été vérifié déjà .

ps: si je fais une recherche "locales" avec synaptic j'ai le paquet "locales" et "util-linux-locales" installé

Dernière modification par robert2a (26-02-2017 12:54:32)

Hors ligne

#18 26-02-2017 12:52:26

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

Oui Robert2a tout est à jour.

Il faudrait (cela aiderai mon système) modifier cela

Feb 26 11:21:21 ux31 org.gnome.Terminal[1091]: Non UTF-8 locale (ANSI_X3.4-1968) is not supported!



Mais je ne peux le faire par l'interface graphique ... paramétrage clavier > input sources
car dans langage j'ai "Unspecified [ANSI_X3.4-1968]
et dans Formats j'ai "United States 'english)"

et je ne peux pas modifier dans cette fenêtre, les listes déroulantes de choix sont vierges !!!!!!

Dernière modification par debi1 (26-02-2017 12:54:04)

Hors ligne

#19 26-02-2017 14:42:36

debi1
Membre
Distrib. : debian 8.2 - 64 bits
Noyau : linux 3.16.0-4-amd64
(G)UI : gnome 3.14.1
Inscription : 01-05-2015

Re : [Résolu] Terminal inaccessible !?

old_geek.gif HOURA !

Je viens de résoudre le pb.

Ce pb de "locales" me titillait. Je ne pouvait rien faire à leur sujet.
J'ai donc comparé un à un les paquets concernés entre mon portable et mon fixe t je me suis rendu compte
que le paquet "exim4" était sur mon portable et non sur mon fixe > j'ai donc désinstallé ce paquet "exim"
puis

apt-get install --reinstall locales


puis

dpkg-reconfigure locales



.... et là hoo miracle la "fameuse" fenêtre bleu de paramétrage des langues est apparue dans xterm
C'est ainsi que j'ai pû sélection fr en UTF-8 partout où il le fallait ... pour retourner ensuite dans paramétrage clavier > input sources ... mes listes déroulantes de sélection de langue étaient cette fois activées !!!!

... et ma fenêtre de terminal se lance maintenant !!!

J'espère ne pas trouver un nouveau pb liée à cette insal de Debian qui pour la première en plus de 10 ans n'a pas été exhaustive !?

Merci à vous tou(te)s et bon dimanche.merci.gif

Hors ligne

Pied de page des forums