Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-04-2017 18:47:16

nico34
Membre
Distrib. : HandyLinux-2.5.1
(G)UI : Xfce
Inscription : 25-07-2016

[Résolu] Installation laser Dell

Bonsoir toutes et tous

après ré installation de Handylinux (ancien disque qui fatiguait), mon imprimante Dell 1110 est détectée quand je la branche (usb)
il y a recherche de pilote et puis rien...en ouvrant la configuration d'imprimante, j'ai ajouter une imprimante, elle est dans périphériques
(Dell Laser(HOLZ491.....) et à nouveau recherche de pilote et la fenêtre se referme après quelques secondes.
La première fois que je l'avais installé, Chalu (merci) m'avais aiguillé vers le paquet splix, j'ai vérifié, les 2 y sont et en dernière version.
Voili, je sèche.

Dernière modification par nico34 (19-05-2017 19:38:54)

Hors ligne

#2 18-05-2017 19:47:23

nico34
Membre
Distrib. : HandyLinux-2.5.1
(G)UI : Xfce
Inscription : 25-07-2016

Re : [Résolu] Installation laser Dell

B'jour

je me permet de remonter le sujet.
je suis toujours en galère, et j'ai un besoin assez urgent de l'imprimante.
j'ai cherché de mon coté, mais rien de concluant.
j'ai re installé splix, puis dé installé cups et ré installation, mais c'est toujours pareil.
dans l'outil de configuration pour CUPS, j'ai fait un tour dans l'aide/dépannage:
la Dell n'est pas listée, donc un clic sur not listed, puis imprim locale et là elle est listée.
puis j'ai le mesage: sorry! there is no obvious solution to this problem.

je joint le diagnostic output (advanced) si cela parle à certains d'entre vous:

Page 1 (Scheduler not running?):
{'cups_connection_failure': False}
Page 2 (Is local server publishing?):
{'local_server_exporting_printers': False}
Page 3 (Choose printer):
{'cups_dests_available': [(u'EPSON-Stylus-CX3600', None)],
'cups_queue_listed': False}
Page 4 (Local or remote?):
{'printer_is_remote': False}
Page 5 (Choose device):
{'cups_device_attributes': {'device-class': u'direct',
                            'device-id': u'MFG:Dell;CMD:GDI;MDL:Laser Printer 1110;CLS:PRINTER;MODE:GDI;STATUS:IDLE;',
                            'device-info': u'Dell Laser Printer 1110',
                            'device-location': u'',
                            'device-make-and-model': u'Dell Laser Printer 1110'},
'cups_device_listed': True,
'cups_device_uri': 'usb://Dell/Laser%20Printer%201110?serial=H0LZ491.........'}
Page 6 (Locale issues):
{'printer_page_size': None,
'system_locale_lang': None,
'user_locale_ctype': 'fr_FR',
'user_locale_messages': 'fr_FR'}

Voilà, ça me sortirait une épine si quelqu'un sait, d'autant que je m'en servais sans souci avant.
Merci

Hors ligne

#3 18-05-2017 19:54:28

Trefix
Adhérent(e)
Lieu : 48
Distrib. : kiss0s-0.5
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox by arpinux
Inscription : 15-02-2015

Re : [Résolu] Installation laser Dell

Bonsoir.
Je ne saurais te dire, mais est-ce que tu aurais gardé des fichiers de configuration de ta précédente installation, par malheur ? Ouvre ton gestionnaire de fichiers, affiche les "cachés" avec un  Ctrl + H (H pour hidden) et regarde ce que tu trouves...

HL > DF // Les cahiers du débutant // DFLinux
.
JE SUIS toujours abonné à CHARLIE

Hors ligne

#4 18-05-2017 23:11:59

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Installation laser Dell

Bonsoir smile
Tu avais une EPSON-Stylus-CX3600 aussi ?

Hors ligne

#5 18-05-2017 23:22:18

nico34
Membre
Distrib. : HandyLinux-2.5.1
(G)UI : Xfce
Inscription : 25-07-2016

Re : [Résolu] Installation laser Dell

Hello vous deux

Trefix, je devrais pouvoir, j'ai toujours le disk. par contre un début de piste où chercher (fichiers cachés)
je pense qu'il doit y en avoir une chiée et un petit tas hmm
je gardais sous le coude l'idée de (tenter de) faire un clone du disk, pour repartir sur un truc qui marchait.
btw pourquoi par malheur ?

chalu, vui toujours l'epson aussi, qui ne me sert que de scan - si tu te souviens
https://handylinux.org/forum/viewtopic.php?id=1559

Hors ligne

#6 19-05-2017 07:43:49

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Installation laser Dell

Et là tu as refait une installation en conservant tes documents ? Tu peux en dire plus ? En tout cas tu as dû avoir un paquet de mises à jour à faire.
As tu tenté comme la première fois de supprimer les deux imprimantes puis d'installer d'abord la Dell et la tester puis l'epson ?

Hors ligne

#7 19-05-2017 11:05:23

nico34
Membre
Distrib. : HandyLinux-2.5.1
(G)UI : Xfce
Inscription : 25-07-2016

Re : [Résolu] Installation laser Dell

Bonjour
j'ai refait une installation complète avec la dernière (?) version de HL,
puis je suis aller récupérer mes fichiers dans mon ancien home
en branchant mon vieux disk en externe (usb).
je viens aussi d'enlever l'epson, puis rebrancher la Dell. Elle est bien détectée mais toujours la même punition
recherche de pilote et fermeture rapide de la fenêtre, et en re ouvrant le gestionnaire d'imprimante (system-config-printer)
j'ai: aucune imprimante installée.

j'ai un peu farfouillé dans mon ancien disk, j'ai dans etc/cups/ppd 3 fichiers
  Dell-Laser-printer-1110.ppd, EPSON-Stylus-CX600.ppd, et EPSON-Stylus-CX600-2.ppd

par contre sur mon disk actuel même chemin, le dossier ppd est vide

Un début de piste ?

Hors ligne

#8 19-05-2017 12:50:29

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Installation laser Dell

Et tu as bien fait les mises à jour ?
Que donnent les commandes

apt-cache policy printer-driver-splix


sudo apt-get update && sudo apt-get dist-upgrade

Hors ligne

#9 19-05-2017 17:00:26

nico34
Membre
Distrib. : HandyLinux-2.5.1
(G)UI : Xfce
Inscription : 25-07-2016

Re : [Résolu] Installation laser Dell

re
quelle patience, merci

retour de

apt-cache policy printer-driver-splix


printer-driver-splix:
  Installé : (aucun)
  Candidat : 2.0.0+svn315-4
 Table de version :
     2.0.0+svn315-4 0
        500 http://httpredir.debian.org/debian/ jessie/main i386 Packages



et

sudo apt-get update && sudo apt-get dist-upgrade


Réception de : 1 http://security.debian.org jessie/updates InRelease [63,1 kB]
Ign http://mozilla.debian.net jessie-backports InRelease                      
Atteint http://repo.handylinux.org jessie InRelease                            
Atteint http://mozilla.debian.net jessie-backports Release.gpg                
Atteint http://mozilla.debian.net jessie-backports Release                    
Réception de : 2 http://security.debian.org jessie/updates/main i386 Packages [406 kB]
Atteint http://repo.handylinux.org jessie/main i386 Packages                  
Atteint http://mozilla.debian.net jessie-backports/firefox-release i386 Packages
Ign http://httpredir.debian.org jessie InRelease                              
Réception de : 3 http://httpredir.debian.org jessie-updates InRelease [145 kB]
Atteint http://httpredir.debian.org jessie Release.gpg                        
Réception de : 4 http://security.debian.org jessie/updates/contrib i386 Packages [2 526 B]
Réception de : 5 http://security.debian.org jessie/updates/non-free i386 Packages [14 B]
Réception de : 6 http://security.debian.org jessie/updates/contrib Translation-en [1 211 B]
Atteint http://httpredir.debian.org jessie Release                            
Réception de : 7 http://security.debian.org jessie/updates/main Translation-en [213 kB]
Réception de : 8 http://httpredir.debian.org jessie-updates/main i386 Packages/DiffIndex [7 900 B]
Réception de : 9 http://httpredir.debian.org jessie-updates/contrib i386 Packages [32 B]
Réception de : 10 http://security.debian.org jessie/updates/non-free Translation-en [14 B]
Réception de : 11 http://httpredir.debian.org jessie-updates/non-free i386 Packages/DiffIndex [736 B]
Réception de : 12 http://httpredir.debian.org jessie-updates/contrib Translation-en [14 B]
Ign http://mozilla.debian.net jessie-backports/firefox-release Translation-fr_FR
Réception de : 13 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [2 704 B]
Ign http://mozilla.debian.net jessie-backports/firefox-release Translation-fr  
Réception de : 14 http://httpredir.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Ign http://mozilla.debian.net jessie-backports/firefox-release Translation-en  
Atteint http://httpredir.debian.org jessie/main i386 Packages                  
Atteint http://httpredir.debian.org jessie/contrib i386 Packages              
Atteint http://httpredir.debian.org jessie/non-free i386 Packages              
Atteint http://httpredir.debian.org jessie/contrib Translation-en              
Atteint http://httpredir.debian.org jessie/main Translation-fr                
Atteint http://httpredir.debian.org jessie/main Translation-en                
Atteint http://httpredir.debian.org jessie/non-free Translation-en            
Ign http://repo.handylinux.org jessie/main Translation-fr_FR                  
Ign http://repo.handylinux.org jessie/main Translation-fr
Ign http://repo.handylinux.org jessie/main Translation-en
843 ko réceptionnés en 32s (26,0 ko/s)
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  hplip-data libqt4-declarative libqt4-designer libqt4-help libqt4-script
  libqt4-scripttools libqt4-test libqt4-xmlpatterns libqtassistantclient4
  libqtwebkit4 libsane-hpaio libwebpdemux1 libwebpmux1 python-imaging
  python-pexpect python-pil python-qt4 python-reportlab python-reportlab-accel
  python-sip
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



j'ai donc lancé un apt-get autoremove

c'est étrange, je fais les mises à jour dès qu'elles sont proposées
et je suis sûr que j'avais vérifié les splix...une conséquence de autoremove ?

puis j'ai branché la Dell, j'ai eu la fenêtre recherche de pilote puis une autre (nouveau)
me demandant de choisir un pilote. j'ai tenté la 1° ligne (base de données) avec pas plus de résultat, cherché sur le site Dell
mais pas trouvé d'autre choix que W$ comme os, et finalement opté pour la 2° ligne (fournir un fichier PPD) que je suis allé copier sur mon ancien disk.
fenêtre suivante, elle est bien là, mais message suivant (après l'essai de page de test) il manque un programme:  usr/lib/cups/filter/rastertoqpdl
j'ai re installé les paquets splix, redémarré ma machine, re branché la Dell et j'ai enfin pu imprimer la page de test.

je ne me souviens pas que cela a été aussi galère la première fois.
j'ai tenté de remettre mon epson (qui ne me sert que de scan) et re souci: elle est détecté, recherche (rapide) de pilote et nada.

Bon je stoppe un peu mon roman, je vais mettre des liens vers les diverses copies écran faites lors des tentatives (plus tard) puis mettre en (quasi) résolu

edit
http://pix.toile-libre.org/upload/origi … 215164.png
http://pix.toile-libre.org/upload/origi … 215285.png

et encore un gros merci chalu pour ton aide

Dernière modification par nico34 (19-05-2017 19:37:48)

Hors ligne

#10 19-05-2017 19:56:27

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Installation laser Dell

Bon en fait, tu n'avais pas le driver printer-driver-splix, c'est sans doute le paquet qui manquait et qu'il fallait installer et ne me remercie pas, tu as trouvé tout seul wink

Hors ligne

#11 19-05-2017 20:05:34

nico34
Membre
Distrib. : HandyLinux-2.5.1
(G)UI : Xfce
Inscription : 25-07-2016

Re : [Résolu] Installation laser Dell

tongue
mon premier message de ce fil:
La première fois que je l'avais installé, Chalu (merci) m'avais aiguillé vers le paquet splix, j'ai vérifié, les 2 y sont et en dernière version.

ils ne sont pas tombé dans un trou noir ?

je vais tenter de remettre l'epson, mais beaucoup moins urgent.
ou bien coller une DFL sur un Lenovo que je viens de récupérer. Mais un plaisir à la fois.

La belle soirée.

Hors ligne

#12 19-05-2017 21:59:19

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Installation laser Dell

nico34 a écrit :

ils ne sont pas tombé dans un trou noir ?


Si certainement puisqu'ensuite le retour indiquait que le paquet n'était  pas installé lol

nico34 a écrit :

printer-driver-splix:
  Installé : (aucun)
  Candidat : 2.0.0+svn315-4
 Table de version :
     2.0.0+svn315-4 0
        500 http://httpredir.debian.org/debian/ jessie/main i386 Packages

Hors ligne

Pied de page des forums