Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-06-2017 15:50:13

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

[résolu] passer de debian 8 à debian 9

bonjour

comment faire ?

de façon sûre , sans risque de  tout casser .

j'ai cru lire  qu'en modifiant le sources list , c'est faisable ?

pas trop risqué ?

vaut il mieux attendre ?

(passer de debian 8 à 9)

Dernière modification par Debian Alain (20-06-2017 11:07:57)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#2 03-06-2017 16:19:06

Trefix
Adhérent(e)
Lieu : 48
Distrib. : kiss0s-0.5
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox by arpinux
Inscription : 15-02-2015

Re : [résolu] passer de debian 8 à debian 9

Bonjour.
Les notes de version te le diront sûrement (j'ai déjà vu passer, ici même)...
Stretch étant annoncée pour le 17/06 (dans deux semaines, donc) je me contenterais de patienter un peu, d'autant qu'avec ses divers projets à base de Debain-stable, arpinux-notre-druide big_smile ne devrait pas manquer de livrer rapidement un tuto qui va bien, pour les n00bz dans notre genre wink

HL > DF // Les cahiers du débutant // DFLinux
.
JE SUIS toujours abonné à CHARLIE

Hors ligne

#3 03-06-2017 16:22:41

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

excuse moi trefix , qu'est ce que tu appelles "les notes de version"  ?

sinon , oui , si debian 9 arrive dans 2 semaines , autant attendre  plutôt que de faire des bêtises .

1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#4 03-06-2017 16:44:26

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] passer de debian 8 à debian 9

Trefix veut sûrement parles des "Notes de publication" (Release notes) qui accompagnent chaque nouvelle version et dont un chapitre est consacré à la mise à niveau.

https://www.debian.org/releases/stretch/releasenotes

Dernière modification par raleur (03-06-2017 16:46:28)

Hors ligne

#5 16-06-2017 08:29:58

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

cher râleur ,

comme suite aux release notes , j'ai commencé à faire une mise à jour de mon systeme avec aptitude .

j'obtiens ceci (entre autres) :

transport de téléchargement https pour APT
apt-transport-https a été installé automatiquement ; il va être enlevé parce que tous les paquets qui en dépendent vont être supprimés



OpenPrintinng CUPS Filters - cups-browsed
cupsbrowsed a été installé automatiquement ; il va être enlevé parce que tous les paquets qui en dépendent vont être supprimés



j'ai pas envie de casser  mon systeme alors  , je te demande tes lumières , raleur , stp . merci


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#6 16-06-2017 08:55:49

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Buster/Sid/Rc-Buggy
Noyau : Linux (≥ 4.12)
(G)UI : i3-wm (≥ 4.13)
Inscription : 07-07-2008
Site Web

Re : [résolu] passer de debian 8 à debian 9

Les releases notes indiquent au contraire qu'aptitude n'est plus l'outil recommandé smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 16-06-2017 12:43:36

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

bonjour à tous ;

qu'en pensez vous ?

pris des notes de publication : https://www.debian.org/releases/stretch … ew-actions
chapitre 4.2 : verifier l'état du systeme

4 2.1. Vérifier les actions en cours dans le gestionnaire de paquets

Dans certains cas, l'utilisation d'apt-get pour l'installation de paquets au lieu d'aptitude peut induire aptitude à considérer un paquet comme « unused » (inutilisé) et à le programmer pour être supprimé. En général, vous devez vous assurer que le système est complètement à jour et « propre » avant de commencer la mise à niveau.

Ainsi, vous devez commencer par vérifier s'il y a des actions en attente dans le gestionnaire de paquets aptitude. Si un paquet est programmé pour être supprimé ou mis à jour dans le gestionnaire des paquets, cela peut poser problème lors de la procédure de mise à niveau. Notez que la correction d'un tel problème n'est possible que si le fichier sources.list pointe encore vers jessie et pas vers stable ou stretch ; consultez la Section A.2, « Vérifier la liste de sources ».

Pour faire cette vérification, vous devez lancer aptitude en mode terminal complet et appuyer sur g (« Go »). S'il affiche une ou plusieurs action(s), vous devez les contrôler et les corriger ou les mettre en œuvre. Si aucune action n'est suggérée, un message sera affiché indiquant « Il n'est prévu d'installer, mettre à jour ou enlever aucun paquet. »



je fais ce qu'aptitude me commande ?

en faisant la commande "go" d'aptitude , celui ci me dit :

Paquets qui vont être supprimés parce qu'ils ne sont plus utilisés (23)



et dans le tas on trouve :

apt-transport-https
cups-browsed
ffmpegthumbs
hp-ppd
libdbil

etc  ...

pardon , je  viens de lire :

4.4.4. Mise à niveau minimale du système
Note
Nous recommandions d'utiliser aptitude lors du processus de mise à niveau pour certaines versions précédentes. Cet outil n'est pas recommandé pour les mises à niveau de Jessie à Stretch.



mon sources.list est bon ? si oui , je n'ai plus qu'à faire la bascule .

$ gedit /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free
# deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free
# deb http://security.debian.org/ stretch/updates main contrib non-free
# deb-src http://security.debian.org/ stretch/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
# deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# installer depuis les backports : apt-get -t jessie-bacports install xxx
# Backports repository
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
# deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

# fr multimedia codecs
# deb http://www.deb-multimedia.org stable main non-free

# multisystem multiboot sur cle usb
# deb http://liveusb.info/multisystem/depot all main
# deb-src http://liveusb.info/multisystem/depot all main

# virtualbox
# deb http://download.virtualbox.org/virtualbox/debian jessie contrib
 

Dernière modification par Debian Alain (16-06-2017 13:32:59)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#8 16-06-2017 13:31:58

Caribou22
Membre
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stretch
Noyau : 4.9 amd64
(G)UI : XFCE
Inscription : 10-11-2014
Site Web

Re : [résolu] passer de debian 8 à debian 9

Ça a été sans problèmes pour moi smile http://debian-facile.org/viewtopic.php?id=17945

Hors ligne

#9 16-06-2017 15:28:21

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] passer de debian 8 à debian 9

Bonjour
tu a pensé a un double "boot" , Jessie et Sid par exemple .
il te faut un deuxième petit disque pour (Stretch ou Testing ou Sid )
avec un update-grub a partir de Jessie tu dois pourvoir ajouter le menu au démarrage de ta deuxième installation.
comme cela tu est tranquille en cas de pépin tu efface le disque et tu recommence .
c'est une alternative au dist-upgrade , tu fais une installation "tout sur une partition" , aucun lien entre les deux installations (a part le menu de grub sur jessie )
ça demande a te procurer un disque supplémentaire  (avec 40Go c'est largement suffisant pour tester )

ps: j'ai cassé ma stretch , je suis revenu a une version normale (mate + lightdm)
c'est vraie que l affichage est pas terrible en mode vesa
tu va pas gagner grand chose de passer en stretch pour l'instant (tu a déja les paquets des backports de jessie je suppose )
moi je vais rester comme ça et surveiller (la machine ne sert que de test )
pour revenir en stretch (aprés un up vers expérimental c'est sportif , aptitude m'a aidé a trouver des solutions ).
donc je suis avec noyau et firmware de stretch ainsi que mesa en version 13
nota : le dernier paquet qui bloqué pour la remise a niveau => libglm1 en version expérimental (17.xxx )
apt-listbugs m'a donné pour le bureau un bug sur firefox version52 et sur le paquet xserver-xorg-core

comme conseil je dirai attendre un peu , voir ce qui se passe
pour une fois que je pousse pas a utiliser stretch  wink
l'erreur au départ c'est la carte en rx550 , une rx460 aurait été beaucoup mieux , j'ai pas fait attention a la prise en charge par stretch , une erreur de ma part  hmm

Dernière modification par robert2a (16-06-2017 18:53:42)

Hors ligne

#10 16-06-2017 19:17:26

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

bonjour ,

voilà ce que j'ai fait :

sudo apt-get update


ok

sudo apt-get upgrade


durée 1h 30 environ

sudo reboot



puis

sudo apt-get dist-upgrade


Des erreurs ont été rencontrées pendant l'exécution :
 apt-listchanges
N: « 50unattended-upgrades.ucf-old » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



après restart (arrêt puis démarrage)

$ sudo apt-get update


[sudo] Mot de passe de alain : 
Atteint:1 http://ftp.fr.debian.org/debian stretch InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                  
Ign:3 http://linux.dropbox.com/debian jessie InRelease                        
Atteint:4 http://ftp.fr.debian.org/debian stretch-updates InRelease            
Atteint:5 http://dl.google.com/linux/chrome/deb stable Release                
Atteint:6 http://linux.dropbox.com/debian jessie Release                      
Atteint:7 http://security.debian.org stretch/updates InRelease                
Atteint:8 ftp://ftp.deb-multimedia.org jessie InRelease                        
Atteint:9 http://www.deb-multimedia.org jessie InRelease                      
Ign:10 https://freefr.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all InRelease
Ign:11 https://deb.opera.com/opera-stable stable InRelease                    
Ign:12 https://apt.movim.eu/debian jessie InRelease                            
Err:13 https://deb.opera.com/opera-stable stable Release                      
  gnutls_handshake() failed: Public key signature verification has failed.
Err:14 https://apt.movim.eu/debian jessie Release                              
  gnutls_handshake() failed: Public key signature verification has failed.
Atteint:16 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease
Err:17 https://freefr.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release
  gnutls_handshake() failed: Public key signature verification has failed.
Lecture des listes de paquets... Fait
E: The repository 'https://deb.opera.com/opera-stable stable Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://apt.movim.eu/debian jessie Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
 



$ cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free

# deb http://security.debian.org/ jessie/updates main contrib non-free
# deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
# deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# installer depuis les backports : apt-get -t jessie-bacports install xxx
# Backports repository
# deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

# fr multimedia codecs
# deb http://www.deb-multimedia.org stable main non-free

# multisystem multiboot sur cle usb
# deb http://liveusb.info/multisystem/depot all main
# deb-src http://liveusb.info/multisystem/depot all main

# virtualbox
# deb http://download.virtualbox.org/virtualbox/debian jessie contrib



$ cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# installer depuis les backports : apt-get -t stretch-backports install xxx
# Backports repository
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

# fr multimedia codecs
# deb http://www.deb-multimedia.org stable main non-free

# multisystem multiboot sur cle usb
# deb http://liveusb.info/multisystem/depot all main
# deb-src http://liveusb.info/multisystem/depot all main

# virtualbox
# deb http://download.virtualbox.org/virtualbox/debian jessie contrib
 



$ sudo apt-get update


Atteint:1 http://ftp.fr.debian.org/debian stretch InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                  
Atteint:3 http://www.deb-multimedia.org jessie InRelease                      
Ign:4 http://linux.dropbox.com/debian jessie InRelease                        
Atteint:6 http://ftp.fr.debian.org/debian stretch-updates InRelease            
Atteint:7 http://dl.google.com/linux/chrome/deb stable Release                
Atteint:8 http://linux.dropbox.com/debian jessie Release                      
Réception de:9 http://security.debian.org stretch/updates InRelease [62,9 kB]  
Atteint:5 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease  
Atteint:10 ftp://ftp.deb-multimedia.org jessie InRelease                      
Ign:11 https://deb.opera.com/opera-stable stable InRelease                    
Ign:12 https://apt.movim.eu/debian jessie InRelease                            
Err:14 https://deb.opera.com/opera-stable stable Release                      
  gnutls_handshake() failed: Public key signature verification has failed.
Err:15 https://apt.movim.eu/debian jessie Release
  gnutls_handshake() failed: Public key signature verification has failed.
Ign:13 https://netcologne.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all InRelease
Err:18 https://10gbps-io.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release
  gnutls_handshake() failed: Public key signature verification has failed.
Lecture des listes de paquets... Fait
E: The repository 'https://deb.opera.com/opera-stable stable Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://apt.movim.eu/debian jessie Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Dernière modification par Debian Alain (16-06-2017 19:37:18)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#11 16-06-2017 19:25:01

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] passer de debian 8 à debian 9

un petit dist-upgrade et reboot


apt-get dist-upgrade
 




reboot
 



pour vérifier après le reboot


apt-get update
 



apt-get upgrade
 



et si il te propose un autoremove ou pas

tu a des erreurs hmm
le sources.list est brouillon , certaines lignes peuvent etre supprimées
pour l afficher en couleur utilise le bouton "code"  => apt_sources

comme ceci


deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free

deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# Backports
deb http://ftp.fr.debian.org/debian stretch-backports main contrib non-free

# fr multimedia codecs
# deb http://www.deb-multimedia.org stable main non-free

# multisystem multiboot sur cle usb
# deb http://liveusb.info/multisystem/depot all main

# virtualbox
# deb http://download.virtualbox.org/virtualbox/debian jessie contrib
 



pour les 3 dernières lignes commentées je sais pas ce qu il faut faire avec  sad

pour purger ton cache apt


apt-get update
 



apt-get autoclean
 



ton dossier /etc/apt/sources.list.d/     est vide ?

a priori tu utilise beaucoup de dépots externe a debian ....  sad

pour te donner une idée voila ce que donne mesa comme info avec une stretch officielle  tongue


name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 3.9, 128 bits) (0xffffffff)
    Version: 13.0.6
    Accelerated: no
    Video memory: 7985MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 13.0.6
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 13.0.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.0 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
 



ceci est ma mémoire de la machine => Video memory: 7985MB  (8Go)
mesa utilise le processeur , donc direct rendering: Yes  mais  Accelerated: no   hmm
il y a une sacrée différence  neutral

Dernière modification par robert2a (16-06-2017 20:25:01)

Hors ligne

#12 16-06-2017 20:22:26

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

# cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# installer depuis les backports : apt-get -t stretch-backports install xxx
# Backports repository
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

# fr multimedia codecs
# deb http://www.deb-multimedia.org stable main non-free



# apt-get update


Atteint:1 http://ftp.fr.debian.org/debian stretch InRelease
Ign:2 http://linux.dropbox.com/debian jessie InRelease                                                                                    
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                                                                              
Atteint:4 http://www.deb-multimedia.org jessie InRelease                                                                                  
Atteint:5 http://ftp.fr.debian.org/debian stretch-updates InRelease                                                                      
Atteint:6 http://linux.dropbox.com/debian jessie Release                                                                                  
Atteint:7 http://dl.google.com/linux/chrome/deb stable Release                                                                            
Ign:8 https://apt.movim.eu/debian jessie InRelease                                                                                        
Ign:9 https://deb.opera.com/opera-stable stable InRelease                                                                                
Atteint:10 ftp://ftp.deb-multimedia.org jessie InRelease                                                                                  
Atteint:11 http://security.debian.org stretch/updates InRelease                                                                          
Err:13 https://apt.movim.eu/debian jessie Release                                                                                        
  gnutls_handshake() failed: Public key signature verification has failed.
Err:16 https://deb.opera.com/opera-stable stable Release      
  gnutls_handshake() failed: Public key signature verification has failed.
Ign:12 https://netcologne.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all InRelease
Atteint:14 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease          
Err:18 https://10gbps-io.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release
  gnutls_handshake() failed: Public key signature verification has failed.
Lecture des listes de paquets... Fait
E: The repository 'https://apt.movim.eu/debian jessie Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://deb.opera.com/opera-stable stable Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
 



# apt-get upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  catdoc docutils-common docutils-doc enblend enfuse fp-compiler-2.6.4 fp-ide-2.6.4 fp-units-base-2.6.4 fp-units-db-2.6.4
  fp-units-fcl-2.6.4 fp-units-fv-2.6.4 fp-units-gfx-2.6.4 fp-units-gnome1-2.6.4 fp-units-gtk-2.6.4 fp-units-gtk2-2.6.4
  fp-units-math-2.6.4 fp-units-misc-2.6.4 fp-units-multimedia-2.6.4 fp-units-net-2.6.4 fp-units-rtl-2.6.4 fp-utils-2.6.4 fpc-2.6.4
  fpc-source-2.6.4 g++-4.9 gcj-4.9-jre-lib gdebi-core gir1.2-clutter-gst-2.0 gir1.2-gkbd-3.0 gir1.2-grilo-0.2
  gir1.2-gst-plugins-base-0.10 gir1.2-gtop-2.0 gir1.2-javascriptcoregtk-3.0 gir1.2-mediaart-1.0 gir1.2-webkit-3.0 gir1.2-xkl-1.0
  gnome-accessibility-themes gnome-packagekit-session gnome-themes-standard gstreamer0.10-gconf gstreamer0.10-gnonlin gstreamer0.10-nice
  gstreamer0.10-pulseaudio gstreamer1.0-clutter gstreamer1.0-gnonlin gstreamer1.0-plugins-base-dbg gstreamer1.0-plugins-good-dbg
  gstreamer1.0-plugins-ugly-dbg hardening-includes hugin hugin-data hugin-tools iceweasel-l10n-fr imagemagick-common kdepimlibs-data
  kipi-plugins-common lazarus-1.2.4 lazarus-doc-1.2.4 lazarus-ide-1.2.4 lazarus-ide-gtk2-1.2.4 lazarus-src-1.2.4 lcl-1.2.4 lcl-gtk2-1.2.4
  lcl-nogui-1.2.4 lcl-units-1.2.4 lcl-utils-1.2.4 libaacplus2:i386 libaec0 libamd2.3.1 libarchive-extract-perl libasn1-8-heimdal
  libastro1 libavahi-client-dev libavahi-common-dev libavcodec56:i386 libavfilter6 libavresample2:i386 libavutil54:i386 libbaloocore4
  libbaloofiles4 libbalooxapian4 libbasicusageenvironment0 libbind9-90 libboost-filesystem1.55.0 libboost-python1.55.0
  libboost-random1.62.0 libboost-regex1.55.0 libboost-system1.55.0 libboost-thread1.55.0 libc6-i686:i386 libcamd2.3.1 libcamel-1.2-49
  libccolamd2.8.0 libcholmod2.1.2 libclutter-gst-2.0-0 libcolamd2.8.0 libcoverart0 libdbus-glib-1-dev libdirectfb-dev libdirectfb-extra
  libdns100 libdvbpsi9 libebackend-1.2-7 libebur128-1 libecal-1.2-16 libedata-cal-1.2-23 libedataserver-1.2-18 libegl1-mesa-drivers
  libelfg0 libept1.4.12 libepub0 libexiv2-13 libfaac0:i386 libfame-0.9-1 libfdk-aac1:i386 libfftw3-3 libfftw3-long3 libflann1.9 libftdi1
  libgcj15 libgdata19 libgdict-1.0-6 libgegl-0.2-0 libgit2-21 libglew1.10 libgnutls-deb0-28:i386 libgphoto2-port10 libgps21 libgps22
  libgrantlee-templates5 libgrilo-0.2-1 libgroupsock4 libgstreamer-plugins-base0.10-0:i386 libgstreamer-plugins-base0.10-dev
  libgstreamer0.10-0:i386 libgstreamer1.0-0-dbg libgtkglext1 libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libgtop2-7
  libhcrypto4-heimdal libhdb9-heimdal libhdf5-100 libhdf5-8 libheimbase1-heimdal libhogweed2:i386 libhunspell-1.3-0 libhx509-5-heimdal
  libical1a libieee1284-3-dev libimobiledevice4 libinput5 libintl-perl libintl-xs-perl libisc95 libisccc90 libisccfg90 libiscsi2
  libjim0.75 libjs-sphinxdoc libjs-underscore libjson-c2:i386 libjsr107cache-java libkactivities-models1 libkcalcore4 libkdcraw-data
  libkdcraw23 libkexiv2-11 libkexiv2-data libkf5akonadicontact5 libkf5akonadicore-bin libkf5bookmarks-data libkf5bookmarks5
  libkf5contacts-data libkf5contacts5 libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiowidgets5 libkf5kipi-data libkf5kipi31.0.0 libkf5mime5 libkf5solid5
  libkf5solid5-data libkf5threadweaver5 libkrb5-26-heimdal libksane-data libksane0 liblensfun-data liblensfun-data-v1 liblensfun0
  liblensfun1 liblinear1 liblivemedia42 libllvm3.5 libllvm3.5:i386 libllvm3.8:i386 liblog-message-perl liblog-message-simple-perl
  liblouis2 liblwres90 libmediaart-1.0-0 libminizip1 libmodule-load-conditional-perl libmono-compilerservices-symbolwriter4.0-cil
  libmusicbrainz5-1 libmysqlclient18 libnepomukcore4 libnettle4:i386 libnm-glib-vpn1 libnm-gtk-common libntdb1 libopencore-amrnb0:i386
  libopencore-amrwb0:i386 libopencv-contrib2.4v5 libopencv-ml2.4v5 libopenjpeg5:i386 libopenraw1 libpackage-constants-perl libpano13-3
  libpano13-bin libpgf6 libpgm-5.2-0 libphonon4qt5-4 libplist2 libpng12-0:i386 libpod-latex-perl libpoppler-qt5-1 libpoppler46
  libpostproc54 libprotobuf9 libpth20 libqca2-plugin-ossl libqextserialport1 libqmi-glib1 libqpdf13 libqt5concurrent5 libqt5glib-2.0-0
  libqt5gstreamer-1.0-0 libqt5gstreamerquick-1.0-0 libqt5positioning5 libqt5serialport5 libqt5xmlpatterns5 libqtglib-2.0-0
  libqtgstreamer-0.10-0 libqtgstreamerui-0.10-0 libqtgstreamerutils-0.10-0 libqtlocation1 libqtwebkit-dev libquazip1 libquvi-dev
  libquvi-scripts libquvi7 librados2 libraw10 librbd1 libre2-3 libresid-builder0c2a librhythmbox-core8 libroken18-heimdal librubberband2
  librygel-core-2.4-2 librygel-renderer-2.4-2 librygel-renderer-gst-2.4-2 librygel-server-2.4-2 libschroedinger-1.0-0:i386
  libservlet3.0-java libshp2 libsidplay2 libsodium18 libspice-client-gtk-3.0-4 libsqlite0 libstreams0 libswresample1:i386 libsz2
  libterm-ui-perl libtext-soundex-perl libtinyxml2-2 libturbojpeg1 libumfpack5.6.2 libupnp6 libusageenvironment2 libusbmuxd2
  libutvideo15:i386 libv4l-dev libvala-0.26-0 libvigraimpex4 libvigraimpex6 libvo-aacenc0:i386 libvo-amrwbenc0:i386 libvpx1:i386
  libwebpmux1 libwebrtc-audio-processing-0 libwind0-heimdal libwine-gecko-2.21 libwine-gecko-2.24 libwireshark5 libwiretap4 libwsutil4
  libx264-142 libx264-146:i386 libx265-51:i386 libxapian22 libxcb-composite0 libxen-4.4 libxfce4util6 libxine2-bin libxine2-ffmpeg
  libxine2-x libzmq5 libzthread-2.3-2 linux-image-4.9.0-0.bpo.3-amd64 marble-data nepomuk-core-data openjdk-7-doc perlmagick python-cffi
  python-characteristic python-cups python-cycler python-dateutil python-dbus-dev python-defusedxml python-docutils python-funcsigs
  python-functools32 python-gdbm python-gst-1.0 python-matplotlib python-mock python-nevow python-ntdb python-pbr python-ply
  python-pyatspi python-pycparser python-pyparsing python-roman python-smbc python-soappy python-subprocess32 python-twisted-conch
  python-twisted-lore python-twisted-mail python-twisted-names python-twisted-news python-twisted-runner python-twisted-web
  python-twisted-words python-wstools qml-module-qtgstreamer qtgstreamer-plugins-qt5 valac-0.26-vapi vlc-plugin-pulse
  xfce-keyboard-shortcuts
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants ont été conservés :
  chromium ffmpegthumbs mplayer2
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de apt-listchanges (3.10) ...
Traceback (most recent call last):
  File "/tmp/tmp.zHZqhbSYwA.aptlc/debconf-helper.py", line 6, in <module>
    import debconf
ModuleNotFoundError: No module named 'debconf'
dpkg: erreur de traitement du paquet apt-listchanges (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apt-listchanges
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



après un reboot

# apt-get update


Atteint:1 http://ftp.fr.debian.org/debian stretch InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                  
Atteint:3 http://www.deb-multimedia.org jessie InRelease                      
Ign:4 http://linux.dropbox.com/debian jessie InRelease                        
Atteint:6 http://dl.google.com/linux/chrome/deb stable Release                
Atteint:7 http://ftp.fr.debian.org/debian stretch-updates InRelease            
Atteint:8 http://linux.dropbox.com/debian jessie Release                      
Atteint:9 http://security.debian.org stretch/updates InRelease                
Atteint:10 ftp://ftp.deb-multimedia.org jessie InRelease                      
Atteint:5 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease  
Ign:12 https://deb.opera.com/opera-stable stable InRelease                    
Ign:13 https://apt.movim.eu/debian jessie InRelease
Err:14 https://apt.movim.eu/debian jessie Release
  gnutls_handshake() failed: Public key signature verification has failed.
Err:15 https://deb.opera.com/opera-stable stable Release
  gnutls_handshake() failed: Public key signature verification has failed.
Ign:11 https://vorboss.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all InRelease
Err:18 https://10gbps-io.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release
  gnutls_handshake() failed: Public key signature verification has failed.
Lecture des listes de paquets... Fait
E: The repository 'https://apt.movim.eu/debian jessie Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://deb.opera.com/opera-stable stable Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
 



# apt-get upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  chromium ffmpegthumbs mplayer2
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de apt-listchanges (3.10) ...
Traceback (most recent call last):
  File "/tmp/tmp.FtNmyzwrJu.aptlc/debconf-helper.py", line 6, in <module>
    import debconf
ModuleNotFoundError: No module named 'debconf'
dpkg: erreur de traitement du paquet apt-listchanges (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apt-listchanges
E: Sub-process /usr/bin/dpkg returned an error code (1)



# dmesg | grep failed


[   21.807924] amdgpu 0000:02:00.0: Direct firmware load for amdgpu/polaris12_mc.bin failed with error -2
[   21.808289] [drm:amdgpu_device_init [amdgpu]] *ERROR* sw_init of IP block <gmc_v8_0> failed -2
[   21.808387] amdgpu 0000:02:00.0: amdgpu_init failed
[   21.809384] amdgpu: probe of 0000:02:00.0 failed with error -2
[   49.510364] systemd[1]: vdr.service: Changed start -> failed
[   49.510597] systemd[1]: vdr.service: Job vdr.service/start finished, result=failed

Dernière modification par Debian Alain (16-06-2017 20:56:39)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#13 16-06-2017 20:27:42

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] passer de debian 8 à debian 9

ceci est a retiré ne sert plus a rien


#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main
 



ceci est correct


deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
 



ceci est incorrect


# installer depuis les backports : apt-get -t stretch-backports install xxx
# Backports repository
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free
 


la bonne ligne est


deb http://ftp.fr.debian.org/debian stretch-backports main contrib non-free
 



ceci est mauvais tu a quelque chose dans /etc/apt/sources.list.d/nom_du_fichier


Ign:2 http://linux.dropbox.com/debian jessie InRelease                                                                                    
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
 



tout ceci est pas normal (tu fais appel a des dépots non debian , qui ne correspondent pas a stretch (jessie ou stable) etc .....  )


Atteint:4 http://www.deb-multimedia.org jessie InRelease
Atteint:6 http://linux.dropbox.com/debian jessie Release
Atteint:7 http://dl.google.com/linux/chrome/deb stable Release
Ign:8 https://apt.movim.eu/debian jessie InRelease                                                                                        
Ign:9 https://deb.opera.com/opera-stable stable InRelease

Atteint:10 ftp://ftp.deb-multimedia.org jessie InRelease
Err:13 https://apt.movim.eu/debian jessie Release                                                                                        
  gnutls_handshake() failed: Public key signature verification has failed.
Err:16 https://deb.opera.com/opera-stable stable Release      
  gnutls_handshake() failed: Public key signature verification has failed.

Ign:12 https://netcologne.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all InRelease
Atteint:14 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease          
Err:18 https://10gbps-io.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release
  gnutls_handshake() failed: Public key signature verification has failed.

E: The repository 'https://apt.movim.eu/debian jessie Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://deb.opera.com/opera-stable stable Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
 



et l autormove me fait peur  , trop de paquet a enlever  hmm
il faut que apt-get update ne renvoie aucune erreur


apt-get update
 


retour


Atteint:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://ftp.fr.debian.org/debian stretch-updates InRelease
Atteint:3 http://ftp.fr.debian.org/debian stretch-backports InRelease
Réception de:4 http://security.debian.org stretch/updates InRelease [62,9 kB]
62,9 ko réceptionnés en 0s (81,9 ko/s)
Lecture des listes de paquets... Fait
 

Dernière modification par robert2a (16-06-2017 20:48:17)

Hors ligne

#14 16-06-2017 21:08:49

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

c'est mieux comme ça ?

# apt-get update


Atteint:1 http://ftp.fr.debian.org/debian stretch InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease          
Atteint:3 http://dl.google.com/linux/chrome/deb stable Release                
Atteint:4 http://ftp.fr.debian.org/debian stretch-updates InRelease            
Réception de:5 http://ftp.fr.debian.org/debian stretch-backports InRelease [46,8 kB]
Atteint:7 http://security.debian.org stretch/updates InRelease                
46,8 ko réceptionnés en 0s (79,1 ko/s)                        
Lecture des listes de paquets... Fait



je  pense que oui , non ?

j'avais oublié /etc/apt/sources.list.d/

malgré tout :

# apt-get upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  chromium ffmpegthumbs mplayer2
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de apt-listchanges (3.10) ...
Traceback (most recent call last):
  File "/tmp/tmp.rl2UOFHDJC.aptlc/debconf-helper.py", line 6, in <module>
    import debconf
ModuleNotFoundError: No module named 'debconf'
dpkg: erreur de traitement du paquet apt-listchanges (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apt-listchanges
E: Sub-process /usr/bin/dpkg returned an error code (1)



# apt-get dist-upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  devede mplayer
Les paquets suivants ont été conservés :
  chromium ffmpegthumbs
Les paquets suivants seront mis à jour :
  mplayer2
1 mis à jour, 0 nouvellement installés, 2 à enlever et 2 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 40,5 ko dans les archives.
Après cette opération, 32,3 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://ftp.fr.debian.org/debian stretch/main amd64 mplayer2 all 3:0.23.0-2 [40,5 kB]
40,5 ko réceptionnés en 0s (340 ko/s)
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 464930 fichiers et répertoires déjà installés.)
Suppression de devede (1:3.23.0-dmo1) ...
Suppression de mplayer (3:1.1.1+20150226+svn37375-dmo5+deb8u3) ...
update-alternatives: utilisation de « /usr/bin/mplayer2 » pour fournir « /usr/bin/mplayer » (mplayer) en mode automatique
(Lecture de la base de données... 464740 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mplayer2_3%3a0.23.0-2_all.deb ...
Dépaquetage de mplayer2 (3:0.23.0-2) sur (1:2.0~git20130903-dmo7) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Paramétrage de mplayer2 (3:0.23.0-2) ...
Paramétrage de apt-listchanges (3.10) ...
Traceback (most recent call last):
  File "/tmp/tmp.ZEowcsMmvH.aptlc/debconf-helper.py", line 6, in <module>
    import debconf
ModuleNotFoundError: No module named 'debconf'
dpkg: erreur de traitement du paquet apt-listchanges (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) ...
Des erreurs ont été rencontrées pendant l'exécution :
 apt-listchanges
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dernière modification par Debian Alain (16-06-2017 21:17:40)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#15 16-06-2017 21:15:01

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] passer de debian 8 à debian 9

j'ai bien compris  old_geek.gif

stretch est a jour ?
ceci donne quoi


uname -a
 



par contre maintenant le souci comment nettoyer et mettre a jour tout ce qui est hors debian
je préfère laisser la parole au experts  hmm
nota: je n utilise que les dépots debian meme si des choses ne fonctionne pas

Dernière modification par robert2a (16-06-2017 21:17:32)

Hors ligne

#16 16-06-2017 21:22:17

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

$ uname -a


Linux debian 4.11.4-amd64 #1 SMP Thu Jun 8 00:37:42 CEST 2017 x86_64 GNU/Linux



$ cat /etc/issue


Debian GNU/Linux 9 \n \l



$ sudo dpkg --configure --force-all -a


[sudo] Mot de passe de alain : 
Paramétrage de apt-listchanges (3.10) ...
Traceback (most recent call last):
  File "/tmp/tmp.l2VkSpLQyq.aptlc/debconf-helper.py", line 6, in <module>
    import debconf
ModuleNotFoundError: No module named 'debconf'
dpkg: erreur de traitement du paquet apt-listchanges (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apt-listchanges



suivant : https://doc.ubuntu-fr.org/probleme_apt

chapitre 15

j'ai fait

En cas d'autres erreurs, pour tenter de débloquer apt sans devoir redémarrer :

sudo rm /var/lib/apt/lists/lock /var/lib/dpkg/lock /var/cache/apt/archives/lock
sudo killall apt-get



pas de résultat

suivant

Autre solution possible :

Supprimer tous les fichiers d'installation du paquet par exemple :

sudo rm /usr/bin/[nom du PAQUET] /usr/share/doc/[nom du PAQUET]
sudo rm /usr/share/man/man1/[nom du PAQUET].1.gz
sudo rm /var/crash/[nom du PAQUET].0.crash
sudo rm /var/lib/dpkg/info/[nom du PAQUET].list
sudo rm /var/lib/dpkg/info/[nom du PAQUET].md5sums
sudo rm /var/lib/dpkg/info/[nom du PAQUET].postinst
sudo rm /var/lib/dpkg/info/[nom du PAQUET].prerm
(Pour les localiser utiliser # locate [nom du PAQUET] par exemple.)

Normalement à partir de là l'erreur a disparu.

Vous pouvez désinstaller le paquet proprement puis le réinstaller :

sudo apt-get remove [nom du PAQUET]; sudo apt-get install [nom du PAQUET]



j'ai préféré faire :

$ sudo apt-get install --reinstall apt-listchanges


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 2 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
E: Internal Error, No file name for apt-listchanges:amd64



pourtant :

$ sudo locate apt-listchanges


/usr/bin/apt-listchanges
/usr/share/apt-listchanges
/usr/share/apt-listchanges/ALCConfig.py
/usr/share/apt-listchanges/ALCConfig.pyc
/usr/share/apt-listchanges/ALChacks.py
/usr/share/apt-listchanges/ALChacks.pyc
/usr/share/apt-listchanges/AptListChangesGtk.py
/usr/share/apt-listchanges/AptListChangesGtk.pyc
/usr/share/apt-listchanges/DebianFiles.py
/usr/share/apt-listchanges/DebianFiles.pyc
/usr/share/apt-listchanges/apt-listchanges.glade
/usr/share/apt-listchanges/apt_listchanges.py
/usr/share/apt-listchanges/apt_listchanges.pyc
/usr/share/doc/apt-listchanges
/usr/share/doc/apt-listchanges/README.Debian
/usr/share/doc/apt-listchanges/TODO
/usr/share/doc/apt-listchanges/changelog.gz
/usr/share/doc/apt-listchanges/copyright
/usr/share/locale/fr/LC_MESSAGES/apt-listchanges.mo
/usr/share/man/fr/man1/apt-listchanges.1.gz
/usr/share/man/man1/apt-listchanges.1.gz
/usr/share/python-support/apt-listchanges.private
/var/lib/dpkg/info/apt-listchanges.conffiles
/var/lib/dpkg/info/apt-listchanges.config
/var/lib/dpkg/info/apt-listchanges.list
/var/lib/dpkg/info/apt-listchanges.md5sums
/var/lib/dpkg/info/apt-listchanges.postinst
/var/lib/dpkg/info/apt-listchanges.postrm
/var/lib/dpkg/info/apt-listchanges.preinst
/var/lib/dpkg/info/apt-listchanges.prerm
/var/lib/dpkg/info/apt-listchanges.templates

Dernière modification par Debian Alain (16-06-2017 23:14:36)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#17 17-06-2017 02:08:41

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] passer de debian 8 à debian 9

tu a migré avec un noyau 4.11 de kernel.org ?
si tu continue a expérimenté des commandes tu va tout cassé si ce n'est pas dèja fait  hmm

il te faut nettoyer ce qui n'est pas debian et qui est surement en version jessie encore . (multimédia et autres )
et le remettre en version stretch (un lien avec tout ce qui n'est pas dans les dépots debian )

pas de problème avec apt-get ou apt-listchanges , juste que tu a des choses exotiques installées en version jessie.
ps : quand je vois des "sudo rm "  j'ai des sueurs  hmm  sad

tu a le bureau fonctionnel ?  si oui regarde avec synaptic ce qu il te propose de désinstaller  (paquet plus utilisés )
mais calmement , et un par un (en vérifiant l origine et la version )

tu a un fichier qui s'appelle "debian_version"  (a priori tu est en 4.9 )


cat /etc/debian_version
 


vire ce vilain noyau 4.11  (avec synaptic et proprement )
il te reste 2 jours pour arriver a une stretch stable  roll  (le point sur les programmes qui ne fonctionne plus , ne pas hésiter a les enlever et les purger )

Dernière modification par robert2a (17-06-2017 02:21:54)

Hors ligne

#18 17-06-2017 09:09:27

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

$ cat /etc/debian_version


9.0



j'ai vérifié avec synaptic : j'avais une quinzaine de "nouveaux fichiers"  à installer dont mesa (nouveaux dans le dépôt)

mesa -va-drivers ne s'installe pas 

This change is not coming from a source that supports changelogs.

Failed to fetch the changelog for mesa-va-drivers
URI was: http://packages.debian.org/changelogs/p … /changelog



quant à mesa-vulkan-drivers , c'est pas mieux

This change is not coming from a source that supports changelogs.

Failed to fetch the changelog for mesa-vulkan-drivers
URI was: http://packages.debian.org/changelogs/p … /changelog



côté "installés (pouvant être supprimés) " , j'en ai une vingtaine .
ça va de libavfilter6 à libzmq5 en passant par libkf5jobwidget5 , libminizip1  et libpostproc54 voire libre2-3

je ne sais pas quoi en faire , j'attends tes conseils .

pour le noyau , je veux bien mais linux a installé un kernel 4.9.0-3
je ne pourrai donc plus rien faire pour ma carte  video

mais je m'exécute

linux-image-4.9.0-0.bpo.2 amd64 )
linux-image-4.9.0-0.bpo.3 amd64 )
linux-image-4.11.4            amd64 )=> retirés

reste

$ uname -a


Linux debian 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2 (2017-06-12) x86_64 GNU/Linux



d'autant plus que :

$ sudo apt-cache search linux-image-4.


[sudo] Mot de passe de alain : 
linux-image-4.9.0-3-686 - Linux 4.9 pour les anciens ordinateurs
linux-image-4.9.0-3-686-pae - Linux 4.9 pour les ordinateurs modernes
linux-image-4.9.0-3-amd64 - Linux 4.9 pour les ordinateurs 64 bits
linux-image-4.9.0-3-rt-686-pae - Linux 4.9 pour les ordinateurs récents avec PREEMPT_RT
linux-image-4.9.0-3-rt-amd64 - Linux 4.9 pour les ordinateurs 64 bits avec PREEMPT_RT
linux-headers-4.9.0-3-686 - Header files for Linux 4.9.0-3-686
linux-headers-4.9.0-3-686-pae - Header files for Linux 4.9.0-3-686-pae
linux-headers-4.9.0-3-amd64 - Header files for Linux 4.9.0-3-amd64
linux-headers-4.9.0-3-rt-686-pae - Header files for Linux 4.9.0-3-rt-686-pae
linux-headers-4.9.0-3-rt-amd64 - Header files for Linux 4.9.0-3-rt-amd64
linux-image-4.9.0-3-686-dbg - Debug symbols for linux-image-4.9.0-3-686
linux-image-4.9.0-3-686-pae-dbg - Debug symbols for linux-image-4.9.0-3-686-pae
linux-image-4.9.0-3-amd64-dbg - Debug symbols for linux-image-4.9.0-3-amd64
linux-image-4.9.0-3-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-3-rt-686-pae
linux-image-4.9.0-3-rt-amd64-dbg - Debug symbols for linux-image-4.9.0-3-rt-amd64



ce qui veut dire que , apparemment , les images officielles des backports n'existent plus


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#19 17-06-2017 10:17:17

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

A l Aide

j ai perdu mon bureau

comment le reinstaller s.v.p.

avec clonezilla , j'ai restauré debian 8

je ré-essaie

$ cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free


deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# installer depuis les backports : apt-get -t jessie-bacports install xxx
# Backports repository
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

# fr multimedia codecs
# deb http://www.deb-multimedia.org stable main non-free

# multisystem multiboot sur cle usb
# deb http://liveusb.info/multisystem/depot all main
# deb-src http://liveusb.info/multisystem/depot all main

# virtualbox
# deb http://download.virtualbox.org/virtualbox/debian jessie contrib



bon , de ce côté là , c'est bon .

$ ls /etc/apt/sources.list.d/


deb-multimedia.org.list.bak  plexmediaserver.list
dropbox.list.bak             plexmediaserver.list.dpkg-old
google-chrome.list           ubuntuzilla.list.bak
movim.list.bak



de ce côté là aussi

$ sudo apt-get update


[sudo] password for alain:
Atteint http://ftp.fr.debian.org stretch InRelease
Ign http://dl.google.com stable InRelease                                      
Atteint http://security.debian.org stretch/updates InRelease                  
Atteint http://ftp.fr.debian.org stretch-updates InRelease                    
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://dl.google.com stable Release                                    
Réception de : 1 http://ftp.fr.debian.org stretch/main Sources/DiffIndex [27,9 kB]
Atteint http://security.debian.org stretch/updates/main Sources                
Atteint http://dl.google.com stable/main amd64 Packages                        
Réception de : 2 http://ftp.fr.debian.org stretch/contrib Sources/DiffIndex [27,8 kB]
Atteint http://security.debian.org stretch/updates/contrib Sources            
Réception de : 3 http://ftp.fr.debian.org stretch/non-free Sources/DiffIndex [27,8 kB]
Atteint http://security.debian.org stretch/updates/non-free Sources            
Atteint http://httpredir.debian.org stretch-backports InRelease                
Atteint http://security.debian.org stretch/updates/main amd64 Packages        
Réception de : 4 http://ftp.fr.debian.org stretch/main amd64 Packages/DiffIndex [27,9 kB]
Réception de : 5 http://ftp.fr.debian.org stretch/contrib amd64 Packages/DiffIndex [27,8 kB]
Réception de : 6 http://ftp.fr.debian.org stretch/non-free amd64 Packages/DiffIndex [27,8 kB]
Réception de : 7 http://ftp.fr.debian.org stretch/main i386 Packages/DiffIndex [27,9 kB]
Réception de : 8 http://ftp.fr.debian.org stretch/contrib i386 Packages/DiffIndex [27,8 kB]
Réception de : 9 http://ftp.fr.debian.org stretch/non-free i386 Packages/DiffIndex [27,8 kB]
Réception de : 10 http://ftp.fr.debian.org stretch/contrib Translation-en/DiffIndex [27,8 kB]
Atteint http://security.debian.org stretch/updates/contrib amd64 Packages      
Atteint http://security.debian.org stretch/updates/non-free amd64 Packages    
Atteint http://security.debian.org stretch/updates/main i386 Packages          
Atteint http://security.debian.org stretch/updates/contrib i386 Packages      
Atteint http://security.debian.org stretch/updates/non-free i386 Packages      
Atteint http://security.debian.org stretch/updates/contrib Translation-en      
Atteint http://security.debian.org stretch/updates/main Translation-en        
Atteint http://security.debian.org stretch/updates/non-free Translation-en    
Réception de : 11 http://ftp.fr.debian.org stretch/main Translation-fr/DiffIndex [27,8 kB]
Réception de : 12 http://ftp.fr.debian.org stretch/main Translation-en/DiffIndex [27,9 kB]
Réception de : 13 http://ftp.fr.debian.org stretch/non-free Translation-en/DiffIndex [27,8 kB]
Atteint http://ftp.fr.debian.org stretch-updates/main Sources
Atteint http://ftp.fr.debian.org stretch-updates/contrib Sources
Atteint http://ftp.fr.debian.org stretch-updates/non-free Sources
Atteint http://ftp.fr.debian.org stretch-updates/main amd64 Packages
Atteint http://ftp.fr.debian.org stretch-updates/contrib amd64 Packages
Atteint http://ftp.fr.debian.org stretch-updates/non-free amd64 Packages
Atteint http://ftp.fr.debian.org stretch-updates/main i386 Packages            
Atteint http://ftp.fr.debian.org stretch-updates/contrib i386 Packages        
Atteint http://ftp.fr.debian.org stretch-updates/non-free i386 Packages        
Ign http://dl.google.com stable/main Translation-fr_FR                        
Atteint http://httpredir.debian.org stretch-backports/main amd64 Packages      
Ign http://dl.google.com stable/main Translation-fr                            
Ign http://dl.google.com stable/main Translation-en                            
Atteint http://ftp.fr.debian.org stretch-updates/contrib Translation-en        
Atteint http://ftp.fr.debian.org stretch-updates/main Translation-en          
Atteint http://httpredir.debian.org stretch-backports/contrib amd64 Packages  
Atteint http://ftp.fr.debian.org stretch-updates/non-free Translation-en      
Atteint http://httpredir.debian.org stretch-backports/non-free amd64 Packages  
Atteint http://httpredir.debian.org stretch-backports/main i386 Packages
Atteint http://httpredir.debian.org stretch-backports/contrib i386 Packages
Atteint http://httpredir.debian.org stretch-backports/non-free i386 Packages
Atteint http://httpredir.debian.org stretch-backports/contrib Translation-en
Atteint http://httpredir.debian.org stretch-backports/main Translation-en
Atteint http://httpredir.debian.org stretch-backports/non-free Translation-en
362 ko réceptionnés en 3s (111 ko/s)
Lecture des listes de paquets... Fait



là , c'est pareil . tout est ok donc , je passe à

# apt-get upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 tuxboot : Dépend: libc6-i386 mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
 


# apt-get -f install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libc6-i686:i386
Veuillez utiliser « apt-get autoremove » pour le supprimer.
Les paquets supplémentaires suivants seront installés :
  binutils libc-bin libc-dev-bin libc-l10n libc6 libc6:i386 libc6-dbg
  libc6-dev libc6-i386 libc6-i686:i386 linux-libc-dev locales
Paquets suggérés :
  binutils-doc glibc-doc glibc-doc:i386 libc-l10n:i386 locales:i386
Les NOUVEAUX paquets suivants seront installés :
  libc-l10n libc6-i386
Les paquets suivants seront mis à jour :
  binutils libc-bin libc-dev-bin libc6 libc6:i386 libc6-dbg libc6-dev
  libc6-i686:i386 linux-libc-dev locales
10 mis à jour, 2 nouvellement installés, 0 à enlever et 2776 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 29,5 Mo dans les archives.
Après cette opération, 7 401 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de : 1 http://ftp.fr.debian.org/debian/ stretch/main locales all 2.24-11 [3 290 kB]
Réception de : 2 http://ftp.fr.debian.org/debian/ stretch/main libc-l10n all 2.24-11 [819 kB]
Réception de : 3 http://ftp.fr.debian.org/debian/ stretch/main libc6-i686 i386 2.24-11 [199 kB]
Réception de : 4 http://ftp.fr.debian.org/debian/ stretch/main libc6 amd64 2.24-11 [2 691 kB]
Réception de : 5 http://ftp.fr.debian.org/debian/ stretch/main libc6 i386 2.24-11 [2 467 kB]
Réception de : 6 http://ftp.fr.debian.org/debian/ stretch/main libc-dev-bin amd64 2.24-11 [258 kB]
Réception de : 7 http://ftp.fr.debian.org/debian/ stretch/main linux-libc-dev amd64 4.9.30-2 [1 251 kB]
Réception de : 8 http://ftp.fr.debian.org/debian/ stretch/main binutils amd64 2.28-5 [3 770 kB]
Réception de : 9 http://ftp.fr.debian.org/debian/ stretch/main libc6-dev amd64 2.24-11 [2 364 kB]
Réception de : 10 http://ftp.fr.debian.org/debian/ stretch/main libc6-dbg amd64 2.24-11 [9 065 kB]
Réception de : 11 http://ftp.fr.debian.org/debian/ stretch/main libc-bin amd64 2.24-11 [779 kB]
Réception de : 12 http://ftp.fr.debian.org/debian/ stretch/main libc6-i386 amd64 2.24-11 [2 593 kB]
29,5 Mo réceptionnés en 4s (7 032 ko/s)
Lecture des fichiers de modifications (« changelog »)... Terminé
apt-listchanges: Envoi des modifications par courriel à root : apt-listchanges : nouveautés pour debian
sendmail: fatal: open /etc/postfix/main.cf: No such file or directory
Préconfiguration des paquets...
(Lecture de la base de données... 381967 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../locales_2.24-11_all.deb ...
Dépaquetage de locales (2.24-11) sur (2.19-18+deb8u9) ...
Sélection du paquet libc-l10n précédemment désélectionné.
Préparation du dépaquetage de .../libc-l10n_2.24-11_all.deb ...
Dépaquetage de libc-l10n (2.24-11) ...
Préparation du dépaquetage de .../libc6-i686_2.24-11_i386.deb ...
Dépaquetage de libc6-i686:i386 (2.24-11) sur (2.19-18+deb8u9) ...
Préparation du dépaquetage de .../libc6_2.24-11_i386.deb ...
Déconfiguration de libc6:amd64 (2.19-18+deb8u9) ...
Checking for services that may need to be restarted...
Checking init scripts...
Dépaquetage de libc6:i386 (2.24-11) sur (2.19-18+deb8u9) ...
Préparation du dépaquetage de .../libc6_2.24-11_amd64.deb ...
Checking for services that may need to be restarted...
Checking init scripts...
Dépaquetage de libc6:amd64 (2.24-11) sur (2.19-18+deb8u9) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u9) ...
Paramétrage de libc6:amd64 (2.24-11) ...
Checking for services that may need to be restarted...
Checking init scripts...

Restarting services possibly affected by the upgrade:
  postfix: restarting...done.
  cups: restarting...done.
  cron: restarting...done.
  atd: restarting...done.

Services restarted successfully.
Paramétrage de libc6:i386 (2.24-11) ...
Installation de la nouvelle version du fichier de configuration /etc/ld.so.conf.d/i386-linux-gnu.conf ...
Checking for services that may need to be restarted...
Checking init scripts...

Restarting services possibly affected by the upgrade:
  postfix: restarting...done.
  cups: restarting...done.
  cron: restarting...done.
  atd: restarting...done.

Services restarted successfully.
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u9) ...
(Lecture de la base de données... 381931 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libc-dev-bin_2.24-11_amd64.deb ...
Dépaquetage de libc-dev-bin (2.24-11) sur (2.19-18+deb8u9) ...
Préparation du dépaquetage de .../linux-libc-dev_4.9.30-2_amd64.deb ...
Dépaquetage de linux-libc-dev:amd64 (4.9.30-2) sur (3.16.43-2) ...
Préparation du dépaquetage de .../binutils_2.28-5_amd64.deb ...
Dépaquetage de binutils (2.28-5) sur (2.25-5+deb8u1) ...
Préparation du dépaquetage de .../libc6-dev_2.24-11_amd64.deb ...
Dépaquetage de libc6-dev:amd64 (2.24-11) sur (2.19-18+deb8u9) ...
Préparation du dépaquetage de .../libc6-dbg_2.24-11_amd64.deb ...
Dépaquetage de libc6-dbg:amd64 (2.24-11) sur (2.19-18+deb8u9) ...
Préparation du dépaquetage de .../libc-bin_2.24-11_amd64.deb ...
Dépaquetage de libc-bin (2.24-11) sur (2.19-18+deb8u9) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Paramétrage de libc-bin (2.24-11) ...
Sélection du paquet libc6-i386 précédemment désélectionné.
(Lecture de la base de données... 382042 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libc6-i386_2.24-11_amd64.deb ...
Dépaquetage de libc6-i386 (2.24-11) ...
Remplacés par des fichiers du paquet libc6:i386 (2.24-11) déjà installé...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11) ...
Paramétrage de libc-l10n (2.24-11) ...
Paramétrage de locales (2.24-11) ...
Installation de la nouvelle version du fichier de configuration /etc/locale.alias ...
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.
Paramétrage de libc6-i686:i386 (2.24-11) ...
Paramétrage de libc-dev-bin (2.24-11) ...
Paramétrage de linux-libc-dev:amd64 (4.9.30-2) ...
Paramétrage de binutils (2.28-5) ...
Paramétrage de libc6-dev:amd64 (2.24-11) ...
Paramétrage de libc6-dbg:amd64 (2.24-11) ...
Paramétrage de libc6-i386 (2.24-11) ...
Paramétrage de tuxboot (0.8debian1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11) ...
 


# apt-get upgrade


tout semble se dérouler normalement


comme je le prévoyais , dpkg m'a fait des erreurs .
style : impossible d'effacer le dossier xxxx , il n'est pas vide
et d'autres encore

comment retrouver ces  erreurs ? (ou le rapport de apt-get upgrade) ?

apparemment , le rapport d'apt se trouve dans /var/log/apt
mais pour les  erreurs dpkg ? on les trouve comment ? j'ai pas  envie de passer 1/4 heure à faire défiler le log pour les trouver .
surtout qu'elles ont eu lieu au début  du processus pour  la plupart .

bon erreurs de dpkg introuvables . ou je sais pas chercher .

# apt-get update


Atteint http://ftp.fr.debian.org stretch InRelease
Ign http://dl.google.com stable InRelease                                      
Atteint http://ftp.fr.debian.org stretch-updates InRelease                    
Atteint http://security.debian.org stretch/updates InRelease                  
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://dl.google.com stable Release                                    
Réception de : 1 http://ftp.fr.debian.org stretch/main Sources/DiffIndex [27,9 kB]
Atteint http://security.debian.org stretch/updates/main Sources                
Atteint http://dl.google.com stable/main amd64 Packages                        
Réception de : 2 http://ftp.fr.debian.org stretch/contrib Sources/DiffIndex [27,8 kB]
Atteint http://security.debian.org stretch/updates/contrib Sources            
Réception de : 3 http://ftp.fr.debian.org stretch/non-free Sources/DiffIndex [27,8 kB]
Atteint http://security.debian.org stretch/updates/non-free Sources            
Atteint http://httpredir.debian.org stretch-backports InRelease                
Réception de : 4 http://ftp.fr.debian.org stretch/main amd64 Packages/DiffIndex [27,9 kB]
Atteint http://security.debian.org stretch/updates/main amd64 Packages        
Réception de : 5 http://ftp.fr.debian.org stretch/contrib amd64 Packages/DiffIndex [27,8 kB]
Réception de : 6 http://ftp.fr.debian.org stretch/non-free amd64 Packages/DiffIndex [27,8 kB]
Réception de : 7 http://ftp.fr.debian.org stretch/main i386 Packages/DiffIndex [27,9 kB]
Réception de : 8 http://ftp.fr.debian.org stretch/contrib i386 Packages/DiffIndex [27,8 kB]
Réception de : 9 http://ftp.fr.debian.org stretch/non-free i386 Packages/DiffIndex [27,8 kB]
Réception de : 10 http://ftp.fr.debian.org stretch/contrib Translation-en/DiffIndex [27,8 kB]
Atteint http://security.debian.org stretch/updates/contrib amd64 Packages      
Atteint http://security.debian.org stretch/updates/non-free amd64 Packages    
Atteint http://security.debian.org stretch/updates/main i386 Packages          
Atteint http://security.debian.org stretch/updates/contrib i386 Packages      
Atteint http://security.debian.org stretch/updates/non-free i386 Packages      
Atteint http://security.debian.org stretch/updates/contrib Translation-en      
Atteint http://security.debian.org stretch/updates/main Translation-en        
Atteint http://security.debian.org stretch/updates/non-free Translation-en    
Réception de : 11 http://ftp.fr.debian.org stretch/main Translation-fr/DiffIndex [27,8 kB]
Réception de : 12 http://ftp.fr.debian.org stretch/main Translation-en/DiffIndex [27,9 kB]
Réception de : 13 http://ftp.fr.debian.org stretch/non-free Translation-en/DiffIndex [27,8 kB]
Atteint http://httpredir.debian.org stretch-backports/main amd64 Packages
Atteint http://ftp.fr.debian.org stretch-updates/main Sources
Atteint http://ftp.fr.debian.org stretch-updates/contrib Sources
Atteint http://ftp.fr.debian.org stretch-updates/non-free Sources
Atteint http://ftp.fr.debian.org stretch-updates/main amd64 Packages
Atteint http://ftp.fr.debian.org stretch-updates/contrib amd64 Packages
Atteint http://ftp.fr.debian.org stretch-updates/non-free amd64 Packages
Atteint http://ftp.fr.debian.org stretch-updates/main i386 Packages            
Atteint http://ftp.fr.debian.org stretch-updates/contrib i386 Packages        
Atteint http://ftp.fr.debian.org stretch-updates/non-free i386 Packages        
Ign http://dl.google.com stable/main Translation-fr_FR                        
Atteint http://ftp.fr.debian.org stretch-updates/contrib Translation-en        
Ign http://dl.google.com stable/main Translation-fr                            
Ign http://dl.google.com stable/main Translation-en                            
Atteint http://ftp.fr.debian.org stretch-updates/main Translation-en          
Atteint http://httpredir.debian.org stretch-backports/contrib amd64 Packages  
Atteint http://ftp.fr.debian.org stretch-updates/non-free Translation-en      
Atteint http://httpredir.debian.org stretch-backports/non-free amd64 Packages  
Atteint http://httpredir.debian.org stretch-backports/main i386 Packages
Atteint http://httpredir.debian.org stretch-backports/contrib i386 Packages
Atteint http://httpredir.debian.org stretch-backports/non-free i386 Packages
Atteint http://httpredir.debian.org stretch-backports/contrib Translation-en
Atteint http://httpredir.debian.org stretch-backports/main Translation-en
Atteint http://httpredir.debian.org stretch-backports/non-free Translation-en
362 ko réceptionnés en 3s (111 ko/s)
Lecture des listes de paquets... Fait
N: « 50unattended-upgrades.ucf-old » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
 

Dernière modification par Debian Alain (17-06-2017 13:21:53)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#20 17-06-2017 13:13:47

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] passer de debian 8 à debian 9

Bonjour
" le dossier machin n'est pas vide il ne sera pas supprimé "
ce n'est pas une erreur mais juste pour te prévenir  (tu a les logs de dpkg dans /var/log/dpkg.log )
nota : debian ne supprimera jamais un dossier qui n'est pas vide et ne modifira pas un fichier de config sans ton accord (en général il fait une copie du fichier , soit de l original , soit du nouveau si tu a refusé la modification)
je vois pas le dist-upgrade ?

le système se débrouille tout seul
il n y a que les applications non debian qui peuvent poser problème comme le multimédia .

tu a lancé la migration en mode texte (sans bureau ) , ça aide les paquets ne sont pas utilisé.
après les 3 commandes update , upgrade et dist-upgrade tu reboot et tu dois avoir l invite de logging graphique.
après surement du nettoyage a faire
faire un point sur ce qui ne fonctionne plus (je pense aux applications non debian )
pour le bureau tu est sous gnome et gdm3 , ça a fonctionné avec les backports , donc sous stretch tu dois avoir la meme chose.

en plus tu a un gpu intel (du processeur ) tu ne la jamais testé sous stretch ce sera l occasion  (enlever la carte RX550 ) l'écran 30 pouces mal géré par le gpu intel ( ce sera toujours le cas , limitation du gpu intel )

si tu a une sauvegarde (de jessie ) l option de faire une installation neuve de stretch est pas mal aussi

évite de migrer avec un noyau non debian , il sera toujours possible d en compiler un plus tard pour stretch , bien que ça ne va pas t apporter grand chose pour l instant .

nota : il peut y avoir des paquets qui ont disparut dans stretch ( pour diverses raisons , je connais pas le détail )

tu a le bureau fonctionnel maintenant ?

Dernière modification par robert2a (17-06-2017 13:19:47)

Hors ligne

#21 17-06-2017 13:31:16

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

merci pour le /var/log/dpkg.log

j'y avais pas pensé .

en fait j'ai réinstallé une vielle sauvegarde de debian 8 (kernel 4.9.0-0.bpo.2)

là je suis en plein dist-upgrade , j'en ai encore pour au moins une heure si tout va bien .

à propos : j'ai vu que conky  ne fonctionne plus sous stretch .

cause code trop vieux ou plutôt syntaxe trop ancienne , tu confirmes ?

dommage , je l'aimais bien .

# apt-get dist-upgrade


Des erreurs ont été rencontrées pendant l'exécution :
 apt-listchanges
N: « 50unattended-upgrades.ucf-old » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



reboot

Dernière modification par Debian Alain (17-06-2017 14:49:16)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#22 17-06-2017 13:43:17

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] passer de debian 8 à debian 9

pour conky faut demander a ceux qui l'utilisent , mais tu est sur qu une mise a niveau n'est pas en cour

le retour des erreurs sur ma machine


journalctl -r -p err
 



-- Logs begin at Sat 2017-06-17 13:29:11 CEST, end at Sat 2017-06-17 13:33:00 CEST. --
juin 17 13:29:53 debian9 pulseaudio[1104]: [pulseaudio] pid.c: Daemon already running.
juin 17 13:29:53 debian9 pulseaudio[1102]: [pulseaudio] pid.c: Daemon already running.
 


sur ma stretch avec la RX550 , mais bon le bureau est minable en VESA  sad

je sais pas si l annonce officielle pour stretch stable va avoir lieu ce soir ou demain matin  en fonction du décalage horaire .

Hors ligne

#23 17-06-2017 16:13:36

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

journalctl -r -p err


-- Logs begin at Sat 2017-06-17 14:50:37 CEST, end at Sat 2017-06-17 14:59:33 CEST. --
juin 17 14:59:33 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:32 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:31 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:30 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:29 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:28 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:27 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:26 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:25 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:24 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:23 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:22 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:21 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:20 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:19 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:18 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:17 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:16 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:15 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:14 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:13 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
juin 17 14:59:12 debian lircd-0.9.4c[991]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
lines 1-23



$ cat /var/log/mail.err


Jun 17 11:41:01 debian postfix/sendmail[9125]: fatal: open /etc/postfix/main.cf: No such file or directory
Jun 17 11:52:45 debian postfix/sendmail[27367]: fatal: open /etc/postfix/main.cf: No such file or directory
Jun 17 14:31:39 debian spamd[18216]: Can't locate Mail/SpamAssassin/CompiledRegexps/body_0.pm in @INC (you may need to install the Mail::SpamAssassin::CompiledRegexps::body_0 module) (@INC contains: /var/lib/spamassassin/compiled/5.024/3.004001 /var/lib/spamassassin/compiled/5.024/3.004001/auto /usr/share/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at (eval 1131) line 1.
 



au démarrage j'ai 2 erreurs "FAILED"

1 avec le video disc recorder (je ne sais pas où la retrouver , dmesg ne me la  donne pas et journalctl est trop long )
1 avec postfix (voir  ci dessus)

je vais installer spamassassin , on verra .

sources.list  :

#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free


deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free

# installer depuis les backports : apt-get -t jessie-bacports install xxx
# Backports repository
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

# fr multimedia codecs
deb http://www.deb-multimedia.org stable main non-free

# multisystem multiboot sur cle usb
# deb http://liveusb.info/multisystem/depot all main
# deb-src http://liveusb.info/multisystem/depot all main

# virtualbox
# deb http://download.virtualbox.org/virtualbox/debian jessie contrib
 



$ sudo apt-get update


[sudo] Mot de passe de alain : 
Atteint:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://www.deb-multimedia.org stable InRelease                      
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                  
Atteint:4 http://ftp.fr.debian.org/debian stretch-updates InRelease            
Atteint:5 http://dl.google.com/linux/chrome/deb stable Release                
Atteint:6 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease  
Atteint:7 http://security.debian.org stretch/updates InRelease  
Lecture des listes de paquets... Fait
 



~$ sudo apt-get upgrade


[sudo] Mot de passe de alain : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  aspectj catdoc docutils-common docutils-doc dvdrip-doc enblend enfuse
  firebird2.5-common firebird2.5-common-doc firebird2.5-server-common
  firebird3.0-common firebird3.0-common-doc fp-compiler-2.6.4 fp-ide-2.6.4
  fp-units-base-2.6.4 fp-units-db-2.6.4 fp-units-fcl-2.6.4 fp-units-fv-2.6.4
  fp-units-gfx-2.6.4 fp-units-gnome1-2.6.4 fp-units-gtk-2.6.4
  fp-units-gtk2-2.6.4 fp-units-math-2.6.4 fp-units-misc-2.6.4
  fp-units-multimedia-2.6.4 fp-units-net-2.6.4 fp-units-rtl-2.6.4
  fp-utils-2.6.4 fpc-2.6.4 fpc-source-2.6.4 fping g++-4.9 gcj-4.9-jre-lib
  gdebi-core gir1.2-clutter-gst-2.0 gir1.2-gkbd-3.0 gir1.2-grilo-0.2
  gir1.2-gst-plugins-base-0.10 gir1.2-gtop-2.0 gir1.2-javascriptcoregtk-3.0
  gir1.2-mediaart-1.0 gir1.2-webkit-3.0 gir1.2-xkl-1.0
  gnome-packagekit-session gstreamer0.10-gconf gstreamer0.10-gnonlin
  gstreamer0.10-nice gstreamer0.10-pulseaudio gstreamer1.0-clutter
  gstreamer1.0-gnonlin gstreamer1.0-plugins-base-dbg
  gstreamer1.0-plugins-good-dbg gstreamer1.0-plugins-ugly-dbg
  gtk2-ex-formfactory-perl hardening-includes hugin hugin-data hugin-tools
  iceweasel-l10n-fr imagemagick-common kdepimlibs-data kipi-plugins-common
  lazarus-1.2.4 lazarus-doc-1.2.4 lazarus-ide-1.2.4 lazarus-ide-gtk2-1.2.4
  lazarus-src-1.2.4 lcl-1.2.4 lcl-gtk2-1.2.4 lcl-nogui-1.2.4 lcl-units-1.2.4
  lcl-utils-1.2.4 libaacplus2:i386 libaec0 libamd2.3.1 libanyevent-perl
  libarchive-extract-perl libasm4-java libasn1-8-heimdal libaspectj-java
  libastro1 libasync-interrupt-perl libavahi-client-dev libavahi-common-dev
  libavcodec56:i386 libavfilter6 libavresample2:i386 libavutil54:i386
  libbaloocore4 libbaloofiles4 libbalooxapian4 libbasicusageenvironment0
  libbind9-90 libboost-python1.55.0 libboost-random1.62.0
  libboost-thread1.55.0 libc6-i686:i386 libcamd2.3.1 libcamel-1.2-49
  libccolamd2.8.0 libcglib3-java libcholmod2.1.2 libclutter-gst-2.0-0
  libcolamd2.8.0 libcommons-lang-java libcoverart0 libdbus-glib-1-dev
  libdirectfb-dev libdirectfb-extra libdns100 libdvbpsi9 libebackend-1.2-7
  libebur128-1 libecal-1.2-16 libedata-cal-1.2-23 libedataserver-1.2-18
  libegl1-mesa-drivers libelfg0 libept1.4.12 libepub0 libev-perl
  libevent-execflow-perl libevent-perl libevent-rpc-perl libexiv2-13
  libfaac0:i386 libfame-0.9-1 libfbclient2 libfbembed2.5 libfdk-aac1:i386
  libfftw3-3 libfftw3-long3 libflann1.9 libftdi1 libgcj15 libgdata19
  libgdict-1.0-6 libgegl-0.2-0 libgeronimo-jpa-2.0-spec-java
  libgeronimo-osgi-support-java libgit2-21 libglew1.10 libgnutls-deb0-28:i386
  libgphoto2-port10 libgps21 libgps22 libgrantlee-templates5 libgrilo-0.2-1
  libgroupsock4 libgstreamer-plugins-base0.10-0:i386
  libgstreamer-plugins-base0.10-dev libgstreamer0.10-0:i386
  libgstreamer1.0-0-dbg libgtkglext1 libgtkhtml-4.0-0 libgtkhtml-4.0-common
  libgtkhtml-editor-4.0-0 libgtop2-7 libguard-perl libhcrypto4-heimdal
  libhdb9-heimdal libhdf5-100 libhdf5-8 libheimbase1-heimdal libhogweed2:i386
  libhunspell-1.3-0 libhx509-5-heimdal libical1a libicu4j-4.4-java
  libicu4j-java libieee1284-3-dev libilmbase6 libimobiledevice4 libinput5
  libintl-perl libintl-xs-perl libisc95 libisccc90 libisccfg90 libiscsi2
  libjetty8-java libjim0.75 libjs-sphinxdoc libjs-underscore libjson-c2:i386
  libkactivities-models1 libkcalcore4 libkdcraw-data libkdcraw23 libkexiv2-11
  libkexiv2-data libkf5akonadicontact5 libkf5akonadicore-bin
  libkf5bookmarks-data libkf5bookmarks5 libkf5contacts-data libkf5contacts5
  libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3
  libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5 libkf5kiofilewidgets5
  libkf5kiowidgets5 libkf5kipi-data libkf5kipi31.0.0 libkf5mime5 libkf5solid5
  libkf5solid5-data libkf5threadweaver5 libkrb5-26-heimdal libksane-data
  libksane0 liblensfun-data liblensfun-data-v1 liblensfun0 liblensfun1
  liblinear1 liblivemedia42 libllvm3.5 libllvm3.5:i386 liblog-message-perl
  liblog-message-simple-perl liblouis2 liblwres90 libmediaart-1.0-0
  libminizip1 libmodule-load-conditional-perl
  libmono-compilerservices-symbolwriter4.0-cil libmusicbrainz5-1
  libmysqlclient18 libnepomukcore4 libnettle4:i386 libnm-glib-vpn1
  libnm-gtk-common libntdb1 libopencore-amrnb0:i386 libopencore-amrwb0:i386
  libopencv-contrib2.4v5 libopencv-ml2.4v5 libopenexr6 libopenjpeg5:i386
  libopenraw1 libopenvg1-mesa liborcus-0.8-0 libosgi-foundation-ee-java
  libpackage-constants-perl libpano13-3 libpano13-bin libpgf6 libpgm-5.2-0
  libphonon4qt5-4 libplist2 libpng12-0:i386 libpod-latex-perl libpoppler-qt5-1
  libpoppler46 libpostproc54 libprotobuf9 libpth20 libqca2-plugin-ossl
  libqextserialport1 libqmi-glib1 libqpdf13 libqt5concurrent5 libqt5glib-2.0-0
  libqt5gstreamer-1.0-0 libqt5gstreamerquick-1.0-0 libqt5positioning5
  libqt5serialport5 libqt5xmlpatterns5 libqtglib-2.0-0 libqtgstreamer-0.10-0
  libqtgstreamerui-0.10-0 libqtgstreamerutils-0.10-0 libqtlocation1
  libqtwebkit-dev libquazip1 libquvi-dev libquvi-scripts libquvi7 librados2
  libraw10 librbd1 libre2-3 libreoffice-gtk libreoffice-sdbc-firebird
  libresid-builder0c2a librhythmbox-core8 libroken18-heimdal librubberband2
  librygel-core-2.4-2 librygel-renderer-2.4-2 librygel-renderer-gst-2.4-2
  librygel-server-2.4-2 libschroedinger-1.0-0:i386 libsereal-decoder-perl
  libsereal-encoder-perl libsereal-perl libservlet3.0-java libshp2 libsidplay2
  libsodium18 libspice-client-gtk-3.0-4 libsqlite0 libstreams0
  libswresample1:i386 libsz2 libterm-ui-perl libtext-soundex-perl
  libtinyxml2-2 libtomcat7-java libtommath1 libturbojpeg1 libumfpack5.6.2
  libupnp6 libusageenvironment2 libusbmuxd2 libutvideo15:i386 libv4l-dev
  libvala-0.26-0 libvigraimpex4 libvigraimpex6 libvlc5 libvlccore8
  libvo-aacenc0:i386 libvo-amrwbenc0:i386 libvpx1:i386 libwebpmux1
  libwebrtc-audio-processing-0 libwind0-heimdal libwine-gecko-2.21
  libwine-gecko-2.24 libwireshark5 libwiretap4 libwps-0.3-3 libwsutil4
  libx264-142 libx264-146:i386 libx265-51:i386 libxapian22 libxcb-composite0
  libxen-4.4 libxine2-bin libxine2-ffmpeg libxine2-x libzmq5 libzthread-2.3-2
  lsdvd m2vrequantiser marble-data nepomuk-core-data ogmtools openjdk-7-doc
  perlmagick python-cffi python-characteristic python-cups python-cycler
  python-dateutil python-dbus-dev python-defusedxml python-docutils
  python-funcsigs python-functools32 python-gdbm python-gst-1.0
  python-matplotlib python-mock python-nevow python-ntdb python-pbr python-ply
  python-pyatspi python-pycparser python-pyparsing python-roman python-smbc
  python-soappy python-subprocess32 python-twisted-conch python-twisted-lore
  python-twisted-mail python-twisted-names python-twisted-news
  python-twisted-runner python-twisted-web python-twisted-words python-wstools
  qml-module-qtgstreamer qtgstreamer-plugins-qt5 transcode-doc transcode-utils
  valac-0.26-vapi vlc-data vlc-plugin-pulse
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants ont été conservés :
  audacity audacity-data avidemux-plugins avidemux-qt chromium ffmpeg
  ffmpegthumbs gpac gpac-modules-base gstreamer1.0-plugins-bad
  gstreamer1.0-plugins-ugly handbrake-cli handbrake-gtk libasound2-plugins
  libasound2-plugins:i386 libavcodec57 libavcodec57:i386 libavfilter6
  libavformat57 libavresample3 libavresample3:i386 libavutil55
  libavutil55:i386 libchromaprint1 libgegl-0.3-0 libgstreamer-plugins-bad1.0-0
  libk3b6-extracodecs libmlt++3 libmlt6 libpostproc54 libquicktime2
  libsuil-0-0 libswresample2 libswresample2:i386 libswscale4 libvlc5
  libvlccore8 libxine2-bin libxine2-ffmpeg libxine2-x melt mencoder mkvtoolnix
  mpv
0 mis à jour, 0 nouvellement installés, 0 à enlever et 44 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de apt-listchanges (3.10) ...
Traceback (most recent call last):
  File "/tmp/tmp.4AkXZE6STx.aptlc/debconf-helper.py", line 6, in <module>
    import debconf
ModuleNotFoundError: No module named 'debconf'
dpkg: erreur de traitement du paquet apt-listchanges (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apt-listchanges
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



$ sudo apt-get autoremove



toujours la mème erreur

pourtant j'ai tout fait bien


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

#24 17-06-2017 17:11:24

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] passer de debian 8 à debian 9

tu pense que ceci a un rapport avec stretch


Atteint:2 http://www.deb-multimedia.org stable InRelease                      
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
Atteint:5 http://dl.google.com/linux/chrome/deb stable Release
 


la stable officielle est jessie , la testing stretch , a mon avis c'est pas top tout ça , sur des dépot  extérieur a debian .

tout ce qui n'est pas dépot debian de tes souces.list une copie dans tes Documents et tu efface tout dans /etc/apt/sources.list.d/tes-fichiers

idem pour ton fichier /etc/apt/sources.list , une sauvegarde et tu efface toutes les lignes qui ne pointe pas sur les dèpots debian et celles du cdrom
un autoremove --purge


apt-get update
 




apt-get autoremove --purge
 



un autoclean


apt-get autoclean
 



jusqu a ce que tu est une stretch propre

ensuite tu pose les questions pour les dépots dont tu a besoin (pour le mutimédia par exemple )
je sais pas si il existe quelque chose pour strech

pour chaque choses qui ne vient pas de debian il faudra chercher ce qui va bien pour stretch
mais avant tout il faut partir de quelque chose de propre pour stretch (avant de penser a remettre des paquets extérieur non debian )

le bureau fonctionne ou pas ?
nota : j'ai relu ton post l autoremove ne fonctionne pas ?

si ça persiste , le mieux est une installation neuve de stretch , parce que la c est la misère  sad

Dernière modification par robert2a (17-06-2017 17:34:04)

Hors ligne

#25 17-06-2017 17:50:23

Debian Alain
Membre
Lieu : BREST 29200
Distrib. : win10 / stretch / ubuntu 17.04 / buster-sid
Noyau : Linux 4.12.0-2-amd64 (stretch)
(G)UI : GNOME 3.22.2 (stretch) 3.26.0 (buster)
Inscription : 11-03-2017

Re : [résolu] passer de debian 8 à debian 9

j'ai commenté le paquet multimédia dans le sources.list donc il ne sera plus utilisé par stretch et
j'ai mis en *.bak le sources.list.d de chrome pour que stretch ne s'en serve pas .

c'était les deux erreurs qui me restaient .

j'avais oublié que stable , c'est encore jessie .

j'applique tes  commandes , on verra bien . à toute à l'heure .

ben non , faut repartir de zero .

et hop ! on recommence !

je pense que je vais encore avoir une  erreur d'APT-listchanges

j'attends la  fin , je  verrai bien .

hé voilà , ça recommence .

Des erreurs ont été rencontrées pendant l'exécution :
apt-listchanges
N: « 50unattended-upgrades.ucf-dist » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
E: Sub-process /usr/bin/dpkg returned an error code (1)



j'abandonne .

je repasse à debian 8 et j'attends quelques jours histoire de télécharger le disque .

j'en ai marre : 3 fois 4 heures de boulot pour rien !

Dernière modification par Debian Alain (17-06-2017 21:28:47)


1498826560.jpg 1498812139.jpg Bip ! Bip !

Hors ligne

Pied de page des forums