Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-10-2017 19:02:50

ottr
Membre
Lieu : Bas-Rhin
Distrib. : Mint 18.2 (anct. Archlinux, Debian 9.2.1)
Noyau : Linux: 4.8.0-53-generic
(G)UI : mate - version génépi & schnaps
Inscription : 14-10-2017

[Résolu] clisp

Bonsoir,

Il me faut le Clisp qui est niché là

https://packages.debian.org/unstable/lisp/clisp

s.v.pl: comment amender la sources-list pour que apt-get le trouve ?

a+ avec toutes mes respectueuses circonvolutions,

rené

Dernière modification par ottr (02-11-2017 11:36:24)

Hors ligne

#2 18-10-2017 19:17:26

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] clisp

C'est bizarre que clisp ne soit pas dans stretch (je viens de vérifier). Mélanger stable et unstable n'est pas une bonne idée.
Ceci dit, le paquet  clisp lui même dépend de peu de chose :


apt-cache show clisp
 



Package: clisp
Version: 1:2.49.20170913-2
Installed-Size: 10767
Maintainer: Debian Common Lisp Team <pkg-common-lisp-devel@lists.alioth.debian.org>
Architecture: amd64
Provides: clisp-fasl-loader-20100806, lisp-compiler
Depends: libc6 (>= 2.23), libffcall1a (>= 1.13), libncurses5 (>= 6), libreadline5 (>= 5.2), libsigsegv2 (>= 2.9), libtinfo5 (>= 6)
Suggests: gdb, clisp-doc, clisp-dev, slime
Conflicts: clisp-dev (<< 1:2.49.60-1)
Breaks: cl-asdf (<< 2:1.704-1), common-lisp-controller (<< 6.19)
Description-fr: GNU CLISP, une implémentation de Common Lisp
 ANSI Common Lisp est un langage de programmation haut niveau, généraliste.
 GNU CLIPS est une implémentation de Common Lisp par Bruno Haible de
 l'Université de Karlsruhe et Michael Stoll de l'Université de Munich (tout
 deux en Allemagne). Il supporte la majorité du Lisp décrit dans le standard
 ANSI Common Lisp. Il tourne sous la majorité des stations de travail Unix
 (GNU/Linux, FreeBSD, NetBSD, OpenBSD, Solaris, Tru64, HP-UX, BeOS,
 NeXTstep, IRIX, AIX et autres) et sur d'autres systèmes (Windows
 NT/2000/XP, Windows 95/98/ME) et nécessite seulement 4Mo de RAM.
 .
 C'est un logiciel libre et peut être distribué selon les termes de la GNU
 GPL mais il est possible de distribuer des applications propriétaires
 commerciales compilées avec GNU CLISP.
 .
 L'interface utilisateur est disponible en Anglais, Allemand, Français,
 Espagnol, Néerlandais, Russe et Danois et peut être modifié à l'exécution.
 GNU CLISP inclut un interpréteur, un compilateur, un debugger, CLOP, MOP,
 une interface pour les autres langages, les sockets,
 l'internationalisation, des grands entiers rapides et plus encore. Une
 interface X11 est disponible à travers CLX, Garnet, CLUE/CLIO. GNU CLISP
 fait tourner Maxima, ACL2 et de nombreux autres paquets Common Lisp.
Description-md5: 4b34a9848e82edbca3a88f7f83ffd84c
Homepage: http://www.clisp.org/
Tag: uitoolkit::ncurses
Section: lisp
Priority: optional
Filename: pool/main/c/clisp/clisp_2.49.20170913-2_amd64.deb
Size: 2462942
MD5sum: 35702d52780c9231ee529f314f41aa67
SHA256: 23d2df3acfe2b1724084382cd3a67ce4f2125757d4f097197acd820b0c0bc294
 



Tu peux déjà vérifier si ça ne va pas chambouler d'autres paquets dans ta stable.

D'autre part il y a un autre common lisp qui est très bien dans la stable : cmucl.
Tiens-tu vraiment as utilisé clisp (qui est plus lent, mais que je trouve plus sympa aussi…) ?


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#3 18-10-2017 19:28:47

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] clisp

En ce qui concerne le sources.list, il suffit d'ajouter les deux lignes :


deb http://deb.debian.org/debian sid main contrib non-free
deb-src http://deb.debian.org/debian sid main contrib non-free
 



Et aussi faire un fichier /etc/apt/preferences comme suit :


Package: *
Pin: release o=Debian,a=unstable,l=Debian
Pin-Priority: 100

Package: *
Pin: release o=Debian,a=stable,l=Debian
Pin-Priority: 900
 



Ensuite il faut faire :


apt-get update
 


Et enfin tu peux simuler une installation de clisp avec apt-get (ou aptitude) :


apt-get -s install clisp
 


Comme ça tu verras si ça ne change pas trop de choses… Je ne garanti pas que ça te permettra d'installer clisp.


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#4 18-10-2017 19:53:13

ottr
Membre
Lieu : Bas-Rhin
Distrib. : Mint 18.2 (anct. Archlinux, Debian 9.2.1)
Noyau : Linux: 4.8.0-53-generic
(G)UI : mate - version génépi & schnaps
Inscription : 14-10-2017

Re : [Résolu] clisp

Merci, suivant tes indications, j'ai installé clisp pour de bon.

Et il semble que ça marche.

rené

Hors ligne

#5 18-10-2017 23:25:50

ottr
Membre
Lieu : Bas-Rhin
Distrib. : Mint 18.2 (anct. Archlinux, Debian 9.2.1)
Noyau : Linux: 4.8.0-53-generic
(G)UI : mate - version génépi & schnaps
Inscription : 14-10-2017

Re : [Résolu] clisp

[Résolu] Oui, j'ai un clisp qui compile.

Merci.

Hors ligne

#6 19-10-2017 03:28:27

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] clisp

ottr a écrit :

[Résolu] Oui, j'ai un clisp qui compile.


Impec et merci du retour.
Le résolu se met dans le titre en éditant le post#1 ainsi :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.
smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums