Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-01-2018 15:01:41

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-1-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017
Site Web

[Résolu] en parlant de deb-multimedia

bonjour .

j'ai inclus , dans mon sources.list , les dépôts multimedia .

voilà mon policy :

~$ apt policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 100 ftp://ftp.deb-multimedia.org testing/non-free i386 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=non-free,b=i386
     origin ftp.deb-multimedia.org
 100 ftp://ftp.deb-multimedia.org testing/non-free amd64 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=non-free,b=amd64
     origin ftp.deb-multimedia.org
 100 ftp://ftp.deb-multimedia.org testing/main i386 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=main,b=i386
     origin ftp.deb-multimedia.org
 100 ftp://ftp.deb-multimedia.org testing/main amd64 Packages
     release v=0.0,o=Unofficial Multimedia Packages,a=testing,n=buster,l=Unofficial Multimedia Packages,c=main,b=amd64
     origin ftp.deb-multimedia.org
   1 http://ftp.fr.debian.org/debian experimental/non-free i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
   1 http://ftp.fr.debian.org/debian experimental/non-free amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
   1 http://ftp.fr.debian.org/debian experimental/contrib i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib,b=i386
     origin ftp.fr.debian.org
   1 http://ftp.fr.debian.org/debian experimental/contrib amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
   1 http://ftp.fr.debian.org/debian experimental/main i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
   1 http://ftp.fr.debian.org/debian experimental/main amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian unstable/non-free i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian unstable/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian unstable/contrib i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=i386
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian unstable/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian unstable/main i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian testing/non-free i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian testing/non-free amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian testing/contrib i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=contrib,b=i386
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian testing/contrib amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian testing/main i386 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
Paquets épinglés :
 



de ce côté là , tout va bien .

je vérifie vlc :

~$ apt policy vlc


vlc:
  Installé : 3.0.0~rc6-1+b1
  Candidat : 3.0.0~rc6-1+b1
 Table de version :
     1:3.0.0~rc5.real-dmo1 100
        100 ftp://ftp.deb-multimedia.org testing/main amd64 Packages
 *** 3.0.0~rc6-1+b1 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
 



je vérifie d'éventuels fichiers deb-multimédia :

~$ dpkg-query -l | grep dmo


ii  x11proto-xf86vidmode-dev                      2.3.1-2                             all          X11 Video Mode extension wire protocol


déjà , ça , c'est curieux .

malgré une désinstallation des  fichiers  dmo et une réinstallation en fichiers "officiels"  ,
rien n'y fait  , j'ai toujours ce message .

mais le plus chouette est à venir :

~$ sudo aptitude why-not vlc


[sudo] Mot de passe de alain : 
p   openssh-client:i386       Fournit             openssh-client                
p   openssh-client:i386       Suggère             ssh-askpass:i386              
p   lxqt-openssh-askpass:i386 Fournit             ssh-askpass:i386              
p   lxqt-openssh-askpass:i386 Suggère             lxqt:i386 | lxqt-core:i386    
p   lxqt:i386                 Suggère             vokoscreen:i386              
p   vokoscreen:i386           Suggère             vlc:i386 | dragonplayer:i386 |
                                                   kplayer:i386                
p   vlc:i386                  Est en conflit avec vlc
 


comprends pas :

p   vlc:i386                  Est en conflit avec vlc


ça veut dire quoi ?

inspiré de cette page et de celle là aussi

Dernière modification par Debian Alain (25-01-2018 19:35:26)


1498812139.jpg Live is Life - Opus 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#2 25-01-2018 15:12:50

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Stretch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : [Résolu] en parlant de deb-multimedia

Bonjour Debian Alain

Ca veut peut-être dire que la version i386 est en conflit avec la version amd64.

Hors ligne

#3 25-01-2018 15:13:09

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu] en parlant de deb-multimedia

Bonjour smile

Tu peux vérifier les candidats et d'où vient la version de ton paquet

apt policy x11proto-xf86vidmode-dev


Je pense qu'il n'y a pas de candidat pour ce paquet dans le dépôt multimedia, il vient donc des dépôts officiels Debian.
Il apparait dans le retour à cause de son nom x11proto-xf86vidmode-dev qui comporte les caractères dmo

Pour VLC , tu as deux versions proposées par les dépôts qui ne peuvent pas être installées en même temps.
Par exemple un paquet version 32bits avec le même version 64 bits

Sinon c'est quoi ton souci exactement ? tu n'arrives pas à installer VLC ?

En ligne

#4 25-01-2018 17:34:56

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-1-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017
Site Web

Re : [Résolu] en parlant de deb-multimedia

merci chalu .

oui , pour celui là , tu as  vu juste .
il n'y a qu'une source : testing

~$ apt policy x11proto-xf86vidmode-dev


x11proto-xf86vidmode-dev:
  Installé : 2.3.1-2
  Candidat : 2.3.1-2
 Table de version :
 *** 2.3.1-2 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        500 http://ftp.fr.debian.org/debian testing/main i386 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main i386 Packages
        100 /var/lib/dpkg/status
 


en effet , l'erreur venait de "dmo" dans "vidmode" .
le programme s'est emmêlé les pinceaux .

pour vlc , il est déjà installé . je n'ai rien eu à toucher .
simplement par  curiosité , j'ai essayé la  commande de smolski (je  crois) et j'ai trouvé ça .

par curiosité , toujours , j'aimerai savoir si j'ai d'autres paquets :i386 en conflit et peut être , si ça vaut la peine , les supprimer ,
résoudre le conflit ou , du moins , comprendre ce qui se passe .

grâce à ce lien : architectures debian

j'ai tapé ceci :

~$ dpkg --print-foreign-architectures


et j'ai obtenu :

i386

Dernière modification par Debian Alain (25-01-2018 21:02:40)


1498812139.jpg Live is Life - Opus 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#5 25-01-2018 18:33:26

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu] en parlant de deb-multimedia

Debian Alain a écrit :

en effet , l'erreur venait de "dmo" dans "vidmode" .
le programme s'est emmêlé les pinceaux .


Pas tout à fait, en fait la commande

dpkg-query -l | grep dmo


liste les paquets installés avec le filtre "dmo". On obtient donc les paquets du dépôt multimédia puisqu'ils ont ces caractères mais il y a aussi "des faux positifs" si tu veux avec les paquets officiels qui peuvent contenir dmo dans leur nom.

En ligne

#6 25-01-2018 18:40:09

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-1-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017
Site Web

Re : [Résolu] en parlant de deb-multimedia

merci chalu .

mais , peux tu m'expliquer cette commande :

~$ apt policy vlc


vlc:
  Installé : 3.0.0~rc6-1+b1
  Candidat : 3.0.0~rc6-1+b1
 Table de version :
     1:3.0.0~rc5.real-dmo1 100
        100 ftp://ftp.deb-multimedia.org testing/main amd64 Packages
 *** 3.0.0~rc6-1+b1 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
 



commande a écrit :

Table de version :
     1:3.0.0~rc5.real-dmo1 100
        100 ftp://ftp.deb-multimedia.org testing/main amd64 Packages


pourtant , je n'ai aucun paquet  de  deb-multimedia ...

comprends pas .

à moins  qu'il faille se  fier à ça :

commande a écrit :

  Installé : 3.0.0~rc6-1+b1


et dans ce cas , ça veut dire quoi puisque je n'ai aucune rc d'installé ?

Dernière modification par Debian Alain (25-01-2018 18:43:43)


1498812139.jpg Live is Life - Opus 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#7 25-01-2018 18:51:18

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : [Résolu] en parlant de deb-multimedia

La commande interroge les dépôts de ton (ou tes) sources.list
vlc:
  Installé : 3.0.0~rc6-1+b1 --> la version installée sur ton système, ça affiche (aucun) quand le paquet n'est pas installé
  Candidat : 3.0.0~rc6-1+b1 --> la version qui serait installée avec la commande root : apt install nom du paquet

Table de version : ---> sous cette ligne c'est la liste de toutes les versions du paquet qui sont présentes dans les dépôts du source.list
     1:3.0.0~rc5.real-dmo1 100
        100 ftp://ftp.deb-multimedia.org testing/main amd64 Packages

---> le paquet vlc existe dans le dépôt multimedia en version 1:3.0.0  et on voit que la préférence/priorité est à 100

*** 3.0.0~rc6-1+b1 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages

---> le paquet vlc existe en version 3.0.0~rc6-1+b1 à la fois dans testing et dans unstable et on voit que la préférence/priorité est à 500 pour testing et 100 pour unstable

        100 /var/lib/dpkg/status
pour la dernière je ne sais pas, elle est toujours là mais je ne saurais te dire à quoi elle sert

En ligne

#8 25-01-2018 19:13:18

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Résolu] en parlant de deb-multimedia

Salut
Table de version c'est toute les versions disponible suivant les dépôts que tu as activés (avec un apt update pour que les infos soient a jour)
Les depots Debian propose une version plus recente par rapport a deb-multimedia.org
De + le depot testing est a 500 en priorité donc il suivra la version de ce dépôt a moins que tu spécifie le contraire

en exemple pour virtualbox sous ma Jessie

apt-cache policy virtualbox


virtualbox:
  Installé : 4.3.36-dfsg-1+deb8u1
  Candidat : 4.3.36-dfsg-1+deb8u1
 Table de version :
     5.1.8-dfsg-6~bpo8+2 0
        100 http://ftp.debian.org/debian/ jessie-backports/contrib i386 Packages
 *** 4.3.36-dfsg-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/contrib i386 Packages
        500 http://security.debian.org/ jessie/updates/contrib i386 Packages
        100 /var/lib/dpkg/status


Comme tu peux le voir je suis en version 4.3.36 même si une version plus recente est dispo dans les backports
et apt update me proposera pas de mise a jour vers la version 5.1.8


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 25-01-2018 19:34:41

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-1-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017
Site Web

Re : [Résolu] en parlant de deb-multimedia

okkayyy .

pour installé / candidat , je m'en doutais un peu .

pour la table de version , je savais pas .

merci .

1498812139.jpg Live is Life - Opus 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

Pied de page des forums